5 Replies Latest reply: Apr 4, 2012 8:15 AM by stingray RSS

    Simple question: Why max 40 rows in my Extension?

    Robert Svebeck


      I have tested this issue with several simple self made extensions and I get the same result all the time. So I must be doing something fundamentally wrong...

      The script looks like this (Yeah, very simple...)


      Qva.AddExtension("SimpleTest", function ()




      The Definition.xml looks like this:


      <?xml version="1.0" encoding="utf-8"?>
      <ExtensionObject Label="SimpleTest" Description="SimpleTest">


      I create a new QV document, load it with inline data which contains at least 200 rows of information.

      I add my extension "SimpleTest" and connect it to one  my dimension  and add an simple expression like sum(Key).

      I activate (webmode enable/disable) the extension  - and I get a message box saying I have 40 rows.

      I always get max 40 rows from my extension, even though it definetely should contain more than 40 rows.

      How can I extend my extension to handle more than 40 rows of data??

      Attached is an ready example...