Introduction

[image]

QlikView Management Service API
Introduction
See Also Send Feedback

The QlikView Management Service API

The QlikView Management Service (QMS) API is exposed as a web service and provides a description of its operations and data objects in WSDL available at http://<server-name>:4799/QMS/Service by default. All communication is using SOAP over HTTP.

To be able to interact with the QMS API web service, a key refered to as the "service key" must be supplied as a header of the HTTP request of each operation call, except for the GetTimeLimitedServiceKey operation which is used to retrieve such a key. This aims to prevent cross-site request forgery (CSRF), see the CSRF article at OWASP.org for more information. The HTTP header containing the service key is called X-Service-Key. For example, the header with a value can look like this:

X-Service-Key: rPnBL6zlbvNr5k2nowI919EJkkOeHsi8

Different security layers controls the access to the different operations. Most operations require membership of a local group named QlikView Management API which aims to control overall API access. Exception to this is the GetTimeLimitedServiceKey operation and EDX related operations. The second layer of security aims to control access at an operation level and involves the local groups QlikView Administrator and QlikView EDX as well as the Document Folder Administrator role. These roles are inclusive, where QlikView Administrator provides the highest access level and QlikView EDX the lowest; e.g. a Document Folder Administrator have access to operations that require QlikView EDX membership, and a QlikView Administrator have access to operations that require Document Folder Administrator membership. Each operation's documentation specifies what exact roles are required to access it.

Using the QlikView Server 11 SDK sample code

The QlikView Server 11 SDK can be installed as a part of the QlikView Server 11 installation and contains a couple of examples on how to use the QMS API. It also contains a code example on how to inject the service key into the HTTP headers of the API web service call. This example is written in C# .NET 3.5 and assumes that the application is using WCF to communicate with the API.

See Also: Samples

Navigating this API reference

The available QMS API operations are listed under the IQMSBackend interface under the QMSBackendInterface namespace. All data objects used by these operations are listed under the three PIX.QMSAPI.DataObjects namespaces. These namespaces are internal QlikView Management Service namespaces and will be used mainly as references in the SOAP XML.

See Also

Reference

IQMSBackend
PIX.QMSAPI.DataObjects
PIX.QMSAPI.DataObjects.CALs
PIX.QMSAPI.DataObjects.Triggers
Send feedback on this topic to QlikTech.


Samples

[image]

QlikView Management Service API
Samples
Send Feedback

The following code samples are installed as a part of the QlikView Server 11 SDK, together with a couple of sample applications on how to use the QMS API. The SDK is a subset of the QlikView Server 11 installation package.

QMS API Samples

Service Key Injection Sample Demonstrates how the service key can be injected in a .NET WCF application.


Service Key Injection Sample

[image]

QlikView Management Service API
Service Key Injection Sample
Send Feedback

This code sample is written in C# based on .NET Framework 4.0 and WCF. It demonstrates how to inject the service key into the HTTP header of each QMS API web service call.

Certificate: Both the URL for connecting to the API and the content of the app.config file differers slightly if a certificate is used so please read the sample carefully.

Installing the certificate is beyond the scope of this sample.

To build and run this example

  1. Create a new C# Console Application project and name it MyTestApplication

  2. Make sure you have the QlikView Management Service running

  3. Right-click the References node in the Solution Explorer and select Add Service Reference

  4. Enter the QMS API WSDL address http://<server-name>:4799/QMS/Service and click Go

    Certificate: If the QlikView Management Service has been configured to use certificate security, you must use https instead, i.e: https://<server-name>:4799/QMS/Service

  5. Enter QMSAPI as name for the service reference namespace

  6. [Optionally] Click on Advanced, select System.Collections.Generic.List for Collection Type and click OK

  7. Click OK to have Visual Studio automatically generate code for communication with the QMS API web service

  8. Right-click the References node in the Solution Explorer and select Add Reference

  9. Under the .NET tab, select System.Configuration and click OK

  10. Replace everything in Program.cs with the following code:

    CopyC#
    using System;
using System.Collections.Generic;
using System.ServiceModel;
using System.ServiceModel.Channels;
using System.ServiceModel.Configuration;
using System.ServiceModel.Description;
using System.ServiceModel.Dispatcher;
using MyTestApplication.QMSAPI;

namespace MyTestApplication
{
    class ServiceKeyBehaviorExtensionElement : BehaviorExtensionElement
    {
        public override Type BehaviorType
        {
            get { return typeof(ServiceKeyEndpointBehavior); }
        }

        protected override object CreateBehavior()
        {
            return new ServiceKeyEndpointBehavior();
        }
    }

    class ServiceKeyEndpointBehavior : IEndpointBehavior
    {
        public void Validate(ServiceEndpoint endpoint) { }

        public void AddBindingParameters(ServiceEndpoint endpoint, BindingParameterCollection bindingParameters) { }

        public void ApplyDispatchBehavior(ServiceEndpoint endpoint, EndpointDispatcher endpointDispatcher) { }

        public void ApplyClientBehavior(ServiceEndpoint endpoint, ClientRuntime clientRuntime)
        {
            clientRuntime.MessageInspectors.Add(new ServiceKeyClientMessageInspector());
        }
    }

    class ServiceKeyClientMessageInspector : IClientMessageInspector
    {
        private const string SERVICE_KEY_HTTP_HEADER = "X-Service-Key";

        public static string ServiceKey { get; set; }

        public object BeforeSendRequest(ref Message request, IClientChannel channel)
        {
            object httpRequestMessageObject;
            if (request.Properties.TryGetValue(HttpRequestMessageProperty.Name, out httpRequestMessageObject))
            {
                HttpRequestMessageProperty httpRequestMessage = httpRequestMessageObject as HttpRequestMessageProperty;
                if (httpRequestMessage != null)
                {
                    httpRequestMessage.Headers[SERVICE_KEY_HTTP_HEADER] = (ServiceKey ?? string.Empty);
                }
                else
                {
                    httpRequestMessage = new HttpRequestMessageProperty();
                    httpRequestMessage.Headers.Add(SERVICE_KEY_HTTP_HEADER, (ServiceKey ?? string.Empty));
                    request.Properties[HttpRequestMessageProperty.Name] = httpRequestMessage;
                }
            }
            else
            {
                HttpRequestMessageProperty httpRequestMessage = new HttpRequestMessageProperty();
                httpRequestMessage.Headers.Add(SERVICE_KEY_HTTP_HEADER, (ServiceKey ?? string.Empty));
                request.Properties.Add(HttpRequestMessageProperty.Name, httpRequestMessage);
            }
            return null;
        }

        public void AfterReceiveReply(ref Message reply, object correlationState) { }
    }

    class Program
    {
        static void Main(string[] args)
        {
            try
            {
                // create a QMS API client
                IQMS apiClient = new QMSClient();

                //If you want to connect to a server different from the one used when creating the service reference,
                //do as follows:
                //
                //NTLM only (default installation)
                //IQMS apiClient = new QMSClient("BasicHttpBinding_IQMS", "http://remotehost:4799/QMS/Service");
                //
                //Certificate security
                //IQMS apiClient = new QMSClient("WSHttpBinding_IQMS", "https://remotehost:4799/QMS/Service");

                // retrieve a time limited service key
                ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();
                // get a list of QVS services
                List<ServiceInfo> qvsServices = apiClient.GetServices(ServiceTypes.QlikViewServer);
                if (qvsServices.Count > 0)
                {
                    // retrieve folder settings for the first QVS in the list
                    QVSSettings qvsSettings = apiClient.GetQVSSettings(qvsServices[0].ID, QVSSettingsScope.Folders);
                    // add a new mount
                    qvsSettings.Folders.UserDocumentMounts.Add(new QVSMount() { Browsable = false, Path = @"\\unc\some", Name = "MyMount" });
                    // save settings
                    apiClient.SaveQVSSettings(qvsSettings);
                    Console.WriteLine("Settings saved. New mount added.");
                }
            }
            catch (System.Exception ex)
            {
                Console.WriteLine("An exception occurred: " + ex.Message);
            }
            // wait for user to press any key
            Console.ReadLine();
        }
    }
}

  11. Open the app.config file in your C# project, e.g. by double-clicking on it in Solution Explorer

  12. Depending on whether certificate security is used or not, add one of the the following XML snippets to your app.config file directly within the <system.serviceModel> tag:

    CopyC# - Without certificates
    <extensions>
    <behaviorExtensions>
        <add name="serviceKeyBehavior" type="MyTestApplication.ServiceKeyBehaviorExtensionElement, MyTestApplication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"/>
    </behaviorExtensions>
</extensions>
<behaviors>
    <endpointBehaviors>
        <behavior name="ServiceKeyEndpointBehavior">
            <serviceKeyBehavior/>
        </behavior>
    </endpointBehaviors>
</behaviors>
    CopyC# - With certificates
    <extensions>
    <behaviorExtensions>
        <add name="serviceKeyBehavior" type="MyTestApplication.ServiceKeyBehaviorExtensionElement, MyTestApplication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"/>
    </behaviorExtensions>
</extensions>
<behaviors>
    <endpointBehaviors>
        <behavior name="ServiceKeyEndpointBehavior">
            <serviceKeyBehavior/>
            <clientCredentials>
                <clientCertificate findValue="CN=QVProxy" x509FindType="FindBySubjectDistinguishedName" storeLocation="LocalMachine" storeName="My" />
                <serviceCertificate>
                    <authentication certificateValidationMode="ChainTrust" revocationMode="NoCheck"/>
                </serviceCertificate>
            </clientCredentials>
        </behavior>
    </endpointBehaviors>
</behaviors>

  13. Add the following XML attribute to the bottom <endpoint ... /> tag of your app.config file:

    CopyC#
    behaviorConfiguration="ServiceKeyEndpointBehavior"

  14. Build and run the solution

Below are two examples of complete app.config files:

  • app.config file not using certificate security

  • app.config file using certificate security


Namespaces
Send Feedback

Namespaces

Namespace | Description
PIX.QMSAPI.DataObjects | Contains all the classes used by the QMSAPI.
PIX.QMSAPI.DataObjects.CALs | Contains CAL specific classes.
PIX.QMSAPI.DataObjects.Document | Contains document specific classes.
PIX.QMSAPI.DataObjects.Enums | Contains the enums used by the QMSAPI.
PIX.QMSAPI.DataObjects.Triggers | Contains trigger specific classes.
PIX.QMSAPI.Exceptions | Contains exceptions defined by the QMSAPI.
PIX.Services | Contains the QMSAPI service definition.


PIX.QMSAPI.DataObjects Namespace

[image]

QlikView Management Service API
PIX.QMSAPI.DataObjects Namespace
Send Feedback
Contains all the classes used by the QMSAPI.

Classes

 | Class | Description
Public class | Category | Represents a single category.
Public class | DirectoryServiceObject |
Public class | DocumentAccessEntry | Represents a single entry, controlling the access to a document.
Public class | DocumentAttribute | Name and Value of a document attribute
Public class | DocumentFolder |
Public class | DocumentFolder..::..DocumentFolderAdministrators |
Public class | DocumentFolder..::..DocumentFolderGeneral |
Public class | DocumentFolder..::..DocumentFolderServices |
Public class | DocumentMetaData |
Public class | DocumentMetaData..::..DocumentMetaDataAuthorization |
Public class | DocumentMetaData..::..DocumentMetaDataCollaboration |
Public class | DocumentMetaData..::..DocumentMetaDataDocumentInfo |
Public class | DocumentMetaData..::..DocumentMetaDataLicensing |
Public class | DocumentMetaData..::..DocumentMetaDataServer |
Public class | DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess |
Public class | DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad | The Document Load element of the document meta data data object.
Public class | DocumentNode |
Public class | DocumentTask |
Public class | DocumentTask..::..TaskDistribute |
Public class | DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic | The Distribute Dynamic element of the document task data object.
Public class | DocumentTask..::..TaskDistribute..::..TaskDistributeNotification |
Public class | DocumentTask..::..TaskDistribute..::..TaskDistributeOutput |
Public class | DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF |
Public class | DocumentTask..::..TaskDistribute..::..TaskDistributeStatic |
Public class | DocumentTask..::..TaskDocumentInfo |
Public class | DocumentTask..::..TaskGeneral |
Public class | DocumentTask..::..TaskReduce |
Public class | DocumentTask..::..TaskReduce..::..TaskReduceDynamic |
Public class | DocumentTask..::..TaskReduce..::..TaskReduceStatic |
Public class | DocumentTask..::..TaskReload |
Public class | DocumentTask..::..TaskServer |
Public class | DocumentTask..::..TaskServer..::..TaskServerAccess |
Public class | DocumentTask..::..TaskServer..::..TaskServerCollaboration |
Public class | DocumentTask..::..TaskServer..::..TaskServerDocumentLoading | The Server document loading element of the document task data object.
Public class | DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting | The Document Load element of the document meta data data object.
Public class | DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting | The Document Load element of the document meta data data object.
Public class | DocumentTask..::..TaskTriggering |
Public class | DSProvider | Represents a Directory Service Provider (DSP).
Public class | DSPSettings | Represents the settings for a Directory Service Provider.
Public class | DSResource | Represents a Directory Service Resource (DSResource).
Public class | EDXStatus |
Public class | EnumSupport |
Public class | ExtensionUploadHandle | Holds information about an extension object upload.
Public class | License | Contains license information including the contents of the LEF file.
Public class | LicenseFeature | Represents a license feature. A feature has a name and a value. Since the type of the value varies depending on the feature, it is of an object type.
Public class | LogFileEntry | Represents a single log entry.
Public class | QDSDocumentSession | Represents a QDS session for a specific document.
Public class | QDSDocumentSessionConfiguration | Represents the configuration of a QDSDocumentSession and is used when creating a new session.
Public class | QDSSettings | Holds all the settings for a QlikView Distribution Service. Some of the settings applies only to unlicensed services.
Public class | QDSSettings..::..QDSAdvanced |
Public class | QDSSettings..::..QDSClusterInfo | Contains a references to a clustered Distribution Services.
Public class | QDSSettings..::..QDSEmail |
Public class | QDSSettings..::..QDSGeneral |
Public class | QDSSettings..::..QDSLogin |
Public class | QVSClusterMember |
Public class | QVSFolderAdministrator |
Public class | QVSMessage | Represents a received from a QVS.
Public class | QVSMount |
Public class | QVSSettings | Represents all configurable settings for a QlikView Server.
Public class | QVSSettings..::..QVSCluster |
Public class | QVSSettings..::..QVSCluster..::..QVSClusterLicense |
Public class | QVSSettings..::..QVSDistribution |
Public class | QVSSettings..::..QVSDocuments |
Public class | QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects |
Public class | QVSSettings..::..QVSDocuments..::..QVSDocumentsServer |
Public class | QVSSettings..::..QVSFolders | Contains folder related QlikView Server settings, such as root folder and mounts.
Public class | QVSSettings..::..QVSFolders..::..QVSFoldersSystem |
Public class | QVSSettings..::..QVSGeneral | Contains general QlikView Server settings, such as server name and login information.
Public class | QVSSettings..::..QVSLogging |
Public class | QVSSettings..::..QVSLogging..::..QVSLoggingLevel |
Public class | QVSSettings..::..QVSPerformance |
Public class | QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU |
Public class | QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument |
Public class | QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions |
Public class | QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory |
Public class | QVSSettings..::..QVSSecurity |
Public class | QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication |
Public class | QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization |
Public class | QVSSupervisionAccount |
Public class | SectionAccessTable | Represents a table which defines how a document is to be reduced combined with which user that should see each reduction.
Public class | SectionAccessTable..::..SectionAccessCell | Represents a single cell.
Public class | SectionAccessTable..::..SectionAccessColumn | Represents a single column
Public class | SectionAccessTable..::..SectionAccessRow | Represents a single row.
Public class | ServerObject | Represents a server object which can be shared with other users.
Public class | ServerObjectMetaData | Represents meta data about a server object.
Public class | ServiceInfo | Holds information about a single service.
Public class | ServiceStatus | Represents the status of a service. Depending on the type of the service, its composition can be either clustered or single. A clustered service has at least one member, a single service has only one member.
Public class | ServiceStatusDetail | This class provides details about the status of a service member. A service can contain one or several members, depending on the type of service and current configuration.
Public class | TaskDistributionDestination | Represents the destination of a distribution.
Public class | TaskDistributionDestination..::..TaskDistributionDestinationFolder |
Public class | TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer |
Public class | TaskDistributionEntry |
Public class | TaskExecutionItem |
Public class | TaskInfo |
Public class | TaskReduction |
Public class | TaskReduction..::..TaskReductionBookmark |
Public class | TaskReduction..::..TaskReductionField |
Public class | TaskStatus | The Task Status data object.
Public class | TaskStatus..::..TaskStatusExtended | The Extended element of the task status node request data object.
Public class | TaskStatus..::..TaskStatusGeneral | The General element of the task status node request data object.
Public class | TaskStatusFilter | A filter class used when requesting task statuses.
Public class | TaskStatusFilter..::..Interval |
Public class | TaskStatusFilter..::..LastExecutionInterval | Represents a Date/Time interval.
Public class | TaskStatusFilter..::..ScheduleInterval |
Public class | TaskStatusNode | The Task Status Node data object.
Public class | TaskStatusNodeRequest | The Task Status Node Request data object.
Public class | TriggerEDXTaskResult | Represents the result of an EDX task.

Enumerations

 | Enumeration | Description
Public enumeration | CALConfigurationScope | Represents the various CAL types and can be used when retrieving the CAL configuration. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | DirectoryServiceObjectType |
Public enumeration | DocumentAccessEntryMode |
Public enumeration | DocumentAccessMethods | Represents the possible methods for accessing a document.
Public enumeration | DocumentCollaborationCreationMode |
Public enumeration | DocumentFolderScope |
Public enumeration | DocumentFolderType |
Public enumeration | DocumentLoadMode |
Public enumeration | DocumentMetaDataScope |
Public enumeration | DocumentTaskScope |
Public enumeration | DocumentType |
Public enumeration | EDXTaskStartResult | The result types when starting an EDX task.
Public enumeration | LogType |
Public enumeration | NamedCALIdentificationMode | Represents the various modes for identifying a named CAL.
Public enumeration | QDSSectionAccessMode |
Public enumeration | QVSAuditLogLevel |
Public enumeration | QVSAuthenticationLevel |
Public enumeration | QVSCacheObjects | The different available cache objects that can be used when calling ClearQVSCache(QVSCacheObjects). This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | QVSLogFileSplitMode |
Public enumeration | QVSLogVerbosity |
Public enumeration | QVSSettingsScope | The different available scopes for a QVSSettings object. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | QVSSupervisionAccountType |
Public enumeration | QVSUserDocumentFolderType | All available QVSUserDocumentFolderType parameters. Sub folders are only available through the node interface.
Public enumeration | ServerDocumentLoadMode |
Public enumeration | ServiceTypes | The different service types. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values. A combination of these can be used when calling for example.
Public enumeration | TaskDistributionDestinationType |
Public enumeration | TaskDistributionOutputType |
Public enumeration | TaskReductionType |
Public enumeration | TaskReloadMode |
Public enumeration | TaskStatusNodeType |
Public enumeration | TaskStatusScope | Determines how much of the task status information that should be retrieved when calling GetTaskStatus(Guid, TaskStatusScope) for example. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | TaskStatusValue |
Public enumeration | TaskTriggerType |
Public enumeration | TaskType | The various task types.
Public enumeration | TaskWizardTrack |
Public enumeration | UserIdentityValueType | The different types of identities.


CALConfigurationScope Enumeration

[image]

QlikView Management Service API
CALConfigurationScope Enumeration
See Also Send Feedback
Represents the various CAL types and can be used when retrieving the CAL configuration.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum CALConfigurationScope
Visual Basic
<FlagsAttribute> _
Public Enumeration CALConfigurationScope

Members

Member name | Value | Description
None | 0 |
DocumentCALs | 1 |
NamedCALs | 2 |
SessionCALs | 4 |
UsageCALs | 8 |
All | 65535 |

See Also

PIX.QMSAPI.DataObjects Namespace
IQMS..::..GetCALConfiguration(Guid, CALConfigurationScope)


Category Class

[image]

QlikView Management Service API
Category Class
Members See Also Send Feedback
Represents a single category.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class Category
Visual Basic
Public Class Category

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..Category

See Also

Category Members
PIX.QMSAPI.DataObjects Namespace


Category Members

[image] [image]

QlikView Management Service API
Category Members
Category Class Properties See Also Send Feedback

The Category type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID of the category.
Public property | Name | The name of the category.

See Also

Category Class


Category Properties

[image] [image]

QlikView Management Service API
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID of the category.
Public property | Name | The name of the category.

See Also

Category Class


ID Property

[image]

QlikView Management Service API
Category..::..ID Property
Category Class See Also Send Feedback
The ID of the category.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

Category Class


Name Property

[image]

QlikView Management Service API
Category..::..Name Property
Category Class See Also Send Feedback
The name of the category.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

Category Class


DirectoryServiceObject Class

[image]

QlikView Management Service API
DirectoryServiceObject Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DirectoryServiceObject"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DirectoryServiceObject
Visual Basic
Public Class DirectoryServiceObject

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DirectoryServiceObject

See Also

DirectoryServiceObject Members


DirectoryServiceObject Members

[image] [image]

QlikView Management Service API
DirectoryServiceObject Members
DirectoryServiceObject Class Properties See Also Send Feedback

The DirectoryServiceObject type exposes the following members.

Properties

 | Name | Description
 | Anonymous |
 | Authenticated |
Public property | Name |
Public property | OtherProperty |
Public property | Type |

See Also

DirectoryServiceObject Class


DirectoryServiceObject Properties

[image] [image]

QlikView Management Service API
DirectoryServiceObject Properties
DirectoryServiceObject Class See Also Send Feedback

The DirectoryServiceObject type exposes the following members.

Properties

 | Name | Description
 | Anonymous |
 | Authenticated |
Public property | Name |
Public property | OtherProperty |
Public property | Type |

See Also

DirectoryServiceObject Class


Anonymous Property

[image]

QlikView Management Service API
DirectoryServiceObject..::..Anonymous Property
DirectoryServiceObject Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DirectoryServiceObject.Anonymous"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public static DirectoryServiceObject Anonymous { get; }
Visual Basic
Public Shared ReadOnly Property Anonymous As DirectoryServiceObject
    Get

See Also

DirectoryServiceObject Class


Authenticated Property

[image]

QlikView Management Service API
DirectoryServiceObject..::..Authenticated Property
DirectoryServiceObject Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DirectoryServiceObject.Authenticated"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public static DirectoryServiceObject Authenticated { get; }
Visual Basic
Public Shared ReadOnly Property Authenticated As DirectoryServiceObject
    Get

See Also

DirectoryServiceObject Class


Name Property

[image]

QlikView Management Service API
DirectoryServiceObject..::..Name Property
DirectoryServiceObject Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DirectoryServiceObject.Name"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

DirectoryServiceObject Class


OtherProperty Property

[image]

QlikView Management Service API
DirectoryServiceObject..::..OtherProperty Property
DirectoryServiceObject Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DirectoryServiceObject.OtherProperty"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string OtherProperty { get; set; }
Visual Basic
Public Property OtherProperty As String
    Get
    Set

See Also

DirectoryServiceObject Class


Type Property

[image]

QlikView Management Service API
DirectoryServiceObject..::..Type Property
DirectoryServiceObject Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DirectoryServiceObject.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DirectoryServiceObjectType Type { get; set; }
Visual Basic
Public Property Type As DirectoryServiceObjectType
    Get
    Set

See Also

DirectoryServiceObject Class


DirectoryServiceObjectType Enumeration

[image]

QlikView Management Service API
DirectoryServiceObjectType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DirectoryServiceObjectType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum DirectoryServiceObjectType
Visual Basic
Public Enumeration DirectoryServiceObjectType

Members

Member name | Value | Description
Undefined | 0 |
Named | 1 |
Authenticated | 2 |
Anonymous | 3 |

See Also


DocumentAccessEntry Class

[image]

QlikView Management Service API
DocumentAccessEntry Class
Members See Also Send Feedback
Represents a single entry, controlling the access to a document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentAccessEntry
Visual Basic
Public Class DocumentAccessEntry

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentAccessEntry

See Also

DocumentAccessEntry Members


DocumentAccessEntry Members

[image] [image]

QlikView Management Service API
DocumentAccessEntry Members
DocumentAccessEntry Class Properties See Also Send Feedback

The DocumentAccessEntry type exposes the following members.

Properties

 | Name | Description
Public property | AccessMode | Specifies whether the access is restricted or not.
Public property | DayOfWeekConstraints | A list of days when access is allowed.
Public property | IsAnonymous | Indicates whether anonymous access is allowed.
Public property | TimeConstraintFrom | A time from which access is allowed.
Public property | TimeConstraintTo | A time from which access is not allowed.
Public property | UserName | The name of the user allowed access.

See Also

DocumentAccessEntry Class


DocumentAccessEntry Properties

[image] [image]

QlikView Management Service API
DocumentAccessEntry Properties
DocumentAccessEntry Class See Also Send Feedback

The DocumentAccessEntry type exposes the following members.

Properties

 | Name | Description
Public property | AccessMode | Specifies whether the access is restricted or not.
Public property | DayOfWeekConstraints | A list of days when access is allowed.
Public property | IsAnonymous | Indicates whether anonymous access is allowed.
Public property | TimeConstraintFrom | A time from which access is allowed.
Public property | TimeConstraintTo | A time from which access is not allowed.
Public property | UserName | The name of the user allowed access.

See Also

DocumentAccessEntry Class


AccessMode Property

[image]

QlikView Management Service API
DocumentAccessEntry..::..AccessMode Property
DocumentAccessEntry Class See Also Send Feedback
Specifies whether the access is restricted or not.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentAccessEntryMode AccessMode { get; set; }
Visual Basic
Public Property AccessMode As DocumentAccessEntryMode
    Get
    Set

See Also

DocumentAccessEntry Class


DayOfWeekConstraints Property

[image]

QlikView Management Service API
DocumentAccessEntry..::..DayOfWeekConstraints Property
DocumentAccessEntry Class See Also Send Feedback
A list of days when access is allowed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DayOfWeek> DayOfWeekConstraints { get; private set; }
Visual Basic
Public Property DayOfWeekConstraints As List(Of DayOfWeek)
    Get
    Private Set

See Also

DocumentAccessEntry Class


IsAnonymous Property

[image]

QlikView Management Service API
DocumentAccessEntry..::..IsAnonymous Property
DocumentAccessEntry Class See Also Send Feedback
Indicates whether anonymous access is allowed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IsAnonymous { get; set; }
Visual Basic
Public Property IsAnonymous As Boolean
    Get
    Set

See Also

DocumentAccessEntry Class


TimeConstraintFrom Property

[image]

QlikView Management Service API
DocumentAccessEntry..::..TimeConstraintFrom Property
DocumentAccessEntry Class See Also Send Feedback
A time from which access is allowed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DateTime TimeConstraintFrom { get; set; }
Visual Basic
Public Property TimeConstraintFrom As DateTime
    Get
    Set

See Also

DocumentAccessEntry Class


TimeConstraintTo Property

[image]

QlikView Management Service API
DocumentAccessEntry..::..TimeConstraintTo Property
DocumentAccessEntry Class See Also Send Feedback
A time from which access is not allowed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DateTime TimeConstraintTo { get; set; }
Visual Basic
Public Property TimeConstraintTo As DateTime
    Get
    Set

See Also

DocumentAccessEntry Class


UserName Property

[image]

QlikView Management Service API
DocumentAccessEntry..::..UserName Property
DocumentAccessEntry Class See Also Send Feedback
The name of the user allowed access.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set

See Also

DocumentAccessEntry Class


DocumentAccessEntryMode Enumeration

[image]

QlikView Management Service API
DocumentAccessEntryMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentAccessEntryMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum DocumentAccessEntryMode
Visual Basic
Public Enumeration DocumentAccessEntryMode

Members

Member name | Value | Description
Always | 0 |
Restricted | 1 |

See Also


DocumentAccessMethods Enumeration

[image]

QlikView Management Service API
DocumentAccessMethods Enumeration
See Also Send Feedback
Represents the possible methods for accessing a document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum DocumentAccessMethods
Visual Basic
<FlagsAttribute> _
Public Enumeration DocumentAccessMethods

Members

Member name | Value | Description
None | 0 |
Download | 1 | Obsolete.
PluginClient | 2 |
ZeroFootprintClient | 4 |
MobileClient | 8 |
All | 65535 |

See Also


DocumentAttribute Class

[image]

QlikView Management Service API
DocumentAttribute Class
Members See Also Send Feedback
Name and Value of a document attribute

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentAttribute
Visual Basic
Public Class DocumentAttribute

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentAttribute

See Also

DocumentAttribute Members


DocumentAttribute Members

[image] [image]

QlikView Management Service API
DocumentAttribute Members
DocumentAttribute Class Properties See Also Send Feedback

The DocumentAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the attribute
Public property | Value | The value of the attribute

See Also

DocumentAttribute Class


DocumentAttribute Properties

[image] [image]

QlikView Management Service API
DocumentAttribute Properties
DocumentAttribute Class See Also Send Feedback

The DocumentAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the attribute
Public property | Value | The value of the attribute

See Also

DocumentAttribute Class


Name Property

[image]

QlikView Management Service API
DocumentAttribute..::..Name Property
DocumentAttribute Class See Also Send Feedback
The name of the attribute

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

DocumentAttribute Class


Value Property

[image]

QlikView Management Service API
DocumentAttribute..::..Value Property
DocumentAttribute Class See Also Send Feedback
The value of the attribute

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

See Also

DocumentAttribute Class


DocumentCollaborationCreationMode Enumeration

[image]

QlikView Management Service API
DocumentCollaborationCreationMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentCollaborationCreationMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum DocumentCollaborationCreationMode
Visual Basic
Public Enumeration DocumentCollaborationCreationMode

Members

Member name | Value | Description
All | 0 |
Restricted | 1 |
None | 2 |

See Also


DocumentFolder Class

[image]

QlikView Management Service API
DocumentFolder Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentFolder"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentFolder
Visual Basic
Public Class DocumentFolder

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentFolder

See Also

DocumentFolder Members


DocumentFolder Members

[image] [image]

QlikView Management Service API
DocumentFolder Members
DocumentFolder Class Properties See Also Send Feedback

The DocumentFolder type exposes the following members.

Properties

 | Name | Description
Public property | Administrators |
Public property | General |
Public property | ID |
Public property | Scope |
Public property | Services |

See Also

DocumentFolder Class


DocumentFolder Properties

[image] [image]

QlikView Management Service API
DocumentFolder Properties
DocumentFolder Class See Also Send Feedback

The DocumentFolder type exposes the following members.

Properties

 | Name | Description
Public property | Administrators |
Public property | General |
Public property | ID |
Public property | Scope |
Public property | Services |

See Also

DocumentFolder Class


Administrators Property

[image]

QlikView Management Service API
DocumentFolder..::..Administrators Property
DocumentFolder Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.Administrators"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentFolder..::..DocumentFolderAdministrators Administrators { get; private set; }
Visual Basic
Public Property Administrators As DocumentFolder..::..DocumentFolderAdministrators
    Get
    Private Set

See Also

DocumentFolder Class


General Property

[image]

QlikView Management Service API
DocumentFolder..::..General Property
DocumentFolder Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.General"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentFolder..::..DocumentFolderGeneral General { get; private set; }
Visual Basic
Public Property General As DocumentFolder..::..DocumentFolderGeneral
    Get
    Private Set

See Also

DocumentFolder Class


ID Property

[image]

QlikView Management Service API
DocumentFolder..::..ID Property
DocumentFolder Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.ID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; private set; }
Visual Basic
Public Property ID As Guid
    Get
    Private Set

See Also

DocumentFolder Class


Scope Property

[image]

QlikView Management Service API
DocumentFolder..::..Scope Property
DocumentFolder Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.Scope"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentFolderScope Scope { get; private set; }
Visual Basic
Public Property Scope As DocumentFolderScope
    Get
    Private Set

See Also

DocumentFolder Class


Services Property

[image]

QlikView Management Service API
DocumentFolder..::..Services Property
DocumentFolder Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.Services"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentFolder..::..DocumentFolderServices Services { get; private set; }
Visual Basic
Public Property Services As DocumentFolder..::..DocumentFolderServices
    Get
    Private Set

See Also

DocumentFolder Class


DocumentFolder.DocumentFolderAdministrators Class

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderAdministrators Class
DocumentFolder Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentFolder.DocumentFolderAdministrators"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentFolderAdministrators
Visual Basic
Public Class DocumentFolderAdministrators

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentFolder..::..DocumentFolderAdministrators

See Also

DocumentFolder..::..DocumentFolderAdministrators Members


DocumentFolder.DocumentFolderAdministrators Members

[image] [image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderAdministrators Members
DocumentFolder..::..DocumentFolderAdministrators Class Properties See Also Send Feedback

The DocumentFolder..::..DocumentFolderAdministrators type exposes the following members.

Properties

 | Name | Description
Public property | UserNames | The qualified user names of the users that are Document Folder Administrators for the document folder.

See Also

DocumentFolder..::..DocumentFolderAdministrators Class


DocumentFolder.DocumentFolderAdministrators Properties

[image] [image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderAdministrators Properties
DocumentFolder..::..DocumentFolderAdministrators Class See Also Send Feedback

The DocumentFolder..::..DocumentFolderAdministrators type exposes the following members.

Properties

 | Name | Description
Public property | UserNames | The qualified user names of the users that are Document Folder Administrators for the document folder.

See Also

DocumentFolder..::..DocumentFolderAdministrators Class


UserNames Property

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderAdministrators..::..UserNames Property
DocumentFolder..::..DocumentFolderAdministrators Class See Also Send Feedback
The qualified user names of the users that are Document Folder Administrators for the document folder.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> UserNames { get; private set; }
Visual Basic
Public Property UserNames As List(Of String)
    Get
    Private Set

See Also

DocumentFolder..::..DocumentFolderAdministrators Class


DocumentFolder.DocumentFolderGeneral Class

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderGeneral Class
DocumentFolder Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentFolder.DocumentFolderGeneral"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentFolderGeneral
Visual Basic
Public Class DocumentFolderGeneral

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentFolder..::..DocumentFolderGeneral

See Also

DocumentFolder..::..DocumentFolderGeneral Members


DocumentFolder.DocumentFolderGeneral Members

[image] [image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderGeneral Members
DocumentFolder..::..DocumentFolderGeneral Class Properties See Also Send Feedback

The DocumentFolder..::..DocumentFolderGeneral type exposes the following members.

Properties

 | Name | Description
Public property | Path |
Public property | SendAlertEmailForDocumentAdministrators | Send alert email to document administrators.
Public property | Type |

See Also

DocumentFolder..::..DocumentFolderGeneral Class


DocumentFolder.DocumentFolderGeneral Properties

[image] [image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderGeneral Properties
DocumentFolder..::..DocumentFolderGeneral Class See Also Send Feedback

The DocumentFolder..::..DocumentFolderGeneral type exposes the following members.

Properties

 | Name | Description
Public property | Path |
Public property | SendAlertEmailForDocumentAdministrators | Send alert email to document administrators.
Public property | Type |

See Also

DocumentFolder..::..DocumentFolderGeneral Class


Path Property

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderGeneral..::..Path Property
DocumentFolder..::..DocumentFolderGeneral Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.DocumentFolderGeneral.Path"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set

See Also

DocumentFolder..::..DocumentFolderGeneral Class


SendAlertEmailForDocumentAdministrators Property

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderGeneral..::..SendAlertEmailForDocumentAdministrators Property
DocumentFolder..::..DocumentFolderGeneral Class See Also Send Feedback
Send alert email to document administrators.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool SendAlertEmailForDocumentAdministrators { get; set; }
Visual Basic
Public Property SendAlertEmailForDocumentAdministrators As Boolean
    Get
    Set

See Also

DocumentFolder..::..DocumentFolderGeneral Class


Type Property

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderGeneral..::..Type Property
DocumentFolder..::..DocumentFolderGeneral Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.DocumentFolderGeneral.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentFolderType Type { get; set; }
Visual Basic
Public Property Type As DocumentFolderType
    Get
    Set

See Also

DocumentFolder..::..DocumentFolderGeneral Class


DocumentFolder.DocumentFolderServices Class

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderServices Class
DocumentFolder Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentFolder.DocumentFolderServices"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentFolderServices
Visual Basic
Public Class DocumentFolderServices

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentFolder..::..DocumentFolderServices

See Also

DocumentFolder..::..DocumentFolderServices Members


DocumentFolder.DocumentFolderServices Members

[image] [image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderServices Members
DocumentFolder..::..DocumentFolderServices Class Properties See Also Send Feedback

The DocumentFolder..::..DocumentFolderServices type exposes the following members.

Properties

 | Name | Description
Public property | QDSID |
Public property | QVSID |

See Also

DocumentFolder..::..DocumentFolderServices Class


DocumentFolder.DocumentFolderServices Properties

[image] [image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderServices Properties
DocumentFolder..::..DocumentFolderServices Class See Also Send Feedback

The DocumentFolder..::..DocumentFolderServices type exposes the following members.

Properties

 | Name | Description
Public property | QDSID |
Public property | QVSID |

See Also

DocumentFolder..::..DocumentFolderServices Class


QDSID Property

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderServices..::..QDSID Property
DocumentFolder..::..DocumentFolderServices Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.DocumentFolderServices.QDSID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QDSID { get; set; }
Visual Basic
Public Property QDSID As Guid
    Get
    Set

See Also

DocumentFolder..::..DocumentFolderServices Class


QVSID Property

[image]

QlikView Management Service API
DocumentFolder..::..DocumentFolderServices..::..QVSID Property
DocumentFolder..::..DocumentFolderServices Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentFolder.DocumentFolderServices.QVSID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QVSID { get; set; }
Visual Basic
Public Property QVSID As Guid
    Get
    Set

See Also

DocumentFolder..::..DocumentFolderServices Class


DocumentFolderScope Enumeration

[image]

QlikView Management Service API
DocumentFolderScope Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentFolderScope"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum DocumentFolderScope
Visual Basic
<FlagsAttribute> _
Public Enumeration DocumentFolderScope

Members

Member name | Value | Description
None | 0 |
General | 1 |
Services | 2 |
Administrators | 4 |
All | 65535 |

See Also


DocumentFolderType Enumeration

[image]

QlikView Management Service API
DocumentFolderType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentFolderType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum DocumentFolderType
Visual Basic
Public Enumeration DocumentFolderType

Members

Member name | Value | Description
User | 1 |
Source | 2 |

See Also


DocumentLoadMode Enumeration

[image]

QlikView Management Service API
DocumentLoadMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentLoadMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum DocumentLoadMode
Visual Basic
Public Enumeration DocumentLoadMode

Members

Member name | Value | Description
Allow | 0 |
Never | 1 |
Preload | 2 |

See Also


DocumentMetaData Class

[image]

QlikView Management Service API
DocumentMetaData Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentMetaData"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentMetaData
Visual Basic
Public Class DocumentMetaData

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentMetaData

See Also

DocumentMetaData Members


DocumentMetaData Members

[image] [image]

QlikView Management Service API
DocumentMetaData Members
DocumentMetaData Class Properties See Also Send Feedback

The DocumentMetaData type exposes the following members.

Properties

 | Name | Description
Public property | Authorization |
Public property | Collaboration |
Public property | DocumentInfo |
Public property | Licensing |
Public property | QVSID |
Public property | Scope |
Public property | Server |
Public property | UserDocument |

See Also

DocumentMetaData Class


DocumentMetaData Properties

[image] [image]

QlikView Management Service API
DocumentMetaData Properties
DocumentMetaData Class See Also Send Feedback

The DocumentMetaData type exposes the following members.

Properties

 | Name | Description
Public property | Authorization |
Public property | Collaboration |
Public property | DocumentInfo |
Public property | Licensing |
Public property | QVSID |
Public property | Scope |
Public property | Server |
Public property | UserDocument |

See Also

DocumentMetaData Class


Authorization Property

[image]

QlikView Management Service API
DocumentMetaData..::..Authorization Property
DocumentMetaData Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.Authorization"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentMetaData..::..DocumentMetaDataAuthorization Authorization { get; private set; }
Visual Basic
Public Property Authorization As DocumentMetaData..::..DocumentMetaDataAuthorization
    Get
    Private Set

See Also

DocumentMetaData Class


Collaboration Property

[image]

QlikView Management Service API
DocumentMetaData..::..Collaboration Property
DocumentMetaData Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.Collaboration"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentMetaData..::..DocumentMetaDataCollaboration Collaboration { get; private set; }
Visual Basic
Public Property Collaboration As DocumentMetaData..::..DocumentMetaDataCollaboration
    Get
    Private Set

See Also

DocumentMetaData Class


DocumentInfo Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentInfo Property
DocumentMetaData Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentInfo"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentMetaData..::..DocumentMetaDataDocumentInfo DocumentInfo { get; private set; }
Visual Basic
Public Property DocumentInfo As DocumentMetaData..::..DocumentMetaDataDocumentInfo
    Get
    Private Set

See Also

DocumentMetaData Class


Licensing Property

[image]

QlikView Management Service API
DocumentMetaData..::..Licensing Property
DocumentMetaData Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.Licensing"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentMetaData..::..DocumentMetaDataLicensing Licensing { get; private set; }
Visual Basic
Public Property Licensing As DocumentMetaData..::..DocumentMetaDataLicensing
    Get
    Private Set

See Also

DocumentMetaData Class


QVSID Property

[image]

QlikView Management Service API
DocumentMetaData..::..QVSID Property
DocumentMetaData Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.QVSID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QVSID { get; set; }
Visual Basic
Public Property QVSID As Guid
    Get
    Set

See Also

DocumentMetaData Class


Scope Property

[image]

QlikView Management Service API
DocumentMetaData..::..Scope Property
DocumentMetaData Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.Scope"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentMetaDataScope Scope { get; private set; }
Visual Basic
Public Property Scope As DocumentMetaDataScope
    Get
    Private Set

See Also

DocumentMetaData Class


Server Property

[image]

QlikView Management Service API
DocumentMetaData..::..Server Property
DocumentMetaData Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.Server"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentMetaData..::..DocumentMetaDataServer Server { get; private set; }
Visual Basic
Public Property Server As DocumentMetaData..::..DocumentMetaDataServer
    Get
    Private Set

See Also

DocumentMetaData Class


UserDocument Property

[image]

QlikView Management Service API
DocumentMetaData..::..UserDocument Property
DocumentMetaData Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.UserDocument"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentNode UserDocument { get; set; }
Visual Basic
Public Property UserDocument As DocumentNode
    Get
    Set

See Also

DocumentMetaData Class


DocumentMetaData.DocumentMetaDataAuthorization Class

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataAuthorization Class
DocumentMetaData Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataAuthorization"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentMetaDataAuthorization
Visual Basic
Public Class DocumentMetaDataAuthorization

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentMetaData..::..DocumentMetaDataAuthorization

See Also

DocumentMetaData..::..DocumentMetaDataAuthorization Members


DocumentMetaData.DocumentMetaDataAuthorization Members

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataAuthorization Members
DocumentMetaData..::..DocumentMetaDataAuthorization Class Properties See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataAuthorization type exposes the following members.

Properties

 | Name | Description
Public property | Access |

See Also

DocumentMetaData..::..DocumentMetaDataAuthorization Class


DocumentMetaData.DocumentMetaDataAuthorization Properties

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataAuthorization Properties
DocumentMetaData..::..DocumentMetaDataAuthorization Class See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataAuthorization type exposes the following members.

Properties

 | Name | Description
Public property | Access |

See Also

DocumentMetaData..::..DocumentMetaDataAuthorization Class


Access Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataAuthorization..::..Access Property
DocumentMetaData..::..DocumentMetaDataAuthorization Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataAuthorization.Access"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DocumentAccessEntry> Access { get; private set; }
Visual Basic
Public Property Access As List(Of DocumentAccessEntry)
    Get
    Private Set

See Also

DocumentMetaData..::..DocumentMetaDataAuthorization Class


DocumentMetaData.DocumentMetaDataCollaboration Class

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataCollaboration Class
DocumentMetaData Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataCollaboration"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentMetaDataCollaboration
Visual Basic
Public Class DocumentMetaDataCollaboration

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentMetaData..::..DocumentMetaDataCollaboration

See Also

DocumentMetaData..::..DocumentMetaDataCollaboration Members


DocumentMetaData.DocumentMetaDataCollaboration Members

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataCollaboration Members
DocumentMetaData..::..DocumentMetaDataCollaboration Class Properties See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataCollaboration type exposes the following members.

Properties

 | Name | Description
Public property | CreationMode |
Public property | CreatorUserNames |

See Also

DocumentMetaData..::..DocumentMetaDataCollaboration Class


DocumentMetaData.DocumentMetaDataCollaboration Properties

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataCollaboration Properties
DocumentMetaData..::..DocumentMetaDataCollaboration Class See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataCollaboration type exposes the following members.

Properties

 | Name | Description
Public property | CreationMode |
Public property | CreatorUserNames |

See Also

DocumentMetaData..::..DocumentMetaDataCollaboration Class


CreationMode Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataCollaboration..::..CreationMode Property
DocumentMetaData..::..DocumentMetaDataCollaboration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataCollaboration.CreationMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentCollaborationCreationMode CreationMode { get; set; }
Visual Basic
Public Property CreationMode As DocumentCollaborationCreationMode
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataCollaboration Class


CreatorUserNames Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataCollaboration..::..CreatorUserNames Property
DocumentMetaData..::..DocumentMetaDataCollaboration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataCollaboration.CreatorUserNames"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> CreatorUserNames { get; private set; }
Visual Basic
Public Property CreatorUserNames As List(Of String)
    Get
    Private Set

See Also

DocumentMetaData..::..DocumentMetaDataCollaboration Class


DocumentMetaData.DocumentMetaDataDocumentInfo Class

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataDocumentInfo Class
DocumentMetaData Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataDocumentInfo"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentMetaDataDocumentInfo
Visual Basic
Public Class DocumentMetaDataDocumentInfo

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentMetaData..::..DocumentMetaDataDocumentInfo

See Also

DocumentMetaData..::..DocumentMetaDataDocumentInfo Members


DocumentMetaData.DocumentMetaDataDocumentInfo Members

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataDocumentInfo Members
DocumentMetaData..::..DocumentMetaDataDocumentInfo Class Properties See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataDocumentInfo type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | The list of Attributes of this document
Public property | Category |
Public property | Description | The Description element of Document Info.
Public property | SourceName |

See Also

DocumentMetaData..::..DocumentMetaDataDocumentInfo Class


DocumentMetaData.DocumentMetaDataDocumentInfo Properties

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataDocumentInfo Properties
DocumentMetaData..::..DocumentMetaDataDocumentInfo Class See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataDocumentInfo type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | The list of Attributes of this document
Public property | Category |
Public property | Description | The Description element of Document Info.
Public property | SourceName |

See Also

DocumentMetaData..::..DocumentMetaDataDocumentInfo Class


Attributes Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataDocumentInfo..::..Attributes Property
DocumentMetaData..::..DocumentMetaDataDocumentInfo Class See Also Send Feedback
The list of Attributes of this document

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DocumentAttribute> Attributes { get; private set; }
Visual Basic
Public Property Attributes As List(Of DocumentAttribute)
    Get
    Private Set

See Also

DocumentMetaData..::..DocumentMetaDataDocumentInfo Class


Category Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataDocumentInfo..::..Category Property
DocumentMetaData..::..DocumentMetaDataDocumentInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataDocumentInfo.Category"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataDocumentInfo Class


Description Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataDocumentInfo..::..Description Property
DocumentMetaData..::..DocumentMetaDataDocumentInfo Class See Also Send Feedback
The Description element of Document Info.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataDocumentInfo Class


SourceName Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataDocumentInfo..::..SourceName Property
DocumentMetaData..::..DocumentMetaDataDocumentInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataDocumentInfo.SourceName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string SourceName { get; set; }
Visual Basic
Public Property SourceName As String
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataDocumentInfo Class


DocumentMetaData.DocumentMetaDataLicensing Class

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataLicensing Class
DocumentMetaData Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataLicensing"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentMetaDataLicensing
Visual Basic
Public Class DocumentMetaDataLicensing

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentMetaData..::..DocumentMetaDataLicensing

See Also

DocumentMetaData..::..DocumentMetaDataLicensing Members


DocumentMetaData.DocumentMetaDataLicensing Members

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataLicensing Members
DocumentMetaData..::..DocumentMetaDataLicensing Class Properties See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataLicensing type exposes the following members.

Properties

 | Name | Description
Public property | AllowDynamicCALAssignment |
Public property | AssignedCALs |
Public property | CALsAllocated |
Public property | CALsEmbedded |

See Also

DocumentMetaData..::..DocumentMetaDataLicensing Class


DocumentMetaData.DocumentMetaDataLicensing Properties

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataLicensing Properties
DocumentMetaData..::..DocumentMetaDataLicensing Class See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataLicensing type exposes the following members.

Properties

 | Name | Description
Public property | AllowDynamicCALAssignment |
Public property | AssignedCALs |
Public property | CALsAllocated |
Public property | CALsEmbedded |

See Also

DocumentMetaData..::..DocumentMetaDataLicensing Class


AllowDynamicCALAssignment Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataLicensing..::..AllowDynamicCALAssignment Property
DocumentMetaData..::..DocumentMetaDataLicensing Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataLicensing.AllowDynamicCALAssignment"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowDynamicCALAssignment { get; set; }
Visual Basic
Public Property AllowDynamicCALAssignment As Boolean
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataLicensing Class


AssignedCALs Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataLicensing..::..AssignedCALs Property
DocumentMetaData..::..DocumentMetaDataLicensing Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataLicensing.AssignedCALs"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<AssignedNamedCAL> AssignedCALs { get; private set; }
Visual Basic
Public Property AssignedCALs As List(Of AssignedNamedCAL)
    Get
    Private Set

See Also

DocumentMetaData..::..DocumentMetaDataLicensing Class


CALsAllocated Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataLicensing..::..CALsAllocated Property
DocumentMetaData..::..DocumentMetaDataLicensing Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataLicensing.CALsAllocated"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int CALsAllocated { get; set; }
Visual Basic
Public Property CALsAllocated As Integer
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataLicensing Class


CALsEmbedded Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataLicensing..::..CALsEmbedded Property
DocumentMetaData..::..DocumentMetaDataLicensing Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataLicensing.CALsEmbedded"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int CALsEmbedded { get; set; }
Visual Basic
Public Property CALsEmbedded As Integer
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataLicensing Class


DocumentMetaData.DocumentMetaDataServer Class

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer Class
DocumentMetaData Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataServer"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentMetaDataServer
Visual Basic
Public Class DocumentMetaDataServer

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentMetaData..::..DocumentMetaDataServer

See Also

DocumentMetaData..::..DocumentMetaDataServer Members


DocumentMetaData.DocumentMetaDataServer Members

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer Members
DocumentMetaData..::..DocumentMetaDataServer Class Properties See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataServer type exposes the following members.

Properties

 | Name | Description
Public property | Access | Under which conditions the document is available to users.
Public property | DocumentLoad | Under which conditions the document is preloaded by the server.
Public property | EnableAuditLogging | If audit logging should be enabled for this document.
Public property | ServerDocumentLoadMode | Document Load mode for this document

See Also

DocumentMetaData..::..DocumentMetaDataServer Class


DocumentMetaData.DocumentMetaDataServer Properties

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer Properties
DocumentMetaData..::..DocumentMetaDataServer Class See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataServer type exposes the following members.

Properties

 | Name | Description
Public property | Access | Under which conditions the document is available to users.
Public property | DocumentLoad | Under which conditions the document is preloaded by the server.
Public property | EnableAuditLogging | If audit logging should be enabled for this document.
Public property | ServerDocumentLoadMode | Document Load mode for this document

See Also

DocumentMetaData..::..DocumentMetaDataServer Class


Access Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..Access Property
DocumentMetaData..::..DocumentMetaDataServer Class See Also Send Feedback
Under which conditions the document is available to users.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Access { get; private set; }
Visual Basic
Public Property Access As DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess
    Get
    Private Set

See Also

DocumentMetaData..::..DocumentMetaDataServer Class


DocumentLoad Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentLoad Property
DocumentMetaData..::..DocumentMetaDataServer Class See Also Send Feedback
Under which conditions the document is preloaded by the server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad> DocumentLoad { get; private set; }
Visual Basic
Public Property DocumentLoad As List(Of DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad)
    Get
    Private Set

See Also

DocumentMetaData..::..DocumentMetaDataServer Class


EnableAuditLogging Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..EnableAuditLogging Property
DocumentMetaData..::..DocumentMetaDataServer Class See Also Send Feedback
If audit logging should be enabled for this document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool EnableAuditLogging { get; set; }
Visual Basic
Public Property EnableAuditLogging As Boolean
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer Class


ServerDocumentLoadMode Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..ServerDocumentLoadMode Property
DocumentMetaData..::..DocumentMetaDataServer Class See Also Send Feedback
Document Load mode for this document

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public ServerDocumentLoadMode ServerDocumentLoadMode { get; set; }
Visual Basic
Public Property ServerDocumentLoadMode As ServerDocumentLoadMode
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer Class


DocumentMetaData.DocumentMetaDataServer.DocumentMetaDataServerAccess Class

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class
DocumentMetaData..::..DocumentMetaDataServer Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentMetaData.DocumentMetaDataServer.DocumentMetaDataServerAccess"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentMetaDataServerAccess
Visual Basic
Public Class DocumentMetaDataServerAccess

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Members


DocumentMetaData.DocumentMetaDataServer.DocumentMetaDataServerAccess Members

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Members
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class Properties See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess type exposes the following members.

Properties

 | Name | Description
Public property | DocumentTimeout | Number of minutes after last registered activity until the document is unloaded from memory.
Public property | Download | The download access
Public property | DownloadUsers | If Download is set to Restricted, this list contains the users who are allowed to download the document.
Public property | EnableSessionCollaboration | If session collaboration is allowed.
Public property | Export | The export access
Public property | ExportUsers | If Export is set to Restricted, this list contains the users who are allowed to export the document.
Public property | MaxConcurrentSessions | The allowed number of open sessions for this document concurrently. Negative number == unlimited
Public property | Methods | The level of download access.
Public property | SessionTimeout | Time of inactivity in seconds until the server can close the session.
Public property | ZeroFootprintClientURL | The access URL for the Ajax zero-footprint client.

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


DocumentMetaData.DocumentMetaDataServer.DocumentMetaDataServerAccess Properties

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Properties
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess type exposes the following members.

Properties

 | Name | Description
Public property | DocumentTimeout | Number of minutes after last registered activity until the document is unloaded from memory.
Public property | Download | The download access
Public property | DownloadUsers | If Download is set to Restricted, this list contains the users who are allowed to download the document.
Public property | EnableSessionCollaboration | If session collaboration is allowed.
Public property | Export | The export access
Public property | ExportUsers | If Export is set to Restricted, this list contains the users who are allowed to export the document.
Public property | MaxConcurrentSessions | The allowed number of open sessions for this document concurrently. Negative number == unlimited
Public property | Methods | The level of download access.
Public property | SessionTimeout | Time of inactivity in seconds until the server can close the session.
Public property | ZeroFootprintClientURL | The access URL for the Ajax zero-footprint client.

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


DocumentTimeout Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..DocumentTimeout Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
Number of minutes after last registered activity until the document is unloaded from memory.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int DocumentTimeout { get; set; }
Visual Basic
Public Property DocumentTimeout As Integer
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


Download Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..Download Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
The download access

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentDownloadAccess Download { get; set; }
Visual Basic
Public Property Download As DocumentDownloadAccess
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


DownloadUsers Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..DownloadUsers Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
If Download is set to Restricted, this list contains the users who are allowed to download the document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> DownloadUsers { get; private set; }
Visual Basic
Public Property DownloadUsers As List(Of String)
    Get
    Private Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


EnableSessionCollaboration Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..EnableSessionCollaboration Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
If session collaboration is allowed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool EnableSessionCollaboration { get; set; }
Visual Basic
Public Property EnableSessionCollaboration As Boolean
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


Export Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..Export Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
The export access

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentDownloadAccess Export { get; set; }
Visual Basic
Public Property Export As DocumentDownloadAccess
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


ExportUsers Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..ExportUsers Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
If Export is set to Restricted, this list contains the users who are allowed to export the document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> ExportUsers { get; private set; }
Visual Basic
Public Property ExportUsers As List(Of String)
    Get
    Private Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


MaxConcurrentSessions Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..MaxConcurrentSessions Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
The allowed number of open sessions for this document concurrently. Negative number == unlimited

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public uint MaxConcurrentSessions { get; set; }
Visual Basic
Public Property MaxConcurrentSessions As UInteger
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


Methods Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..Methods Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
The level of download access.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentAccessMethods Methods { get; set; }
Visual Basic
Public Property Methods As DocumentAccessMethods
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


SessionTimeout Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..SessionTimeout Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
Time of inactivity in seconds until the server can close the session.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int SessionTimeout { get; set; }
Visual Basic
Public Property SessionTimeout As Integer
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


ZeroFootprintClientURL Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess..::..ZeroFootprintClientURL Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class See Also Send Feedback
The access URL for the Ajax zero-footprint client.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ZeroFootprintClientURL { get; set; }
Visual Basic
Public Property ZeroFootprintClientURL As String
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerAccess Class


DocumentMetaData.DocumentMetaDataServer.DocumentMetaDataServerDocumentLoad Class

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class
DocumentMetaData..::..DocumentMetaDataServer Class Members See Also Send Feedback
The Document Load element of the document meta data data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentMetaDataServerDocumentLoad
Visual Basic
Public Class DocumentMetaDataServerDocumentLoad

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Members


DocumentMetaData.DocumentMetaDataServer.DocumentMetaDataServerDocumentLoad Members

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Members
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class Properties See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad type exposes the following members.

Properties

 | Name | Description
Public property | Mode | The document load mode on this server.
Public property | QlikViewServerClusterNodeId | The id of the QlikView Server cluster node where the document load mode should be set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class


DocumentMetaData.DocumentMetaDataServer.DocumentMetaDataServerDocumentLoad Properties

[image] [image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Properties
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class See Also Send Feedback

The DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad type exposes the following members.

Properties

 | Name | Description
Public property | Mode | The document load mode on this server.
Public property | QlikViewServerClusterNodeId | The id of the QlikView Server cluster node where the document load mode should be set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class


Mode Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad..::..Mode Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class See Also Send Feedback
The document load mode on this server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentLoadMode Mode { get; set; }
Visual Basic
Public Property Mode As DocumentLoadMode
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class


QlikViewServerClusterNodeId Property

[image]

QlikView Management Service API
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad..::..QlikViewServerClusterNodeId Property
DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class See Also Send Feedback
The id of the QlikView Server cluster node where the document load mode should be set

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QlikViewServerClusterNodeId { get; set; }
Visual Basic
Public Property QlikViewServerClusterNodeId As Guid
    Get
    Set

See Also

DocumentMetaData..::..DocumentMetaDataServer..::..DocumentMetaDataServerDocumentLoad Class


DocumentMetaDataScope Enumeration

[image]

QlikView Management Service API
DocumentMetaDataScope Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentMetaDataScope"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum DocumentMetaDataScope
Visual Basic
<FlagsAttribute> _
Public Enumeration DocumentMetaDataScope

Members

Member name | Value | Description
None | 0 |
Authorization | 1 |
DocumentInfo | 2 |
Collaboration | 4 |
Server | 8 |
Licensing | 16 |
All | 65535 |

See Also


DocumentNode Class

[image]

QlikView Management Service API
DocumentNode Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentNode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentNode
Visual Basic
Public Class DocumentNode

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentNode

See Also

DocumentNode Members


DocumentNode Members

[image] [image]

QlikView Management Service API
DocumentNode Members
DocumentNode Class Properties See Also Send Feedback

The DocumentNode type exposes the following members.

Properties

 | Name | Description
Public property | FolderID |
Public property | ID |
Public property | IsOrphan |
Public property | IsSubFolder |
Public property | Name |
Public property | PathName |
Public property | RelativePath |
Public property | TaskCount |
Public property | Type |

See Also

DocumentNode Class


DocumentNode Properties

[image] [image]

QlikView Management Service API
DocumentNode Properties
DocumentNode Class See Also Send Feedback

The DocumentNode type exposes the following members.

Properties

 | Name | Description
Public property | FolderID |
Public property | ID |
Public property | IsOrphan |
Public property | IsSubFolder |
Public property | Name |
Public property | PathName |
Public property | RelativePath |
Public property | TaskCount |
Public property | Type |

See Also

DocumentNode Class


FolderID Property

[image]

QlikView Management Service API
DocumentNode..::..FolderID Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.FolderID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid FolderID { get; set; }
Visual Basic
Public Property FolderID As Guid
    Get
    Set

See Also

DocumentNode Class


ID Property

[image]

QlikView Management Service API
DocumentNode..::..ID Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.ID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; private set; }
Visual Basic
Public Property ID As Guid
    Get
    Private Set

See Also

DocumentNode Class


IsOrphan Property

[image]

QlikView Management Service API
DocumentNode..::..IsOrphan Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.IsOrphan"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IsOrphan { get; set; }
Visual Basic
Public Property IsOrphan As Boolean
    Get
    Set

See Also

DocumentNode Class


IsSubFolder Property

[image]

QlikView Management Service API
DocumentNode..::..IsSubFolder Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.IsSubFolder"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IsSubFolder { get; set; }
Visual Basic
Public Property IsSubFolder As Boolean
    Get
    Set

See Also

DocumentNode Class


Name Property

[image]

QlikView Management Service API
DocumentNode..::..Name Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.Name"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

DocumentNode Class


PathName Property

[image]

QlikView Management Service API
DocumentNode..::..PathName Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.PathName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string PathName { get; }
Visual Basic
Public ReadOnly Property PathName As String
    Get

See Also

DocumentNode Class


RelativePath Property

[image]

QlikView Management Service API
DocumentNode..::..RelativePath Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.RelativePath"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string RelativePath { get; set; }
Visual Basic
Public Property RelativePath As String
    Get
    Set

See Also

DocumentNode Class


TaskCount Property

[image]

QlikView Management Service API
DocumentNode..::..TaskCount Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.TaskCount"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int TaskCount { get; set; }
Visual Basic
Public Property TaskCount As Integer
    Get
    Set

See Also

DocumentNode Class


Type Property

[image]

QlikView Management Service API
DocumentNode..::..Type Property
DocumentNode Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentNode.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentType Type { get; set; }
Visual Basic
Public Property Type As DocumentType
    Get
    Set

See Also

DocumentNode Class


DocumentTask Class

[image]

QlikView Management Service API
DocumentTask Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DocumentTask : IClipboardEnabled
Visual Basic
Public Class DocumentTask _
    Implements IClipboardEnabled

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask

See Also

DocumentTask Members


DocumentTask Members

[image] [image]

QlikView Management Service API
DocumentTask Members
DocumentTask Class Properties See Also Send Feedback

The DocumentTask type exposes the following members.

Properties

 | Name | Description
Public property | Distribute |
Public property | Document |
Public property | DocumentInfo |
Public property | General |
Public property | ID |
Public property | QDSID |
Public property | Reduce |
Public property | Reload |
Public property | Scope |
Public property | Server |
Public property | Triggering |

See Also

DocumentTask Class


DocumentTask Properties

[image] [image]

QlikView Management Service API
DocumentTask Properties
DocumentTask Class See Also Send Feedback

The DocumentTask type exposes the following members.

Properties

 | Name | Description
Public property | Distribute |
Public property | Document |
Public property | DocumentInfo |
Public property | General |
Public property | ID |
Public property | QDSID |
Public property | Reduce |
Public property | Reload |
Public property | Scope |
Public property | Server |
Public property | Triggering |

See Also

DocumentTask Class


Distribute Property

[image]

QlikView Management Service API
DocumentTask..::..Distribute Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.Distribute"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskDistribute Distribute { get; private set; }
Visual Basic
Public Property Distribute As DocumentTask..::..TaskDistribute
    Get
    Private Set

See Also

DocumentTask Class


Document Property

[image]

QlikView Management Service API
DocumentTask..::..Document Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.Document"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentNode Document { get; set; }
Visual Basic
Public Property Document As DocumentNode
    Get
    Set

See Also

DocumentTask Class


DocumentInfo Property

[image]

QlikView Management Service API
DocumentTask..::..DocumentInfo Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.DocumentInfo"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskDocumentInfo DocumentInfo { get; private set; }
Visual Basic
Public Property DocumentInfo As DocumentTask..::..TaskDocumentInfo
    Get
    Private Set

See Also

DocumentTask Class


General Property

[image]

QlikView Management Service API
DocumentTask..::..General Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.General"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskGeneral General { get; private set; }
Visual Basic
Public Property General As DocumentTask..::..TaskGeneral
    Get
    Private Set

See Also

DocumentTask Class


ID Property

[image]

QlikView Management Service API
DocumentTask..::..ID Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.ID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

DocumentTask Class


QDSID Property

[image]

QlikView Management Service API
DocumentTask..::..QDSID Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.QDSID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QDSID { get; set; }
Visual Basic
Public Property QDSID As Guid
    Get
    Set

See Also

DocumentTask Class


Reduce Property

[image]

QlikView Management Service API
DocumentTask..::..Reduce Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.Reduce"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskReduce Reduce { get; private set; }
Visual Basic
Public Property Reduce As DocumentTask..::..TaskReduce
    Get
    Private Set

See Also

DocumentTask Class


Reload Property

[image]

QlikView Management Service API
DocumentTask..::..Reload Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.Reload"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskReload Reload { get; private set; }
Visual Basic
Public Property Reload As DocumentTask..::..TaskReload
    Get
    Private Set

See Also

DocumentTask Class


Scope Property

[image]

QlikView Management Service API
DocumentTask..::..Scope Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.Scope"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTaskScope Scope { get; private set; }
Visual Basic
Public Property Scope As DocumentTaskScope
    Get
    Private Set

See Also

DocumentTask Class


Server Property

[image]

QlikView Management Service API
DocumentTask..::..Server Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.Server"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskServer Server { get; private set; }
Visual Basic
Public Property Server As DocumentTask..::..TaskServer
    Get
    Private Set

See Also

DocumentTask Class


Triggering Property

[image]

QlikView Management Service API
DocumentTask..::..Triggering Property
DocumentTask Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.Triggering"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskTriggering Triggering { get; private set; }
Visual Basic
Public Property Triggering As DocumentTask..::..TaskTriggering
    Get
    Private Set

See Also

DocumentTask Class


DocumentTask.TaskDistribute Class

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute Class
DocumentTask Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistribute
Visual Basic
Public Class TaskDistribute

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskDistribute

See Also

DocumentTask..::..TaskDistribute Members


DocumentTask.TaskDistribute Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute Members
DocumentTask..::..TaskDistribute Class Properties See Also Send Feedback

The DocumentTask..::..TaskDistribute type exposes the following members.

Properties

 | Name | Description
Public property | Dynamic |
Public property | IsDistributing |
Public property | Notification |
Public property | Output |
Public property | Static |

See Also

DocumentTask..::..TaskDistribute Class


DocumentTask.TaskDistribute Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute Properties
DocumentTask..::..TaskDistribute Class See Also Send Feedback

The DocumentTask..::..TaskDistribute type exposes the following members.

Properties

 | Name | Description
Public property | Dynamic |
Public property | IsDistributing |
Public property | Notification |
Public property | Output |
Public property | Static |

See Also

DocumentTask..::..TaskDistribute Class


Dynamic Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..Dynamic Property
DocumentTask..::..TaskDistribute Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.Dynamic"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Dynamic { get; private set; }
Visual Basic
Public Property Dynamic As DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic
    Get
    Private Set

See Also

DocumentTask..::..TaskDistribute Class


IsDistributing Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..IsDistributing Property
DocumentTask..::..TaskDistribute Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.IsDistributing"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IsDistributing { get; }
Visual Basic
Public ReadOnly Property IsDistributing As Boolean
    Get

See Also

DocumentTask..::..TaskDistribute Class


Notification Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..Notification Property
DocumentTask..::..TaskDistribute Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.Notification"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Notification { get; private set; }
Visual Basic
Public Property Notification As DocumentTask..::..TaskDistribute..::..TaskDistributeNotification
    Get
    Private Set

See Also

DocumentTask..::..TaskDistribute Class


Output Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..Output Property
DocumentTask..::..TaskDistribute Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.Output"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Output { get; private set; }
Visual Basic
Public Property Output As DocumentTask..::..TaskDistribute..::..TaskDistributeOutput
    Get
    Private Set

See Also

DocumentTask..::..TaskDistribute Class


Static Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..Static Property
DocumentTask..::..TaskDistribute Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.Static"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Static { get; private set; }
Visual Basic
Public Property Static As DocumentTask..::..TaskDistribute..::..TaskDistributeStatic
    Get
    Private Set

See Also

DocumentTask..::..TaskDistribute Class


DocumentTask.TaskDistribute.TaskDistributeDynamic Class

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class
DocumentTask..::..TaskDistribute Class Members See Also Send Feedback
The Distribute Dynamic element of the document task data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributeDynamic
Visual Basic
Public Class TaskDistributeDynamic

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Members


DocumentTask.TaskDistribute.TaskDistributeDynamic Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Members
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class Properties See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic type exposes the following members.

Properties

 | Name | Description
Public property | Destinations |
Public property | FieldName |
Public property | IdentityType |
Public property | ValidateEmails |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class


DocumentTask.TaskDistribute.TaskDistributeDynamic Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Properties
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic type exposes the following members.

Properties

 | Name | Description
Public property | Destinations |
Public property | FieldName |
Public property | IdentityType |
Public property | ValidateEmails |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class


Destinations Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic..::..Destinations Property
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeDynamic.Destinations"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<TaskDistributionDestination> Destinations { get; private set; }
Visual Basic
Public Property Destinations As List(Of TaskDistributionDestination)
    Get
    Private Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class


FieldName Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic..::..FieldName Property
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeDynamic.FieldName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string FieldName { get; set; }
Visual Basic
Public Property FieldName As String
    Get
    Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class


IdentityType Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic..::..IdentityType Property
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeDynamic.IdentityType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public UserIdentityValueType IdentityType { get; set; }
Visual Basic
Public Property IdentityType As UserIdentityValueType
    Get
    Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class


ValidateEmails Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic..::..ValidateEmails Property
DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeDynamic.ValidateEmails"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool ValidateEmails { get; set; }
Visual Basic
Public Property ValidateEmails As Boolean
    Get
    Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeDynamic Class


DocumentTask.TaskDistribute.TaskDistributeNotification Class

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Class
DocumentTask..::..TaskDistribute Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeNotification"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributeNotification
Visual Basic
Public Class TaskDistributeNotification

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskDistribute..::..TaskDistributeNotification

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Members


DocumentTask.TaskDistribute.TaskDistributeNotification Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Members
DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Class Properties See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeNotification type exposes the following members.

Properties

 | Name | Description
Public property | SendNotificationEmail |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Class


DocumentTask.TaskDistribute.TaskDistributeNotification Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Properties
DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Class See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeNotification type exposes the following members.

Properties

 | Name | Description
Public property | SendNotificationEmail |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Class


SendNotificationEmail Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeNotification..::..SendNotificationEmail Property
DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeNotification.SendNotificationEmail"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool SendNotificationEmail { get; set; }
Visual Basic
Public Property SendNotificationEmail As Boolean
    Get
    Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeNotification Class


DocumentTask.TaskDistribute.TaskDistributeOutput Class

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class
DocumentTask..::..TaskDistribute Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeOutput"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributeOutput
Visual Basic
Public Class TaskDistributeOutput

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskDistribute..::..TaskDistributeOutput

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Members


DocumentTask.TaskDistribute.TaskDistributeOutput Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Members
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class Properties See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeOutput type exposes the following members.

Properties

 | Name | Description
Public property | PDF |
Public property | Type |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class


DocumentTask.TaskDistribute.TaskDistributeOutput Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Properties
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeOutput type exposes the following members.

Properties

 | Name | Description
Public property | PDF |
Public property | Type |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class


PDF Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..PDF Property
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeOutput.PDF"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF PDF { get; private set; }
Visual Basic
Public Property PDF As DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF
    Get
    Private Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class


Type Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..Type Property
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeOutput.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskDistributionOutputType Type { get; set; }
Visual Basic
Public Property Type As TaskDistributionOutputType
    Get
    Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class


DocumentTask.TaskDistribute.TaskDistributeOutput.TaskDistributeOutputPDF Class

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeOutput.TaskDistributeOutputPDF"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributeOutputPDF
Visual Basic
Public Class TaskDistributeOutputPDF

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Members


DocumentTask.TaskDistribute.TaskDistributeOutput.TaskDistributeOutputPDF Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Members
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class Properties See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF type exposes the following members.

Properties

 | Name | Description
Public property | ReportID |
Public property | ReportName |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class


DocumentTask.TaskDistribute.TaskDistributeOutput.TaskDistributeOutputPDF Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Properties
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF type exposes the following members.

Properties

 | Name | Description
Public property | ReportID |
Public property | ReportName |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class


ReportID Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF..::..ReportID Property
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeOutput.TaskDistributeOutputPDF.ReportID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ReportID { get; set; }
Visual Basic
Public Property ReportID As String
    Get
    Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class


ReportName Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF..::..ReportName Property
DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeOutput.TaskDistributeOutputPDF.ReportName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ReportName { get; set; }
Visual Basic
Public Property ReportName As String
    Get
    Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeOutput..::..TaskDistributeOutputPDF Class


DocumentTask.TaskDistribute.TaskDistributeStatic Class

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Class
DocumentTask..::..TaskDistribute Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeStatic"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributeStatic
Visual Basic
Public Class TaskDistributeStatic

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskDistribute..::..TaskDistributeStatic

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Members


DocumentTask.TaskDistribute.TaskDistributeStatic Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Members
DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Class Properties See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeStatic type exposes the following members.

Properties

 | Name | Description
Public property | DistributionEntries |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Class


DocumentTask.TaskDistribute.TaskDistributeStatic Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Properties
DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Class See Also Send Feedback

The DocumentTask..::..TaskDistribute..::..TaskDistributeStatic type exposes the following members.

Properties

 | Name | Description
Public property | DistributionEntries |

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Class


DistributionEntries Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDistribute..::..TaskDistributeStatic..::..DistributionEntries Property
DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDistribute.TaskDistributeStatic.DistributionEntries"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<TaskDistributionEntry> DistributionEntries { get; private set; }
Visual Basic
Public Property DistributionEntries As List(Of TaskDistributionEntry)
    Get
    Private Set

See Also

DocumentTask..::..TaskDistribute..::..TaskDistributeStatic Class


DocumentTask.TaskDocumentInfo Class

[image]

QlikView Management Service API
DocumentTask..::..TaskDocumentInfo Class
DocumentTask Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskDocumentInfo"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDocumentInfo
Visual Basic
Public Class TaskDocumentInfo

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskDocumentInfo

See Also

DocumentTask..::..TaskDocumentInfo Members


DocumentTask.TaskDocumentInfo Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDocumentInfo Members
DocumentTask..::..TaskDocumentInfo Class Properties See Also Send Feedback

The DocumentTask..::..TaskDocumentInfo type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | The list of Attributes of this document
Public property | Category |
Public property | Description |

See Also

DocumentTask..::..TaskDocumentInfo Class


DocumentTask.TaskDocumentInfo Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskDocumentInfo Properties
DocumentTask..::..TaskDocumentInfo Class See Also Send Feedback

The DocumentTask..::..TaskDocumentInfo type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | The list of Attributes of this document
Public property | Category |
Public property | Description |

See Also

DocumentTask..::..TaskDocumentInfo Class


Attributes Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDocumentInfo..::..Attributes Property
DocumentTask..::..TaskDocumentInfo Class See Also Send Feedback
The list of Attributes of this document

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DocumentAttribute> Attributes { get; private set; }
Visual Basic
Public Property Attributes As List(Of DocumentAttribute)
    Get
    Private Set

See Also

DocumentTask..::..TaskDocumentInfo Class


Category Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDocumentInfo..::..Category Property
DocumentTask..::..TaskDocumentInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDocumentInfo.Category"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set

See Also

DocumentTask..::..TaskDocumentInfo Class


Description Property

[image]

QlikView Management Service API
DocumentTask..::..TaskDocumentInfo..::..Description Property
DocumentTask..::..TaskDocumentInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskDocumentInfo.Description"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set

See Also

DocumentTask..::..TaskDocumentInfo Class


DocumentTask.TaskGeneral Class

[image]

QlikView Management Service API
DocumentTask..::..TaskGeneral Class
DocumentTask Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskGeneral"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskGeneral
Visual Basic
Public Class TaskGeneral

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskGeneral

See Also

DocumentTask..::..TaskGeneral Members


DocumentTask.TaskGeneral Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskGeneral Members
DocumentTask..::..TaskGeneral Class Properties See Also Send Feedback

The DocumentTask..::..TaskGeneral type exposes the following members.

Properties

 | Name | Description
Public property | Enabled |
Public property | TaskDescription |
Public property | TaskName |
Public property | TaskWizardTrack |

See Also

DocumentTask..::..TaskGeneral Class


DocumentTask.TaskGeneral Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskGeneral Properties
DocumentTask..::..TaskGeneral Class See Also Send Feedback

The DocumentTask..::..TaskGeneral type exposes the following members.

Properties

 | Name | Description
Public property | Enabled |
Public property | TaskDescription |
Public property | TaskName |
Public property | TaskWizardTrack |

See Also

DocumentTask..::..TaskGeneral Class


Enabled Property

[image]

QlikView Management Service API
DocumentTask..::..TaskGeneral..::..Enabled Property
DocumentTask..::..TaskGeneral Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskGeneral.Enabled"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

See Also

DocumentTask..::..TaskGeneral Class


TaskDescription Property

[image]

QlikView Management Service API
DocumentTask..::..TaskGeneral..::..TaskDescription Property
DocumentTask..::..TaskGeneral Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskGeneral.TaskDescription"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string TaskDescription { get; set; }
Visual Basic
Public Property TaskDescription As String
    Get
    Set

See Also

DocumentTask..::..TaskGeneral Class


TaskName Property

[image]

QlikView Management Service API
DocumentTask..::..TaskGeneral..::..TaskName Property
DocumentTask..::..TaskGeneral Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskGeneral.TaskName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string TaskName { get; set; }
Visual Basic
Public Property TaskName As String
    Get
    Set

See Also

DocumentTask..::..TaskGeneral Class


TaskWizardTrack Property

[image]

QlikView Management Service API
DocumentTask..::..TaskGeneral..::..TaskWizardTrack Property
DocumentTask..::..TaskGeneral Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskGeneral.TaskWizardTrack"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskWizardTrack TaskWizardTrack { get; set; }
Visual Basic
Public Property TaskWizardTrack As TaskWizardTrack
    Get
    Set

See Also

DocumentTask..::..TaskGeneral Class


DocumentTask.TaskReduce Class

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce Class
DocumentTask Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskReduce
Visual Basic
Public Class TaskReduce

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskReduce

See Also

DocumentTask..::..TaskReduce Members


DocumentTask.TaskReduce Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskReduce Members
DocumentTask..::..TaskReduce Class Properties See Also Send Feedback

The DocumentTask..::..TaskReduce type exposes the following members.

Properties

 | Name | Description
Public property | DocumentNameTemplate |
Public property | Dynamic |
Public property | Static |

See Also

DocumentTask..::..TaskReduce Class


DocumentTask.TaskReduce Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskReduce Properties
DocumentTask..::..TaskReduce Class See Also Send Feedback

The DocumentTask..::..TaskReduce type exposes the following members.

Properties

 | Name | Description
Public property | DocumentNameTemplate |
Public property | Dynamic |
Public property | Static |

See Also

DocumentTask..::..TaskReduce Class


DocumentNameTemplate Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..DocumentNameTemplate Property
DocumentTask..::..TaskReduce Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce.DocumentNameTemplate"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string DocumentNameTemplate { get; set; }
Visual Basic
Public Property DocumentNameTemplate As String
    Get
    Set

See Also

DocumentTask..::..TaskReduce Class


Dynamic Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..Dynamic Property
DocumentTask..::..TaskReduce Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce.Dynamic"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskReduce..::..TaskReduceDynamic Dynamic { get; private set; }
Visual Basic
Public Property Dynamic As DocumentTask..::..TaskReduce..::..TaskReduceDynamic
    Get
    Private Set

See Also

DocumentTask..::..TaskReduce Class


Static Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..Static Property
DocumentTask..::..TaskReduce Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce.Static"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskReduce..::..TaskReduceStatic Static { get; private set; }
Visual Basic
Public Property Static As DocumentTask..::..TaskReduce..::..TaskReduceStatic
    Get
    Private Set

See Also

DocumentTask..::..TaskReduce Class


DocumentTask.TaskReduce.TaskReduceDynamic Class

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class
DocumentTask..::..TaskReduce Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce.TaskReduceDynamic"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskReduceDynamic
Visual Basic
Public Class TaskReduceDynamic

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskReduce..::..TaskReduceDynamic

See Also

DocumentTask..::..TaskReduce..::..TaskReduceDynamic Members


DocumentTask.TaskReduce.TaskReduceDynamic Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceDynamic Members
DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class Properties See Also Send Feedback

The DocumentTask..::..TaskReduce..::..TaskReduceDynamic type exposes the following members.

Properties

 | Name | Description
Public property | FieldName |
Public property | Type |

See Also

DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class


DocumentTask.TaskReduce.TaskReduceDynamic Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceDynamic Properties
DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class See Also Send Feedback

The DocumentTask..::..TaskReduce..::..TaskReduceDynamic type exposes the following members.

Properties

 | Name | Description
Public property | FieldName |
Public property | Type |

See Also

DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class


FieldName Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceDynamic..::..FieldName Property
DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce.TaskReduceDynamic.FieldName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string FieldName { get; set; }
Visual Basic
Public Property FieldName As String
    Get
    Set

See Also

DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class


Type Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceDynamic..::..Type Property
DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce.TaskReduceDynamic.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskReductionType Type { get; set; }
Visual Basic
Public Property Type As TaskReductionType
    Get
    Set

See Also

DocumentTask..::..TaskReduce..::..TaskReduceDynamic Class


DocumentTask.TaskReduce.TaskReduceStatic Class

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceStatic Class
DocumentTask..::..TaskReduce Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce.TaskReduceStatic"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskReduceStatic
Visual Basic
Public Class TaskReduceStatic

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskReduce..::..TaskReduceStatic

See Also

DocumentTask..::..TaskReduce..::..TaskReduceStatic Members


DocumentTask.TaskReduce.TaskReduceStatic Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceStatic Members
DocumentTask..::..TaskReduce..::..TaskReduceStatic Class Properties See Also Send Feedback

The DocumentTask..::..TaskReduce..::..TaskReduceStatic type exposes the following members.

Properties

 | Name | Description
Public property | Reductions |

See Also

DocumentTask..::..TaskReduce..::..TaskReduceStatic Class


DocumentTask.TaskReduce.TaskReduceStatic Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceStatic Properties
DocumentTask..::..TaskReduce..::..TaskReduceStatic Class See Also Send Feedback

The DocumentTask..::..TaskReduce..::..TaskReduceStatic type exposes the following members.

Properties

 | Name | Description
Public property | Reductions |

See Also

DocumentTask..::..TaskReduce..::..TaskReduceStatic Class


Reductions Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReduce..::..TaskReduceStatic..::..Reductions Property
DocumentTask..::..TaskReduce..::..TaskReduceStatic Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReduce.TaskReduceStatic.Reductions"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<TaskReduction> Reductions { get; private set; }
Visual Basic
Public Property Reductions As List(Of TaskReduction)
    Get
    Private Set

See Also

DocumentTask..::..TaskReduce..::..TaskReduceStatic Class


DocumentTask.TaskReload Class

[image]

QlikView Management Service API
DocumentTask..::..TaskReload Class
DocumentTask Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskReload"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskReload
Visual Basic
Public Class TaskReload

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskReload

See Also

DocumentTask..::..TaskReload Members


DocumentTask.TaskReload Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskReload Members
DocumentTask..::..TaskReload Class Properties See Also Send Feedback

The DocumentTask..::..TaskReload type exposes the following members.

Properties

 | Name | Description
Public property | Mode |
Public property | ScriptParameterName |
Public property | ScriptParameterValue |
Public property | ScriptParameterValueField |
Public property | SectionAccessMode |
Public property | SectionAccessPassword |
Public property | SectionAccessUserName |

See Also

DocumentTask..::..TaskReload Class


DocumentTask.TaskReload Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskReload Properties
DocumentTask..::..TaskReload Class See Also Send Feedback

The DocumentTask..::..TaskReload type exposes the following members.

Properties

 | Name | Description
Public property | Mode |
Public property | ScriptParameterName |
Public property | ScriptParameterValue |
Public property | ScriptParameterValueField |
Public property | SectionAccessMode |
Public property | SectionAccessPassword |
Public property | SectionAccessUserName |

See Also

DocumentTask..::..TaskReload Class


Mode Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReload..::..Mode Property
DocumentTask..::..TaskReload Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReload.Mode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskReloadMode Mode { get; set; }
Visual Basic
Public Property Mode As TaskReloadMode
    Get
    Set

See Also

DocumentTask..::..TaskReload Class


ScriptParameterName Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReload..::..ScriptParameterName Property
DocumentTask..::..TaskReload Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReload.ScriptParameterName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ScriptParameterName { get; set; }
Visual Basic
Public Property ScriptParameterName As String
    Get
    Set

See Also

DocumentTask..::..TaskReload Class


ScriptParameterValue Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReload..::..ScriptParameterValue Property
DocumentTask..::..TaskReload Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReload.ScriptParameterValue"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ScriptParameterValue { get; set; }
Visual Basic
Public Property ScriptParameterValue As String
    Get
    Set

See Also

DocumentTask..::..TaskReload Class


ScriptParameterValueField Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReload..::..ScriptParameterValueField Property
DocumentTask..::..TaskReload Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReload.ScriptParameterValueField"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ScriptParameterValueField { get; set; }
Visual Basic
Public Property ScriptParameterValueField As String
    Get
    Set

See Also

DocumentTask..::..TaskReload Class


SectionAccessMode Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReload..::..SectionAccessMode Property
DocumentTask..::..TaskReload Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReload.SectionAccessMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QDSSectionAccessMode SectionAccessMode { get; set; }
Visual Basic
Public Property SectionAccessMode As QDSSectionAccessMode
    Get
    Set

See Also

DocumentTask..::..TaskReload Class


SectionAccessPassword Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReload..::..SectionAccessPassword Property
DocumentTask..::..TaskReload Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReload.SectionAccessPassword"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string SectionAccessPassword { get; set; }
Visual Basic
Public Property SectionAccessPassword As String
    Get
    Set

See Also

DocumentTask..::..TaskReload Class


SectionAccessUserName Property

[image]

QlikView Management Service API
DocumentTask..::..TaskReload..::..SectionAccessUserName Property
DocumentTask..::..TaskReload Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskReload.SectionAccessUserName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string SectionAccessUserName { get; set; }
Visual Basic
Public Property SectionAccessUserName As String
    Get
    Set

See Also

DocumentTask..::..TaskReload Class


DocumentTask.TaskServer Class

[image]

QlikView Management Service API
DocumentTask..::..TaskServer Class
DocumentTask Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskServer"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskServer
Visual Basic
Public Class TaskServer

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskServer

See Also

DocumentTask..::..TaskServer Members


DocumentTask.TaskServer Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer Members
DocumentTask..::..TaskServer Class Properties See Also Send Feedback

The DocumentTask..::..TaskServer type exposes the following members.

Properties

 | Name | Description
Public property | Access | The access metadata .
Public property | Collaboration | The collaboration metadata .
Public property | DocumentLoading | The DocumentLoading metadata.
Public property | EnableAuditLogging | Controls whether audit logging is enabled on the document task.

See Also

DocumentTask..::..TaskServer Class


DocumentTask.TaskServer Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer Properties
DocumentTask..::..TaskServer Class See Also Send Feedback

The DocumentTask..::..TaskServer type exposes the following members.

Properties

 | Name | Description
Public property | Access | The access metadata .
Public property | Collaboration | The collaboration metadata .
Public property | DocumentLoading | The DocumentLoading metadata.
Public property | EnableAuditLogging | Controls whether audit logging is enabled on the document task.

See Also

DocumentTask..::..TaskServer Class


Access Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..Access Property
DocumentTask..::..TaskServer Class See Also Send Feedback
The access metadata .

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskServer..::..TaskServerAccess Access { get; private set; }
Visual Basic
Public Property Access As DocumentTask..::..TaskServer..::..TaskServerAccess
    Get
    Private Set

See Also

DocumentTask..::..TaskServer Class


Collaboration Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..Collaboration Property
DocumentTask..::..TaskServer Class See Also Send Feedback
The collaboration metadata .

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskServer..::..TaskServerCollaboration Collaboration { get; private set; }
Visual Basic
Public Property Collaboration As DocumentTask..::..TaskServer..::..TaskServerCollaboration
    Get
    Private Set

See Also

DocumentTask..::..TaskServer Class


DocumentLoading Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..DocumentLoading Property
DocumentTask..::..TaskServer Class See Also Send Feedback
The DocumentLoading metadata.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentTask..::..TaskServer..::..TaskServerDocumentLoading DocumentLoading { get; private set; }
Visual Basic
Public Property DocumentLoading As DocumentTask..::..TaskServer..::..TaskServerDocumentLoading
    Get
    Private Set

See Also

DocumentTask..::..TaskServer Class


EnableAuditLogging Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..EnableAuditLogging Property
DocumentTask..::..TaskServer Class See Also Send Feedback
Controls whether audit logging is enabled on the document task.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool EnableAuditLogging { get; set; }
Visual Basic
Public Property EnableAuditLogging As Boolean
    Get
    Set

See Also

DocumentTask..::..TaskServer Class


DocumentTask.TaskServer.TaskServerAccess Class

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess Class
DocumentTask..::..TaskServer Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskServer.TaskServerAccess"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskServerAccess
Visual Basic
Public Class TaskServerAccess

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskServer..::..TaskServerAccess

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Members


DocumentTask.TaskServer.TaskServerAccess Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess Members
DocumentTask..::..TaskServer..::..TaskServerAccess Class Properties See Also Send Feedback

The DocumentTask..::..TaskServer..::..TaskServerAccess type exposes the following members.

Properties

 | Name | Description
Public property | DocumentTimeout | Number of minutes after last registered activity until the document is unloaded from memory.
Public property | Download | The level of download access.
Public property | DownloadUsers | If DownloadAccess is set to Restricted, this list contains the users who are allowed to download the document.
Public property | EnableSessionCollaboration | If session collaboration is allowed.
Public property | Export | The level of export access.
Public property | ExportUsers | If ExportAccess is set to Restricted, this list contains the users who are allowed to export the document.
Public property | MaxConcurrentSessions | The allowed number of open sessions for this document concurrently. Negative number == unlimited
Public property | Methods | The method for accessing this document.
Public property | SessionTimeout | Time of inactivity in seconds until the server can close the session.
Public property | ZeroFootprintClientURL | The URL of the AJAX zero-footprint client.

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


DocumentTask.TaskServer.TaskServerAccess Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess Properties
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback

The DocumentTask..::..TaskServer..::..TaskServerAccess type exposes the following members.

Properties

 | Name | Description
Public property | DocumentTimeout | Number of minutes after last registered activity until the document is unloaded from memory.
Public property | Download | The level of download access.
Public property | DownloadUsers | If DownloadAccess is set to Restricted, this list contains the users who are allowed to download the document.
Public property | EnableSessionCollaboration | If session collaboration is allowed.
Public property | Export | The level of export access.
Public property | ExportUsers | If ExportAccess is set to Restricted, this list contains the users who are allowed to export the document.
Public property | MaxConcurrentSessions | The allowed number of open sessions for this document concurrently. Negative number == unlimited
Public property | Methods | The method for accessing this document.
Public property | SessionTimeout | Time of inactivity in seconds until the server can close the session.
Public property | ZeroFootprintClientURL | The URL of the AJAX zero-footprint client.

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


DocumentTimeout Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..DocumentTimeout Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
Number of minutes after last registered activity until the document is unloaded from memory.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int DocumentTimeout { get; set; }
Visual Basic
Public Property DocumentTimeout As Integer
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


Download Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..Download Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
The level of download access.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentDownloadAccess Download { get; set; }
Visual Basic
Public Property Download As DocumentDownloadAccess
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


DownloadUsers Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..DownloadUsers Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
If DownloadAccess is set to Restricted, this list contains the users who are allowed to download the document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> DownloadUsers { get; private set; }
Visual Basic
Public Property DownloadUsers As List(Of String)
    Get
    Private Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


EnableSessionCollaboration Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..EnableSessionCollaboration Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
If session collaboration is allowed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool EnableSessionCollaboration { get; set; }
Visual Basic
Public Property EnableSessionCollaboration As Boolean
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


Export Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..Export Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
The level of export access.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentDownloadAccess Export { get; set; }
Visual Basic
Public Property Export As DocumentDownloadAccess
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


ExportUsers Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..ExportUsers Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
If ExportAccess is set to Restricted, this list contains the users who are allowed to export the document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> ExportUsers { get; private set; }
Visual Basic
Public Property ExportUsers As List(Of String)
    Get
    Private Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


MaxConcurrentSessions Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..MaxConcurrentSessions Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
The allowed number of open sessions for this document concurrently. Negative number == unlimited

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public uint MaxConcurrentSessions { get; set; }
Visual Basic
Public Property MaxConcurrentSessions As UInteger
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


Methods Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..Methods Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
The method for accessing this document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentAccessMethods Methods { get; set; }
Visual Basic
Public Property Methods As DocumentAccessMethods
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


SessionTimeout Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..SessionTimeout Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
Time of inactivity in seconds until the server can close the session.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int SessionTimeout { get; set; }
Visual Basic
Public Property SessionTimeout As Integer
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


ZeroFootprintClientURL Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerAccess..::..ZeroFootprintClientURL Property
DocumentTask..::..TaskServer..::..TaskServerAccess Class See Also Send Feedback
The URL of the AJAX zero-footprint client.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ZeroFootprintClientURL { get; set; }
Visual Basic
Public Property ZeroFootprintClientURL As String
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerAccess Class


DocumentTask.TaskServer.TaskServerCollaboration Class

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerCollaboration Class
DocumentTask..::..TaskServer Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskServer.TaskServerCollaboration"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskServerCollaboration
Visual Basic
Public Class TaskServerCollaboration

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskServer..::..TaskServerCollaboration

See Also

DocumentTask..::..TaskServer..::..TaskServerCollaboration Members


DocumentTask.TaskServer.TaskServerCollaboration Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerCollaboration Members
DocumentTask..::..TaskServer..::..TaskServerCollaboration Class Properties See Also Send Feedback

The DocumentTask..::..TaskServer..::..TaskServerCollaboration type exposes the following members.

Properties

 | Name | Description
Public property | CreationMode |
Public property | CreatorUserNames |

See Also

DocumentTask..::..TaskServer..::..TaskServerCollaboration Class


DocumentTask.TaskServer.TaskServerCollaboration Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerCollaboration Properties
DocumentTask..::..TaskServer..::..TaskServerCollaboration Class See Also Send Feedback

The DocumentTask..::..TaskServer..::..TaskServerCollaboration type exposes the following members.

Properties

 | Name | Description
Public property | CreationMode |
Public property | CreatorUserNames |

See Also

DocumentTask..::..TaskServer..::..TaskServerCollaboration Class


CreationMode Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerCollaboration..::..CreationMode Property
DocumentTask..::..TaskServer..::..TaskServerCollaboration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskServer.TaskServerCollaboration.CreationMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentCollaborationCreationMode CreationMode { get; set; }
Visual Basic
Public Property CreationMode As DocumentCollaborationCreationMode
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerCollaboration Class


CreatorUserNames Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerCollaboration..::..CreatorUserNames Property
DocumentTask..::..TaskServer..::..TaskServerCollaboration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskServer.TaskServerCollaboration.CreatorUserNames"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> CreatorUserNames { get; private set; }
Visual Basic
Public Property CreatorUserNames As List(Of String)
    Get
    Private Set

See Also

DocumentTask..::..TaskServer..::..TaskServerCollaboration Class


DocumentTask.TaskServer.TaskServerDocumentLoading Class

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Class
DocumentTask..::..TaskServer Class Members See Also Send Feedback
The Server document loading element of the document task data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskServerDocumentLoading
Visual Basic
Public Class TaskServerDocumentLoading

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskServer..::..TaskServerDocumentLoading

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Members


DocumentTask.TaskServer.TaskServerDocumentLoading Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Members
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Class Properties See Also Send Feedback

The DocumentTask..::..TaskServer..::..TaskServerDocumentLoading type exposes the following members.

Properties

 | Name | Description
Public property | ServerSettings | Setting if the document is allowed to load or be preloaded on the server.

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Class


DocumentTask.TaskServer.TaskServerDocumentLoading Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Properties
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Class See Also Send Feedback

The DocumentTask..::..TaskServer..::..TaskServerDocumentLoading type exposes the following members.

Properties

 | Name | Description
Public property | ServerSettings | Setting if the document is allowed to load or be preloaded on the server.

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Class


ServerSettings Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..ServerSettings Property
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Class See Also Send Feedback
Setting if the document is allowed to load or be preloaded on the server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting> ServerSettings { get; set; }
Visual Basic
Public Property ServerSettings As List(Of DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting)
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Class


DocumentTask.TaskServer.TaskServerDocumentLoading.TaskServerDocumentLoadServerSetting Class

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading Class Members See Also Send Feedback
The Document Load element of the document meta data data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskServerDocumentLoadServerSetting
Visual Basic
Public Class TaskServerDocumentLoadServerSetting

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Members


DocumentTask.TaskServer.TaskServerDocumentLoading.TaskServerDocumentLoadServerSetting Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Members
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class Properties See Also Send Feedback

The Server document loading element of the document task data object.

The DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting type exposes the following members.

Properties

 | Name | Description
Public property | ClusterSettings | Setting if the document is allowed to load or be preloaded on the cluster node.
Public property | Mode | Setting if the document is allowed to load or be preloaded on the server.
Public property | QlikViewServerId | The id of the QlikView Server resource where the document load mode should be set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class


DocumentTask.TaskServer.TaskServerDocumentLoading.TaskServerDocumentLoadServerSetting Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Properties
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class See Also Send Feedback

The DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting type exposes the following members.

Properties

 | Name | Description
Public property | ClusterSettings | Setting if the document is allowed to load or be preloaded on the cluster node.
Public property | Mode | Setting if the document is allowed to load or be preloaded on the server.
Public property | QlikViewServerId | The id of the QlikView Server resource where the document load mode should be set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class


ClusterSettings Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..ClusterSettings Property
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class See Also Send Feedback
Setting if the document is allowed to load or be preloaded on the cluster node.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting> ClusterSettings { get; set; }
Visual Basic
Public Property ClusterSettings As List(Of DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting)
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class


Mode Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..Mode Property
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class See Also Send Feedback
Setting if the document is allowed to load or be preloaded on the server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public ServerDocumentLoadMode Mode { get; set; }
Visual Basic
Public Property Mode As ServerDocumentLoadMode
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class


QlikViewServerId Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..QlikViewServerId Property
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class See Also Send Feedback
The id of the QlikView Server resource where the document load mode should be set

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QlikViewServerId { get; set; }
Visual Basic
Public Property QlikViewServerId As Guid
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class


DocumentTask.TaskServer.TaskServerDocumentLoading.TaskServerDocumentLoadServerSetting.TaskDocumentLoadClusterSetting Class

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting Class Members See Also Send Feedback
The Document Load element of the document meta data data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDocumentLoadClusterSetting
Visual Basic
Public Class TaskDocumentLoadClusterSetting

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Members


DocumentTask.TaskServer.TaskServerDocumentLoading.TaskServerDocumentLoadServerSetting.TaskDocumentLoadClusterSetting Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Members
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class Properties See Also Send Feedback

The Document Load element of the document meta data data object.

The DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting type exposes the following members.

Properties

 | Name | Description
Public property | Mode | The document load mode on this server.
Public property | QlikViewServerClusterNodeId | The id of the QlikView Server cluster node where the document load mode should be set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class


DocumentTask.TaskServer.TaskServerDocumentLoading.TaskServerDocumentLoadServerSetting.TaskDocumentLoadClusterSetting Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Properties
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class See Also Send Feedback

The DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting type exposes the following members.

Properties

 | Name | Description
Public property | Mode | The document load mode on this server.
Public property | QlikViewServerClusterNodeId | The id of the QlikView Server cluster node where the document load mode should be set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class


Mode Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting..::..Mode Property
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class See Also Send Feedback
The document load mode on this server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentLoadMode Mode { get; set; }
Visual Basic
Public Property Mode As DocumentLoadMode
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class


QlikViewServerClusterNodeId Property

[image]

QlikView Management Service API
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting..::..QlikViewServerClusterNodeId Property
DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class See Also Send Feedback
The id of the QlikView Server cluster node where the document load mode should be set

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QlikViewServerClusterNodeId { get; set; }
Visual Basic
Public Property QlikViewServerClusterNodeId As Guid
    Get
    Set

See Also

DocumentTask..::..TaskServer..::..TaskServerDocumentLoading..::..TaskServerDocumentLoadServerSetting..::..TaskDocumentLoadClusterSetting Class


DocumentTask.TaskTriggering Class

[image]

QlikView Management Service API
DocumentTask..::..TaskTriggering Class
DocumentTask Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTask.TaskTriggering"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskTriggering
Visual Basic
Public Class TaskTriggering

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DocumentTask..::..TaskTriggering

See Also

DocumentTask..::..TaskTriggering Members


DocumentTask.TaskTriggering Members

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskTriggering Members
DocumentTask..::..TaskTriggering Class Properties See Also Send Feedback

The DocumentTask..::..TaskTriggering type exposes the following members.

Properties

 | Name | Description
Public property | ExecutionAttempts |
Public property | ExecutionTimeout |
Public property | TaskDependencies |
Public property | Triggers |

See Also

DocumentTask..::..TaskTriggering Class


DocumentTask.TaskTriggering Properties

[image] [image]

QlikView Management Service API
DocumentTask..::..TaskTriggering Properties
DocumentTask..::..TaskTriggering Class See Also Send Feedback

The DocumentTask..::..TaskTriggering type exposes the following members.

Properties

 | Name | Description
Public property | ExecutionAttempts |
Public property | ExecutionTimeout |
Public property | TaskDependencies |
Public property | Triggers |

See Also

DocumentTask..::..TaskTriggering Class


ExecutionAttempts Property

[image]

QlikView Management Service API
DocumentTask..::..TaskTriggering..::..ExecutionAttempts Property
DocumentTask..::..TaskTriggering Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskTriggering.ExecutionAttempts"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public uint ExecutionAttempts { get; set; }
Visual Basic
Public Property ExecutionAttempts As UInteger
    Get
    Set

See Also

DocumentTask..::..TaskTriggering Class


ExecutionTimeout Property

[image]

QlikView Management Service API
DocumentTask..::..TaskTriggering..::..ExecutionTimeout Property
DocumentTask..::..TaskTriggering Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskTriggering.ExecutionTimeout"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public uint ExecutionTimeout { get; set; }
Visual Basic
Public Property ExecutionTimeout As UInteger
    Get
    Set

See Also

DocumentTask..::..TaskTriggering Class


TaskDependencies Property

[image]

QlikView Management Service API
DocumentTask..::..TaskTriggering..::..TaskDependencies Property
DocumentTask..::..TaskTriggering Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskTriggering.TaskDependencies"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<TaskInfo> TaskDependencies { get; private set; }
Visual Basic
Public Property TaskDependencies As List(Of TaskInfo)
    Get
    Private Set

See Also

DocumentTask..::..TaskTriggering Class


Triggers Property

[image]

QlikView Management Service API
DocumentTask..::..TaskTriggering..::..Triggers Property
DocumentTask..::..TaskTriggering Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DocumentTask.TaskTriggering.Triggers"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<Trigger> Triggers { get; private set; }
Visual Basic
Public Property Triggers As List(Of Trigger)
    Get
    Private Set

See Also

DocumentTask..::..TaskTriggering Class


DocumentTaskScope Enumeration

[image]

QlikView Management Service API
DocumentTaskScope Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentTaskScope"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum DocumentTaskScope
Visual Basic
<FlagsAttribute> _
Public Enumeration DocumentTaskScope

Members

Member name | Value | Description
None | 0 |
General | 1 |
Reload | 2 |
Reduce | 4 |
Distribute | 8 |
DocumentInfo | 16 |
Triggering | 32 |
Server | 64 |
All | 65535 |

See Also


DocumentType Enumeration

[image]

QlikView Management Service API
DocumentType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.DocumentType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum DocumentType
Visual Basic
Public Enumeration DocumentType

Members

Member name | Value | Description
User | 1 |
Source | 2 |

See Also


DSProvider Class

[image]

QlikView Management Service API
DSProvider Class
Members See Also Send Feedback
Represents a Directory Service Provider (DSP).

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DSProvider
Visual Basic
Public Class DSProvider

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DSProvider

See Also

DSProvider Members


DSProvider Members

[image] [image]

QlikView Management Service API
DSProvider Members
DSProvider Class Properties See Also Send Feedback

The DSProvider type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the provider
Public property | Type | The type of the provider

See Also

DSProvider Class


DSProvider Properties

[image] [image]

QlikView Management Service API
DSProvider Properties
DSProvider Class See Also Send Feedback

The DSProvider type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the provider
Public property | Type | The type of the provider

See Also

DSProvider Class


Name Property

[image]

QlikView Management Service API
DSProvider..::..Name Property
DSProvider Class See Also Send Feedback
The name of the provider

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

DSProvider Class


Type Property

[image]

QlikView Management Service API
DSProvider..::..Type Property
DSProvider Class See Also Send Feedback
The type of the provider

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Type { get; private set; }
Visual Basic
Public Property Type As String
    Get
    Private Set

See Also

DSProvider Class


DSPSettings Class

[image]

QlikView Management Service API
DSPSettings Class
Members See Also Send Feedback
Represents the settings for a Directory Service Provider.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DSPSettings
Visual Basic
Public Class DSPSettings

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DSPSettings

See Also

DSPSettings Members


DSPSettings Members

[image] [image]

QlikView Management Service API
DSPSettings Members
DSPSettings Class Properties See Also Send Feedback

The DSPSettings type exposes the following members.

Properties

 | Name | Description
Public property | CustomDirectoryPort |
Public property | DSCID |
Public property | DSPType |
Public property | Resources |

See Also

DSPSettings Class


DSPSettings Properties

[image] [image]

QlikView Management Service API
DSPSettings Properties
DSPSettings Class See Also Send Feedback

The DSPSettings type exposes the following members.

Properties

 | Name | Description
Public property | CustomDirectoryPort |
Public property | DSCID |
Public property | DSPType |
Public property | Resources |

See Also

DSPSettings Class


CustomDirectoryPort Property

[image]

QlikView Management Service API
DSPSettings..::..CustomDirectoryPort Property
DSPSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DSPSettings.CustomDirectoryPort"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int CustomDirectoryPort { get; set; }
Visual Basic
Public Property CustomDirectoryPort As Integer
    Get
    Set

See Also

DSPSettings Class


DSCID Property

[image]

QlikView Management Service API
DSPSettings..::..DSCID Property
DSPSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DSPSettings.DSCID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid DSCID { get; set; }
Visual Basic
Public Property DSCID As Guid
    Get
    Set

See Also

DSPSettings Class


DSPType Property

[image]

QlikView Management Service API
DSPSettings..::..DSPType Property
DSPSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DSPSettings.DSPType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string DSPType { get; set; }
Visual Basic
Public Property DSPType As String
    Get
    Set

See Also

DSPSettings Class


Resources Property

[image]

QlikView Management Service API
DSPSettings..::..Resources Property
DSPSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.DSPSettings.Resources"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DSResource> Resources { get; set; }
Visual Basic
Public Property Resources As List(Of DSResource)
    Get
    Set

See Also

DSPSettings Class


DSResource Class

[image]

QlikView Management Service API
DSResource Class
Members See Also Send Feedback
Represents a Directory Service Resource (DSResource).

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class DSResource
Visual Basic
Public Class DSResource

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..DSResource

See Also

DSResource Members


DSResource Members

[image] [image]

QlikView Management Service API
DSResource Members
DSResource Class Properties See Also Send Feedback

The DSResource type exposes the following members.

Properties

 | Name | Description
Public property | ErrStatus | The current status of this resource.
Public property | Id | The id of the resource.
Public property | Name | The name of the resource
Public property | Password | The password to be used when accessing this resource.
Public property | Path | The path of the resource
Public property | Settings | The settings for this resource.
Public property | Type | The type of the resource
Public property | Username | The user name to be used when accessing this resource.

See Also

DSResource Class


DSResource Properties

[image] [image]

QlikView Management Service API
DSResource Properties
DSResource Class See Also Send Feedback

The DSResource type exposes the following members.

Properties

 | Name | Description
Public property | ErrStatus | The current status of this resource.
Public property | Id | The id of the resource.
Public property | Name | The name of the resource
Public property | Password | The password to be used when accessing this resource.
Public property | Path | The path of the resource
Public property | Settings | The settings for this resource.
Public property | Type | The type of the resource
Public property | Username | The user name to be used when accessing this resource.

See Also

DSResource Class


ErrStatus Property

[image]

QlikView Management Service API
DSResource..::..ErrStatus Property
DSResource Class See Also Send Feedback
The current status of this resource.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ErrStatus { get; private set; }
Visual Basic
Public Property ErrStatus As String
    Get
    Private Set

See Also

DSResource Class


Id Property

[image]

QlikView Management Service API
DSResource..::..Id Property
DSResource Class See Also Send Feedback
The id of the resource.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid Id { get; private set; }
Visual Basic
Public Property Id As Guid
    Get
    Private Set

See Also

DSResource Class


Name Property

[image]

QlikView Management Service API
DSResource..::..Name Property
DSResource Class See Also Send Feedback
The name of the resource

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

DSResource Class


Password Property

[image]

QlikView Management Service API
DSResource..::..Password Property
DSResource Class See Also Send Feedback
The password to be used when accessing this resource.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Password { get; private set; }
Visual Basic
Public Property Password As String
    Get
    Private Set

See Also

DSResource Class


Path Property

[image]

QlikView Management Service API
DSResource..::..Path Property
DSResource Class See Also Send Feedback
The path of the resource

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Path { get; private set; }
Visual Basic
Public Property Path As String
    Get
    Private Set

See Also

DSResource Class


Settings Property

[image]

QlikView Management Service API
DSResource..::..Settings Property
DSResource Class See Also Send Feedback
The settings for this resource.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public IDictionary<string, string> Settings { get; private set; }
Visual Basic
Public Property Settings As IDictionary(Of String, String)
    Get
    Private Set

See Also

DSResource Class


Type Property

[image]

QlikView Management Service API
DSResource..::..Type Property
DSResource Class See Also Send Feedback
The type of the resource

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Type { get; private set; }
Visual Basic
Public Property Type As String
    Get
    Private Set

See Also

DSResource Class


Username Property

[image]

QlikView Management Service API
DSResource..::..Username Property
DSResource Class See Also Send Feedback
The user name to be used when accessing this resource.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Username { get; private set; }
Visual Basic
Public Property Username As String
    Get
    Private Set

See Also

DSResource Class


EDXStatus Class

[image]

QlikView Management Service API
EDXStatus Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.EDXStatus"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class EDXStatus
Visual Basic
Public Class EDXStatus

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..EDXStatus

See Also

EDXStatus Members


EDXStatus Members

[image] [image]

QlikView Management Service API
EDXStatus Members
EDXStatus Class Properties See Also Send Feedback

The EDXStatus type exposes the following members.

Properties

 | Name | Description
Public property | Category |
Public property | DocumentPath |
Public property | ExecId |
Public property | FinishTime |
Public property | LogFileFullPath |
Public property | QdsId |
Public property | StartTime |
Public property | Summary |
Public property | TaskId |
Public property | TaskName |
Public property | TaskStartResult |
Public property | TaskStartResultCode |
Public property | TaskStatus |
Public property | TaskType |
Public property | TriggeredTasksId |

See Also

EDXStatus Class


EDXStatus Properties

[image] [image]

QlikView Management Service API
EDXStatus Properties
EDXStatus Class See Also Send Feedback

The EDXStatus type exposes the following members.

Properties

 | Name | Description
Public property | Category |
Public property | DocumentPath |
Public property | ExecId |
Public property | FinishTime |
Public property | LogFileFullPath |
Public property | QdsId |
Public property | StartTime |
Public property | Summary |
Public property | TaskId |
Public property | TaskName |
Public property | TaskStartResult |
Public property | TaskStartResultCode |
Public property | TaskStatus |
Public property | TaskType |
Public property | TriggeredTasksId |

See Also

EDXStatus Class


Category Property

[image]

QlikView Management Service API
EDXStatus..::..Category Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.Category"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set

See Also

EDXStatus Class


DocumentPath Property

[image]

QlikView Management Service API
EDXStatus..::..DocumentPath Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.DocumentPath"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string DocumentPath { get; set; }
Visual Basic
Public Property DocumentPath As String
    Get
    Set

See Also

EDXStatus Class


ExecId Property

[image]

QlikView Management Service API
EDXStatus..::..ExecId Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.ExecId"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ExecId { get; set; }
Visual Basic
Public Property ExecId As Guid
    Get
    Set

See Also

EDXStatus Class


FinishTime Property

[image]

QlikView Management Service API
EDXStatus..::..FinishTime Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.FinishTime"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string FinishTime { get; set; }
Visual Basic
Public Property FinishTime As String
    Get
    Set

See Also

EDXStatus Class


LogFileFullPath Property

[image]

QlikView Management Service API
EDXStatus..::..LogFileFullPath Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.LogFileFullPath"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string LogFileFullPath { get; set; }
Visual Basic
Public Property LogFileFullPath As String
    Get
    Set

See Also

EDXStatus Class


QdsId Property

[image]

QlikView Management Service API
EDXStatus..::..QdsId Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.QdsId"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QdsId { get; set; }
Visual Basic
Public Property QdsId As Guid
    Get
    Set

See Also

EDXStatus Class


StartTime Property

[image]

QlikView Management Service API
EDXStatus..::..StartTime Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.StartTime"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string StartTime { get; set; }
Visual Basic
Public Property StartTime As String
    Get
    Set

See Also

EDXStatus Class


Summary Property

[image]

QlikView Management Service API
EDXStatus..::..Summary Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.Summary"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Summary { get; set; }
Visual Basic
Public Property Summary As String
    Get
    Set

See Also

EDXStatus Class


TaskId Property

[image]

QlikView Management Service API
EDXStatus..::..TaskId Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.TaskId"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid TaskId { get; set; }
Visual Basic
Public Property TaskId As Guid
    Get
    Set

See Also

EDXStatus Class


TaskName Property

[image]

QlikView Management Service API
EDXStatus..::..TaskName Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.TaskName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string TaskName { get; set; }
Visual Basic
Public Property TaskName As String
    Get
    Set

See Also

EDXStatus Class


TaskStartResult Property

[image]

QlikView Management Service API
EDXStatus..::..TaskStartResult Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.TaskStartResult"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public EDXTaskStartResult TaskStartResult { get; set; }
Visual Basic
Public Property TaskStartResult As EDXTaskStartResult
    Get
    Set

See Also

EDXStatus Class


TaskStartResultCode Property

[image]

QlikView Management Service API
EDXStatus..::..TaskStartResultCode Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.TaskStartResultCode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int TaskStartResultCode { get; set; }
Visual Basic
Public Property TaskStartResultCode As Integer
    Get
    Set

See Also

EDXStatus Class


TaskStatus Property

[image]

QlikView Management Service API
EDXStatus..::..TaskStatus Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.TaskStatus"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusValue TaskStatus { get; set; }
Visual Basic
Public Property TaskStatus As TaskStatusValue
    Get
    Set

See Also

EDXStatus Class


TaskType Property

[image]

QlikView Management Service API
EDXStatus..::..TaskType Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.TaskType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskType TaskType { get; set; }
Visual Basic
Public Property TaskType As TaskType
    Get
    Set

See Also

EDXStatus Class


TriggeredTasksId Property

[image]

QlikView Management Service API
EDXStatus..::..TriggeredTasksId Property
EDXStatus Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.EDXStatus.TriggeredTasksId"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<TaskExecutionItem> TriggeredTasksId { get; set; }
Visual Basic
Public Property TriggeredTasksId As List(Of TaskExecutionItem)
    Get
    Set

See Also

EDXStatus Class


EDXTaskStartResult Enumeration

[image]

QlikView Management Service API
EDXTaskStartResult Enumeration
See Also Send Feedback
The result types when starting an EDX task.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum EDXTaskStartResult
Visual Basic
Public Enumeration EDXTaskStartResult

Members

Member name | Value | Description
Success | 0 | The task was started successfully.
TaskNotFound | 1 | The task was not found.
TaskIsAlreadyRunning | 2 | The task was already running.
NoEDXTriggerFound | 3 | The task did not have an EDX trigger.
CouldNotDetermineTaskByName | 7 | Failed to identify the task by name only. There might by multiple tasks with similar names.
FailedToContactDistributionService | 8 | The task could not be started because the QDS was not available.
OtherError | 9 | An unknown error occured.

See Also

PIX.QMSAPI.DataObjects..::..TriggerEDXTaskResult


EnumSupport Class

[image]

QlikView Management Service API
EnumSupport Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.EnumSupport"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public static class EnumSupport
Visual Basic
Public NotInheritable Class EnumSupport

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..EnumSupport

See Also

EnumSupport Members


EnumSupport Members

[image] [image]

QlikView Management Service API
EnumSupport Members
EnumSupport Class See Also Send Feedback

See Also

EnumSupport Class


ExtensionUploadHandle Class

[image]

QlikView Management Service API
ExtensionUploadHandle Class
Members See Also Send Feedback
Holds information about an extension object upload.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class ExtensionUploadHandle
Visual Basic
Public Class ExtensionUploadHandle

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..ExtensionUploadHandle

See Also

ExtensionUploadHandle Members


ExtensionUploadHandle Members

[image] [image]

QlikView Management Service API
ExtensionUploadHandle Members
ExtensionUploadHandle Class Properties See Also Send Feedback

The ExtensionUploadHandle type exposes the following members.

Properties

 | Name | Description
Public property | Position | The number of bytes currently written.
Public property | QVSClusterID | The ID of the QVS cluster to receive the upload.
Public property | QVSClusterMemberID | The ID of the QVS cluster member to receive the upload.
Public property | QVSHandle | The handle ID of the upload.

See Also

ExtensionUploadHandle Class


ExtensionUploadHandle Properties

[image] [image]

QlikView Management Service API
ExtensionUploadHandle Properties
ExtensionUploadHandle Class See Also Send Feedback

The ExtensionUploadHandle type exposes the following members.

Properties

 | Name | Description
Public property | Position | The number of bytes currently written.
Public property | QVSClusterID | The ID of the QVS cluster to receive the upload.
Public property | QVSClusterMemberID | The ID of the QVS cluster member to receive the upload.
Public property | QVSHandle | The handle ID of the upload.

See Also

ExtensionUploadHandle Class


Position Property

[image]

QlikView Management Service API
ExtensionUploadHandle..::..Position Property
ExtensionUploadHandle Class See Also Send Feedback
The number of bytes currently written.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public long Position { get; set; }
Visual Basic
Public Property Position As Long
    Get
    Set

See Also

ExtensionUploadHandle Class


QVSClusterID Property

[image]

QlikView Management Service API
ExtensionUploadHandle..::..QVSClusterID Property
ExtensionUploadHandle Class See Also Send Feedback
The ID of the QVS cluster to receive the upload.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QVSClusterID { get; private set; }
Visual Basic
Public Property QVSClusterID As Guid
    Get
    Private Set

See Also

ExtensionUploadHandle Class


QVSClusterMemberID Property

[image]

QlikView Management Service API
ExtensionUploadHandle..::..QVSClusterMemberID Property
ExtensionUploadHandle Class See Also Send Feedback
The ID of the QVS cluster member to receive the upload.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QVSClusterMemberID { get; private set; }
Visual Basic
Public Property QVSClusterMemberID As Guid
    Get
    Private Set

See Also

ExtensionUploadHandle Class


QVSHandle Property

[image]

QlikView Management Service API
ExtensionUploadHandle..::..QVSHandle Property
ExtensionUploadHandle Class See Also Send Feedback
The handle ID of the upload.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int QVSHandle { get; private set; }
Visual Basic
Public Property QVSHandle As Integer
    Get
    Private Set

See Also

ExtensionUploadHandle Class


License Class

[image]

QlikView Management Service API
License Class
Members See Also Send Feedback
Contains license information including the contents of the LEF file.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class License
Visual Basic
Public Class License

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..License

See Also

License Members


License Members

[image] [image]

QlikView Management Service API
License Members
License Class Fields Properties See Also Send Feedback

The License type exposes the following members.

Fields

 | Name | Description
Public field | Features | A list of features available in the license.

Properties

 | Name | Description
Public property | Control | The control number of the license. This is used to validate the serial number.
Public property | Corporation | The corporation of the licensee.
Public property | LEFFile | The LEF (License Enabler File) which defines the features of the license.
Public property | LEFOk | The current state of the LEF file. Set to true if it is valid, otherwise false.
Public property | LicenseType | The type of the license.
Public property | Name | The name of the licensee.
Public property | Serial | The serial number of the license.

See Also

License Class


License Fields

[image] [image]

QlikView Management Service API
License Fields
License Class See Also Send Feedback

The License type exposes the following members.

Fields

 | Name | Description
Public field | Features | A list of features available in the license.

See Also

License Class


Features Field

[image]

QlikView Management Service API
License..::..Features Field
License Class See Also Send Feedback
A list of features available in the license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<LicenseFeature> Features
Visual Basic
Public Features As List(Of LicenseFeature)

See Also

License Class


License Properties

[image] [image]

QlikView Management Service API
License Properties
License Class See Also Send Feedback

The License type exposes the following members.

Properties

 | Name | Description
Public property | Control | The control number of the license. This is used to validate the serial number.
Public property | Corporation | The corporation of the licensee.
Public property | LEFFile | The LEF (License Enabler File) which defines the features of the license.
Public property | LEFOk | The current state of the LEF file. Set to true if it is valid, otherwise false.
Public property | LicenseType | The type of the license.
Public property | Name | The name of the licensee.
Public property | Serial | The serial number of the license.

See Also

License Class


Control Property

[image]

QlikView Management Service API
License..::..Control Property
License Class See Also Send Feedback
The control number of the license. This is used to validate the serial number.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Control { get; set; }
Visual Basic
Public Property Control As String
    Get
    Set

See Also

License Class


Corporation Property

[image]

QlikView Management Service API
License..::..Corporation Property
License Class See Also Send Feedback
The corporation of the licensee.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Corporation { get; set; }
Visual Basic
Public Property Corporation As String
    Get
    Set

See Also

License Class


LEFFile Property

[image]

QlikView Management Service API
License..::..LEFFile Property
License Class See Also Send Feedback
The LEF (License Enabler File) which defines the features of the license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string LEFFile { get; set; }
Visual Basic
Public Property LEFFile As String
    Get
    Set

See Also

License Class


LEFOk Property

[image]

QlikView Management Service API
License..::..LEFOk Property
License Class See Also Send Feedback
The current state of the LEF file. Set to true if it is valid, otherwise false.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool LEFOk { get; set; }
Visual Basic
Public Property LEFOk As Boolean
    Get
    Set

See Also

License Class


LicenseType Property

[image]

QlikView Management Service API
License..::..LicenseType Property
License Class See Also Send Feedback
The type of the license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public LicenseType LicenseType { get; set; }
Visual Basic
Public Property LicenseType As LicenseType
    Get
    Set

See Also

License Class


Name Property

[image]

QlikView Management Service API
License..::..Name Property
License Class See Also Send Feedback
The name of the licensee.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

License Class


Serial Property

[image]

QlikView Management Service API
License..::..Serial Property
License Class See Also Send Feedback
The serial number of the license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Serial { get; set; }
Visual Basic
Public Property Serial As String
    Get
    Set

See Also

License Class


LicenseFeature Class

[image]

QlikView Management Service API
LicenseFeature Class
Members See Also Send Feedback
Represents a license feature. A feature has a name and a value. Since the type of the value varies depending on the feature, it is of an object type.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class LicenseFeature
Visual Basic
Public Class LicenseFeature

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..LicenseFeature

See Also

LicenseFeature Members


LicenseFeature Members

[image] [image]

QlikView Management Service API
LicenseFeature Members
LicenseFeature Class Properties See Also Send Feedback

The LicenseFeature type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the feature.
Public property | Value | The value of the feature.

See Also

LicenseFeature Class


LicenseFeature Properties

[image] [image]

QlikView Management Service API
LicenseFeature Properties
LicenseFeature Class See Also Send Feedback

The LicenseFeature type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the feature.
Public property | Value | The value of the feature.

See Also

LicenseFeature Class


Name Property

[image]

QlikView Management Service API
LicenseFeature..::..Name Property
LicenseFeature Class See Also Send Feedback
The name of the feature.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

LicenseFeature Class


Value Property

[image]

QlikView Management Service API
LicenseFeature..::..Value Property
LicenseFeature Class See Also Send Feedback
The value of the feature.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

See Also

LicenseFeature Class


LogFileEntry Class

[image]

QlikView Management Service API
LogFileEntry Class
Members See Also Send Feedback
Represents a single log entry.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class LogFileEntry
Visual Basic
Public Class LogFileEntry

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..LogFileEntry

See Also

LogFileEntry Members


LogFileEntry Members

[image] [image]

QlikView Management Service API
LogFileEntry Members
LogFileEntry Class Properties See Also Send Feedback

The LogFileEntry type exposes the following members.

Properties

 | Name | Description
Public property | Text | The log message.
Public property | Time | Time stamp of the log entry.
Public property | Type | The type of the log entry.

See Also

LogFileEntry Class


LogFileEntry Properties

[image] [image]

QlikView Management Service API
LogFileEntry Properties
LogFileEntry Class See Also Send Feedback

The LogFileEntry type exposes the following members.

Properties

 | Name | Description
Public property | Text | The log message.
Public property | Time | Time stamp of the log entry.
Public property | Type | The type of the log entry.

See Also

LogFileEntry Class


Text Property

[image]

QlikView Management Service API
LogFileEntry..::..Text Property
LogFileEntry Class See Also Send Feedback
The log message.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Text { get; private set; }
Visual Basic
Public Property Text As String
    Get
    Private Set

See Also

LogFileEntry Class


Time Property

[image]

QlikView Management Service API
LogFileEntry..::..Time Property
LogFileEntry Class See Also Send Feedback
Time stamp of the log entry.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DateTime Time { get; private set; }
Visual Basic
Public Property Time As DateTime
    Get
    Private Set

See Also

LogFileEntry Class


Type Property

[image]

QlikView Management Service API
LogFileEntry..::..Type Property
LogFileEntry Class See Also Send Feedback
The type of the log entry.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public LogType Type { get; private set; }
Visual Basic
Public Property Type As LogType
    Get
    Private Set

See Also

LogFileEntry Class


LogType Enumeration

[image]

QlikView Management Service API
LogType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.LogType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum LogType
Visual Basic
Public Enumeration LogType

Members

Member name | Value | Description
Information | 0 |
Warning | 1 |
Error | 2 |

See Also


NamedCALIdentificationMode Enumeration

[image]

QlikView Management Service API
NamedCALIdentificationMode Enumeration
See Also Send Feedback
Represents the various modes for identifying a named CAL.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum NamedCALIdentificationMode
Visual Basic
Public Enumeration NamedCALIdentificationMode

Members

Member name | Value | Description
UserName | 0 |
MachineName | 1 |

See Also


QDSDocumentSession Class

[image]

QlikView Management Service API
QDSDocumentSession Class
Members See Also Send Feedback
Represents a QDS session for a specific document.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QDSDocumentSession
Visual Basic
Public Class QDSDocumentSession

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QDSDocumentSession

See Also

QDSDocumentSession Members


QDSDocumentSession Members

[image] [image]

QlikView Management Service API
QDSDocumentSession Members
QDSDocumentSession Class Properties See Also Send Feedback

The QDSDocumentSession type exposes the following members.

Properties

 | Name | Description
Public property | OpenDocumentResult | The state of the session.
Public property | QDSID | The ID of the QDS used by the session.
Public property | SessionID | The ID of the session.

See Also

QDSDocumentSession Class


QDSDocumentSession Properties

[image] [image]

QlikView Management Service API
QDSDocumentSession Properties
QDSDocumentSession Class See Also Send Feedback

The QDSDocumentSession type exposes the following members.

Properties

 | Name | Description
Public property | OpenDocumentResult | The state of the session.
Public property | QDSID | The ID of the QDS used by the session.
Public property | SessionID | The ID of the session.

See Also

QDSDocumentSession Class


OpenDocumentResult Property

[image]

QlikView Management Service API
QDSDocumentSession..::..OpenDocumentResult Property
QDSDocumentSession Class See Also Send Feedback
The state of the session.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DocumentState OpenDocumentResult { get; private set; }
Visual Basic
Public Property OpenDocumentResult As DocumentState
    Get
    Private Set

See Also

QDSDocumentSession Class


QDSID Property

[image]

QlikView Management Service API
QDSDocumentSession..::..QDSID Property
QDSDocumentSession Class See Also Send Feedback
The ID of the QDS used by the session.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QDSID { get; private set; }
Visual Basic
Public Property QDSID As Guid
    Get
    Private Set

See Also

QDSDocumentSession Class


SessionID Property

[image]

QlikView Management Service API
QDSDocumentSession..::..SessionID Property
QDSDocumentSession Class See Also Send Feedback
The ID of the session.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid SessionID { get; private set; }
Visual Basic
Public Property SessionID As Guid
    Get
    Private Set

See Also

QDSDocumentSession Class


QDSDocumentSessionConfiguration Class

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration Class
Members See Also Send Feedback
Represents the configuration of a QDSDocumentSession and is used when creating a new session.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QDSDocumentSessionConfiguration
Visual Basic
Public Class QDSDocumentSessionConfiguration

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QDSDocumentSessionConfiguration

See Also

QDSDocumentSessionConfiguration Members


QDSDocumentSessionConfiguration Members

[image] [image]

QlikView Management Service API
QDSDocumentSessionConfiguration Members
QDSDocumentSessionConfiguration Class Properties See Also Send Feedback

The QDSDocumentSessionConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ClearLocks | Set this to true if the current locks in the document should be cleared.
Public property | ClearOneAndOnlyOne |
Public property | ClearSelections | Set this to true if the current selections in the document should be cleared.
Public property | EncryptedSectionAccessPassword |
Public property | EncryptedSectionAccessUserName |
Public property | FilePath | The full path of the file to be used by the session.
Public property | GroupName |
Public property | QDSID | The id of the QDS for which to create a session.
Public property | Reduce | Set this to true of the document should be reduced.

See Also

QDSDocumentSessionConfiguration Class


QDSDocumentSessionConfiguration Properties

[image] [image]

QlikView Management Service API
QDSDocumentSessionConfiguration Properties
QDSDocumentSessionConfiguration Class See Also Send Feedback

The QDSDocumentSessionConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | ClearLocks | Set this to true if the current locks in the document should be cleared.
Public property | ClearOneAndOnlyOne |
Public property | ClearSelections | Set this to true if the current selections in the document should be cleared.
Public property | EncryptedSectionAccessPassword |
Public property | EncryptedSectionAccessUserName |
Public property | FilePath | The full path of the file to be used by the session.
Public property | GroupName |
Public property | QDSID | The id of the QDS for which to create a session.
Public property | Reduce | Set this to true of the document should be reduced.

See Also

QDSDocumentSessionConfiguration Class


ClearLocks Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..ClearLocks Property
QDSDocumentSessionConfiguration Class See Also Send Feedback
Set this to true if the current locks in the document should be cleared.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool ClearLocks { get; set; }
Visual Basic
Public Property ClearLocks As Boolean
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


ClearOneAndOnlyOne Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..ClearOneAndOnlyOne Property
QDSDocumentSessionConfiguration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QDSDocumentSessionConfiguration.ClearOneAndOnlyOne"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool ClearOneAndOnlyOne { get; set; }
Visual Basic
Public Property ClearOneAndOnlyOne As Boolean
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


ClearSelections Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..ClearSelections Property
QDSDocumentSessionConfiguration Class See Also Send Feedback
Set this to true if the current selections in the document should be cleared.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool ClearSelections { get; set; }
Visual Basic
Public Property ClearSelections As Boolean
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


EncryptedSectionAccessPassword Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..EncryptedSectionAccessPassword Property
QDSDocumentSessionConfiguration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QDSDocumentSessionConfiguration.EncryptedSectionAccessPassword"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string EncryptedSectionAccessPassword { get; set; }
Visual Basic
Public Property EncryptedSectionAccessPassword As String
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


EncryptedSectionAccessUserName Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..EncryptedSectionAccessUserName Property
QDSDocumentSessionConfiguration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QDSDocumentSessionConfiguration.EncryptedSectionAccessUserName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string EncryptedSectionAccessUserName { get; set; }
Visual Basic
Public Property EncryptedSectionAccessUserName As String
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


FilePath Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..FilePath Property
QDSDocumentSessionConfiguration Class See Also Send Feedback
The full path of the file to be used by the session.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


GroupName Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..GroupName Property
QDSDocumentSessionConfiguration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QDSDocumentSessionConfiguration.GroupName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string GroupName { get; set; }
Visual Basic
Public Property GroupName As String
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


QDSID Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..QDSID Property
QDSDocumentSessionConfiguration Class See Also Send Feedback
The id of the QDS for which to create a session.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QDSID { get; set; }
Visual Basic
Public Property QDSID As Guid
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


Reduce Property

[image]

QlikView Management Service API
QDSDocumentSessionConfiguration..::..Reduce Property
QDSDocumentSessionConfiguration Class See Also Send Feedback
Set this to true of the document should be reduced.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Reduce { get; set; }
Visual Basic
Public Property Reduce As Boolean
    Get
    Set

See Also

QDSDocumentSessionConfiguration Class


QDSSectionAccessMode Enumeration

[image]

QlikView Management Service API
QDSSectionAccessMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QDSSectionAccessMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum QDSSectionAccessMode
Visual Basic
Public Enumeration QDSSectionAccessMode

Members

Member name | Value | Description
UseQDSAccount | 0 |
SpecifyCredentials | 1 |

See Also


QDSSettings Class

[image]

QlikView Management Service API
QDSSettings Class
Members See Also Send Feedback
Holds all the settings for a QlikView Distribution Service. Some of the settings applies only to unlicensed services.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QDSSettings
Visual Basic
Public Class QDSSettings

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QDSSettings

See Also

QDSSettings Members


QDSSettings Members

[image] [image]

QlikView Management Service API
QDSSettings Members
QDSSettings Class Properties See Also Send Feedback

The QDSSettings type exposes the following members.

Properties

 | Name | Description
Public property | Advanced |
Public property | Email |
Public property | General | The general settings such as application folder and cluster members.
Public property | ID | The ID of the QlikView Distribution Service.
Public property | Login |
Public property | Scope | The scope of settings that this object represents. If this object was retrieved by calling GetQDSSettings(Guid, QDSSettingsScope), this property contains the value of the requested scope.

See Also

QDSSettings Class


QDSSettings Properties

[image] [image]

QlikView Management Service API
QDSSettings Properties
QDSSettings Class See Also Send Feedback

The QDSSettings type exposes the following members.

Properties

 | Name | Description
Public property | Advanced |
Public property | Email |
Public property | General | The general settings such as application folder and cluster members.
Public property | ID | The ID of the QlikView Distribution Service.
Public property | Login |
Public property | Scope | The scope of settings that this object represents. If this object was retrieved by calling GetQDSSettings(Guid, QDSSettingsScope), this property contains the value of the requested scope.

See Also

QDSSettings Class


Advanced Property

[image]

QlikView Management Service API
QDSSettings..::..Advanced Property
QDSSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QDSSettings.Advanced"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QDSSettings..::..QDSAdvanced Advanced { get; private set; }
Visual Basic
Public Property Advanced As QDSSettings..::..QDSAdvanced
    Get
    Private Set

See Also

QDSSettings Class


Email Property

[image]

QlikView Management Service API
QDSSettings..::..Email Property
QDSSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QDSSettings.Email"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QDSSettings..::..QDSEmail Email { get; private set; }
Visual Basic
Public Property Email As QDSSettings..::..QDSEmail
    Get
    Private Set

See Also

QDSSettings Class


General Property

[image]

QlikView Management Service API
QDSSettings..::..General Property
QDSSettings Class See Also Send Feedback
The general settings such as application folder and cluster members.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QDSSettings..::..QDSGeneral General { get; private set; }
Visual Basic
Public Property General As QDSSettings..::..QDSGeneral
    Get
    Private Set

See Also

QDSSettings Class


ID Property

[image]

QlikView Management Service API
QDSSettings..::..ID Property
QDSSettings Class See Also Send Feedback
The ID of the QlikView Distribution Service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

QDSSettings Class


Login Property

[image]

QlikView Management Service API
QDSSettings..::..Login Property
QDSSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QDSSettings.Login"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QDSSettings..::..QDSLogin Login { get; private set; }
Visual Basic
Public Property Login As QDSSettings..::..QDSLogin
    Get
    Private Set

See Also

QDSSettings Class


Scope Property

[image]

QlikView Management Service API
QDSSettings..::..Scope Property
QDSSettings Class See Also Send Feedback
The scope of settings that this object represents. If this object was retrieved by calling GetQDSSettings(Guid, QDSSettingsScope), this property contains the value of the requested scope.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QDSSettingsScope Scope { get; private set; }
Visual Basic
Public Property Scope As QDSSettingsScope
    Get
    Private Set

See Also

QDSSettings Class


QDSSettings.QDSAdvanced Class

[image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced Class
QDSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QDSSettings.QDSAdvanced"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QDSAdvanced
Visual Basic
Public Class QDSAdvanced

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QDSSettings..::..QDSAdvanced

See Also

QDSSettings..::..QDSAdvanced Members


QDSSettings.QDSAdvanced Members

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced Members
QDSSettings..::..QDSAdvanced Class Properties See Also Send Feedback

Holds all the settings for a QlikView Distribution Service. Some of the settings applies only to unlicensed services.

The QDSSettings..::..QDSAdvanced type exposes the following members.

Properties

Name Description
Public property CPUAffinity
Using this value, specific processors can be deselected for use by QlikView Server. QlikView Server will automatically select the processors to use and this setting needs to be changed when you wish to override that choice.
Public property CPUPriority
This value increases or decreases the priority of the QlikView Server process, depending on how much CPU capacity the process is utilizing. It should not be changed if the server is a dedicated QlikView Server server.
Public property MaxQvbAdmin
The number of simultaneous QVBs the QlikView Distribution Service can use for the management of tasks in the Management Console.
Public property MaxQvbDist
The number of QVBs that the QlikView Distribution Service can send tasks to simultaneously.
Public property SectionAccessPassword
The username used for section access.

Remarks

Requires Publisher license.
Public property SectionAccessUsername
The username used for section access.

Remarks

Requires Publisher license.

See Also

QDSSettings..::..QDSAdvanced Class


QDSSettings.QDSAdvanced Properties

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced Properties
QDSSettings..::..QDSAdvanced Class See Also Send Feedback

The QDSSettings..::..QDSAdvanced type exposes the following members.

Properties

Name Description
Public property CPUAffinity
Using this value, specific processors can be deselected for use by QlikView Server. QlikView Server will automatically select the processors to use and this setting needs to be changed when you wish to override that choice.
Public property CPUPriority
This value increases or decreases the priority of the QlikView Server process, depending on how much CPU capacity the process is utilizing. It should not be changed if the server is a dedicated QlikView Server server.
Public property MaxQvbAdmin
The number of simultaneous QVBs the QlikView Distribution Service can use for the management of tasks in the Management Console.
Public property MaxQvbDist
The number of QVBs that the QlikView Distribution Service can send tasks to simultaneously.
Public property SectionAccessPassword
The username used for section access.

Remarks

Requires Publisher license.
Public property SectionAccessUsername
The username used for section access.

Remarks

Requires Publisher license.

See Also

QDSSettings..::..QDSAdvanced Class


CPUAffinity Property

[image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced..::..CPUAffinity Property
QDSSettings..::..QDSAdvanced Class See Also Send Feedback
Using this value, specific processors can be deselected for use by QlikView Server. QlikView Server will automatically select the processors to use and this setting needs to be changed when you wish to override that choice.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<bool> CPUAffinity { get; private set; }
Visual Basic
Public Property CPUAffinity As List(Of Boolean)
    Get
    Private Set

See Also

QDSSettings..::..QDSAdvanced Class


CPUPriority Property

[image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced..::..CPUPriority Property
QDSSettings..::..QDSAdvanced Class See Also Send Feedback
This value increases or decreases the priority of the QlikView Server process, depending on how much CPU capacity the process is utilizing. It should not be changed if the server is a dedicated QlikView Server server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public CPUPriority CPUPriority { get; set; }
Visual Basic
Public Property CPUPriority As CPUPriority
    Get
    Set

See Also

QDSSettings..::..QDSAdvanced Class


MaxQvbAdmin Property

[image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced..::..MaxQvbAdmin Property
QDSSettings..::..QDSAdvanced Class See Also Send Feedback
The number of simultaneous QVBs the QlikView Distribution Service can use for the management of tasks in the Management Console.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int MaxQvbAdmin { get; set; }
Visual Basic
Public Property MaxQvbAdmin As Integer
    Get
    Set

See Also

QDSSettings..::..QDSAdvanced Class


MaxQvbDist Property

[image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced..::..MaxQvbDist Property
QDSSettings..::..QDSAdvanced Class See Also Send Feedback
The number of QVBs that the QlikView Distribution Service can send tasks to simultaneously.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int MaxQvbDist { get; set; }
Visual Basic
Public Property MaxQvbDist As Integer
    Get
    Set

See Also

QDSSettings..::..QDSAdvanced Class


SectionAccessPassword Property

[image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced..::..SectionAccessPassword Property
QDSSettings..::..QDSAdvanced Class See Also Send Feedback
The username used for section access.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string SectionAccessPassword { get; set; }
Visual Basic
Public Property SectionAccessPassword As String
    Get
    Set

See Also

QDSSettings..::..QDSAdvanced Class


SectionAccessUsername Property

[image]

QlikView Management Service API
QDSSettings..::..QDSAdvanced..::..SectionAccessUsername Property
QDSSettings..::..QDSAdvanced Class See Also Send Feedback
The username used for section access.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string SectionAccessUsername { get; set; }
Visual Basic
Public Property SectionAccessUsername As String
    Get
    Set

See Also

QDSSettings..::..QDSAdvanced Class


QDSSettings.QDSClusterInfo Class

[image]

QlikView Management Service API
QDSSettings..::..QDSClusterInfo Class
QDSSettings Class Members See Also Send Feedback
Contains a references to a clustered Distribution Services.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QDSClusterInfo
Visual Basic
Public Class QDSClusterInfo

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QDSSettings..::..QDSClusterInfo

See Also

QDSSettings..::..QDSClusterInfo Members


QDSSettings.QDSClusterInfo Members

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSClusterInfo Members
QDSSettings..::..QDSClusterInfo Class Properties See Also Send Feedback

Holds all the settings for a QlikView Distribution Service. Some of the settings applies only to unlicensed services.

The QDSSettings..::..QDSClusterInfo type exposes the following members.

Properties

 | Name | Description
Public property | Url | The Url pointing to the Directory Service.

See Also

QDSSettings..::..QDSClusterInfo Class


QDSSettings.QDSClusterInfo Properties

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSClusterInfo Properties
QDSSettings..::..QDSClusterInfo Class See Also Send Feedback

The QDSSettings..::..QDSClusterInfo type exposes the following members.

Properties

 | Name | Description
Public property | Url | The Url pointing to the Directory Service.

See Also

QDSSettings..::..QDSClusterInfo Class


Url Property

[image]

QlikView Management Service API
QDSSettings..::..QDSClusterInfo..::..Url Property
QDSSettings..::..QDSClusterInfo Class See Also Send Feedback
The Url pointing to the Directory Service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Uri Url { get; set; }
Visual Basic
Public Property Url As Uri
    Get
    Set

See Also

QDSSettings..::..QDSClusterInfo Class


QDSSettings.QDSEmail Class

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail Class
QDSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QDSSettings.QDSEmail"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QDSEmail
Visual Basic
Public Class QDSEmail

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QDSSettings..::..QDSEmail

See Also

QDSSettings..::..QDSEmail Members


QDSSettings.QDSEmail Members

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSEmail Members
QDSSettings..::..QDSEmail Class Properties See Also Send Feedback

Holds all the settings for a QlikView Distribution Service. Some of the settings applies only to unlicensed services.

The QDSSettings..::..QDSEmail type exposes the following members.

Properties

Name Description
Public property AlertHtmlBody
The body to used when the Distribution Server sends alerts in html formatted emails.

Remarks

Requires Publisher license.
Public property AlertHtmlSubject
The subject to used when the Distribution Server sends alerts in html formatted emails.

Remarks

Requires Publisher license.
Public property AlertMailAddresses
A list of email addresses to which alerts should be sent.
Public property AlertPlainBody
The body to used when the Distribution Server sends alerts in text formatted emails.

Remarks

Requires Publisher license.
Public property AlertPlainSubject
The subject to used when the Distribution Server sends alerts in text formatted emails.

Remarks

Requires Publisher license.
Public property AttachmentHtmlBody
The body to be used when document attachments are distributed by the Distribution Service using html formatted emails.

Remarks

Requires Publisher license.
Public property AttachmentHtmlSubject
The subject to be used when document attachments are distributed by the Distribution Service using html formatted emails.

Remarks

Requires Publisher license.
Public property AttachmentPlainBody
The body to be used when document attachments are distributed by the Distribution Service using plain text emails.

Remarks

Requires Publisher license.
Public property AttachmentPlainSubject
The subject to be used when document attachments are distributed by the Distribution Service using plain text emails.

Remarks

Requires Publisher license.
Public property NotifyHtmlBody
The body to used when the Distribution Server sends notifications in html formatted emails.

Remarks

Requires Publisher license.
Public property NotifyHtmlSubject
The subject to used when the Distribution Server sends notifications in html formatted emails.

Remarks

Requires Publisher license.
Public property NotifyPlainBody
The body to used when the Distribution Server sends notifications in plain text formatted emails.

Remarks

Requires Publisher license.
Public property NotifyPlainSubject
The subject to used when the Distribution Server sends notifications in plain text formatted emails.

Remarks

Requires Publisher license.

See Also

QDSSettings..::..QDSEmail Class


QDSSettings.QDSEmail Properties

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSEmail Properties
QDSSettings..::..QDSEmail Class See Also Send Feedback

The QDSSettings..::..QDSEmail type exposes the following members.

Properties

Name Description
Public property AlertHtmlBody
The body to used when the Distribution Server sends alerts in html formatted emails.

Remarks

Requires Publisher license.
Public property AlertHtmlSubject
The subject to used when the Distribution Server sends alerts in html formatted emails.

Remarks

Requires Publisher license.
Public property AlertMailAddresses
A list of email addresses to which alerts should be sent.
Public property AlertPlainBody
The body to used when the Distribution Server sends alerts in text formatted emails.

Remarks

Requires Publisher license.
Public property AlertPlainSubject
The subject to used when the Distribution Server sends alerts in text formatted emails.

Remarks

Requires Publisher license.
Public property AttachmentHtmlBody
The body to be used when document attachments are distributed by the Distribution Service using html formatted emails.

Remarks

Requires Publisher license.
Public property AttachmentHtmlSubject
The subject to be used when document attachments are distributed by the Distribution Service using html formatted emails.

Remarks

Requires Publisher license.
Public property AttachmentPlainBody
The body to be used when document attachments are distributed by the Distribution Service using plain text emails.

Remarks

Requires Publisher license.
Public property AttachmentPlainSubject
The subject to be used when document attachments are distributed by the Distribution Service using plain text emails.

Remarks

Requires Publisher license.
Public property NotifyHtmlBody
The body to used when the Distribution Server sends notifications in html formatted emails.

Remarks

Requires Publisher license.
Public property NotifyHtmlSubject
The subject to used when the Distribution Server sends notifications in html formatted emails.

Remarks

Requires Publisher license.
Public property NotifyPlainBody
The body to used when the Distribution Server sends notifications in plain text formatted emails.

Remarks

Requires Publisher license.
Public property NotifyPlainSubject
The subject to used when the Distribution Server sends notifications in plain text formatted emails.

Remarks

Requires Publisher license.

See Also

QDSSettings..::..QDSEmail Class


AlertHtmlBody Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AlertHtmlBody Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The body to used when the Distribution Server sends alerts in html formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AlertHtmlBody { get; set; }
Visual Basic
Public Property AlertHtmlBody As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


AlertHtmlSubject Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AlertHtmlSubject Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The subject to used when the Distribution Server sends alerts in html formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AlertHtmlSubject { get; set; }
Visual Basic
Public Property AlertHtmlSubject As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


AlertMailAddresses Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AlertMailAddresses Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
A list of email addresses to which alerts should be sent.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> AlertMailAddresses { get; set; }
Visual Basic
Public Property AlertMailAddresses As List(Of String)
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


AlertPlainBody Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AlertPlainBody Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The body to used when the Distribution Server sends alerts in text formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AlertPlainBody { get; set; }
Visual Basic
Public Property AlertPlainBody As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


AlertPlainSubject Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AlertPlainSubject Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The subject to used when the Distribution Server sends alerts in text formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AlertPlainSubject { get; set; }
Visual Basic
Public Property AlertPlainSubject As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


AttachmentHtmlBody Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AttachmentHtmlBody Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The body to be used when document attachments are distributed by the Distribution Service using html formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AttachmentHtmlBody { get; set; }
Visual Basic
Public Property AttachmentHtmlBody As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


AttachmentHtmlSubject Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AttachmentHtmlSubject Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The subject to be used when document attachments are distributed by the Distribution Service using html formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AttachmentHtmlSubject { get; set; }
Visual Basic
Public Property AttachmentHtmlSubject As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


AttachmentPlainBody Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AttachmentPlainBody Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The body to be used when document attachments are distributed by the Distribution Service using plain text emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AttachmentPlainBody { get; set; }
Visual Basic
Public Property AttachmentPlainBody As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


AttachmentPlainSubject Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..AttachmentPlainSubject Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The subject to be used when document attachments are distributed by the Distribution Service using plain text emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AttachmentPlainSubject { get; set; }
Visual Basic
Public Property AttachmentPlainSubject As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


NotifyHtmlBody Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..NotifyHtmlBody Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The body to used when the Distribution Server sends notifications in html formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string NotifyHtmlBody { get; set; }
Visual Basic
Public Property NotifyHtmlBody As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


NotifyHtmlSubject Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..NotifyHtmlSubject Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The subject to used when the Distribution Server sends notifications in html formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string NotifyHtmlSubject { get; set; }
Visual Basic
Public Property NotifyHtmlSubject As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


NotifyPlainBody Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..NotifyPlainBody Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The body to used when the Distribution Server sends notifications in plain text formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string NotifyPlainBody { get; set; }
Visual Basic
Public Property NotifyPlainBody As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


NotifyPlainSubject Property

[image]

QlikView Management Service API
QDSSettings..::..QDSEmail..::..NotifyPlainSubject Property
QDSSettings..::..QDSEmail Class See Also Send Feedback
The subject to used when the Distribution Server sends notifications in plain text formatted emails.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string NotifyPlainSubject { get; set; }
Visual Basic
Public Property NotifyPlainSubject As String
    Get
    Set

See Also

QDSSettings..::..QDSEmail Class


QDSSettings.QDSGeneral Class

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral Class
QDSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QDSSettings.QDSGeneral"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QDSGeneral
Visual Basic
Public Class QDSGeneral

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QDSSettings..::..QDSGeneral

See Also

QDSSettings..::..QDSGeneral Members


QDSSettings.QDSGeneral Members

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSGeneral Members
QDSSettings..::..QDSGeneral Class Properties See Also Send Feedback

Holds all the settings for a QlikView Distribution Service. Some of the settings applies only to unlicensed services.

The QDSSettings..::..QDSGeneral type exposes the following members.

Properties

Name Description
Public property ApplicationDataFolder
The path where data for the Distribution Service is saved. For clustered environments, the value of this must be changed so that each node in the cluster refers to the same path.

Remarks

Requires Publisher license.
Public property ClusterInfo
Holds a list of all QlikView Distribution Services in the same cluster.

Remarks

Requires Publisher license.
Public property ClusterName
The name of the cluster
Public property DisableTaskTriggersForDocAdmins
When set to true, document administrators will not be able to activate any triggers when creating or editing tasks and triggers.

Remarks

Requires Publisher license.
Public property LogLevel
The log level to be used.
Public property SelectedDscID
The ID of the currently set Directory Service Connector.

Remarks

Requires Publisher license.
Public property ShowAlerts
When set to true it indicates a scheduled downtime.
Public property SourceFolders
The path of the Source Documents folder.

Remarks

Requires Publisher license.

See Also

QDSSettings..::..QDSGeneral Class


QDSSettings.QDSGeneral Properties

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSGeneral Properties
QDSSettings..::..QDSGeneral Class See Also Send Feedback

The QDSSettings..::..QDSGeneral type exposes the following members.

Properties

Name Description
Public property ApplicationDataFolder
The path where data for the Distribution Service is saved. For clustered environments, the value of this must be changed so that each node in the cluster refers to the same path.

Remarks

Requires Publisher license.
Public property ClusterInfo
Holds a list of all QlikView Distribution Services in the same cluster.

Remarks

Requires Publisher license.
Public property ClusterName
The name of the cluster
Public property DisableTaskTriggersForDocAdmins
When set to true, document administrators will not be able to activate any triggers when creating or editing tasks and triggers.

Remarks

Requires Publisher license.
Public property LogLevel
The log level to be used.
Public property SelectedDscID
The ID of the currently set Directory Service Connector.

Remarks

Requires Publisher license.
Public property ShowAlerts
When set to true it indicates a scheduled downtime.
Public property SourceFolders
The path of the Source Documents folder.

Remarks

Requires Publisher license.

See Also

QDSSettings..::..QDSGeneral Class


ApplicationDataFolder Property

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral..::..ApplicationDataFolder Property
QDSSettings..::..QDSGeneral Class See Also Send Feedback
The path where data for the Distribution Service is saved. For clustered environments, the value of this must be changed so that each node in the cluster refers to the same path.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ApplicationDataFolder { get; set; }
Visual Basic
Public Property ApplicationDataFolder As String
    Get
    Set

See Also

QDSSettings..::..QDSGeneral Class


ClusterInfo Property

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral..::..ClusterInfo Property
QDSSettings..::..QDSGeneral Class See Also Send Feedback
Holds a list of all QlikView Distribution Services in the same cluster.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<QDSSettings..::..QDSClusterInfo> ClusterInfo { get; private set; }
Visual Basic
Public Property ClusterInfo As List(Of QDSSettings..::..QDSClusterInfo)
    Get
    Private Set

See Also

QDSSettings..::..QDSGeneral Class


ClusterName Property

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral..::..ClusterName Property
QDSSettings..::..QDSGeneral Class See Also Send Feedback
The name of the cluster

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ClusterName { get; set; }
Visual Basic
Public Property ClusterName As String
    Get
    Set

See Also

QDSSettings..::..QDSGeneral Class


DisableTaskTriggersForDocAdmins Property

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral..::..DisableTaskTriggersForDocAdmins Property
QDSSettings..::..QDSGeneral Class See Also Send Feedback
When set to true, document administrators will not be able to activate any triggers when creating or editing tasks and triggers.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool DisableTaskTriggersForDocAdmins { get; set; }
Visual Basic
Public Property DisableTaskTriggersForDocAdmins As Boolean
    Get
    Set

See Also

QDSSettings..::..QDSGeneral Class


LogLevel Property

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral..::..LogLevel Property
QDSSettings..::..QDSGeneral Class See Also Send Feedback
The log level to be used.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public LogLevel LogLevel { get; set; }
Visual Basic
Public Property LogLevel As LogLevel
    Get
    Set

See Also

QDSSettings..::..QDSGeneral Class


SelectedDscID Property

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral..::..SelectedDscID Property
QDSSettings..::..QDSGeneral Class See Also Send Feedback
The ID of the currently set Directory Service Connector.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid SelectedDscID { get; set; }
Visual Basic
Public Property SelectedDscID As Guid
    Get
    Set

See Also

QDSSettings..::..QDSGeneral Class


ShowAlerts Property

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral..::..ShowAlerts Property
QDSSettings..::..QDSGeneral Class See Also Send Feedback
When set to true it indicates a scheduled downtime.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool ShowAlerts { get; set; }
Visual Basic
Public Property ShowAlerts As Boolean
    Get
    Set

See Also

QDSSettings..::..QDSGeneral Class


SourceFolders Property

[image]

QlikView Management Service API
QDSSettings..::..QDSGeneral..::..SourceFolders Property
QDSSettings..::..QDSGeneral Class See Also Send Feedback
The path of the Source Documents folder.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DocumentFolder> SourceFolders { get; private set; }
Visual Basic
Public Property SourceFolders As List(Of DocumentFolder)
    Get
    Private Set

See Also

QDSSettings..::..QDSGeneral Class


QDSSettings.QDSLogin Class

[image]

QlikView Management Service API
QDSSettings..::..QDSLogin Class
QDSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QDSSettings.QDSLogin"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QDSLogin
Visual Basic
Public Class QDSLogin

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QDSSettings..::..QDSLogin

See Also

QDSSettings..::..QDSLogin Members


QDSSettings.QDSLogin Members

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSLogin Members
QDSSettings..::..QDSLogin Class Properties See Also Send Feedback

Holds all the settings for a QlikView Distribution Service. Some of the settings applies only to unlicensed services.

The QDSSettings..::..QDSLogin type exposes the following members.

Properties

Name Description
Public property Password
Password to be used when administrating a Distribution Service on another computer.

Remarks

Requires Publisher license.
Public property Username
Username to be used when administrating a Distribution Service on another computer.

Remarks

Requires Publisher license.

See Also

QDSSettings..::..QDSLogin Class


QDSSettings.QDSLogin Properties

[image] [image]

QlikView Management Service API
QDSSettings..::..QDSLogin Properties
QDSSettings..::..QDSLogin Class See Also Send Feedback

The QDSSettings..::..QDSLogin type exposes the following members.

Properties

Name Description
Public property Password
Password to be used when administrating a Distribution Service on another computer.

Remarks

Requires Publisher license.
Public property Username
Username to be used when administrating a Distribution Service on another computer.

Remarks

Requires Publisher license.

See Also

QDSSettings..::..QDSLogin Class


Password Property

[image]

QlikView Management Service API
QDSSettings..::..QDSLogin..::..Password Property
QDSSettings..::..QDSLogin Class See Also Send Feedback
Password to be used when administrating a Distribution Service on another computer.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set

See Also

QDSSettings..::..QDSLogin Class


Username Property

[image]

QlikView Management Service API
QDSSettings..::..QDSLogin..::..Username Property
QDSSettings..::..QDSLogin Class See Also Send Feedback
Username to be used when administrating a Distribution Service on another computer.

Remarks

Requires Publisher license.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Username { get; set; }
Visual Basic
Public Property Username As String
    Get
    Set

See Also

QDSSettings..::..QDSLogin Class


QVSAuditLogLevel Enumeration

[image]

QlikView Management Service API
QVSAuditLogLevel Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSAuditLogLevel"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum QVSAuditLogLevel
Visual Basic
Public Enumeration QVSAuditLogLevel

Members

Member name | Value | Description
None | 0 |
Basic | 1 |
Detail | 2 |

See Also


QVSAuthenticationLevel Enumeration

[image]

QlikView Management Service API
QVSAuthenticationLevel Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSAuthenticationLevel"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum QVSAuthenticationLevel
Visual Basic
Public Enumeration QVSAuthenticationLevel

Members

Member name | Value | Description
AlwaysAnonymous | 0 |
AllowAnonymous | 1 |
ProhibitAnonymous | 2 |

See Also


QVSCacheObjects Enumeration

[image]

QlikView Management Service API
QVSCacheObjects Enumeration
See Also Send Feedback
The different available cache objects that can be used when calling ClearQVSCache(QVSCacheObjects).

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum QVSCacheObjects
Visual Basic
<FlagsAttribute> _
Public Enumeration QVSCacheObjects

Members

Member name | Value | Description
None | 0 | No object specified.
License | 1 | Cached QlikView Server license information.
Settings | 2 | Cached QlikView Server settings.
UserDocumentList | 4 | Cached QlikView Server user document file structure.
UserDocumentMetaData | 8 | Cached QlikView Server user document meta data.
CALConfiguration | 16 | Cached QlikView Server CAL configuration.
All | 65535 | All cache objects.

See Also

PIX.QMSAPI.DataObjects Namespace
IQMS..::..ClearQVSCache(QVSCacheObjects)


QVSClusterMember Class

[image]

QlikView Management Service API
QVSClusterMember Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSClusterMember"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSClusterMember
Visual Basic
Public Class QVSClusterMember

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSClusterMember

See Also

QVSClusterMember Members


QVSClusterMember Members

[image] [image]

QlikView Management Service API
QVSClusterMember Members
QVSClusterMember Class Properties See Also Send Feedback

The QVSClusterMember type exposes the following members.

Properties

 | Name | Description
Public property | Address |
Public property | ExternalMachineName |
Public property | ID |

See Also

QVSClusterMember Class


QVSClusterMember Properties

[image] [image]

QlikView Management Service API
QVSClusterMember Properties
QVSClusterMember Class See Also Send Feedback

The QVSClusterMember type exposes the following members.

Properties

 | Name | Description
Public property | Address |
Public property | ExternalMachineName |
Public property | ID |

See Also

QVSClusterMember Class


Address Property

[image]

QlikView Management Service API
QVSClusterMember..::..Address Property
QVSClusterMember Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSClusterMember.Address"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set

See Also

QVSClusterMember Class


ExternalMachineName Property

[image]

QlikView Management Service API
QVSClusterMember..::..ExternalMachineName Property
QVSClusterMember Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSClusterMember.ExternalMachineName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ExternalMachineName { get; set; }
Visual Basic
Public Property ExternalMachineName As String
    Get
    Set

See Also

QVSClusterMember Class


ID Property

[image]

QlikView Management Service API
QVSClusterMember..::..ID Property
QVSClusterMember Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSClusterMember.ID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

QVSClusterMember Class


QVSFolderAdministrator Class

[image]

QlikView Management Service API
QVSFolderAdministrator Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSFolderAdministrator"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSFolderAdministrator
Visual Basic
Public Class QVSFolderAdministrator

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSFolderAdministrator

See Also

QVSFolderAdministrator Members


QVSFolderAdministrator Members

[image] [image]

QlikView Management Service API
QVSFolderAdministrator Members
QVSFolderAdministrator Class Properties See Also Send Feedback

The QVSFolderAdministrator type exposes the following members.

Properties

 | Name | Description
Public property | FolderID |
Public property | FolderType |
Public property | UserName |

See Also

QVSFolderAdministrator Class


QVSFolderAdministrator Properties

[image] [image]

QlikView Management Service API
QVSFolderAdministrator Properties
QVSFolderAdministrator Class See Also Send Feedback

The QVSFolderAdministrator type exposes the following members.

Properties

 | Name | Description
Public property | FolderID |
Public property | FolderType |
Public property | UserName |

See Also

QVSFolderAdministrator Class


FolderID Property

[image]

QlikView Management Service API
QVSFolderAdministrator..::..FolderID Property
QVSFolderAdministrator Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSFolderAdministrator.FolderID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid FolderID { get; set; }
Visual Basic
Public Property FolderID As Guid
    Get
    Set

See Also

QVSFolderAdministrator Class


FolderType Property

[image]

QlikView Management Service API
QVSFolderAdministrator..::..FolderType Property
QVSFolderAdministrator Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSFolderAdministrator.FolderType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSUserDocumentFolderType FolderType { get; set; }
Visual Basic
Public Property FolderType As QVSUserDocumentFolderType
    Get
    Set

See Also

QVSFolderAdministrator Class


UserName Property

[image]

QlikView Management Service API
QVSFolderAdministrator..::..UserName Property
QVSFolderAdministrator Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSFolderAdministrator.UserName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set

See Also

QVSFolderAdministrator Class


QVSLogFileSplitMode Enumeration

[image]

QlikView Management Service API
QVSLogFileSplitMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSLogFileSplitMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum QVSLogFileSplitMode
Visual Basic
Public Enumeration QVSLogFileSplitMode

Members

Member name | Value | Description
Never | 0 |
Daily | 1 |
Weekly | 2 |
Monthly | 3 |
Yearly | 4 |

See Also


QVSLogVerbosity Enumeration

[image]

QlikView Management Service API
QVSLogVerbosity Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSLogVerbosity"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum QVSLogVerbosity
Visual Basic
Public Enumeration QVSLogVerbosity

Members

Member name | Value | Description
High | 700 |
Medium | 500 |
Low | 300 |

See Also


QVSMessage Class

[image]

QlikView Management Service API
QVSMessage Class
Members See Also Send Feedback
Represents a received from a QVS.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSMessage
Visual Basic
Public Class QVSMessage

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSMessage

See Also

QVSMessage Members


QVSMessage Members

[image] [image]

QlikView Management Service API
QVSMessage Members
QVSMessage Class Properties See Also Send Feedback

The QVSMessage type exposes the following members.

Properties

 | Name | Description
Public property | SubTexts | Associated, more detailed, messages.
Public property | Text | The main message.

See Also

QVSMessage Class


QVSMessage Properties

[image] [image]

QlikView Management Service API
QVSMessage Properties
QVSMessage Class See Also Send Feedback

The QVSMessage type exposes the following members.

Properties

 | Name | Description
Public property | SubTexts | Associated, more detailed, messages.
Public property | Text | The main message.

See Also

QVSMessage Class


SubTexts Property

[image]

QlikView Management Service API
QVSMessage..::..SubTexts Property
QVSMessage Class See Also Send Feedback
Associated, more detailed, messages.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> SubTexts { get; private set; }
Visual Basic
Public Property SubTexts As List(Of String)
    Get
    Private Set

See Also

QVSMessage Class


Text Property

[image]

QlikView Management Service API
QVSMessage..::..Text Property
QVSMessage Class See Also Send Feedback
The main message.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

See Also

QVSMessage Class


QVSMount Class

[image]

QlikView Management Service API
QVSMount Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSMount"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSMount
Visual Basic
Public Class QVSMount

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSMount

See Also

QVSMount Members


QVSMount Members

[image] [image]

QlikView Management Service API
QVSMount Members
QVSMount Class Properties See Also Send Feedback

The QVSMount type exposes the following members.

Properties

 | Name | Description
Public property | Browsable |
Public property | FolderID |
Public property | Name |
Public property | Path |

See Also

QVSMount Class


QVSMount Properties

[image] [image]

QlikView Management Service API
QVSMount Properties
QVSMount Class See Also Send Feedback

The QVSMount type exposes the following members.

Properties

 | Name | Description
Public property | Browsable |
Public property | FolderID |
Public property | Name |
Public property | Path |

See Also

QVSMount Class


Browsable Property

[image]

QlikView Management Service API
QVSMount..::..Browsable Property
QVSMount Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSMount.Browsable"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Browsable { get; set; }
Visual Basic
Public Property Browsable As Boolean
    Get
    Set

See Also

QVSMount Class


FolderID Property

[image]

QlikView Management Service API
QVSMount..::..FolderID Property
QVSMount Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSMount.FolderID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid FolderID { get; set; }
Visual Basic
Public Property FolderID As Guid
    Get
    Set

See Also

QVSMount Class


Name Property

[image]

QlikView Management Service API
QVSMount..::..Name Property
QVSMount Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSMount.Name"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

QVSMount Class


Path Property

[image]

QlikView Management Service API
QVSMount..::..Path Property
QVSMount Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSMount.Path"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set

See Also

QVSMount Class


QVSSettings Class

[image]

QlikView Management Service API
QVSSettings Class
Members See Also Send Feedback
Represents all configurable settings for a QlikView Server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSSettings
Visual Basic
Public Class QVSSettings

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings

See Also

QVSSettings Members


QVSSettings Members

[image] [image]

QlikView Management Service API
QVSSettings Members
QVSSettings Class Properties See Also Send Feedback

The QVSSettings type exposes the following members.

Properties

 | Name | Description
Public property | Cluster | Cluster related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Cluster.
Public property | Distribution | Distribution related QlikView Server settings, such as supervision accounts. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Distribution.
Public property | Documents | Document related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Documents.
Public property | Folders | Folder related QlikView Server settings, such as root folder and mounts. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Folders.
Public property | General | General QlikView Server settings, such as server name and login information. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes General.
Public property | IsOEMLicensed |
Public property | Logging | Logging related QlikView Server settings, such as log folder and level. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Logging.
Public property | Performance | Performance related QlikView Server settings, such as CPU, memory and session configurations. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Performance.
Public property | QVSID | The ID of the QlikView Server that this settings belongs to. If this object was retrieved by calling GetQVSSettings(Guid, QVSSettingsScope), this property contains the value of the requested QVS ID.
Public property | Scope | The scope of settings that this object represents. If this object was retrieved by calling GetQVSSettings(Guid, QVSSettingsScope), this property contains the value of the requested scope.
Public property | Security | Security related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Security.

See Also

QVSSettings Class


QVSSettings Properties

[image] [image]

QlikView Management Service API
QVSSettings Properties
QVSSettings Class See Also Send Feedback

The QVSSettings type exposes the following members.

Properties

 | Name | Description
Public property | Cluster | Cluster related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Cluster.
Public property | Distribution | Distribution related QlikView Server settings, such as supervision accounts. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Distribution.
Public property | Documents | Document related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Documents.
Public property | Folders | Folder related QlikView Server settings, such as root folder and mounts. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Folders.
Public property | General | General QlikView Server settings, such as server name and login information. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes General.
Public property | IsOEMLicensed |
Public property | Logging | Logging related QlikView Server settings, such as log folder and level. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Logging.
Public property | Performance | Performance related QlikView Server settings, such as CPU, memory and session configurations. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Performance.
Public property | QVSID | The ID of the QlikView Server that this settings belongs to. If this object was retrieved by calling GetQVSSettings(Guid, QVSSettingsScope), this property contains the value of the requested QVS ID.
Public property | Scope | The scope of settings that this object represents. If this object was retrieved by calling GetQVSSettings(Guid, QVSSettingsScope), this property contains the value of the requested scope.
Public property | Security | Security related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Security.

See Also

QVSSettings Class


Cluster Property

[image]

QlikView Management Service API
QVSSettings..::..Cluster Property
QVSSettings Class See Also Send Feedback
Cluster related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Cluster.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSCluster Cluster { get; private set; }
Visual Basic
Public Property Cluster As QVSSettings..::..QVSCluster
    Get
    Private Set

See Also

QVSSettings Class


Distribution Property

[image]

QlikView Management Service API
QVSSettings..::..Distribution Property
QVSSettings Class See Also Send Feedback
Distribution related QlikView Server settings, such as supervision accounts. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Distribution.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSDistribution Distribution { get; private set; }
Visual Basic
Public Property Distribution As QVSSettings..::..QVSDistribution
    Get
    Private Set

See Also

QVSSettings Class


Documents Property

[image]

QlikView Management Service API
QVSSettings..::..Documents Property
QVSSettings Class See Also Send Feedback
Document related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Documents.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSDocuments Documents { get; private set; }
Visual Basic
Public Property Documents As QVSSettings..::..QVSDocuments
    Get
    Private Set

See Also

QVSSettings Class


Folders Property

[image]

QlikView Management Service API
QVSSettings..::..Folders Property
QVSSettings Class See Also Send Feedback
Folder related QlikView Server settings, such as root folder and mounts. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Folders.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSFolders Folders { get; private set; }
Visual Basic
Public Property Folders As QVSSettings..::..QVSFolders
    Get
    Private Set

See Also

QVSSettings Class


General Property

[image]

QlikView Management Service API
QVSSettings..::..General Property
QVSSettings Class See Also Send Feedback
General QlikView Server settings, such as server name and login information. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes General.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSGeneral General { get; private set; }
Visual Basic
Public Property General As QVSSettings..::..QVSGeneral
    Get
    Private Set

See Also

QVSSettings Class


IsOEMLicensed Property

[image]

QlikView Management Service API
QVSSettings..::..IsOEMLicensed Property
QVSSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.IsOEMLicensed"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IsOEMLicensed { get; set; }
Visual Basic
Public Property IsOEMLicensed As Boolean
    Get
    Set

See Also

QVSSettings Class


Logging Property

[image]

QlikView Management Service API
QVSSettings..::..Logging Property
QVSSettings Class See Also Send Feedback
Logging related QlikView Server settings, such as log folder and level. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Logging.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSLogging Logging { get; private set; }
Visual Basic
Public Property Logging As QVSSettings..::..QVSLogging
    Get
    Private Set

See Also

QVSSettings Class


Performance Property

[image]

QlikView Management Service API
QVSSettings..::..Performance Property
QVSSettings Class See Also Send Feedback
Performance related QlikView Server settings, such as CPU, memory and session configurations. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Performance.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSPerformance Performance { get; private set; }
Visual Basic
Public Property Performance As QVSSettings..::..QVSPerformance
    Get
    Private Set

See Also

QVSSettings Class


QVSID Property

[image]

QlikView Management Service API
QVSSettings..::..QVSID Property
QVSSettings Class See Also Send Feedback
The ID of the QlikView Server that this settings belongs to. If this object was retrieved by calling GetQVSSettings(Guid, QVSSettingsScope), this property contains the value of the requested QVS ID.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QVSID { get; set; }
Visual Basic
Public Property QVSID As Guid
    Get
    Set

See Also

QVSSettings Class


Scope Property

[image]

QlikView Management Service API
QVSSettings..::..Scope Property
QVSSettings Class See Also Send Feedback
The scope of settings that this object represents. If this object was retrieved by calling GetQVSSettings(Guid, QVSSettingsScope), this property contains the value of the requested scope.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettingsScope Scope { get; private set; }
Visual Basic
Public Property Scope As QVSSettingsScope
    Get
    Private Set

See Also

QVSSettings Class


Security Property

[image]

QlikView Management Service API
QVSSettings..::..Security Property
QVSSettings Class See Also Send Feedback
Security related QlikView Server settings. Must not be nullNothingnullptra null reference (Nothing in Visual Basic) if Scope includes Security.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSSecurity Security { get; private set; }
Visual Basic
Public Property Security As QVSSettings..::..QVSSecurity
    Get
    Private Set

See Also

QVSSettings Class


QVSSettings.QVSCluster Class

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster Class
QVSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSCluster
Visual Basic
Public Class QVSCluster

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSCluster

See Also

QVSSettings..::..QVSCluster Members


QVSSettings.QVSCluster Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSCluster Members
QVSSettings..::..QVSCluster Class Properties See Also Send Feedback

Represents all configurable settings for a QlikView Server.

The QVSSettings..::..QVSCluster type exposes the following members.

Properties

 | Name | Description
Public property | AlternateBuildNumber |
Public property | AlternateDocumentRootFolder |
Public property | License |
Public property | Members |

See Also

QVSSettings..::..QVSCluster Class


QVSSettings.QVSCluster Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSCluster Properties
QVSSettings..::..QVSCluster Class See Also Send Feedback

The QVSSettings..::..QVSCluster type exposes the following members.

Properties

 | Name | Description
Public property | AlternateBuildNumber |
Public property | AlternateDocumentRootFolder |
Public property | License |
Public property | Members |

See Also

QVSSettings..::..QVSCluster Class


AlternateBuildNumber Property

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..AlternateBuildNumber Property
QVSSettings..::..QVSCluster Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster.AlternateBuildNumber"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int AlternateBuildNumber { get; set; }
Visual Basic
Public Property AlternateBuildNumber As Integer
    Get
    Set

See Also

QVSSettings..::..QVSCluster Class


AlternateDocumentRootFolder Property

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..AlternateDocumentRootFolder Property
QVSSettings..::..QVSCluster Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster.AlternateDocumentRootFolder"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AlternateDocumentRootFolder { get; set; }
Visual Basic
Public Property AlternateDocumentRootFolder As String
    Get
    Set

See Also

QVSSettings..::..QVSCluster Class


License Property

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..License Property
QVSSettings..::..QVSCluster Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster.License"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSCluster..::..QVSClusterLicense License { get; private set; }
Visual Basic
Public Property License As QVSSettings..::..QVSCluster..::..QVSClusterLicense
    Get
    Private Set

See Also

QVSSettings..::..QVSCluster Class


Members Property

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..Members Property
QVSSettings..::..QVSCluster Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster.Members"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<QVSClusterMember> Members { get; private set; }
Visual Basic
Public Property Members As List(Of QVSClusterMember)
    Get
    Private Set

See Also

QVSSettings..::..QVSCluster Class


QVSSettings.QVSCluster.QVSClusterLicense Class

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..QVSClusterLicense Class
QVSSettings..::..QVSCluster Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster.QVSClusterLicense"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSClusterLicense
Visual Basic
Public Class QVSClusterLicense

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSCluster..::..QVSClusterLicense

See Also

QVSSettings..::..QVSCluster..::..QVSClusterLicense Members


QVSSettings.QVSCluster.QVSClusterLicense Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..QVSClusterLicense Members
QVSSettings..::..QVSCluster..::..QVSClusterLicense Class Properties See Also Send Feedback

The QVSSettings..::..QVSCluster..::..QVSClusterLicense type exposes the following members.

Properties

 | Name | Description
Public property | AllowsClustering |
Public property | ControlNumber |
Public property | SerialNumber |

See Also

QVSSettings..::..QVSCluster..::..QVSClusterLicense Class


QVSSettings.QVSCluster.QVSClusterLicense Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..QVSClusterLicense Properties
QVSSettings..::..QVSCluster..::..QVSClusterLicense Class See Also Send Feedback

The QVSSettings..::..QVSCluster..::..QVSClusterLicense type exposes the following members.

Properties

 | Name | Description
Public property | AllowsClustering |
Public property | ControlNumber |
Public property | SerialNumber |

See Also

QVSSettings..::..QVSCluster..::..QVSClusterLicense Class


AllowsClustering Property

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..QVSClusterLicense..::..AllowsClustering Property
QVSSettings..::..QVSCluster..::..QVSClusterLicense Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster.QVSClusterLicense.AllowsClustering"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowsClustering { get; set; }
Visual Basic
Public Property AllowsClustering As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSCluster..::..QVSClusterLicense Class


ControlNumber Property

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..QVSClusterLicense..::..ControlNumber Property
QVSSettings..::..QVSCluster..::..QVSClusterLicense Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster.QVSClusterLicense.ControlNumber"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ControlNumber { get; set; }
Visual Basic
Public Property ControlNumber As String
    Get
    Set

See Also

QVSSettings..::..QVSCluster..::..QVSClusterLicense Class


SerialNumber Property

[image]

QlikView Management Service API
QVSSettings..::..QVSCluster..::..QVSClusterLicense..::..SerialNumber Property
QVSSettings..::..QVSCluster..::..QVSClusterLicense Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSCluster.QVSClusterLicense.SerialNumber"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string SerialNumber { get; set; }
Visual Basic
Public Property SerialNumber As String
    Get
    Set

See Also

QVSSettings..::..QVSCluster..::..QVSClusterLicense Class


QVSSettings.QVSDistribution Class

[image]

QlikView Management Service API
QVSSettings..::..QVSDistribution Class
QVSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSDistribution"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSDistribution
Visual Basic
Public Class QVSDistribution

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSDistribution

See Also

QVSSettings..::..QVSDistribution Members


QVSSettings.QVSDistribution Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSDistribution Members
QVSSettings..::..QVSDistribution Class Properties See Also Send Feedback

Represents all configurable settings for a QlikView Server.

The QVSSettings..::..QVSDistribution type exposes the following members.

Properties

 | Name | Description
Public property | Accounts |
Public property | IsPublisherQDS |
Public property | QDSID |

See Also

QVSSettings..::..QVSDistribution Class


QVSSettings.QVSDistribution Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSDistribution Properties
QVSSettings..::..QVSDistribution Class See Also Send Feedback

The QVSSettings..::..QVSDistribution type exposes the following members.

Properties

 | Name | Description
Public property | Accounts |
Public property | IsPublisherQDS |
Public property | QDSID |

See Also

QVSSettings..::..QVSDistribution Class


Accounts Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDistribution..::..Accounts Property
QVSSettings..::..QVSDistribution Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDistribution.Accounts"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<QVSSupervisionAccount> Accounts { get; private set; }
Visual Basic
Public Property Accounts As List(Of QVSSupervisionAccount)
    Get
    Private Set

See Also

QVSSettings..::..QVSDistribution Class


IsPublisherQDS Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDistribution..::..IsPublisherQDS Property
QVSSettings..::..QVSDistribution Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDistribution.IsPublisherQDS"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IsPublisherQDS { get; set; }
Visual Basic
Public Property IsPublisherQDS As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDistribution Class


QDSID Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDistribution..::..QDSID Property
QVSSettings..::..QVSDistribution Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDistribution.QDSID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QDSID { get; set; }
Visual Basic
Public Property QDSID As Guid
    Get
    Set

See Also

QVSSettings..::..QVSDistribution Class


QVSSettings.QVSDocuments Class

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments Class
QVSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSDocuments
Visual Basic
Public Class QVSDocuments

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSDocuments

See Also

QVSSettings..::..QVSDocuments Members


QVSSettings.QVSDocuments Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSDocuments Members
QVSSettings..::..QVSDocuments Class Properties See Also Send Feedback

Represents all configurable settings for a QlikView Server.

The QVSSettings..::..QVSDocuments type exposes the following members.

Properties

 | Name | Description
Public property | Objects |
Public property | Q4CMaxNumberOfDocuments |
Public property | Server |

See Also

QVSSettings..::..QVSDocuments Class


QVSSettings.QVSDocuments Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSDocuments Properties
QVSSettings..::..QVSDocuments Class See Also Send Feedback

The QVSSettings..::..QVSDocuments type exposes the following members.

Properties

 | Name | Description
Public property | Objects |
Public property | Q4CMaxNumberOfDocuments |
Public property | Server |

See Also

QVSSettings..::..QVSDocuments Class


Objects Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..Objects Property
QVSSettings..::..QVSDocuments Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.Objects"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Objects { get; private set; }
Visual Basic
Public Property Objects As QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects
    Get
    Private Set

See Also

QVSSettings..::..QVSDocuments Class


Q4CMaxNumberOfDocuments Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..Q4CMaxNumberOfDocuments Property
QVSSettings..::..QVSDocuments Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.Q4CMaxNumberOfDocuments"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int Q4CMaxNumberOfDocuments { get; set; }
Visual Basic
Public Property Q4CMaxNumberOfDocuments As Integer
    Get
    Set

See Also

QVSSettings..::..QVSDocuments Class


Server Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..Server Property
QVSSettings..::..QVSDocuments Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.Server"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Server { get; private set; }
Visual Basic
Public Property Server As QVSSettings..::..QVSDocuments..::..QVSDocumentsServer
    Get
    Private Set

See Also

QVSSettings..::..QVSDocuments Class


QVSSettings.QVSDocuments.QVSDocumentsObjects Class

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class
QVSSettings..::..QVSDocuments Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsObjects"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSDocumentsObjects
Visual Basic
Public Class QVSDocumentsObjects

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Members


QVSSettings.QVSDocuments.QVSDocumentsObjects Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Members
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class Properties See Also Send Feedback

The QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects type exposes the following members.

Properties

 | Name | Description
Public property | AllowMoveObjects |
Public property | DefaultLabelOthers |
Public property | DefaultLabelTotal |

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class


QVSSettings.QVSDocuments.QVSDocumentsObjects Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Properties
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class See Also Send Feedback

The QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects type exposes the following members.

Properties

 | Name | Description
Public property | AllowMoveObjects |
Public property | DefaultLabelOthers |
Public property | DefaultLabelTotal |

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class


AllowMoveObjects Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects..::..AllowMoveObjects Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsObjects.AllowMoveObjects"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowMoveObjects { get; set; }
Visual Basic
Public Property AllowMoveObjects As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class


DefaultLabelOthers Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects..::..DefaultLabelOthers Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsObjects.DefaultLabelOthers"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string DefaultLabelOthers { get; set; }
Visual Basic
Public Property DefaultLabelOthers As String
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class


DefaultLabelTotal Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects..::..DefaultLabelTotal Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsObjects.DefaultLabelTotal"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string DefaultLabelTotal { get; set; }
Visual Basic
Public Property DefaultLabelTotal As String
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsObjects Class


QVSSettings.QVSDocuments.QVSDocumentsServer Class

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class
QVSSettings..::..QVSDocuments Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSDocumentsServer
Visual Basic
Public Class QVSDocumentsServer

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSDocuments..::..QVSDocumentsServer

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Members


QVSSettings.QVSDocuments.QVSDocumentsServer Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Members
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class Properties See Also Send Feedback

The QVSSettings..::..QVSDocuments..::..QVSDocumentsServer type exposes the following members.

Properties

 | Name | Description
Public property | AllowAnonymousServerBookmarkCollaboration |
Public property | AllowDocumentDownload |
Public property | AllowDocumentUpload |
Public property | AllowPrintAndExport | The Allow Print and Export to Excel setting for the documents server.
Public property | AllowServerAnnotations |
Public property | AllowServerCollaboration |
Public property | AllowSessionCollaboration |
Public property | OverlayDocuments |
Public property | ProhibitQVPXSessionRecovery |
Public property | Timeout |

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


QVSSettings.QVSDocuments.QVSDocumentsServer Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Properties
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

The QVSSettings..::..QVSDocuments..::..QVSDocumentsServer type exposes the following members.

Properties

 | Name | Description
Public property | AllowAnonymousServerBookmarkCollaboration |
Public property | AllowDocumentDownload |
Public property | AllowDocumentUpload |
Public property | AllowPrintAndExport | The Allow Print and Export to Excel setting for the documents server.
Public property | AllowServerAnnotations |
Public property | AllowServerCollaboration |
Public property | AllowSessionCollaboration |
Public property | OverlayDocuments |
Public property | ProhibitQVPXSessionRecovery |
Public property | Timeout |

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


AllowAnonymousServerBookmarkCollaboration Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..AllowAnonymousServerBookmarkCollaboration Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.AllowAnonymousServerBookmarkCollaboration"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowAnonymousServerBookmarkCollaboration { get; set; }
Visual Basic
Public Property AllowAnonymousServerBookmarkCollaboration As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


AllowDocumentDownload Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..AllowDocumentDownload Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.AllowDocumentDownload"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowDocumentDownload { get; set; }
Visual Basic
Public Property AllowDocumentDownload As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


AllowDocumentUpload Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..AllowDocumentUpload Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.AllowDocumentUpload"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowDocumentUpload { get; set; }
Visual Basic
Public Property AllowDocumentUpload As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


AllowPrintAndExport Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..AllowPrintAndExport Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback
The Allow Print and Export to Excel setting for the documents server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowPrintAndExport { get; set; }
Visual Basic
Public Property AllowPrintAndExport As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


AllowServerAnnotations Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..AllowServerAnnotations Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.AllowServerAnnotations"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowServerAnnotations { get; set; }
Visual Basic
Public Property AllowServerAnnotations As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


AllowServerCollaboration Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..AllowServerCollaboration Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.AllowServerCollaboration"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowServerCollaboration { get; set; }
Visual Basic
Public Property AllowServerCollaboration As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


AllowSessionCollaboration Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..AllowSessionCollaboration Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.AllowSessionCollaboration"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowSessionCollaboration { get; set; }
Visual Basic
Public Property AllowSessionCollaboration As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


OverlayDocuments Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..OverlayDocuments Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.OverlayDocuments"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool OverlayDocuments { get; set; }
Visual Basic
Public Property OverlayDocuments As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


ProhibitQVPXSessionRecovery Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..ProhibitQVPXSessionRecovery Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.ProhibitQVPXSessionRecovery"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool ProhibitQVPXSessionRecovery { get; set; }
Visual Basic
Public Property ProhibitQVPXSessionRecovery As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


Timeout Property

[image]

QlikView Management Service API
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer..::..Timeout Property
QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSDocuments.QVSDocumentsServer.Timeout"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int Timeout { get; set; }
Visual Basic
Public Property Timeout As Integer
    Get
    Set

See Also

QVSSettings..::..QVSDocuments..::..QVSDocumentsServer Class


QVSSettings.QVSFolders Class

[image]

QlikView Management Service API
QVSSettings..::..QVSFolders Class
QVSSettings Class Members See Also Send Feedback
Contains folder related QlikView Server settings, such as root folder and mounts.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSFolders
Visual Basic
Public Class QVSFolders

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSFolders

See Also

QVSSettings..::..QVSFolders Members


QVSSettings.QVSFolders Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSFolders Members
QVSSettings..::..QVSFolders Class Properties See Also Send Feedback

Represents all configurable settings for a QlikView Server.

The QVSSettings..::..QVSFolders type exposes the following members.

Properties

Name | Description
Public property Q4CDocumentPaths
The user document paths for Q4C (QlikView For Communities) enabled documents
Note
Q4C is a special type of license allowing only a limited number of documents with unlimited number of users. Useful for example for website applications.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.
Public property | System
Public property UserDocumentAdministrators
The user document folder administrators of the QlikView Server.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.
Public property UserDocumentMounts
The user document mounts of the QlikView Server.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.
Public property UserDocumentRootFolder
The user document root folder of the QlikView Server.

See Also

QVSSettings..::..QVSFolders Class


QVSSettings.QVSFolders Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSFolders Properties
QVSSettings..::..QVSFolders Class See Also Send Feedback

The QVSSettings..::..QVSFolders type exposes the following members.

Properties

Name | Description
Public property Q4CDocumentPaths
The user document paths for Q4C (QlikView For Communities) enabled documents
Note
Q4C is a special type of license allowing only a limited number of documents with unlimited number of users. Useful for example for website applications.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.
Public property | System
Public property UserDocumentAdministrators
The user document folder administrators of the QlikView Server.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.
Public property UserDocumentMounts
The user document mounts of the QlikView Server.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.
Public property UserDocumentRootFolder
The user document root folder of the QlikView Server.

See Also

QVSSettings..::..QVSFolders Class


Q4CDocumentPaths Property

[image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..Q4CDocumentPaths Property
QVSSettings..::..QVSFolders Class See Also Send Feedback
The user document paths for Q4C (QlikView For Communities) enabled documents
Note
Q4C is a special type of license allowing only a limited number of documents with unlimited number of users. Useful for example for website applications.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> Q4CDocumentPaths { get; private set; }
Visual Basic
Public Property Q4CDocumentPaths As List(Of String)
    Get
    Private Set

See Also

QVSSettings..::..QVSFolders Class


System Property

[image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..System Property
QVSSettings..::..QVSFolders Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSFolders.System"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSFolders..::..QVSFoldersSystem System { get; private set; }
Visual Basic
Public Property System As QVSSettings..::..QVSFolders..::..QVSFoldersSystem
    Get
    Private Set

See Also

QVSSettings..::..QVSFolders Class


UserDocumentAdministrators Property

[image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..UserDocumentAdministrators Property
QVSSettings..::..QVSFolders Class See Also Send Feedback
The user document folder administrators of the QlikView Server.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<QVSFolderAdministrator> UserDocumentAdministrators { get; private set; }
Visual Basic
Public Property UserDocumentAdministrators As List(Of QVSFolderAdministrator)
    Get
    Private Set

See Also

QVSSettings..::..QVSFolders Class


UserDocumentMounts Property

[image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..UserDocumentMounts Property
QVSSettings..::..QVSFolders Class See Also Send Feedback
The user document mounts of the QlikView Server.
Note
Must not be nullNothingnullptra null reference (Nothing in Visual Basic) when passed to an API operation.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<QVSMount> UserDocumentMounts { get; private set; }
Visual Basic
Public Property UserDocumentMounts As List(Of QVSMount)
    Get
    Private Set

See Also

QVSSettings..::..QVSFolders Class


UserDocumentRootFolder Property

[image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..UserDocumentRootFolder Property
QVSSettings..::..QVSFolders Class See Also Send Feedback
The user document root folder of the QlikView Server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string UserDocumentRootFolder { get; set; }
Visual Basic
Public Property UserDocumentRootFolder As String
    Get
    Set

See Also

QVSSettings..::..QVSFolders Class


QVSSettings.QVSFolders.QVSFoldersSystem Class

[image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..QVSFoldersSystem Class
QVSSettings..::..QVSFolders Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSFolders.QVSFoldersSystem"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSFoldersSystem
Visual Basic
Public Class QVSFoldersSystem

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSFolders..::..QVSFoldersSystem

See Also

QVSSettings..::..QVSFolders..::..QVSFoldersSystem Members


QVSSettings.QVSFolders.QVSFoldersSystem Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..QVSFoldersSystem Members
QVSSettings..::..QVSFolders..::..QVSFoldersSystem Class Properties See Also Send Feedback

Contains folder related QlikView Server settings, such as root folder and mounts.

The QVSSettings..::..QVSFolders..::..QVSFoldersSystem type exposes the following members.

Properties

 | Name | Description
Public property | ExportTemporaryFolder |

See Also

QVSSettings..::..QVSFolders..::..QVSFoldersSystem Class


QVSSettings.QVSFolders.QVSFoldersSystem Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..QVSFoldersSystem Properties
QVSSettings..::..QVSFolders..::..QVSFoldersSystem Class See Also Send Feedback

The QVSSettings..::..QVSFolders..::..QVSFoldersSystem type exposes the following members.

Properties

 | Name | Description
Public property | ExportTemporaryFolder |

See Also

QVSSettings..::..QVSFolders..::..QVSFoldersSystem Class


ExportTemporaryFolder Property

[image]

QlikView Management Service API
QVSSettings..::..QVSFolders..::..QVSFoldersSystem..::..ExportTemporaryFolder Property
QVSSettings..::..QVSFolders..::..QVSFoldersSystem Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSFolders.QVSFoldersSystem.ExportTemporaryFolder"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ExportTemporaryFolder { get; set; }
Visual Basic
Public Property ExportTemporaryFolder As String
    Get
    Set

See Also

QVSSettings..::..QVSFolders..::..QVSFoldersSystem Class


QVSSettings.QVSGeneral Class

[image]

QlikView Management Service API
QVSSettings..::..QVSGeneral Class
QVSSettings Class Members See Also Send Feedback
Contains general QlikView Server settings, such as server name and login information.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSGeneral
Visual Basic
Public Class QVSGeneral

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSGeneral

See Also

QVSSettings..::..QVSGeneral Members


QVSSettings.QVSGeneral Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSGeneral Members
QVSSettings..::..QVSGeneral Class Properties See Also Send Feedback

Represents all configurable settings for a QlikView Server.

The QVSSettings..::..QVSGeneral type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the QlikView Server.
Public property | Password | The password needed in combination with UserName to connect to the QlikView Server.
Public property | ShowAlerts | When set to true it indicates a scheduled downtime.
Public property | UserName | The user name needed to connect to the QlikView Server.

See Also

QVSSettings..::..QVSGeneral Class


QVSSettings.QVSGeneral Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSGeneral Properties
QVSSettings..::..QVSGeneral Class See Also Send Feedback

The QVSSettings..::..QVSGeneral type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the QlikView Server.
Public property | Password | The password needed in combination with UserName to connect to the QlikView Server.
Public property | ShowAlerts | When set to true it indicates a scheduled downtime.
Public property | UserName | The user name needed to connect to the QlikView Server.

See Also

QVSSettings..::..QVSGeneral Class


Name Property

[image]

QlikView Management Service API
QVSSettings..::..QVSGeneral..::..Name Property
QVSSettings..::..QVSGeneral Class See Also Send Feedback
The name of the QlikView Server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

QVSSettings..::..QVSGeneral Class


Password Property

[image]

QlikView Management Service API
QVSSettings..::..QVSGeneral..::..Password Property
QVSSettings..::..QVSGeneral Class See Also Send Feedback
The password needed in combination with UserName to connect to the QlikView Server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set

See Also

QVSSettings..::..QVSGeneral Class


ShowAlerts Property

[image]

QlikView Management Service API
QVSSettings..::..QVSGeneral..::..ShowAlerts Property
QVSSettings..::..QVSGeneral Class See Also Send Feedback
When set to true it indicates a scheduled downtime.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool ShowAlerts { get; set; }
Visual Basic
Public Property ShowAlerts As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSGeneral Class


UserName Property

[image]

QlikView Management Service API
QVSSettings..::..QVSGeneral..::..UserName Property
QVSSettings..::..QVSGeneral Class See Also Send Feedback
The user name needed to connect to the QlikView Server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set

See Also

QVSSettings..::..QVSGeneral Class


QVSSettings.QVSLogging Class

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging Class
QVSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSLogging
Visual Basic
Public Class QVSLogging

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSLogging

See Also

QVSSettings..::..QVSLogging Members


QVSSettings.QVSLogging Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSLogging Members
QVSSettings..::..QVSLogging Class Properties See Also Send Feedback

Represents all configurable settings for a QlikView Server.

The QVSSettings..::..QVSLogging type exposes the following members.

Properties

 | Name | Description
Public property | FileSplitMode |
Public property | Folder |
Public property | Level |
Public property | Verbosity |

See Also

QVSSettings..::..QVSLogging Class


QVSSettings.QVSLogging Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSLogging Properties
QVSSettings..::..QVSLogging Class See Also Send Feedback

The QVSSettings..::..QVSLogging type exposes the following members.

Properties

 | Name | Description
Public property | FileSplitMode |
Public property | Folder |
Public property | Level |
Public property | Verbosity |

See Also

QVSSettings..::..QVSLogging Class


FileSplitMode Property

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..FileSplitMode Property
QVSSettings..::..QVSLogging Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.FileSplitMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSLogFileSplitMode FileSplitMode { get; set; }
Visual Basic
Public Property FileSplitMode As QVSLogFileSplitMode
    Get
    Set

See Also

QVSSettings..::..QVSLogging Class


Folder Property

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..Folder Property
QVSSettings..::..QVSLogging Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.Folder"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Folder { get; set; }
Visual Basic
Public Property Folder As String
    Get
    Set

See Also

QVSSettings..::..QVSLogging Class


Level Property

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..Level Property
QVSSettings..::..QVSLogging Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.Level"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSLogging..::..QVSLoggingLevel Level { get; private set; }
Visual Basic
Public Property Level As QVSSettings..::..QVSLogging..::..QVSLoggingLevel
    Get
    Private Set

See Also

QVSSettings..::..QVSLogging Class


Verbosity Property

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..Verbosity Property
QVSSettings..::..QVSLogging Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.Verbosity"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSLogVerbosity Verbosity { get; set; }
Visual Basic
Public Property Verbosity As QVSLogVerbosity
    Get
    Set

See Also

QVSSettings..::..QVSLogging Class


QVSSettings.QVSLogging.QVSLoggingLevel Class

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class
QVSSettings..::..QVSLogging Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.QVSLoggingLevel"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSLoggingLevel
Visual Basic
Public Class QVSLoggingLevel

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSLogging..::..QVSLoggingLevel

See Also

QVSSettings..::..QVSLogging..::..QVSLoggingLevel Members


QVSSettings.QVSLogging.QVSLoggingLevel Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Members
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class Properties See Also Send Feedback

The QVSSettings..::..QVSLogging..::..QVSLoggingLevel type exposes the following members.

Properties

 | Name | Description
Public property | EnableEventLogging |
Public property | EnablePerformanceLogging |
Public property | EnableSessionLogging |
Public property | PerformanceLoggingInterval |

See Also

QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class


QVSSettings.QVSLogging.QVSLoggingLevel Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Properties
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class See Also Send Feedback

The QVSSettings..::..QVSLogging..::..QVSLoggingLevel type exposes the following members.

Properties

 | Name | Description
Public property | EnableEventLogging |
Public property | EnablePerformanceLogging |
Public property | EnableSessionLogging |
Public property | PerformanceLoggingInterval |

See Also

QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class


EnableEventLogging Property

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..QVSLoggingLevel..::..EnableEventLogging Property
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.QVSLoggingLevel.EnableEventLogging"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool EnableEventLogging { get; set; }
Visual Basic
Public Property EnableEventLogging As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class


EnablePerformanceLogging Property

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..QVSLoggingLevel..::..EnablePerformanceLogging Property
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.QVSLoggingLevel.EnablePerformanceLogging"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool EnablePerformanceLogging { get; set; }
Visual Basic
Public Property EnablePerformanceLogging As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class


EnableSessionLogging Property

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..QVSLoggingLevel..::..EnableSessionLogging Property
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.QVSLoggingLevel.EnableSessionLogging"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool EnableSessionLogging { get; set; }
Visual Basic
Public Property EnableSessionLogging As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class


PerformanceLoggingInterval Property

[image]

QlikView Management Service API
QVSSettings..::..QVSLogging..::..QVSLoggingLevel..::..PerformanceLoggingInterval Property
QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSLogging.QVSLoggingLevel.PerformanceLoggingInterval"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int PerformanceLoggingInterval { get; set; }
Visual Basic
Public Property PerformanceLoggingInterval As Integer
    Get
    Set

See Also

QVSSettings..::..QVSLogging..::..QVSLoggingLevel Class


QVSSettings.QVSPerformance Class

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance Class
QVSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSPerformance
Visual Basic
Public Class QVSPerformance

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSPerformance

See Also

QVSSettings..::..QVSPerformance Members


QVSSettings.QVSPerformance Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance Members
QVSSettings..::..QVSPerformance Class Properties See Also Send Feedback

Represents all configurable settings for a QlikView Server.

The QVSSettings..::..QVSPerformance type exposes the following members.

Properties

 | Name | Description
Public property | CPU |
Public property | Document |
Public property | Sessions |
Public property | WorkingSetMemory |

See Also

QVSSettings..::..QVSPerformance Class


QVSSettings.QVSPerformance Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance Properties
QVSSettings..::..QVSPerformance Class See Also Send Feedback

The QVSSettings..::..QVSPerformance type exposes the following members.

Properties

 | Name | Description
Public property | CPU |
Public property | Document |
Public property | Sessions |
Public property | WorkingSetMemory |

See Also

QVSSettings..::..QVSPerformance Class


CPU Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..CPU Property
QVSSettings..::..QVSPerformance Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.CPU"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU CPU { get; private set; }
Visual Basic
Public Property CPU As QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU
    Get
    Private Set

See Also

QVSSettings..::..QVSPerformance Class


Document Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..Document Property
QVSSettings..::..QVSPerformance Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.Document"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Document { get; private set; }
Visual Basic
Public Property Document As QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument
    Get
    Private Set

See Also

QVSSettings..::..QVSPerformance Class


Sessions Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..Sessions Property
QVSSettings..::..QVSPerformance Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.Sessions"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Sessions { get; private set; }
Visual Basic
Public Property Sessions As QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions
    Get
    Private Set

See Also

QVSSettings..::..QVSPerformance Class


WorkingSetMemory Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..WorkingSetMemory Property
QVSSettings..::..QVSPerformance Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.WorkingSetMemory"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory WorkingSetMemory { get; private set; }
Visual Basic
Public Property WorkingSetMemory As QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory
    Get
    Private Set

See Also

QVSSettings..::..QVSPerformance Class


QVSSettings.QVSPerformance.QVSPerformanceCPU Class

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class
QVSSettings..::..QVSPerformance Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceCPU"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSPerformanceCPU
Visual Basic
Public Class QVSPerformanceCPU

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Members


QVSSettings.QVSPerformance.QVSPerformanceCPU Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Members
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class Properties See Also Send Feedback

The QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU type exposes the following members.

Properties

 | Name | Description
Public property | Affinity |
Public property | Throttle |

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class


QVSSettings.QVSPerformance.QVSPerformanceCPU Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Properties
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class See Also Send Feedback

The QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU type exposes the following members.

Properties

 | Name | Description
Public property | Affinity |
Public property | Throttle |

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class


Affinity Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU..::..Affinity Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceCPU.Affinity"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<bool> Affinity { get; private set; }
Visual Basic
Public Property Affinity As List(Of Boolean)
    Get
    Private Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class


Throttle Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU..::..Throttle Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceCPU.Throttle"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public double Throttle { get; set; }
Visual Basic
Public Property Throttle As Double
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceCPU Class


QVSSettings.QVSPerformance.QVSPerformanceDocument Class

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class
QVSSettings..::..QVSPerformance Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceDocument"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSPerformanceDocument
Visual Basic
Public Class QVSPerformanceDocument

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Members


QVSSettings.QVSPerformance.QVSPerformanceDocument Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Members
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class Properties See Also Send Feedback

The QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument type exposes the following members.

Properties

 | Name | Description
Public property | AllowDocumentAutoLoad |
Public property | MaxChartSymbols |
Public property | ObjectCalculationTimeLimit |

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class


QVSSettings.QVSPerformance.QVSPerformanceDocument Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Properties
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class See Also Send Feedback

The QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument type exposes the following members.

Properties

 | Name | Description
Public property | AllowDocumentAutoLoad |
Public property | MaxChartSymbols |
Public property | ObjectCalculationTimeLimit |

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class


AllowDocumentAutoLoad Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument..::..AllowDocumentAutoLoad Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceDocument.AllowDocumentAutoLoad"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowDocumentAutoLoad { get; set; }
Visual Basic
Public Property AllowDocumentAutoLoad As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class


MaxChartSymbols Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument..::..MaxChartSymbols Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceDocument.MaxChartSymbols"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int MaxChartSymbols { get; set; }
Visual Basic
Public Property MaxChartSymbols As Integer
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class


ObjectCalculationTimeLimit Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument..::..ObjectCalculationTimeLimit Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceDocument.ObjectCalculationTimeLimit"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int ObjectCalculationTimeLimit { get; set; }
Visual Basic
Public Property ObjectCalculationTimeLimit As Integer
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceDocument Class


QVSSettings.QVSPerformance.QVSPerformanceSessions Class

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class
QVSSettings..::..QVSPerformance Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceSessions"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSPerformanceSessions
Visual Basic
Public Class QVSPerformanceSessions

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Members


QVSSettings.QVSPerformance.QVSPerformanceSessions Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Members
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class Properties See Also Send Feedback

The QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions type exposes the following members.

Properties

 | Name | Description
Public property | ConcurrentSessionsTimeout |
Public property | MaxConcurrentSessions |
Public property | MaxInactiveSessionTime |
Public property | MaxTotalSessionTime |

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class


QVSSettings.QVSPerformance.QVSPerformanceSessions Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Properties
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class See Also Send Feedback

The QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions type exposes the following members.

Properties

 | Name | Description
Public property | ConcurrentSessionsTimeout |
Public property | MaxConcurrentSessions |
Public property | MaxInactiveSessionTime |
Public property | MaxTotalSessionTime |

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class


ConcurrentSessionsTimeout Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions..::..ConcurrentSessionsTimeout Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceSessions.ConcurrentSessionsTimeout"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int ConcurrentSessionsTimeout { get; set; }
Visual Basic
Public Property ConcurrentSessionsTimeout As Integer
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class


MaxConcurrentSessions Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions..::..MaxConcurrentSessions Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceSessions.MaxConcurrentSessions"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int MaxConcurrentSessions { get; set; }
Visual Basic
Public Property MaxConcurrentSessions As Integer
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class


MaxInactiveSessionTime Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions..::..MaxInactiveSessionTime Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceSessions.MaxInactiveSessionTime"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int MaxInactiveSessionTime { get; set; }
Visual Basic
Public Property MaxInactiveSessionTime As Integer
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class


MaxTotalSessionTime Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions..::..MaxTotalSessionTime Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceSessions.MaxTotalSessionTime"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int MaxTotalSessionTime { get; set; }
Visual Basic
Public Property MaxTotalSessionTime As Integer
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceSessions Class


QVSSettings.QVSPerformance.QVSPerformanceWorkingSetMemory Class

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class
QVSSettings..::..QVSPerformance Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSPerformance.QVSPerformanceWorkingSetMemory"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSPerformanceWorkingSetMemory
Visual Basic
Public Class QVSPerformanceWorkingSetMemory

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Members


QVSSettings.QVSPerformance.QVSPerformanceWorkingSetMemory Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Members
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class Properties See Also Send Feedback

The QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory type exposes the following members.

Properties

 | Name | Description
Public property | HighLimit | In percent [%].
Public property | LowLimit | In percent [%].

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class


QVSSettings.QVSPerformance.QVSPerformanceWorkingSetMemory Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Properties
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class See Also Send Feedback

The QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory type exposes the following members.

Properties

 | Name | Description
Public property | HighLimit | In percent [%].
Public property | LowLimit | In percent [%].

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class


HighLimit Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory..::..HighLimit Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class See Also Send Feedback
In percent [%].

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int HighLimit { get; set; }
Visual Basic
Public Property HighLimit As Integer
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class


LowLimit Property

[image]

QlikView Management Service API
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory..::..LowLimit Property
QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class See Also Send Feedback
In percent [%].

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int LowLimit { get; set; }
Visual Basic
Public Property LowLimit As Integer
    Get
    Set

See Also

QVSSettings..::..QVSPerformance..::..QVSPerformanceWorkingSetMemory Class


QVSSettings.QVSSecurity Class

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity Class
QVSSettings Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSSecurity
Visual Basic
Public Class QVSSecurity

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSSecurity

See Also

QVSSettings..::..QVSSecurity Members


QVSSettings.QVSSecurity Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSSecurity Members
QVSSettings..::..QVSSecurity Class Properties See Also Send Feedback

Represents all configurable settings for a QlikView Server.

The QVSSettings..::..QVSSecurity type exposes the following members.

Properties

 | Name | Description
Public property | AllowAlternateAdmin |
Public property | AllowDynamicUpdate |
Public property | AllowExtensions |
Public property | AllowServerMacroExecution |
Public property | AllowServerSystemAccessMacroExecution |
Public property | Authentication |
Public property | Authorization |
Public property | CompressNetworkTraffic |
Public property | EnableAuditLogging | Audit logging of client activity.
Public property | EnableHTTPPush |
Public property | ExtensionsFolder |

See Also

QVSSettings..::..QVSSecurity Class


QVSSettings.QVSSecurity Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSSecurity Properties
QVSSettings..::..QVSSecurity Class See Also Send Feedback

The QVSSettings..::..QVSSecurity type exposes the following members.

Properties

 | Name | Description
Public property | AllowAlternateAdmin |
Public property | AllowDynamicUpdate |
Public property | AllowExtensions |
Public property | AllowServerMacroExecution |
Public property | AllowServerSystemAccessMacroExecution |
Public property | Authentication |
Public property | Authorization |
Public property | CompressNetworkTraffic |
Public property | EnableAuditLogging | Audit logging of client activity.
Public property | EnableHTTPPush |
Public property | ExtensionsFolder |

See Also

QVSSettings..::..QVSSecurity Class


AllowAlternateAdmin Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..AllowAlternateAdmin Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.AllowAlternateAdmin"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowAlternateAdmin { get; set; }
Visual Basic
Public Property AllowAlternateAdmin As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


AllowDynamicUpdate Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..AllowDynamicUpdate Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.AllowDynamicUpdate"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowDynamicUpdate { get; set; }
Visual Basic
Public Property AllowDynamicUpdate As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


AllowExtensions Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..AllowExtensions Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.AllowExtensions"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowExtensions { get; set; }
Visual Basic
Public Property AllowExtensions As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


AllowServerMacroExecution Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..AllowServerMacroExecution Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.AllowServerMacroExecution"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowServerMacroExecution { get; set; }
Visual Basic
Public Property AllowServerMacroExecution As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


AllowServerSystemAccessMacroExecution Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..AllowServerSystemAccessMacroExecution Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.AllowServerSystemAccessMacroExecution"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool AllowServerSystemAccessMacroExecution { get; set; }
Visual Basic
Public Property AllowServerSystemAccessMacroExecution As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


Authentication Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..Authentication Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.Authentication"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Authentication { get; private set; }
Visual Basic
Public Property Authentication As QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication
    Get
    Private Set

See Also

QVSSettings..::..QVSSecurity Class


Authorization Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..Authorization Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.Authorization"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Authorization { get; private set; }
Visual Basic
Public Property Authorization As QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization
    Get
    Private Set

See Also

QVSSettings..::..QVSSecurity Class


CompressNetworkTraffic Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..CompressNetworkTraffic Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.CompressNetworkTraffic"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool CompressNetworkTraffic { get; set; }
Visual Basic
Public Property CompressNetworkTraffic As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


EnableAuditLogging Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..EnableAuditLogging Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback
Audit logging of client activity.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSAuditLogLevel EnableAuditLogging { get; set; }
Visual Basic
Public Property EnableAuditLogging As QVSAuditLogLevel
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


EnableHTTPPush Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..EnableHTTPPush Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.EnableHTTPPush"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool EnableHTTPPush { get; set; }
Visual Basic
Public Property EnableHTTPPush As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


ExtensionsFolder Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..ExtensionsFolder Property
QVSSettings..::..QVSSecurity Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.ExtensionsFolder"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string ExtensionsFolder { get; set; }
Visual Basic
Public Property ExtensionsFolder As String
    Get
    Set

See Also

QVSSettings..::..QVSSecurity Class


QVSSettings.QVSSecurity.QVSSecurityAuthentication Class

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class
QVSSettings..::..QVSSecurity Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.QVSSecurityAuthentication"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSSecurityAuthentication
Visual Basic
Public Class QVSSecurityAuthentication

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Members


QVSSettings.QVSSecurity.QVSSecurityAuthentication Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Members
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class Properties See Also Send Feedback

The QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication type exposes the following members.

Properties

 | Name | Description
Public property | Level |
Public property | UseDomainAccountForAnonymous |

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class


QVSSettings.QVSSecurity.QVSSecurityAuthentication Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Properties
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class See Also Send Feedback

The QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication type exposes the following members.

Properties

 | Name | Description
Public property | Level |
Public property | UseDomainAccountForAnonymous |

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class


Level Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication..::..Level Property
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.QVSSecurityAuthentication.Level"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSAuthenticationLevel Level { get; set; }
Visual Basic
Public Property Level As QVSAuthenticationLevel
    Get
    Set

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class


UseDomainAccountForAnonymous Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication..::..UseDomainAccountForAnonymous Property
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.QVSSecurityAuthentication.UseDomainAccountForAnonymous"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool UseDomainAccountForAnonymous { get; set; }
Visual Basic
Public Property UseDomainAccountForAnonymous As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthentication Class


QVSSettings.QVSSecurity.QVSSecurityAuthorization Class

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Class
QVSSettings..::..QVSSecurity Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.QVSSecurityAuthorization"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSSecurityAuthorization
Visual Basic
Public Class QVSSecurityAuthorization

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Members


QVSSettings.QVSSecurity.QVSSecurityAuthorization Members

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Members
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Class Properties See Also Send Feedback

The QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization type exposes the following members.

Properties

 | Name | Description
Public property | UseDMSAuthorization |

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Class


QVSSettings.QVSSecurity.QVSSecurityAuthorization Properties

[image] [image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Properties
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Class See Also Send Feedback

The QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization type exposes the following members.

Properties

 | Name | Description
Public property | UseDMSAuthorization |

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Class


UseDMSAuthorization Property

[image]

QlikView Management Service API
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization..::..UseDMSAuthorization Property
QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSettings.QVSSecurity.QVSSecurityAuthorization.UseDMSAuthorization"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool UseDMSAuthorization { get; set; }
Visual Basic
Public Property UseDMSAuthorization As Boolean
    Get
    Set

See Also

QVSSettings..::..QVSSecurity..::..QVSSecurityAuthorization Class


QVSSettingsScope Enumeration

[image]

QlikView Management Service API
QVSSettingsScope Enumeration
See Also Send Feedback
The different available scopes for a QVSSettings object.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum QVSSettingsScope
Visual Basic
<FlagsAttribute> _
Public Enumeration QVSSettingsScope

Members

Member name | Value | Description
None | 0 | No scope specified.
General | 1 | Represents general settings, such as server name and login information, and corresponds to General.
Folders | 2 | Represents folder settings, such as root folder and mounts, and corresponds to Folders.
Documents | 4 | Represents document settings and corresponds to Documents.
Performance | 8 | Represents performance settings, such as CPU, memory and session configurations, and corresponds to Performance.
Logging | 16 | Represents logging settings, such as log folder and level, and corresponds to Logging.
Security | 32 | Represents security settings and corresponds to Security.
Cluster | 64 | Represents cluster settings and corresponds to Cluster.
Distribution | 128 | Represents distribution settings, such as supervision accounts, and corresponds to Distribution.
All | 65535 | Full scope. Represents all settings.

See Also

PIX.QMSAPI.DataObjects..::..QVSSettings


QVSSupervisionAccount Class

[image]

QlikView Management Service API
QVSSupervisionAccount Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSupervisionAccount"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class QVSSupervisionAccount
Visual Basic
Public Class QVSSupervisionAccount

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..QVSSupervisionAccount

See Also

QVSSupervisionAccount Members


QVSSupervisionAccount Members

[image] [image]

QlikView Management Service API
QVSSupervisionAccount Members
QVSSupervisionAccount Class Properties See Also Send Feedback

The QVSSupervisionAccount type exposes the following members.

Properties

 | Name | Description
Public property | AccountName |
Public property | ID |
Public property | MountName |
Public property | Type |

See Also

QVSSupervisionAccount Class


QVSSupervisionAccount Properties

[image] [image]

QlikView Management Service API
QVSSupervisionAccount Properties
QVSSupervisionAccount Class See Also Send Feedback

The QVSSupervisionAccount type exposes the following members.

Properties

 | Name | Description
Public property | AccountName |
Public property | ID |
Public property | MountName |
Public property | Type |

See Also

QVSSupervisionAccount Class


AccountName Property

[image]

QlikView Management Service API
QVSSupervisionAccount..::..AccountName Property
QVSSupervisionAccount Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSupervisionAccount.AccountName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string AccountName { get; set; }
Visual Basic
Public Property AccountName As String
    Get
    Set

See Also

QVSSupervisionAccount Class


ID Property

[image]

QlikView Management Service API
QVSSupervisionAccount..::..ID Property
QVSSupervisionAccount Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSupervisionAccount.ID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

QVSSupervisionAccount Class


MountName Property

[image]

QlikView Management Service API
QVSSupervisionAccount..::..MountName Property
QVSSupervisionAccount Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSupervisionAccount.MountName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string MountName { get; set; }
Visual Basic
Public Property MountName As String
    Get
    Set

See Also

QVSSupervisionAccount Class


Type Property

[image]

QlikView Management Service API
QVSSupervisionAccount..::..Type Property
QVSSupervisionAccount Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.QVSSupervisionAccount.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public QVSSupervisionAccountType Type { get; set; }
Visual Basic
Public Property Type As QVSSupervisionAccountType
    Get
    Set

See Also

QVSSupervisionAccount Class


QVSSupervisionAccountType Enumeration

[image]

QlikView Management Service API
QVSSupervisionAccountType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.QVSSupervisionAccountType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum QVSSupervisionAccountType
Visual Basic
Public Enumeration QVSSupervisionAccountType

Members

Member name | Value | Description
QlikViewServer | 0 |
Mount | 1 |

See Also


QVSUserDocumentFolderType Enumeration

[image]

QlikView Management Service API
QVSUserDocumentFolderType Enumeration
See Also Send Feedback
All available QVSUserDocumentFolderType parameters. Sub folders are only available through the node interface.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum QVSUserDocumentFolderType
Visual Basic
Public Enumeration QVSUserDocumentFolderType

Members

Member name | Value | Description
Server | 1 | The QVS itself.
Root | 2 | A root folder.
Mount | 3 | A mounted folder.

See Also


SectionAccessTable Class

[image]

QlikView Management Service API
SectionAccessTable Class
Members See Also Send Feedback
Represents a table which defines how a document is to be reduced combined with which user that should see each reduction.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class SectionAccessTable
Visual Basic
Public Class SectionAccessTable

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..SectionAccessTable

See Also

SectionAccessTable Members


SectionAccessTable Members

[image] [image]

QlikView Management Service API
SectionAccessTable Members
SectionAccessTable Class Properties See Also Send Feedback

The SectionAccessTable type exposes the following members.

Properties

 | Name | Description
Public property | Columns | The columns of the table.
Public property | ID | The ID of the table.
Public property | Name | The name of the table.
Public property | Roles | roles of the
Public property | Rows | The rows of the table.
Public property | Scope | The scope of the table. Depending on the value a given instance of this class can contain information about columns or all data rows.

See Also

SectionAccessTable Class


SectionAccessTable Properties

[image] [image]

QlikView Management Service API
SectionAccessTable Properties
SectionAccessTable Class See Also Send Feedback

The SectionAccessTable type exposes the following members.

Properties

 | Name | Description
Public property | Columns | The columns of the table.
Public property | ID | The ID of the table.
Public property | Name | The name of the table.
Public property | Roles | roles of the
Public property | Rows | The rows of the table.
Public property | Scope | The scope of the table. Depending on the value a given instance of this class can contain information about columns or all data rows.

See Also

SectionAccessTable Class


Columns Property

[image]

QlikView Management Service API
SectionAccessTable..::..Columns Property
SectionAccessTable Class See Also Send Feedback
The columns of the table.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<SectionAccessTable..::..SectionAccessColumn> Columns { get; private set; }
Visual Basic
Public Property Columns As List(Of SectionAccessTable..::..SectionAccessColumn)
    Get
    Private Set

See Also

SectionAccessTable Class


ID Property

[image]

QlikView Management Service API
SectionAccessTable..::..ID Property
SectionAccessTable Class See Also Send Feedback
The ID of the table.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

SectionAccessTable Class


Name Property

[image]

QlikView Management Service API
SectionAccessTable..::..Name Property
SectionAccessTable Class See Also Send Feedback
The name of the table.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

SectionAccessTable Class


Roles Property

[image]

QlikView Management Service API
SectionAccessTable..::..Roles Property
SectionAccessTable Class See Also Send Feedback
roles of the

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> Roles { get; set; }
Visual Basic
Public Property Roles As List(Of String)
    Get
    Set

See Also

SectionAccessTable Class


Rows Property

[image]

QlikView Management Service API
SectionAccessTable..::..Rows Property
SectionAccessTable Class See Also Send Feedback
The rows of the table.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<SectionAccessTable..::..SectionAccessRow> Rows { get; private set; }
Visual Basic
Public Property Rows As List(Of SectionAccessTable..::..SectionAccessRow)
    Get
    Private Set

See Also

SectionAccessTable Class


Scope Property

[image]

QlikView Management Service API
SectionAccessTable..::..Scope Property
SectionAccessTable Class See Also Send Feedback
The scope of the table. Depending on the value a given instance of this class can contain information about columns or all data rows.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public SectionAccessScope Scope { get; private set; }
Visual Basic
Public Property Scope As SectionAccessScope
    Get
    Private Set

See Also

SectionAccessTable Class


SectionAccessTable.SectionAccessCell Class

[image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessCell Class
SectionAccessTable Class Members See Also Send Feedback
Represents a single cell.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class SectionAccessCell
Visual Basic
Public Class SectionAccessCell

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..SectionAccessTable..::..SectionAccessCell

See Also

SectionAccessTable..::..SectionAccessCell Members


SectionAccessTable.SectionAccessCell Members

[image] [image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessCell Members
SectionAccessTable..::..SectionAccessCell Class Properties See Also Send Feedback

Represents a table which defines how a document is to be reduced combined with which user that should see each reduction.

The SectionAccessTable..::..SectionAccessCell type exposes the following members.

Properties

 | Name | Description
Public property | Value | The value of the cell.

See Also

SectionAccessTable..::..SectionAccessCell Class


SectionAccessTable.SectionAccessCell Properties

[image] [image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessCell Properties
SectionAccessTable..::..SectionAccessCell Class See Also Send Feedback

The SectionAccessTable..::..SectionAccessCell type exposes the following members.

Properties

 | Name | Description
Public property | Value | The value of the cell.

See Also

SectionAccessTable..::..SectionAccessCell Class


Value Property

[image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessCell..::..Value Property
SectionAccessTable..::..SectionAccessCell Class See Also Send Feedback
The value of the cell.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

See Also

SectionAccessTable..::..SectionAccessCell Class


SectionAccessTable.SectionAccessColumn Class

[image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessColumn Class
SectionAccessTable Class Members See Also Send Feedback
Represents a single column

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class SectionAccessColumn
Visual Basic
Public Class SectionAccessColumn

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..SectionAccessTable..::..SectionAccessColumn

See Also

SectionAccessTable..::..SectionAccessColumn Members


SectionAccessTable.SectionAccessColumn Members

[image] [image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessColumn Members
SectionAccessTable..::..SectionAccessColumn Class Properties See Also Send Feedback

Represents a table which defines how a document is to be reduced combined with which user that should see each reduction.

The SectionAccessTable..::..SectionAccessColumn type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the column

See Also

SectionAccessTable..::..SectionAccessColumn Class


SectionAccessTable.SectionAccessColumn Properties

[image] [image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessColumn Properties
SectionAccessTable..::..SectionAccessColumn Class See Also Send Feedback

The SectionAccessTable..::..SectionAccessColumn type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the column

See Also

SectionAccessTable..::..SectionAccessColumn Class


Name Property

[image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessColumn..::..Name Property
SectionAccessTable..::..SectionAccessColumn Class See Also Send Feedback
The name of the column

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

SectionAccessTable..::..SectionAccessColumn Class


SectionAccessTable.SectionAccessRow Class

[image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessRow Class
SectionAccessTable Class Members See Also Send Feedback
Represents a single row.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class SectionAccessRow
Visual Basic
Public Class SectionAccessRow

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..SectionAccessTable..::..SectionAccessRow

See Also

SectionAccessTable..::..SectionAccessRow Members


SectionAccessTable.SectionAccessRow Members

[image] [image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessRow Members
SectionAccessTable..::..SectionAccessRow Class Properties See Also Send Feedback

Represents a table which defines how a document is to be reduced combined with which user that should see each reduction.

The SectionAccessTable..::..SectionAccessRow type exposes the following members.

Properties

 | Name | Description
Public property | Cells | A list of cells for the row.
Public property | RowNumber | The row number.

See Also

SectionAccessTable..::..SectionAccessRow Class


SectionAccessTable.SectionAccessRow Properties

[image] [image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessRow Properties
SectionAccessTable..::..SectionAccessRow Class See Also Send Feedback

The SectionAccessTable..::..SectionAccessRow type exposes the following members.

Properties

 | Name | Description
Public property | Cells | A list of cells for the row.
Public property | RowNumber | The row number.

See Also

SectionAccessTable..::..SectionAccessRow Class


Cells Property

[image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessRow..::..Cells Property
SectionAccessTable..::..SectionAccessRow Class See Also Send Feedback
A list of cells for the row.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<SectionAccessTable..::..SectionAccessCell> Cells { get; set; }
Visual Basic
Public Property Cells As List(Of SectionAccessTable..::..SectionAccessCell)
    Get
    Set

See Also

SectionAccessTable..::..SectionAccessRow Class


RowNumber Property

[image]

QlikView Management Service API
SectionAccessTable..::..SectionAccessRow..::..RowNumber Property
SectionAccessTable..::..SectionAccessRow Class See Also Send Feedback
The row number.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int RowNumber { get; set; }
Visual Basic
Public Property RowNumber As Integer
    Get
    Set

See Also

SectionAccessTable..::..SectionAccessRow Class


ServerDocumentLoadMode Enumeration

[image]

QlikView Management Service API
ServerDocumentLoadMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.ServerDocumentLoadMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum ServerDocumentLoadMode
Visual Basic
Public Enumeration ServerDocumentLoadMode

Members

Member name | Value | Description
Allow | 0 |
Preload | 1 |
Granular | 2 |

See Also


ServerObject Class

[image]

QlikView Management Service API
ServerObject Class
Members See Also Send Feedback
Represents a server object which can be shared with other users.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class ServerObject
Visual Basic
Public Class ServerObject

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..ServerObject

See Also

ServerObject Members


ServerObject Members

[image] [image]

QlikView Management Service API
ServerObject Members
ServerObject Class Properties See Also Send Feedback

The ServerObject type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ID of the server object
Public property | OwnerId | The id of the owner.
Public property | OwnerName | The name of the owner
Public property | Shared | Flag indicating whether the data object is shared or not.
Public property | SubType | The subtype, which depends on the type.
Public property | Temporary | Flag indicating whether the data object is temporary or not.
Public property | Type | The type (eg Bookmark, Sheet, Report or SheetObject).
Public property | UtcModifyTime | The time of when the data object was last modified

See Also

ServerObject Class


ServerObject Properties

[image] [image]

QlikView Management Service API
ServerObject Properties
ServerObject Class See Also Send Feedback

The ServerObject type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ID of the server object
Public property | OwnerId | The id of the owner.
Public property | OwnerName | The name of the owner
Public property | Shared | Flag indicating whether the data object is shared or not.
Public property | SubType | The subtype, which depends on the type.
Public property | Temporary | Flag indicating whether the data object is temporary or not.
Public property | Type | The type (eg Bookmark, Sheet, Report or SheetObject).
Public property | UtcModifyTime | The time of when the data object was last modified

See Also

ServerObject Class


Id Property

[image]

QlikView Management Service API
ServerObject..::..Id Property
ServerObject Class See Also Send Feedback
The ID of the server object

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

See Also

ServerObject Class


OwnerId Property

[image]

QlikView Management Service API
ServerObject..::..OwnerId Property
ServerObject Class See Also Send Feedback
The id of the owner.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string OwnerId { get; set; }
Visual Basic
Public Property OwnerId As String
    Get
    Set

See Also

ServerObject Class


OwnerName Property

[image]

QlikView Management Service API
ServerObject..::..OwnerName Property
ServerObject Class See Also Send Feedback
The name of the owner

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string OwnerName { get; set; }
Visual Basic
Public Property OwnerName As String
    Get
    Set

See Also

ServerObject Class


Shared Property

[image]

QlikView Management Service API
ServerObject..::..Shared Property
ServerObject Class See Also Send Feedback
Flag indicating whether the data object is shared or not.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Shared { get; set; }
Visual Basic
Public Property Shared As Boolean
    Get
    Set

See Also

ServerObject Class


SubType Property

[image]

QlikView Management Service API
ServerObject..::..SubType Property
ServerObject Class See Also Send Feedback
The subtype, which depends on the type.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string SubType { get; set; }
Visual Basic
Public Property SubType As String
    Get
    Set

See Also

ServerObject Class


Temporary Property

[image]

QlikView Management Service API
ServerObject..::..Temporary Property
ServerObject Class See Also Send Feedback
Flag indicating whether the data object is temporary or not.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Temporary { get; set; }
Visual Basic
Public Property Temporary As Boolean
    Get
    Set

See Also

ServerObject Class


Type Property

[image]

QlikView Management Service API
ServerObject..::..Type Property
ServerObject Class See Also Send Feedback
The type (eg Bookmark, Sheet, Report or SheetObject).

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set

See Also

ServerObject Class


UtcModifyTime Property

[image]

QlikView Management Service API
ServerObject..::..UtcModifyTime Property
ServerObject Class See Also Send Feedback
The time of when the data object was last modified

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string UtcModifyTime { get; set; }
Visual Basic
Public Property UtcModifyTime As String
    Get
    Set

See Also

ServerObject Class


ServerObjectMetaData Class

[image]

QlikView Management Service API
ServerObjectMetaData Class
Members See Also Send Feedback
Represents meta data about a server object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class ServerObjectMetaData
Visual Basic
Public Class ServerObjectMetaData

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..ServerObjectMetaData

See Also

ServerObjectMetaData Members


ServerObjectMetaData Members

[image] [image]

QlikView Management Service API
ServerObjectMetaData Members
ServerObjectMetaData Class Properties See Also Send Feedback

The ServerObjectMetaData type exposes the following members.

Properties

 | Name | Description
Public property | DocumentName | The name of the document where this server object is defined.
Public property | Id | The ID of the server object.
Public property | OwnerId | The id of the owner.
Public property | Restricted | Flag indicating whether the data object is restricted or not.
Public property | Shared | Flag indicating whether the data object is shared or not.
Public property | SubType | The subtype, which depends on the type.
Public property | Type | The type (eg Bookmark, Sheet, Report or SheetObject).
Public property | UtcModifyTime | The time of when the data object was last modified

See Also

ServerObjectMetaData Class


ServerObjectMetaData Properties

[image] [image]

QlikView Management Service API
ServerObjectMetaData Properties
ServerObjectMetaData Class See Also Send Feedback

The ServerObjectMetaData type exposes the following members.

Properties

 | Name | Description
Public property | DocumentName | The name of the document where this server object is defined.
Public property | Id | The ID of the server object.
Public property | OwnerId | The id of the owner.
Public property | Restricted | Flag indicating whether the data object is restricted or not.
Public property | Shared | Flag indicating whether the data object is shared or not.
Public property | SubType | The subtype, which depends on the type.
Public property | Type | The type (eg Bookmark, Sheet, Report or SheetObject).
Public property | UtcModifyTime | The time of when the data object was last modified

See Also

ServerObjectMetaData Class


DocumentName Property

[image]

QlikView Management Service API
ServerObjectMetaData..::..DocumentName Property
ServerObjectMetaData Class See Also Send Feedback
The name of the document where this server object is defined.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string DocumentName { get; set; }
Visual Basic
Public Property DocumentName As String
    Get
    Set

See Also

ServerObjectMetaData Class


Id Property

[image]

QlikView Management Service API
ServerObjectMetaData..::..Id Property
ServerObjectMetaData Class See Also Send Feedback
The ID of the server object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

See Also

ServerObjectMetaData Class


OwnerId Property

[image]

QlikView Management Service API
ServerObjectMetaData..::..OwnerId Property
ServerObjectMetaData Class See Also Send Feedback
The id of the owner.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string OwnerId { get; set; }
Visual Basic
Public Property OwnerId As String
    Get
    Set

See Also

ServerObjectMetaData Class


Restricted Property

[image]

QlikView Management Service API
ServerObjectMetaData..::..Restricted Property
ServerObjectMetaData Class See Also Send Feedback
Flag indicating whether the data object is restricted or not.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Restricted { get; set; }
Visual Basic
Public Property Restricted As Boolean
    Get
    Set

See Also

ServerObjectMetaData Class


Shared Property

[image]

QlikView Management Service API
ServerObjectMetaData..::..Shared Property
ServerObjectMetaData Class See Also Send Feedback
Flag indicating whether the data object is shared or not.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Shared { get; set; }
Visual Basic
Public Property Shared As Boolean
    Get
    Set

See Also

ServerObjectMetaData Class


SubType Property

[image]

QlikView Management Service API
ServerObjectMetaData..::..SubType Property
ServerObjectMetaData Class See Also Send Feedback
The subtype, which depends on the type.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string SubType { get; set; }
Visual Basic
Public Property SubType As String
    Get
    Set

See Also

ServerObjectMetaData Class


Type Property

[image]

QlikView Management Service API
ServerObjectMetaData..::..Type Property
ServerObjectMetaData Class See Also Send Feedback
The type (eg Bookmark, Sheet, Report or SheetObject).

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set

See Also

ServerObjectMetaData Class


UtcModifyTime Property

[image]

QlikView Management Service API
ServerObjectMetaData..::..UtcModifyTime Property
ServerObjectMetaData Class See Also Send Feedback
The time of when the data object was last modified

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string UtcModifyTime { get; set; }
Visual Basic
Public Property UtcModifyTime As String
    Get
    Set

See Also

ServerObjectMetaData Class


ServiceInfo Class

[image]

QlikView Management Service API
ServiceInfo Class
Members See Also Send Feedback
Holds information about a single service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class ServiceInfo
Visual Basic
Public Class ServiceInfo

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..ServiceInfo

See Also

ServiceInfo Members


ServiceInfo Members

[image] [image]

QlikView Management Service API
ServiceInfo Members
ServiceInfo Class Properties See Also Send Feedback

The ServiceInfo type exposes the following members.

Properties

 | Name | Description
Public property | Address | The address of the service.
Public property | ClusterNodeCount | The number of nodes clustered within the service.
Public property | ID | The ID of the service.
Public property | Name | The name of the service.
Public property | Type | The type of the service.

See Also

ServiceInfo Class


ServiceInfo Properties

[image] [image]

QlikView Management Service API
ServiceInfo Properties
ServiceInfo Class See Also Send Feedback

The ServiceInfo type exposes the following members.

Properties

 | Name | Description
Public property | Address | The address of the service.
Public property | ClusterNodeCount | The number of nodes clustered within the service.
Public property | ID | The ID of the service.
Public property | Name | The name of the service.
Public property | Type | The type of the service.

See Also

ServiceInfo Class


Address Property

[image]

QlikView Management Service API
ServiceInfo..::..Address Property
ServiceInfo Class See Also Send Feedback
The address of the service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Uri Address { get; set; }
Visual Basic
Public Property Address As Uri
    Get
    Set

See Also

ServiceInfo Class


ClusterNodeCount Property

[image]

QlikView Management Service API
ServiceInfo..::..ClusterNodeCount Property
ServiceInfo Class See Also Send Feedback
The number of nodes clustered within the service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int ClusterNodeCount { get; set; }
Visual Basic
Public Property ClusterNodeCount As Integer
    Get
    Set

See Also

ServiceInfo Class


ID Property

[image]

QlikView Management Service API
ServiceInfo..::..ID Property
ServiceInfo Class See Also Send Feedback
The ID of the service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

ServiceInfo Class


Name Property

[image]

QlikView Management Service API
ServiceInfo..::..Name Property
ServiceInfo Class See Also Send Feedback
The name of the service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

ServiceInfo Class


Type Property

[image]

QlikView Management Service API
ServiceInfo..::..Type Property
ServiceInfo Class See Also Send Feedback
The type of the service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public ServiceTypes Type { get; set; }
Visual Basic
Public Property Type As ServiceTypes
    Get
    Set

See Also

ServiceInfo Class


ServiceStatus Class

[image]

QlikView Management Service API
ServiceStatus Class
Members See Also Send Feedback
Represents the status of a service. Depending on the type of the service, its composition can be either clustered or single. A clustered service has at least one member, a single service has only one member.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class ServiceStatus
Visual Basic
Public Class ServiceStatus

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..ServiceStatus

See Also

ServiceStatus Members


ServiceStatus Members

[image] [image]

QlikView Management Service API
ServiceStatus Members
ServiceStatus Class Properties See Also Send Feedback

The ServiceStatus type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID of the service
Public property | MemberStatusDetails | The members of the service
Public property | Name | The name of the service
Public property | ServiceComposition | The composition of the service.
Public property | ServiceType | The type the service
Public property | Url | The url of the service

See Also

ServiceStatus Class


ServiceStatus Properties

[image] [image]

QlikView Management Service API
ServiceStatus Properties
ServiceStatus Class See Also Send Feedback

The ServiceStatus type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID of the service
Public property | MemberStatusDetails | The members of the service
Public property | Name | The name of the service
Public property | ServiceComposition | The composition of the service.
Public property | ServiceType | The type the service
Public property | Url | The url of the service

See Also

ServiceStatus Class


ID Property

[image]

QlikView Management Service API
ServiceStatus..::..ID Property
ServiceStatus Class See Also Send Feedback
The ID of the service

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

ServiceStatus Class


MemberStatusDetails Property

[image]

QlikView Management Service API
ServiceStatus..::..MemberStatusDetails Property
ServiceStatus Class See Also Send Feedback
The members of the service

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<ServiceStatusDetail> MemberStatusDetails { get; private set; }
Visual Basic
Public Property MemberStatusDetails As List(Of ServiceStatusDetail)
    Get
    Private Set

See Also

ServiceStatus Class


Name Property

[image]

QlikView Management Service API
ServiceStatus..::..Name Property
ServiceStatus Class See Also Send Feedback
The name of the service

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

ServiceStatus Class


ServiceComposition Property

[image]

QlikView Management Service API
ServiceStatus..::..ServiceComposition Property
ServiceStatus Class See Also Send Feedback
The composition of the service.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public ServiceComposition ServiceComposition { get; set; }
Visual Basic
Public Property ServiceComposition As ServiceComposition
    Get
    Set

See Also

ServiceStatus Class


ServiceType Property

[image]

QlikView Management Service API
ServiceStatus..::..ServiceType Property
ServiceStatus Class See Also Send Feedback
The type the service

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public ServiceTypes ServiceType { get; set; }
Visual Basic
Public Property ServiceType As ServiceTypes
    Get
    Set

See Also

ServiceStatus Class


Url Property

[image]

QlikView Management Service API
ServiceStatus..::..Url Property
ServiceStatus Class See Also Send Feedback
The url of the service

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Uri Url { get; set; }
Visual Basic
Public Property Url As Uri
    Get
    Set

See Also

ServiceStatus Class


ServiceStatusDetail Class

[image]

QlikView Management Service API
ServiceStatusDetail Class
Members See Also Send Feedback
This class provides details about the status of a service member. A service can contain one or several members, depending on the type of service and current configuration.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class ServiceStatusDetail
Visual Basic
Public Class ServiceStatusDetail

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..ServiceStatusDetail

See Also

ServiceStatusDetail Members


ServiceStatusDetail Members

[image] [image]

QlikView Management Service API
ServiceStatusDetail Members
ServiceStatusDetail Class Properties See Also Send Feedback

The ServiceStatusDetail type exposes the following members.

Properties

 | Name | Description
Public property | Host | The host where the service member is running.
Public property | ID | The ID of the service member.
Public property | Message | A list of messages describing the current state.
Public property | Status | The status of the service member which can have multiple flags set.

See Also

ServiceStatusDetail Class


ServiceStatusDetail Properties

[image] [image]

QlikView Management Service API
ServiceStatusDetail Properties
ServiceStatusDetail Class See Also Send Feedback

The ServiceStatusDetail type exposes the following members.

Properties

 | Name | Description
Public property | Host | The host where the service member is running.
Public property | ID | The ID of the service member.
Public property | Message | A list of messages describing the current state.
Public property | Status | The status of the service member which can have multiple flags set.

See Also

ServiceStatusDetail Class


Host Property

[image]

QlikView Management Service API
ServiceStatusDetail..::..Host Property
ServiceStatusDetail Class See Also Send Feedback
The host where the service member is running.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Host { get; set; }
Visual Basic
Public Property Host As String
    Get
    Set

See Also

ServiceStatusDetail Class


ID Property

[image]

QlikView Management Service API
ServiceStatusDetail..::..ID Property
ServiceStatusDetail Class See Also Send Feedback
The ID of the service member.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

ServiceStatusDetail Class


Message Property

[image]

QlikView Management Service API
ServiceStatusDetail..::..Message Property
ServiceStatusDetail Class See Also Send Feedback
A list of messages describing the current state.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> Message { get; set; }
Visual Basic
Public Property Message As List(Of String)
    Get
    Set

See Also

ServiceStatusDetail Class


Status Property

[image]

QlikView Management Service API
ServiceStatusDetail..::..Status Property
ServiceStatusDetail Class See Also Send Feedback
The status of the service member which can have multiple flags set.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public ServiceStatusFlag Status { get; set; }
Visual Basic
Public Property Status As ServiceStatusFlag
    Get
    Set

See Also

ServiceStatusDetail Class


ServiceTypes Enumeration

[image]

QlikView Management Service API
ServiceTypes Enumeration
See Also Send Feedback
The different service types.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

A combination of these can be used when calling for example.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum ServiceTypes
Visual Basic
<FlagsAttribute> _
Public Enumeration ServiceTypes

Members

Member name | Value | Description
None | 0 |
QlikViewManagementService | 1 |
QlikViewDistributionService | 2 |
QlikViewServer | 4 |
QlikViewDirectoryServiceConnector | 8 |
QlikViewWebServer | 16 |
RemoteQlikViewManagementService | 32 |
All | 65535 |

See Also

PIX.QMSAPI.DataObjects Namespace
IQMS..::..GetServices(ServiceTypes)


TaskDistributionDestination Class

[image]

QlikView Management Service API
TaskDistributionDestination Class
Members See Also Send Feedback
Represents the destination of a distribution.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributionDestination
Visual Basic
Public Class TaskDistributionDestination

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskDistributionDestination

See Also

TaskDistributionDestination Members


TaskDistributionDestination Members

[image] [image]

QlikView Management Service API
TaskDistributionDestination Members
TaskDistributionDestination Class Properties See Also Send Feedback

The TaskDistributionDestination type exposes the following members.

Properties

 | Name | Description
Public property | Folder | A folder destination.
Public property | ID | The ID of the distribution.
Public property | QlikViewServer | The destination QVS.
Public property | Type | The type of the destination.

See Also

TaskDistributionDestination Class


TaskDistributionDestination Properties

[image] [image]

QlikView Management Service API
TaskDistributionDestination Properties
TaskDistributionDestination Class See Also Send Feedback

The TaskDistributionDestination type exposes the following members.

Properties

 | Name | Description
Public property | Folder | A folder destination.
Public property | ID | The ID of the distribution.
Public property | QlikViewServer | The destination QVS.
Public property | Type | The type of the destination.

See Also

TaskDistributionDestination Class


Folder Property

[image]

QlikView Management Service API
TaskDistributionDestination..::..Folder Property
TaskDistributionDestination Class See Also Send Feedback
A folder destination.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskDistributionDestination..::..TaskDistributionDestinationFolder Folder { get; private set; }
Visual Basic
Public Property Folder As TaskDistributionDestination..::..TaskDistributionDestinationFolder
    Get
    Private Set

See Also

TaskDistributionDestination Class


ID Property

[image]

QlikView Management Service API
TaskDistributionDestination..::..ID Property
TaskDistributionDestination Class See Also Send Feedback
The ID of the distribution.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

TaskDistributionDestination Class


QlikViewServer Property

[image]

QlikView Management Service API
TaskDistributionDestination..::..QlikViewServer Property
TaskDistributionDestination Class See Also Send Feedback
The destination QVS.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer QlikViewServer { get; private set; }
Visual Basic
Public Property QlikViewServer As TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer
    Get
    Private Set

See Also

TaskDistributionDestination Class


Type Property

[image]

QlikView Management Service API
TaskDistributionDestination..::..Type Property
TaskDistributionDestination Class See Also Send Feedback
The type of the destination.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskDistributionDestinationType Type { get; set; }
Visual Basic
Public Property Type As TaskDistributionDestinationType
    Get
    Set

See Also

TaskDistributionDestination Class


TaskDistributionDestination.TaskDistributionDestinationFolder Class

[image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationFolder Class
TaskDistributionDestination Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskDistributionDestination.TaskDistributionDestinationFolder"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributionDestinationFolder
Visual Basic
Public Class TaskDistributionDestinationFolder

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskDistributionDestination..::..TaskDistributionDestinationFolder

See Also

TaskDistributionDestination..::..TaskDistributionDestinationFolder Members


TaskDistributionDestination.TaskDistributionDestinationFolder Members

[image] [image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationFolder Members
TaskDistributionDestination..::..TaskDistributionDestinationFolder Class Properties See Also Send Feedback

Represents the destination of a distribution.

The TaskDistributionDestination..::..TaskDistributionDestinationFolder type exposes the following members.

Properties

 | Name | Description
Public property | Name |

See Also

TaskDistributionDestination..::..TaskDistributionDestinationFolder Class


TaskDistributionDestination.TaskDistributionDestinationFolder Properties

[image] [image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationFolder Properties
TaskDistributionDestination..::..TaskDistributionDestinationFolder Class See Also Send Feedback

The TaskDistributionDestination..::..TaskDistributionDestinationFolder type exposes the following members.

Properties

 | Name | Description
Public property | Name |

See Also

TaskDistributionDestination..::..TaskDistributionDestinationFolder Class


Name Property

[image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationFolder..::..Name Property
TaskDistributionDestination..::..TaskDistributionDestinationFolder Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskDistributionDestination.TaskDistributionDestinationFolder.Name"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

TaskDistributionDestination..::..TaskDistributionDestinationFolder Class


TaskDistributionDestination.TaskDistributionDestinationQlikViewServer Class

[image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class
TaskDistributionDestination Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskDistributionDestination.TaskDistributionDestinationQlikViewServer"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributionDestinationQlikViewServer
Visual Basic
Public Class TaskDistributionDestinationQlikViewServer

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer

See Also

TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Members


TaskDistributionDestination.TaskDistributionDestinationQlikViewServer Members

[image] [image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Members
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class Properties See Also Send Feedback

Represents the destination of a distribution.

The TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID of the QlikView Server.
Public property | Mount | The mount path.
Public property | Name |

See Also

TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class


TaskDistributionDestination.TaskDistributionDestinationQlikViewServer Properties

[image] [image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Properties
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class See Also Send Feedback

The TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID of the QlikView Server.
Public property | Mount | The mount path.
Public property | Name |

See Also

TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class


ID Property

[image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer..::..ID Property
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class See Also Send Feedback
The ID of the QlikView Server.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class


Mount Property

[image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer..::..Mount Property
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class See Also Send Feedback
The mount path.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Mount { get; set; }
Visual Basic
Public Property Mount As String
    Get
    Set

See Also

TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class


Name Property

[image]

QlikView Management Service API
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer..::..Name Property
TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskDistributionDestination.TaskDistributionDestinationQlikViewServer.Name"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

TaskDistributionDestination..::..TaskDistributionDestinationQlikViewServer Class


TaskDistributionDestinationType Enumeration

[image]

QlikView Management Service API
TaskDistributionDestinationType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskDistributionDestinationType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskDistributionDestinationType
Visual Basic
Public Enumeration TaskDistributionDestinationType

Members

Member name | Value | Description
None | 0 |
QlikViewServer | 1 |
Folder | 2 |
Mail | 3 |

See Also


TaskDistributionEntry Class

[image]

QlikView Management Service API
TaskDistributionEntry Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskDistributionEntry"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskDistributionEntry
Visual Basic
Public Class TaskDistributionEntry

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskDistributionEntry

See Also

TaskDistributionEntry Members


TaskDistributionEntry Members

[image] [image]

QlikView Management Service API
TaskDistributionEntry Members
TaskDistributionEntry Class Properties See Also Send Feedback

The TaskDistributionEntry type exposes the following members.

Properties

 | Name | Description
Public property | Destination |
Public property | Recipients |

See Also

TaskDistributionEntry Class


TaskDistributionEntry Properties

[image] [image]

QlikView Management Service API
TaskDistributionEntry Properties
TaskDistributionEntry Class See Also Send Feedback

The TaskDistributionEntry type exposes the following members.

Properties

 | Name | Description
Public property | Destination |
Public property | Recipients |

See Also

TaskDistributionEntry Class


Destination Property

[image]

QlikView Management Service API
TaskDistributionEntry..::..Destination Property
TaskDistributionEntry Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskDistributionEntry.Destination"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskDistributionDestination Destination { get; set; }
Visual Basic
Public Property Destination As TaskDistributionDestination
    Get
    Set

See Also

TaskDistributionEntry Class


Recipients Property

[image]

QlikView Management Service API
TaskDistributionEntry..::..Recipients Property
TaskDistributionEntry Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskDistributionEntry.Recipients"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<DirectoryServiceObject> Recipients { get; set; }
Visual Basic
Public Property Recipients As List(Of DirectoryServiceObject)
    Get
    Set

See Also

TaskDistributionEntry Class


TaskDistributionOutputType Enumeration

[image]

QlikView Management Service API
TaskDistributionOutputType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskDistributionOutputType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskDistributionOutputType
Visual Basic
Public Enumeration TaskDistributionOutputType

Members

Member name | Value | Description
QlikViewDocument | 0 |
PDFReport | 1 |

See Also


TaskExecutionItem Class

[image]

QlikView Management Service API
TaskExecutionItem Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskExecutionItem"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskExecutionItem
Visual Basic
Public Class TaskExecutionItem

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskExecutionItem

See Also

TaskExecutionItem Members


TaskExecutionItem Members

[image] [image]

QlikView Management Service API
TaskExecutionItem Members
TaskExecutionItem Class Properties See Also Send Feedback

The TaskExecutionItem type exposes the following members.

Properties

 | Name | Description
Public property | ExecId |
Public property | TaskId |

See Also

TaskExecutionItem Class


TaskExecutionItem Properties

[image] [image]

QlikView Management Service API
TaskExecutionItem Properties
TaskExecutionItem Class See Also Send Feedback

The TaskExecutionItem type exposes the following members.

Properties

 | Name | Description
Public property | ExecId |
Public property | TaskId |

See Also

TaskExecutionItem Class


ExecId Property

[image]

QlikView Management Service API
TaskExecutionItem..::..ExecId Property
TaskExecutionItem Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskExecutionItem.ExecId"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ExecId { get; set; }
Visual Basic
Public Property ExecId As Guid
    Get
    Set

See Also

TaskExecutionItem Class


TaskId Property

[image]

QlikView Management Service API
TaskExecutionItem..::..TaskId Property
TaskExecutionItem Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskExecutionItem.TaskId"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid TaskId { get; set; }
Visual Basic
Public Property TaskId As Guid
    Get
    Set

See Also

TaskExecutionItem Class


TaskInfo Class

[image]

QlikView Management Service API
TaskInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskInfo"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskInfo
Visual Basic
Public Class TaskInfo

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskInfo

See Also

TaskInfo Members


TaskInfo Members

[image] [image]

QlikView Management Service API
TaskInfo Members
TaskInfo Class Properties See Also Send Feedback

The TaskInfo type exposes the following members.

Properties

 | Name | Description
Public property | Enabled |
Public property | ID |
Public property | Name |
Public property | QDSID |
Public property | Type |

See Also

TaskInfo Class


TaskInfo Properties

[image] [image]

QlikView Management Service API
TaskInfo Properties
TaskInfo Class See Also Send Feedback

The TaskInfo type exposes the following members.

Properties

 | Name | Description
Public property | Enabled |
Public property | ID |
Public property | Name |
Public property | QDSID |
Public property | Type |

See Also

TaskInfo Class


Enabled Property

[image]

QlikView Management Service API
TaskInfo..::..Enabled Property
TaskInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskInfo.Enabled"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

See Also

TaskInfo Class


ID Property

[image]

QlikView Management Service API
TaskInfo..::..ID Property
TaskInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskInfo.ID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

TaskInfo Class


Name Property

[image]

QlikView Management Service API
TaskInfo..::..Name Property
TaskInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskInfo.Name"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

TaskInfo Class


QDSID Property

[image]

QlikView Management Service API
TaskInfo..::..QDSID Property
TaskInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskInfo.QDSID"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QDSID { get; set; }
Visual Basic
Public Property QDSID As Guid
    Get
    Set

See Also

TaskInfo Class


Type Property

[image]

QlikView Management Service API
TaskInfo..::..Type Property
TaskInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskInfo.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskType Type { get; set; }
Visual Basic
Public Property Type As TaskType
    Get
    Set

See Also

TaskInfo Class


TaskReduction Class

[image]

QlikView Management Service API
TaskReduction Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskReduction"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskReduction
Visual Basic
Public Class TaskReduction

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskReduction

See Also

TaskReduction Members


TaskReduction Members

[image] [image]

QlikView Management Service API
TaskReduction Members
TaskReduction Class Properties See Also Send Feedback

The TaskReduction type exposes the following members.

Properties

 | Name | Description
Public property | Bookmark |
Public property | Field |
Public property | Type |

See Also

TaskReduction Class


TaskReduction Properties

[image] [image]

QlikView Management Service API
TaskReduction Properties
TaskReduction Class See Also Send Feedback

The TaskReduction type exposes the following members.

Properties

 | Name | Description
Public property | Bookmark |
Public property | Field |
Public property | Type |

See Also

TaskReduction Class


Bookmark Property

[image]

QlikView Management Service API
TaskReduction..::..Bookmark Property
TaskReduction Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskReduction.Bookmark"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskReduction..::..TaskReductionBookmark Bookmark { get; private set; }
Visual Basic
Public Property Bookmark As TaskReduction..::..TaskReductionBookmark
    Get
    Private Set

See Also

TaskReduction Class


Field Property

[image]

QlikView Management Service API
TaskReduction..::..Field Property
TaskReduction Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskReduction.Field"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskReduction..::..TaskReductionField Field { get; private set; }
Visual Basic
Public Property Field As TaskReduction..::..TaskReductionField
    Get
    Private Set

See Also

TaskReduction Class


Type Property

[image]

QlikView Management Service API
TaskReduction..::..Type Property
TaskReduction Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskReduction.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskReductionType Type { get; set; }
Visual Basic
Public Property Type As TaskReductionType
    Get
    Set

See Also

TaskReduction Class


TaskReduction.TaskReductionBookmark Class

[image]

QlikView Management Service API
TaskReduction..::..TaskReductionBookmark Class
TaskReduction Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskReduction.TaskReductionBookmark"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskReductionBookmark
Visual Basic
Public Class TaskReductionBookmark

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskReduction..::..TaskReductionBookmark

See Also

TaskReduction..::..TaskReductionBookmark Members


TaskReduction.TaskReductionBookmark Members

[image] [image]

QlikView Management Service API
TaskReduction..::..TaskReductionBookmark Members
TaskReduction..::..TaskReductionBookmark Class Properties See Also Send Feedback

The TaskReduction..::..TaskReductionBookmark type exposes the following members.

Properties

 | Name | Description
Public property | Name |

See Also

TaskReduction..::..TaskReductionBookmark Class


TaskReduction.TaskReductionBookmark Properties

[image] [image]

QlikView Management Service API
TaskReduction..::..TaskReductionBookmark Properties
TaskReduction..::..TaskReductionBookmark Class See Also Send Feedback

The TaskReduction..::..TaskReductionBookmark type exposes the following members.

Properties

 | Name | Description
Public property | Name |

See Also

TaskReduction..::..TaskReductionBookmark Class


Name Property

[image]

QlikView Management Service API
TaskReduction..::..TaskReductionBookmark..::..Name Property
TaskReduction..::..TaskReductionBookmark Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskReduction.TaskReductionBookmark.Name"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

TaskReduction..::..TaskReductionBookmark Class


TaskReduction.TaskReductionField Class

[image]

QlikView Management Service API
TaskReduction..::..TaskReductionField Class
TaskReduction Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskReduction.TaskReductionField"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskReductionField
Visual Basic
Public Class TaskReductionField

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskReduction..::..TaskReductionField

See Also

TaskReduction..::..TaskReductionField Members


TaskReduction.TaskReductionField Members

[image] [image]

QlikView Management Service API
TaskReduction..::..TaskReductionField Members
TaskReduction..::..TaskReductionField Class Properties See Also Send Feedback

The TaskReduction..::..TaskReductionField type exposes the following members.

Properties

 | Name | Description
Public property | IsNumeric |
Public property | Name |
Public property | Number |
Public property | Value |

See Also

TaskReduction..::..TaskReductionField Class


TaskReduction.TaskReductionField Properties

[image] [image]

QlikView Management Service API
TaskReduction..::..TaskReductionField Properties
TaskReduction..::..TaskReductionField Class See Also Send Feedback

The TaskReduction..::..TaskReductionField type exposes the following members.

Properties

 | Name | Description
Public property | IsNumeric |
Public property | Name |
Public property | Number |
Public property | Value |

See Also

TaskReduction..::..TaskReductionField Class


IsNumeric Property

[image]

QlikView Management Service API
TaskReduction..::..TaskReductionField..::..IsNumeric Property
TaskReduction..::..TaskReductionField Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskReduction.TaskReductionField.IsNumeric"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IsNumeric { get; set; }
Visual Basic
Public Property IsNumeric As Boolean
    Get
    Set

See Also

TaskReduction..::..TaskReductionField Class


Name Property

[image]

QlikView Management Service API
TaskReduction..::..TaskReductionField..::..Name Property
TaskReduction..::..TaskReductionField Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskReduction.TaskReductionField.Name"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

TaskReduction..::..TaskReductionField Class


Number Property

[image]

QlikView Management Service API
TaskReduction..::..TaskReductionField..::..Number Property
TaskReduction..::..TaskReductionField Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskReduction.TaskReductionField.Number"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public double Number { get; set; }
Visual Basic
Public Property Number As Double
    Get
    Set

See Also

TaskReduction..::..TaskReductionField Class


Value Property

[image]

QlikView Management Service API
TaskReduction..::..TaskReductionField..::..Value Property
TaskReduction..::..TaskReductionField Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskReduction.TaskReductionField.Value"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

See Also

TaskReduction..::..TaskReductionField Class


TaskReductionType Enumeration

[image]

QlikView Management Service API
TaskReductionType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskReductionType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskReductionType
Visual Basic
Public Enumeration TaskReductionType

Members

Member name | Value | Description
None | 0 |
ByField | 1 |
ByBookmark | 2 |

See Also


TaskReloadMode Enumeration

[image]

QlikView Management Service API
TaskReloadMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskReloadMode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskReloadMode
Visual Basic
Public Enumeration TaskReloadMode

Members

Member name | Value | Description
None | 0 |
Full | 1 |
Partial | 2 |

See Also


TaskStatus Class

[image]

QlikView Management Service API
TaskStatus Class
Members See Also Send Feedback
The Task Status data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskStatus
Visual Basic
Public Class TaskStatus

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatus

See Also

TaskStatus Members


TaskStatus Members

[image] [image]

QlikView Management Service API
TaskStatus Members
TaskStatus Class Properties See Also Send Feedback

The TaskStatus type exposes the following members.

Properties

 | Name | Description
Public property | Deleted | Indicates that task has been deleted. The scope will be None since additional information is unknown.
Public property | Extended | The Extended element of the task status metadata.
Public property | General | The General element of the task status metadata.
Public property | Scope | The scope of the task status object.
Public property | TaskID | The task ID.

See Also

TaskStatus Class


TaskStatus Properties

[image] [image]

QlikView Management Service API
TaskStatus Properties
TaskStatus Class See Also Send Feedback

The TaskStatus type exposes the following members.

Properties

 | Name | Description
Public property | Deleted | Indicates that task has been deleted. The scope will be None since additional information is unknown.
Public property | Extended | The Extended element of the task status metadata.
Public property | General | The General element of the task status metadata.
Public property | Scope | The scope of the task status object.
Public property | TaskID | The task ID.

See Also

TaskStatus Class


Deleted Property

[image]

QlikView Management Service API
TaskStatus..::..Deleted Property
TaskStatus Class See Also Send Feedback
Indicates that task has been deleted. The scope will be None since additional information is unknown.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool Deleted { get; set; }
Visual Basic
Public Property Deleted As Boolean
    Get
    Set

See Also

TaskStatus Class


Extended Property

[image]

QlikView Management Service API
TaskStatus..::..Extended Property
TaskStatus Class See Also Send Feedback
The Extended element of the task status metadata.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatus..::..TaskStatusExtended Extended { get; private set; }
Visual Basic
Public Property Extended As TaskStatus..::..TaskStatusExtended
    Get
    Private Set

See Also

TaskStatus Class


General Property

[image]

QlikView Management Service API
TaskStatus..::..General Property
TaskStatus Class See Also Send Feedback
The General element of the task status metadata.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatus..::..TaskStatusGeneral General { get; private set; }
Visual Basic
Public Property General As TaskStatus..::..TaskStatusGeneral
    Get
    Private Set

See Also

TaskStatus Class


Scope Property

[image]

QlikView Management Service API
TaskStatus..::..Scope Property
TaskStatus Class See Also Send Feedback
The scope of the task status object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusScope Scope { get; private set; }
Visual Basic
Public Property Scope As TaskStatusScope
    Get
    Private Set

See Also

TaskStatus Class


TaskID Property

[image]

QlikView Management Service API
TaskStatus..::..TaskID Property
TaskStatus Class See Also Send Feedback
The task ID.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid TaskID { get; private set; }
Visual Basic
Public Property TaskID As Guid
    Get
    Private Set

See Also

TaskStatus Class


TaskStatus.TaskStatusExtended Class

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended Class
TaskStatus Class Members See Also Send Feedback
The Extended element of the task status node request data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskStatusExtended
Visual Basic
Public Class TaskStatusExtended

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatus..::..TaskStatusExtended

See Also

TaskStatus..::..TaskStatusExtended Members


TaskStatus.TaskStatusExtended Members

[image] [image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended Members
TaskStatus..::..TaskStatusExtended Class Properties See Also Send Feedback

The Task Status data object.

The TaskStatus..::..TaskStatusExtended type exposes the following members.

Properties

 | Name | Description
Public property | Category | The category.
Public property | DocumentPath | The source or user document file path or name.
Public property | FinishedTime | The time finished at if ever run.
Public property | LastLogMessages | The last five log messages, or last five error messages if status is failed.
Public property | QDSID | The QDS ID.
Public property | StartTime | The started at time, scheduled start time, or "not scheduled"
Public property | TaskSummary | The task summary.

See Also

TaskStatus..::..TaskStatusExtended Class


TaskStatus.TaskStatusExtended Properties

[image] [image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended Properties
TaskStatus..::..TaskStatusExtended Class See Also Send Feedback

The TaskStatus..::..TaskStatusExtended type exposes the following members.

Properties

 | Name | Description
Public property | Category | The category.
Public property | DocumentPath | The source or user document file path or name.
Public property | FinishedTime | The time finished at if ever run.
Public property | LastLogMessages | The last five log messages, or last five error messages if status is failed.
Public property | QDSID | The QDS ID.
Public property | StartTime | The started at time, scheduled start time, or "not scheduled"
Public property | TaskSummary | The task summary.

See Also

TaskStatus..::..TaskStatusExtended Class


Category Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended..::..Category Property
TaskStatus..::..TaskStatusExtended Class See Also Send Feedback
The category.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Category { get; set; }
Visual Basic
Public Property Category As String
    Get
    Set

See Also

TaskStatus..::..TaskStatusExtended Class


DocumentPath Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended..::..DocumentPath Property
TaskStatus..::..TaskStatusExtended Class See Also Send Feedback
The source or user document file path or name.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string DocumentPath { get; set; }
Visual Basic
Public Property DocumentPath As String
    Get
    Set

See Also

TaskStatus..::..TaskStatusExtended Class


FinishedTime Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended..::..FinishedTime Property
TaskStatus..::..TaskStatusExtended Class See Also Send Feedback
The time finished at if ever run.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string FinishedTime { get; set; }
Visual Basic
Public Property FinishedTime As String
    Get
    Set

See Also

TaskStatus..::..TaskStatusExtended Class


LastLogMessages Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended..::..LastLogMessages Property
TaskStatus..::..TaskStatusExtended Class See Also Send Feedback
The last five log messages, or last five error messages if status is failed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string LastLogMessages { get; set; }
Visual Basic
Public Property LastLogMessages As String
    Get
    Set

See Also

TaskStatus..::..TaskStatusExtended Class


QDSID Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended..::..QDSID Property
TaskStatus..::..TaskStatusExtended Class See Also Send Feedback
The QDS ID.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QDSID { get; set; }
Visual Basic
Public Property QDSID As Guid
    Get
    Set

See Also

TaskStatus..::..TaskStatusExtended Class


StartTime Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended..::..StartTime Property
TaskStatus..::..TaskStatusExtended Class See Also Send Feedback
The started at time, scheduled start time, or "not scheduled"

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string StartTime { get; set; }
Visual Basic
Public Property StartTime As String
    Get
    Set

See Also

TaskStatus..::..TaskStatusExtended Class


TaskSummary Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusExtended..::..TaskSummary Property
TaskStatus..::..TaskStatusExtended Class See Also Send Feedback
The task summary.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string TaskSummary { get; set; }
Visual Basic
Public Property TaskSummary As String
    Get
    Set

See Also

TaskStatus..::..TaskStatusExtended Class


TaskStatus.TaskStatusGeneral Class

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusGeneral Class
TaskStatus Class Members See Also Send Feedback
The General element of the task status node request data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskStatusGeneral
Visual Basic
Public Class TaskStatusGeneral

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatus..::..TaskStatusGeneral

See Also

TaskStatus..::..TaskStatusGeneral Members


TaskStatus.TaskStatusGeneral Members

[image] [image]

QlikView Management Service API
TaskStatus..::..TaskStatusGeneral Members
TaskStatus..::..TaskStatusGeneral Class Properties See Also Send Feedback

The Task Status data object.

The TaskStatus..::..TaskStatusGeneral type exposes the following members.

Properties

 | Name | Description
Public property | Status | The current status.
Public property | TaskName | The task name.
Public property | TaskType | The task type.

See Also

TaskStatus..::..TaskStatusGeneral Class


TaskStatus.TaskStatusGeneral Properties

[image] [image]

QlikView Management Service API
TaskStatus..::..TaskStatusGeneral Properties
TaskStatus..::..TaskStatusGeneral Class See Also Send Feedback

The TaskStatus..::..TaskStatusGeneral type exposes the following members.

Properties

 | Name | Description
Public property | Status | The current status.
Public property | TaskName | The task name.
Public property | TaskType | The task type.

See Also

TaskStatus..::..TaskStatusGeneral Class


Status Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusGeneral..::..Status Property
TaskStatus..::..TaskStatusGeneral Class See Also Send Feedback
The current status.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusValue Status { get; set; }
Visual Basic
Public Property Status As TaskStatusValue
    Get
    Set

See Also

TaskStatus..::..TaskStatusGeneral Class


TaskName Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusGeneral..::..TaskName Property
TaskStatus..::..TaskStatusGeneral Class See Also Send Feedback
The task name.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string TaskName { get; set; }
Visual Basic
Public Property TaskName As String
    Get
    Set

See Also

TaskStatus..::..TaskStatusGeneral Class


TaskType Property

[image]

QlikView Management Service API
TaskStatus..::..TaskStatusGeneral..::..TaskType Property
TaskStatus..::..TaskStatusGeneral Class See Also Send Feedback
The task type.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskType TaskType { get; set; }
Visual Basic
Public Property TaskType As TaskType
    Get
    Set

See Also

TaskStatus..::..TaskStatusGeneral Class


TaskStatusFilter Class

[image]

QlikView Management Service API
TaskStatusFilter Class
Members See Also Send Feedback
A filter class used when requesting task statuses.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskStatusFilter : ICloneable
Visual Basic
Public Class TaskStatusFilter _
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatusFilter

See Also

TaskStatusFilter Members


TaskStatusFilter Members

[image] [image]

QlikView Management Service API
TaskStatusFilter Members
TaskStatusFilter Class Properties See Also Send Feedback

The TaskStatusFilter type exposes the following members.

Properties

 | Name | Description
Public property | Categories | If one or more categories are added to this property, only tasks with a matching category are returned.
Public property | EnabledState | Only tasks with a matching state is returned.
Public property | LastExecution | The Date/Time interval of the last execution date. Only tasks with a last execution date within the interval will be returned.
Public property | QDSIds | If one or more QDSId's are added to this property, only tasks from the corresponding QDS's are returned.
Public property | Schedule | Properties for Filtering based on Started/Scheduled.
Public property | TaskIds | If one or more task id's are added to this property, only those tasks are returned.
Public property | TaskName | The name of the task to search for. To get a successful match there must be an exact match between the provided TaskName and the actual task(s). The search is case insensitive and supports wild cards. Also, it is possible to search form multiple task names by separating them with a semi-colon.
Public property | TaskStatuses | If one or more task statuses are added to this property, only tasks with a matching status are returned.
Public property | TaskTypes | If one or more task types are added to this property, only tasks with a matching type are returned.

See Also

TaskStatusFilter Class


TaskStatusFilter Properties

[image] [image]

QlikView Management Service API
TaskStatusFilter Properties
TaskStatusFilter Class See Also Send Feedback

The TaskStatusFilter type exposes the following members.

Properties

 | Name | Description
Public property | Categories | If one or more categories are added to this property, only tasks with a matching category are returned.
Public property | EnabledState | Only tasks with a matching state is returned.
Public property | LastExecution | The Date/Time interval of the last execution date. Only tasks with a last execution date within the interval will be returned.
Public property | QDSIds | If one or more QDSId's are added to this property, only tasks from the corresponding QDS's are returned.
Public property | Schedule | Properties for Filtering based on Started/Scheduled.
Public property | TaskIds | If one or more task id's are added to this property, only those tasks are returned.
Public property | TaskName | The name of the task to search for. To get a successful match there must be an exact match between the provided TaskName and the actual task(s). The search is case insensitive and supports wild cards. Also, it is possible to search form multiple task names by separating them with a semi-colon.
Public property | TaskStatuses | If one or more task statuses are added to this property, only tasks with a matching status are returned.
Public property | TaskTypes | If one or more task types are added to this property, only tasks with a matching type are returned.

See Also

TaskStatusFilter Class


Categories Property

[image]

QlikView Management Service API
TaskStatusFilter..::..Categories Property
TaskStatusFilter Class See Also Send Feedback
If one or more categories are added to this property, only tasks with a matching category are returned.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<string> Categories { get; private set; }
Visual Basic
Public Property Categories As List(Of String)
    Get
    Private Set

See Also

TaskStatusFilter Class


EnabledState Property

[image]

QlikView Management Service API
TaskStatusFilter..::..EnabledState Property
TaskStatusFilter Class See Also Send Feedback
Only tasks with a matching state is returned.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public EnabledState EnabledState { get; set; }
Visual Basic
Public Property EnabledState As EnabledState
    Get
    Set

See Also

TaskStatusFilter Class


LastExecution Property

[image]

QlikView Management Service API
TaskStatusFilter..::..LastExecution Property
TaskStatusFilter Class See Also Send Feedback
The Date/Time interval of the last execution date. Only tasks with a last execution date within the interval will be returned.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusFilter..::..LastExecutionInterval LastExecution { get; set; }
Visual Basic
Public Property LastExecution As TaskStatusFilter..::..LastExecutionInterval
    Get
    Set

Remarks

Setting the To/From properties of LastExecution to DateTime.MinValue will match tasks which has never executed.

See Also

TaskStatusFilter Class


QDSIds Property

[image]

QlikView Management Service API
TaskStatusFilter..::..QDSIds Property
TaskStatusFilter Class See Also Send Feedback
If one or more QDSId's are added to this property, only tasks from the corresponding QDS's are returned.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<Guid> QDSIds { get; private set; }
Visual Basic
Public Property QDSIds As List(Of Guid)
    Get
    Private Set

See Also

TaskStatusFilter Class


Schedule Property

[image]

QlikView Management Service API
TaskStatusFilter..::..Schedule Property
TaskStatusFilter Class See Also Send Feedback
Properties for Filtering based on Started/Scheduled.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusFilter..::..ScheduleInterval Schedule { get; private set; }
Visual Basic
Public Property Schedule As TaskStatusFilter..::..ScheduleInterval
    Get
    Private Set

See Also

TaskStatusFilter Class


TaskIds Property

[image]

QlikView Management Service API
TaskStatusFilter..::..TaskIds Property
TaskStatusFilter Class See Also Send Feedback
If one or more task id's are added to this property, only those tasks are returned.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<Guid> TaskIds { get; private set; }
Visual Basic
Public Property TaskIds As List(Of Guid)
    Get
    Private Set

See Also

TaskStatusFilter Class


TaskName Property

[image]

QlikView Management Service API
TaskStatusFilter..::..TaskName Property
TaskStatusFilter Class Example See Also Send Feedback
The name of the task to search for.

To get a successful match there must be an exact match between the provided TaskName and the actual task(s). The search is case insensitive and supports wild cards. Also, it is possible to search form multiple task names by separating them with a semi-colon.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string TaskName { get; set; }
Visual Basic
Public Property TaskName As String
    Get
    Set

Examples

Here are a few examples showing the use of wild cards and semi colon.
  • "k*" will include all words beginning with k.
  • "*k" will include all words that ends with k.
  • "k*n" will include all words that begins with k and ends with n.
  • "*k*" will include all words that contains k.
  • "k*;n*" will include all words that begins with k or n.

See Also

TaskStatusFilter Class


TaskStatuses Property

[image]

QlikView Management Service API
TaskStatusFilter..::..TaskStatuses Property
TaskStatusFilter Class See Also Send Feedback
If one or more task statuses are added to this property, only tasks with a matching status are returned.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<TaskStatusValue> TaskStatuses { get; private set; }
Visual Basic
Public Property TaskStatuses As List(Of TaskStatusValue)
    Get
    Private Set

See Also

TaskStatusFilter Class


TaskTypes Property

[image]

QlikView Management Service API
TaskStatusFilter..::..TaskTypes Property
TaskStatusFilter Class See Also Send Feedback
If one or more task types are added to this property, only tasks with a matching type are returned.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<TaskType> TaskTypes { get; private set; }
Visual Basic
Public Property TaskTypes As List(Of TaskType)
    Get
    Private Set

See Also

TaskStatusFilter Class


TaskStatusFilter.Interval Class

[image]

QlikView Management Service API
TaskStatusFilter..::..Interval Class
TaskStatusFilter Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskStatusFilter.Interval"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public abstract class Interval
Visual Basic
Public MustInherit Class Interval

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatusFilter..::..Interval
PIX.QMSAPI.DataObjects..::..TaskStatusFilter..::..LastExecutionInterval
PIX.QMSAPI.DataObjects..::..TaskStatusFilter..::..ScheduleInterval

See Also

TaskStatusFilter..::..Interval Members


TaskStatusFilter.Interval Members

[image] [image]

QlikView Management Service API
TaskStatusFilter..::..Interval Members
TaskStatusFilter..::..Interval Class Properties See Also Send Feedback

A filter class used when requesting task statuses.

The TaskStatusFilter..::..Interval type exposes the following members.

Properties

 | Name | Description
Public property | From | The start of the interval.
Public property | To | The end of the interval.

See Also

TaskStatusFilter..::..Interval Class


TaskStatusFilter.Interval Properties

[image] [image]

QlikView Management Service API
TaskStatusFilter..::..Interval Properties
TaskStatusFilter..::..Interval Class See Also Send Feedback

The TaskStatusFilter..::..Interval type exposes the following members.

Properties

 | Name | Description
Public property | From | The start of the interval.
Public property | To | The end of the interval.

See Also

TaskStatusFilter..::..Interval Class


From Property

[image]

QlikView Management Service API
TaskStatusFilter..::..Interval..::..From Property
TaskStatusFilter..::..Interval Class See Also Send Feedback
The start of the interval.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DateTime From { get; set; }
Visual Basic
Public Property From As DateTime
    Get
    Set

See Also

TaskStatusFilter..::..Interval Class


To Property

[image]

QlikView Management Service API
TaskStatusFilter..::..Interval..::..To Property
TaskStatusFilter..::..Interval Class See Also Send Feedback
The end of the interval.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public DateTime To { get; set; }
Visual Basic
Public Property To As DateTime
    Get
    Set

See Also

TaskStatusFilter..::..Interval Class


TaskStatusFilter.LastExecutionInterval Class

[image]

QlikView Management Service API
TaskStatusFilter..::..LastExecutionInterval Class
TaskStatusFilter Class Members See Also Send Feedback
Represents a Date/Time interval.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class LastExecutionInterval : TaskStatusFilter..::..Interval,
    ICloneable
Visual Basic
Public Class LastExecutionInterval _
    Inherits TaskStatusFilter..::..Interval _
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatusFilter..::..Interval
PIX.QMSAPI.DataObjects..::..TaskStatusFilter..::..LastExecutionInterval

See Also

TaskStatusFilter..::..LastExecutionInterval Members


TaskStatusFilter.LastExecutionInterval Members

[image] [image]

QlikView Management Service API
TaskStatusFilter..::..LastExecutionInterval Members
TaskStatusFilter..::..LastExecutionInterval Class Properties See Also Send Feedback

A filter class used when requesting task statuses.

The TaskStatusFilter..::..LastExecutionInterval type exposes the following members.

Properties

 | Name | Description
Public property | From | The start of the interval. (Inherited from TaskStatusFilter..::..Interval.)
Public property | IncludeNever | Include tasks that have never been executed.
Public property | To | The end of the interval. (Inherited from TaskStatusFilter..::..Interval.)

See Also

TaskStatusFilter..::..LastExecutionInterval Class


TaskStatusFilter.LastExecutionInterval Properties

[image] [image]

QlikView Management Service API
TaskStatusFilter..::..LastExecutionInterval Properties
TaskStatusFilter..::..LastExecutionInterval Class See Also Send Feedback

The TaskStatusFilter..::..LastExecutionInterval type exposes the following members.

Properties

 | Name | Description
Public property | From | The start of the interval. (Inherited from TaskStatusFilter..::..Interval.)
Public property | IncludeNever | Include tasks that have never been executed.
Public property | To | The end of the interval. (Inherited from TaskStatusFilter..::..Interval.)

See Also

TaskStatusFilter..::..LastExecutionInterval Class


IncludeNever Property

[image]

QlikView Management Service API
TaskStatusFilter..::..LastExecutionInterval..::..IncludeNever Property
TaskStatusFilter..::..LastExecutionInterval Class See Also Send Feedback
Include tasks that have never been executed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IncludeNever { get; set; }
Visual Basic
Public Property IncludeNever As Boolean
    Get
    Set

See Also

TaskStatusFilter..::..LastExecutionInterval Class


TaskStatusFilter.ScheduleInterval Class

[image]

QlikView Management Service API
TaskStatusFilter..::..ScheduleInterval Class
TaskStatusFilter Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskStatusFilter.ScheduleInterval"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class ScheduleInterval : TaskStatusFilter..::..Interval,
    ICloneable
Visual Basic
Public Class ScheduleInterval _
    Inherits TaskStatusFilter..::..Interval _
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatusFilter..::..Interval
PIX.QMSAPI.DataObjects..::..TaskStatusFilter..::..ScheduleInterval

See Also

TaskStatusFilter..::..ScheduleInterval Members


TaskStatusFilter.ScheduleInterval Members

[image] [image]

QlikView Management Service API
TaskStatusFilter..::..ScheduleInterval Members
TaskStatusFilter..::..ScheduleInterval Class Properties See Also Send Feedback

A filter class used when requesting task statuses.

The TaskStatusFilter..::..ScheduleInterval type exposes the following members.

Properties

 | Name | Description
Public property | From | The start of the interval. (Inherited from TaskStatusFilter..::..Interval.)
Public property | IncludeNotScheduled |
Public property | IncludeOnEvent |
Public property | IncludeOnExternalEvent |
Public property | IncludeOnMultipleEvents |
Public property | To | The end of the interval. (Inherited from TaskStatusFilter..::..Interval.)

See Also

TaskStatusFilter..::..ScheduleInterval Class


TaskStatusFilter.ScheduleInterval Properties

[image] [image]

QlikView Management Service API
TaskStatusFilter..::..ScheduleInterval Properties
TaskStatusFilter..::..ScheduleInterval Class See Also Send Feedback

The TaskStatusFilter..::..ScheduleInterval type exposes the following members.

Properties

 | Name | Description
Public property | From | The start of the interval. (Inherited from TaskStatusFilter..::..Interval.)
Public property | IncludeNotScheduled |
Public property | IncludeOnEvent |
Public property | IncludeOnExternalEvent |
Public property | IncludeOnMultipleEvents |
Public property | To | The end of the interval. (Inherited from TaskStatusFilter..::..Interval.)

See Also

TaskStatusFilter..::..ScheduleInterval Class


IncludeNotScheduled Property

[image]

QlikView Management Service API
TaskStatusFilter..::..ScheduleInterval..::..IncludeNotScheduled Property
TaskStatusFilter..::..ScheduleInterval Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskStatusFilter.ScheduleInterval.IncludeNotScheduled"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IncludeNotScheduled { get; set; }
Visual Basic
Public Property IncludeNotScheduled As Boolean
    Get
    Set

See Also

TaskStatusFilter..::..ScheduleInterval Class


IncludeOnEvent Property

[image]

QlikView Management Service API
TaskStatusFilter..::..ScheduleInterval..::..IncludeOnEvent Property
TaskStatusFilter..::..ScheduleInterval Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskStatusFilter.ScheduleInterval.IncludeOnEvent"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IncludeOnEvent { get; set; }
Visual Basic
Public Property IncludeOnEvent As Boolean
    Get
    Set

See Also

TaskStatusFilter..::..ScheduleInterval Class


IncludeOnExternalEvent Property

[image]

QlikView Management Service API
TaskStatusFilter..::..ScheduleInterval..::..IncludeOnExternalEvent Property
TaskStatusFilter..::..ScheduleInterval Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskStatusFilter.ScheduleInterval.IncludeOnExternalEvent"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IncludeOnExternalEvent { get; set; }
Visual Basic
Public Property IncludeOnExternalEvent As Boolean
    Get
    Set

See Also

TaskStatusFilter..::..ScheduleInterval Class


IncludeOnMultipleEvents Property

[image]

QlikView Management Service API
TaskStatusFilter..::..ScheduleInterval..::..IncludeOnMultipleEvents Property
TaskStatusFilter..::..ScheduleInterval Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskStatusFilter.ScheduleInterval.IncludeOnMultipleEvents"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool IncludeOnMultipleEvents { get; set; }
Visual Basic
Public Property IncludeOnMultipleEvents As Boolean
    Get
    Set

See Also

TaskStatusFilter..::..ScheduleInterval Class


TaskStatusNode Class

[image]

QlikView Management Service API
TaskStatusNode Class
Members See Also Send Feedback
The Task Status Node data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskStatusNode
Visual Basic
Public Class TaskStatusNode

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatusNode

See Also

TaskStatusNode Members


TaskStatusNode Members

[image] [image]

QlikView Management Service API
TaskStatusNode Members
TaskStatusNode Class Properties See Also Send Feedback

The TaskStatusNode type exposes the following members.

Properties

 | Name | Description
Public property | FailCount | How many times the task has failed.
Public property | HasChildren | If the node has any children.
Public property | ID | The ID of the task status node.
Public property | Name | The name of the node.
Public property | ParentID | The ID of the parent node.
Public property | RequestID | The ID of the request.
Public property | RootType | The type of the root node.
Public property | RunCount | How many times the task has run.
Public property | Status | The status of the object.
Public property | TaskStatus | The current status of the task.
Public property | Type | The type of the identified node.
Public property | WarningCount | How many warnings the task has.

See Also

TaskStatusNode Class


TaskStatusNode Properties

[image] [image]

QlikView Management Service API
TaskStatusNode Properties
TaskStatusNode Class See Also Send Feedback

The TaskStatusNode type exposes the following members.

Properties

 | Name | Description
Public property | FailCount | How many times the task has failed.
Public property | HasChildren | If the node has any children.
Public property | ID | The ID of the task status node.
Public property | Name | The name of the node.
Public property | ParentID | The ID of the parent node.
Public property | RequestID | The ID of the request.
Public property | RootType | The type of the root node.
Public property | RunCount | How many times the task has run.
Public property | Status | The status of the object.
Public property | TaskStatus | The current status of the task.
Public property | Type | The type of the identified node.
Public property | WarningCount | How many warnings the task has.

See Also

TaskStatusNode Class


FailCount Property

[image]

QlikView Management Service API
TaskStatusNode..::..FailCount Property
TaskStatusNode Class See Also Send Feedback
How many times the task has failed.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int FailCount { get; set; }
Visual Basic
Public Property FailCount As Integer
    Get
    Set

See Also

TaskStatusNode Class


HasChildren Property

[image]

QlikView Management Service API
TaskStatusNode..::..HasChildren Property
TaskStatusNode Class See Also Send Feedback
If the node has any children.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool HasChildren { get; set; }
Visual Basic
Public Property HasChildren As Boolean
    Get
    Set

See Also

TaskStatusNode Class


ID Property

[image]

QlikView Management Service API
TaskStatusNode..::..ID Property
TaskStatusNode Class See Also Send Feedback
The ID of the task status node.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; private set; }
Visual Basic
Public Property ID As Guid
    Get
    Private Set

See Also

TaskStatusNode Class


Name Property

[image]

QlikView Management Service API
TaskStatusNode..::..Name Property
TaskStatusNode Class See Also Send Feedback
The name of the node.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

TaskStatusNode Class


ParentID Property

[image]

QlikView Management Service API
TaskStatusNode..::..ParentID Property
TaskStatusNode Class See Also Send Feedback
The ID of the parent node.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ParentID { get; set; }
Visual Basic
Public Property ParentID As Guid
    Get
    Set

See Also

TaskStatusNode Class


RequestID Property

[image]

QlikView Management Service API
TaskStatusNode..::..RequestID Property
TaskStatusNode Class See Also Send Feedback
The ID of the request.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid RequestID { get; set; }
Visual Basic
Public Property RequestID As Guid
    Get
    Set

See Also

TaskStatusNode Class


RootType Property

[image]

QlikView Management Service API
TaskStatusNode..::..RootType Property
TaskStatusNode Class See Also Send Feedback
The type of the root node.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusNodeType RootType { get; set; }
Visual Basic
Public Property RootType As TaskStatusNodeType
    Get
    Set

See Also

TaskStatusNode Class


RunCount Property

[image]

QlikView Management Service API
TaskStatusNode..::..RunCount Property
TaskStatusNode Class See Also Send Feedback
How many times the task has run.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int RunCount { get; set; }
Visual Basic
Public Property RunCount As Integer
    Get
    Set

See Also

TaskStatusNode Class


Status Property

[image]

QlikView Management Service API
TaskStatusNode..::..Status Property
TaskStatusNode Class See Also Send Feedback
The status of the object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusValue Status { get; set; }
Visual Basic
Public Property Status As TaskStatusValue
    Get
    Set

See Also

TaskStatusNode Class


TaskStatus Property

[image]

QlikView Management Service API
TaskStatusNode..::..TaskStatus Property
TaskStatusNode Class See Also Send Feedback
The current status of the task.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatus TaskStatus { get; set; }
Visual Basic
Public Property TaskStatus As TaskStatus
    Get
    Set

See Also

TaskStatusNode Class


Type Property

[image]

QlikView Management Service API
TaskStatusNode..::..Type Property
TaskStatusNode Class See Also Send Feedback
The type of the identified node.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusNodeType Type { get; set; }
Visual Basic
Public Property Type As TaskStatusNodeType
    Get
    Set

See Also

TaskStatusNode Class


WarningCount Property

[image]

QlikView Management Service API
TaskStatusNode..::..WarningCount Property
TaskStatusNode Class See Also Send Feedback
How many warnings the task has.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int WarningCount { get; set; }
Visual Basic
Public Property WarningCount As Integer
    Get
    Set

See Also

TaskStatusNode Class


TaskStatusNodeRequest Class

[image]

QlikView Management Service API
TaskStatusNodeRequest Class
Members See Also Send Feedback
The Task Status Node Request data object.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TaskStatusNodeRequest
Visual Basic
Public Class TaskStatusNodeRequest

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TaskStatusNodeRequest

See Also

TaskStatusNodeRequest Members


TaskStatusNodeRequest Members

[image] [image]

QlikView Management Service API
TaskStatusNodeRequest Members
TaskStatusNodeRequest Class Properties See Also Send Feedback

The TaskStatusNodeRequest type exposes the following members.

Properties

 | Name | Description
Public property | CategoryName | A specific category to target.
Public property | HasCategoryName |
Public property | HasQDSId |
Public property | HasTaskId |
Public property | ID | The ID of the task status node request.
Public property | QDSID | A specific QDS to target.
Public property | RootType | Only QDS, Category or Task are allowed for TaskStatusNodeRequest. DependentTask will produce an error.
Public property | TaskID | A specific task to target.
Public property | Type |
Public property | UseFlatTaskList | If a flat or indented task list is to be used.

See Also

TaskStatusNodeRequest Class


TaskStatusNodeRequest Properties

[image] [image]

QlikView Management Service API
TaskStatusNodeRequest Properties
TaskStatusNodeRequest Class See Also Send Feedback

The TaskStatusNodeRequest type exposes the following members.

Properties

 | Name | Description
Public property | CategoryName | A specific category to target.
Public property | HasCategoryName |
Public property | HasQDSId |
Public property | HasTaskId |
Public property | ID | The ID of the task status node request.
Public property | QDSID | A specific QDS to target.
Public property | RootType | Only QDS, Category or Task are allowed for TaskStatusNodeRequest. DependentTask will produce an error.
Public property | TaskID | A specific task to target.
Public property | Type |
Public property | UseFlatTaskList | If a flat or indented task list is to be used.

See Also

TaskStatusNodeRequest Class


CategoryName Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..CategoryName Property
TaskStatusNodeRequest Class See Also Send Feedback
A specific category to target.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public string CategoryName { get; private set; }
Visual Basic
Public Property CategoryName As String
    Get
    Private Set

See Also

TaskStatusNodeRequest Class


HasCategoryName Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..HasCategoryName Property
TaskStatusNodeRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskStatusNodeRequest.HasCategoryName"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool HasCategoryName { get; }
Visual Basic
Public ReadOnly Property HasCategoryName As Boolean
    Get

See Also

TaskStatusNodeRequest Class


HasQDSId Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..HasQDSId Property
TaskStatusNodeRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskStatusNodeRequest.HasQDSId"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool HasQDSId { get; }
Visual Basic
Public ReadOnly Property HasQDSId As Boolean
    Get

See Also

TaskStatusNodeRequest Class


HasTaskId Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..HasTaskId Property
TaskStatusNodeRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskStatusNodeRequest.HasTaskId"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool HasTaskId { get; }
Visual Basic
Public ReadOnly Property HasTaskId As Boolean
    Get

See Also

TaskStatusNodeRequest Class


ID Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..ID Property
TaskStatusNodeRequest Class See Also Send Feedback
The ID of the task status node request.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ID { get; private set; }
Visual Basic
Public Property ID As Guid
    Get
    Private Set

See Also

TaskStatusNodeRequest Class


QDSID Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..QDSID Property
TaskStatusNodeRequest Class See Also Send Feedback
A specific QDS to target.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid QDSID { get; private set; }
Visual Basic
Public Property QDSID As Guid
    Get
    Private Set

See Also

TaskStatusNodeRequest Class


RootType Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..RootType Property
TaskStatusNodeRequest Class See Also Send Feedback
Only QDS, Category or Task are allowed for TaskStatusNodeRequest. DependentTask will produce an error.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusNodeType RootType { get; private set; }
Visual Basic
Public Property RootType As TaskStatusNodeType
    Get
    Private Set

See Also

TaskStatusNodeRequest Class


TaskID Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..TaskID Property
TaskStatusNodeRequest Class See Also Send Feedback
A specific task to target.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid TaskID { get; private set; }
Visual Basic
Public Property TaskID As Guid
    Get
    Private Set

See Also

TaskStatusNodeRequest Class


Type Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..Type Property
TaskStatusNodeRequest Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TaskStatusNodeRequest.Type"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusNodeType Type { get; }
Visual Basic
Public ReadOnly Property Type As TaskStatusNodeType
    Get

See Also

TaskStatusNodeRequest Class


UseFlatTaskList Property

[image]

QlikView Management Service API
TaskStatusNodeRequest..::..UseFlatTaskList Property
TaskStatusNodeRequest Class See Also Send Feedback
If a flat or indented task list is to be used.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public bool UseFlatTaskList { get; set; }
Visual Basic
Public Property UseFlatTaskList As Boolean
    Get
    Set

See Also

TaskStatusNodeRequest Class


TaskStatusNodeType Enumeration

[image]

QlikView Management Service API
TaskStatusNodeType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskStatusNodeType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskStatusNodeType
Visual Basic
Public Enumeration TaskStatusNodeType

Members

Member name | Value | Description
QDS | 0 |
Category | 1 |
Task | 2 |
DependentTask | 3 |

See Also


TaskStatusScope Enumeration

[image]

QlikView Management Service API
TaskStatusScope Enumeration
See Also Send Feedback
Determines how much of the task status information that should be retrieved when calling GetTaskStatus(Guid, TaskStatusScope) for example.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
[FlagsAttribute]
public enum TaskStatusScope
Visual Basic
<FlagsAttribute> _
Public Enumeration TaskStatusScope

Members

Member name | Value | Description
None | 0 | Only its ID and information about the task being deleted or not will be returned.
General | 1 | Name, task type and status will be returned.
Extended | 2 | Category, DocumentPath, FinishedTime, LastLogMessages, QDSID, StartTime and TaskSummary will be returned.
All | 65535 | All the information will be returned.

See Also

PIX.QMSAPI.DataObjects Namespace
PIX.QMSAPI.DataObjects..::..TaskStatus
IQMS..::..GetTaskStatus(Guid, TaskStatusScope)
IQMS..::..GetTaskStatuses(TaskStatusFilter, TaskStatusScope)
IQMS..::..GetTaskStatusNodes(List<(Of <<'(TaskStatusNodeRequest>)>>), TaskStatusFilter, TaskStatusScope)


TaskStatusValue Enumeration

[image]

QlikView Management Service API
TaskStatusValue Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskStatusValue"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskStatusValue
Visual Basic
Public Enumeration TaskStatusValue

Members

Member name | Value | Description
Waiting | 1 | The task is waiting to be executed.
Running | 2 | The task is running
Aborting | 3 | The task is aborting the execution.
Failed | 4 | The task failed.
Warning | 5 | The task completed with a warning.
Completed | 6 | The task has completed successfully.

See Also


TaskTriggerType Enumeration

[image]

QlikView Management Service API
TaskTriggerType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskTriggerType"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskTriggerType
Visual Basic
Public Enumeration TaskTriggerType

Members

Member name | Value | Description
OnceTrigger | 1 |
HourlyTrigger | 2 |
DailyTrigger | 3 |
WeeklyTrigger | 4 |
MonthlyTrigger | 5 |
ContinuousTrigger | 6 |
ExternalEventTrigger | 7 |
TaskFinishedTrigger | 8 |
TaskFailedTrigger | 9 |
AndTrigger | 10 |

See Also


TaskType Enumeration

[image]

QlikView Management Service API
TaskType Enumeration
See Also Send Feedback
The various task types.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskType
Visual Basic
Public Enumeration TaskType

Members

Member name | Value | Description
Undefined | 0 |
DocumentTask | 1 | A document task.
ExternalProgramTask | 2 | A task which triggers an external program.
DBCommandTask | 3 | A database command task.
PauseTask | 4 |
QvdCreationTask | 5 | Qvd Creation task type.
TemplateTask | 6 | Document template task type

See Also


TaskWizardTrack Enumeration

[image]

QlikView Management Service API
TaskWizardTrack Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.TaskWizardTrack"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum TaskWizardTrack
Visual Basic
Public Enumeration TaskWizardTrack

Members

Member name | Value | Description
None | 0 |
ReloadOnly | 1 |
StaticDistribution | 2 |
ReduceWithStaticDistribution | 3 |
ReduceWithDynamicDistribution | 4 |
DynamicDistribution | 5 |
PersonalDocuments | 6 |

See Also


TriggerEDXTaskResult Class

[image]

QlikView Management Service API
TriggerEDXTaskResult Class
Members See Also Send Feedback
Represents the result of an EDX task.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public class TriggerEDXTaskResult
Visual Basic
Public Class TriggerEDXTaskResult

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects..::..TriggerEDXTaskResult

See Also

TriggerEDXTaskResult Members


TriggerEDXTaskResult Members

[image] [image]

QlikView Management Service API
TriggerEDXTaskResult Members
TriggerEDXTaskResult Class Properties See Also Send Feedback

The TriggerEDXTaskResult type exposes the following members.

Properties

 | Name | Description
Public property | EDXTaskStartResult | The result message from trying to start the EDX task.
Public property | EDXTaskStartResultCode |
Public property | ExecId | The execution id of this task.
Public property | Status | The current status of the task.
Public property | TriggeredTasksId | A lists of tasks triggered by the execution of this task.

See Also

TriggerEDXTaskResult Class


TriggerEDXTaskResult Properties

[image] [image]

QlikView Management Service API
TriggerEDXTaskResult Properties
TriggerEDXTaskResult Class See Also Send Feedback

The TriggerEDXTaskResult type exposes the following members.

Properties

 | Name | Description
Public property | EDXTaskStartResult | The result message from trying to start the EDX task.
Public property | EDXTaskStartResultCode |
Public property | ExecId | The execution id of this task.
Public property | Status | The current status of the task.
Public property | TriggeredTasksId | A lists of tasks triggered by the execution of this task.

See Also

TriggerEDXTaskResult Class


EDXTaskStartResult Property

[image]

QlikView Management Service API
TriggerEDXTaskResult..::..EDXTaskStartResult Property
TriggerEDXTaskResult Class See Also Send Feedback
The result message from trying to start the EDX task.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public EDXTaskStartResult EDXTaskStartResult { get; set; }
Visual Basic
Public Property EDXTaskStartResult As EDXTaskStartResult
    Get
    Set

See Also

TriggerEDXTaskResult Class


EDXTaskStartResultCode Property

[image]

QlikView Management Service API
TriggerEDXTaskResult..::..EDXTaskStartResultCode Property
TriggerEDXTaskResult Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.TriggerEDXTaskResult.EDXTaskStartResultCode"]

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public int EDXTaskStartResultCode { get; set; }
Visual Basic
Public Property EDXTaskStartResultCode As Integer
    Get
    Set

See Also

TriggerEDXTaskResult Class


ExecId Property

[image]

QlikView Management Service API
TriggerEDXTaskResult..::..ExecId Property
TriggerEDXTaskResult Class See Also Send Feedback
The execution id of this task.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public Guid ExecId { get; set; }
Visual Basic
Public Property ExecId As Guid
    Get
    Set

See Also

TriggerEDXTaskResult Class


Status Property

[image]

QlikView Management Service API
TriggerEDXTaskResult..::..Status Property
TriggerEDXTaskResult Class See Also Send Feedback
The current status of the task.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public TaskStatusValue Status { get; set; }
Visual Basic
Public Property Status As TaskStatusValue
    Get
    Set

See Also

TriggerEDXTaskResult Class


TriggeredTasksId Property

[image]

QlikView Management Service API
TriggerEDXTaskResult..::..TriggeredTasksId Property
TriggerEDXTaskResult Class See Also Send Feedback
A lists of tasks triggered by the execution of this task.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public List<TaskExecutionItem> TriggeredTasksId { get; set; }
Visual Basic
Public Property TriggeredTasksId As List(Of TaskExecutionItem)
    Get
    Set

See Also

TriggerEDXTaskResult Class


UserIdentityValueType Enumeration

[image]

QlikView Management Service API
UserIdentityValueType Enumeration
See Also Send Feedback
The different types of identities.

Namespace: PIX.QMSAPI.DataObjects

Syntax

C#
public enum UserIdentityValueType
Visual Basic
Public Enumeration UserIdentityValueType

Members

Member name | Value | Description
SecurityIdentifier | 2 |
DisplayName | 4 |
SAMAccountName | 8 |
EmailAddress | 16 |
UserPrincipalName | 128 |
EmailAddressNoValidate | 2048 |

See Also


PIX.QMSAPI.DataObjects.CALs Namespace

[image]

QlikView Management Service API
PIX.QMSAPI.DataObjects.CALs Namespace
Send Feedback
Contains CAL specific classes.

Classes

 | Class | Description
Public class | AssignedNamedCAL |
Public class | CAL | Base class for the various license types.
Public class | CALConfiguration | Represents the CAL configuration on a QVS.
Public class | CALConfiguration..::..CALConfigurationDocumentCALs | Represents the document CAL configuration.
Public class | CALConfiguration..::..CALConfigurationNamedCALs | Represents the Named CAL configuration.
Public class | CALConfiguration..::..CALConfigurationSessionCALs |
Public class | CALConfiguration..::..CALConfigurationUsageCALs |
Public class | DocumentCAL | Represents a Document CAL.
Public class | LeasedNamedCAL | Represents a leased CAL.
Public class | UserCALs | Holds the licenses assigned to a single user.


AssignedNamedCAL Class

[image]

QlikView Management Service API
AssignedNamedCAL Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.CALs.AssignedNamedCAL"]

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class AssignedNamedCAL : CAL
Visual Basic
Public Class AssignedNamedCAL _
    Inherits CAL

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CAL
PIX.QMSAPI.DataObjects.CALs..::..AssignedNamedCAL

See Also

AssignedNamedCAL Members
PIX.QMSAPI.DataObjects.CALs Namespace


AssignedNamedCAL Members

[image] [image]

QlikView Management Service API
AssignedNamedCAL Members
AssignedNamedCAL Class Properties See Also Send Feedback

The AssignedNamedCAL type exposes the following members.

Properties

 | Name | Description
Public property | LastUsed | Date when the license was used the last time. (Inherited from CAL.)
Public property | MachineID | The ID of the machine where this license was used. (Inherited from CAL.)
Public property | QuarantinedUntil | The date to which this license is quarantined. (Inherited from CAL.)
Public property | UserName | The name of the user to which the license is assigned. (Inherited from CAL.)

See Also

AssignedNamedCAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


AssignedNamedCAL Properties

[image] [image]

QlikView Management Service API
AssignedNamedCAL Properties
AssignedNamedCAL Class See Also Send Feedback

The AssignedNamedCAL type exposes the following members.

Properties

 | Name | Description
Public property | LastUsed | Date when the license was used the last time. (Inherited from CAL.)
Public property | MachineID | The ID of the machine where this license was used. (Inherited from CAL.)
Public property | QuarantinedUntil | The date to which this license is quarantined. (Inherited from CAL.)
Public property | UserName | The name of the user to which the license is assigned. (Inherited from CAL.)

See Also

AssignedNamedCAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


CAL Class

[image]

QlikView Management Service API
CAL Class
Members See Also Send Feedback
Base class for the various license types.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class CAL
Visual Basic
Public Class CAL

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CAL
PIX.QMSAPI.DataObjects.CALs..::..AssignedNamedCAL
PIX.QMSAPI.DataObjects.CALs..::..DocumentCAL
PIX.QMSAPI.DataObjects.CALs..::..LeasedNamedCAL

See Also

CAL Members
PIX.QMSAPI.DataObjects.CALs Namespace


CAL Members

[image] [image]

QlikView Management Service API
CAL Members
CAL Class Properties See Also Send Feedback

The CAL type exposes the following members.

Properties

 | Name | Description
Public property | LastUsed | Date when the license was used the last time.
Public property | MachineID | The ID of the machine where this license was used.
Public property | QuarantinedUntil | The date to which this license is quarantined.
Public property | UserName | The name of the user to which the license is assigned.

See Also

CAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


CAL Properties

[image] [image]

QlikView Management Service API
CAL Properties
CAL Class See Also Send Feedback

The CAL type exposes the following members.

Properties

 | Name | Description
Public property | LastUsed | Date when the license was used the last time.
Public property | MachineID | The ID of the machine where this license was used.
Public property | QuarantinedUntil | The date to which this license is quarantined.
Public property | UserName | The name of the user to which the license is assigned.

See Also

CAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


LastUsed Property

[image]

QlikView Management Service API
CAL..::..LastUsed Property
CAL Class See Also Send Feedback
Date when the license was used the last time.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public DateTime LastUsed { get; set; }
Visual Basic
Public Property LastUsed As DateTime
    Get
    Set

See Also

CAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


MachineID Property

[image]

QlikView Management Service API
CAL..::..MachineID Property
CAL Class See Also Send Feedback
The ID of the machine where this license was used.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public string MachineID { get; set; }
Visual Basic
Public Property MachineID As String
    Get
    Set

See Also

CAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


QuarantinedUntil Property

[image]

QlikView Management Service API
CAL..::..QuarantinedUntil Property
CAL Class See Also Send Feedback
The date to which this license is quarantined.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public DateTime QuarantinedUntil { get; set; }
Visual Basic
Public Property QuarantinedUntil As DateTime
    Get
    Set

See Also

CAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


UserName Property

[image]

QlikView Management Service API
CAL..::..UserName Property
CAL Class See Also Send Feedback
The name of the user to which the license is assigned.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set

See Also

CAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration Class

[image]

QlikView Management Service API
CALConfiguration Class
Members See Also Send Feedback
Represents the CAL configuration on a QVS.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class CALConfiguration
Visual Basic
Public Class CALConfiguration

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CALConfiguration

See Also

CALConfiguration Members
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration Members

[image] [image]

QlikView Management Service API
CALConfiguration Members
CALConfiguration Class Properties See Also Send Feedback

The CALConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | DocumentCALs | The Document CAL configuration on the QVS.
Public property | NamedCALs | The Named CAL configuration on the QVS.
Public property | QVSID | The ID of the QVS from which the configuration was retrieved.
Public property | Scope | The scope used when retrieving the configuration.
Public property | SessionCALs | The Session CAL configuration on the QVS.
Public property | Uncapped |
Public property | UsageCALs | The Usage CAL configuration on the QVS.

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration Properties

[image] [image]

QlikView Management Service API
CALConfiguration Properties
CALConfiguration Class See Also Send Feedback

The CALConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | DocumentCALs | The Document CAL configuration on the QVS.
Public property | NamedCALs | The Named CAL configuration on the QVS.
Public property | QVSID | The ID of the QVS from which the configuration was retrieved.
Public property | Scope | The scope used when retrieving the configuration.
Public property | SessionCALs | The Session CAL configuration on the QVS.
Public property | Uncapped |
Public property | UsageCALs | The Usage CAL configuration on the QVS.

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


DocumentCALs Property

[image]

QlikView Management Service API
CALConfiguration..::..DocumentCALs Property
CALConfiguration Class See Also Send Feedback
The Document CAL configuration on the QVS.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public CALConfiguration..::..CALConfigurationDocumentCALs DocumentCALs { get; private set; }
Visual Basic
Public Property DocumentCALs As CALConfiguration..::..CALConfigurationDocumentCALs
    Get
    Private Set

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


NamedCALs Property

[image]

QlikView Management Service API
CALConfiguration..::..NamedCALs Property
CALConfiguration Class See Also Send Feedback
The Named CAL configuration on the QVS.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public CALConfiguration..::..CALConfigurationNamedCALs NamedCALs { get; private set; }
Visual Basic
Public Property NamedCALs As CALConfiguration..::..CALConfigurationNamedCALs
    Get
    Private Set

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


QVSID Property

[image]

QlikView Management Service API
CALConfiguration..::..QVSID Property
CALConfiguration Class See Also Send Feedback
The ID of the QVS from which the configuration was retrieved.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public Guid QVSID { get; private set; }
Visual Basic
Public Property QVSID As Guid
    Get
    Private Set

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


Scope Property

[image]

QlikView Management Service API
CALConfiguration..::..Scope Property
CALConfiguration Class See Also Send Feedback
The scope used when retrieving the configuration.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public CALConfigurationScope Scope { get; private set; }
Visual Basic
Public Property Scope As CALConfigurationScope
    Get
    Private Set

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


SessionCALs Property

[image]

QlikView Management Service API
CALConfiguration..::..SessionCALs Property
CALConfiguration Class See Also Send Feedback
The Session CAL configuration on the QVS.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public CALConfiguration..::..CALConfigurationSessionCALs SessionCALs { get; private set; }
Visual Basic
Public Property SessionCALs As CALConfiguration..::..CALConfigurationSessionCALs
    Get
    Private Set

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


Uncapped Property

[image]

QlikView Management Service API
CALConfiguration..::..Uncapped Property
CALConfiguration Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.CALs.CALConfiguration.Uncapped"]

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public bool Uncapped { get; set; }
Visual Basic
Public Property Uncapped As Boolean
    Get
    Set

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


UsageCALs Property

[image]

QlikView Management Service API
CALConfiguration..::..UsageCALs Property
CALConfiguration Class See Also Send Feedback
The Usage CAL configuration on the QVS.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public CALConfiguration..::..CALConfigurationUsageCALs UsageCALs { get; private set; }
Visual Basic
Public Property UsageCALs As CALConfiguration..::..CALConfigurationUsageCALs
    Get
    Private Set

See Also

CALConfiguration Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationDocumentCALs Class

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationDocumentCALs Class
CALConfiguration Class Members See Also Send Feedback
Represents the document CAL configuration.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class CALConfigurationDocumentCALs
Visual Basic
Public Class CALConfigurationDocumentCALs

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CALConfiguration..::..CALConfigurationDocumentCALs

See Also

CALConfiguration..::..CALConfigurationDocumentCALs Members
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationDocumentCALs Members

[image] [image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationDocumentCALs Members
CALConfiguration..::..CALConfigurationDocumentCALs Class Properties See Also Send Feedback

Represents the CAL configuration on a QVS.

The CALConfiguration..::..CALConfigurationDocumentCALs type exposes the following members.

Properties

 | Name | Description
Public property | Assigned | The number of currently assigned Document CALs
Public property | InLicense | Number of CALs allowed as defined in the currently set license.
Public property | Limit | The configured number of Document CALs. If Limit changed, QVS needs to be restarted.

See Also

CALConfiguration..::..CALConfigurationDocumentCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationDocumentCALs Properties

[image] [image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationDocumentCALs Properties
CALConfiguration..::..CALConfigurationDocumentCALs Class See Also Send Feedback

The CALConfiguration..::..CALConfigurationDocumentCALs type exposes the following members.

Properties

 | Name | Description
Public property | Assigned | The number of currently assigned Document CALs
Public property | InLicense | Number of CALs allowed as defined in the currently set license.
Public property | Limit | The configured number of Document CALs. If Limit changed, QVS needs to be restarted.

See Also

CALConfiguration..::..CALConfigurationDocumentCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


Assigned Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationDocumentCALs..::..Assigned Property
CALConfiguration..::..CALConfigurationDocumentCALs Class See Also Send Feedback
The number of currently assigned Document CALs

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int Assigned { get; set; }
Visual Basic
Public Property Assigned As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationDocumentCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


InLicense Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationDocumentCALs..::..InLicense Property
CALConfiguration..::..CALConfigurationDocumentCALs Class See Also Send Feedback
Number of CALs allowed as defined in the currently set license.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int InLicense { get; set; }
Visual Basic
Public Property InLicense As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationDocumentCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


Limit Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationDocumentCALs..::..Limit Property
CALConfiguration..::..CALConfigurationDocumentCALs Class See Also Send Feedback
The configured number of Document CALs. If Limit changed, QVS needs to be restarted.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int Limit { get; set; }
Visual Basic
Public Property Limit As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationDocumentCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationNamedCALs Class

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs Class
CALConfiguration Class Members See Also Send Feedback
Represents the Named CAL configuration.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class CALConfigurationNamedCALs
Visual Basic
Public Class CALConfigurationNamedCALs

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CALConfiguration..::..CALConfigurationNamedCALs

See Also

CALConfiguration..::..CALConfigurationNamedCALs Members
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationNamedCALs Members

[image] [image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs Members
CALConfiguration..::..CALConfigurationNamedCALs Class Properties See Also Send Feedback

Represents the CAL configuration on a QVS.

The CALConfiguration..::..CALConfigurationNamedCALs type exposes the following members.

Properties

 | Name | Description
Public property | AllowDynamicAssignment | Controls whether dynamic license assignment is allowed or not.
Public property | AllowLicenseLease | Controls whether license lease is allowed or not.
Public property | Assigned | The number of currently assigned Named CALs.
Public property | AssignedCALs | The currently assigned CALs.
Public property | IdentificationMode | Controls the identification mode to be used. Either by machine or user name.
Public property | InLicense | The maximum number of Named CALs as defined in the current license.
Public property | LeasedCALs | The currently leased CALs.
Public property | Limit | The currently configured maximum number of assigned Named CALs allowed.

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationNamedCALs Properties

[image] [image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs Properties
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback

The CALConfiguration..::..CALConfigurationNamedCALs type exposes the following members.

Properties

 | Name | Description
Public property | AllowDynamicAssignment | Controls whether dynamic license assignment is allowed or not.
Public property | AllowLicenseLease | Controls whether license lease is allowed or not.
Public property | Assigned | The number of currently assigned Named CALs.
Public property | AssignedCALs | The currently assigned CALs.
Public property | IdentificationMode | Controls the identification mode to be used. Either by machine or user name.
Public property | InLicense | The maximum number of Named CALs as defined in the current license.
Public property | LeasedCALs | The currently leased CALs.
Public property | Limit | The currently configured maximum number of assigned Named CALs allowed.

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


AllowDynamicAssignment Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs..::..AllowDynamicAssignment Property
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback
Controls whether dynamic license assignment is allowed or not.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public bool AllowDynamicAssignment { get; set; }
Visual Basic
Public Property AllowDynamicAssignment As Boolean
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


AllowLicenseLease Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs..::..AllowLicenseLease Property
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback
Controls whether license lease is allowed or not.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public bool AllowLicenseLease { get; set; }
Visual Basic
Public Property AllowLicenseLease As Boolean
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


Assigned Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs..::..Assigned Property
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback
The number of currently assigned Named CALs.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int Assigned { get; set; }
Visual Basic
Public Property Assigned As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


AssignedCALs Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs..::..AssignedCALs Property
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback
The currently assigned CALs.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public List<AssignedNamedCAL> AssignedCALs { get; private set; }
Visual Basic
Public Property AssignedCALs As List(Of AssignedNamedCAL)
    Get
    Private Set

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


IdentificationMode Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs..::..IdentificationMode Property
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback
Controls the identification mode to be used. Either by machine or user name.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public NamedCALIdentificationMode IdentificationMode { get; set; }
Visual Basic
Public Property IdentificationMode As NamedCALIdentificationMode
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


InLicense Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs..::..InLicense Property
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback
The maximum number of Named CALs as defined in the current license.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int InLicense { get; set; }
Visual Basic
Public Property InLicense As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


LeasedCALs Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs..::..LeasedCALs Property
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback
The currently leased CALs.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public List<LeasedNamedCAL> LeasedCALs { get; private set; }
Visual Basic
Public Property LeasedCALs As List(Of LeasedNamedCAL)
    Get
    Private Set

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


Limit Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationNamedCALs..::..Limit Property
CALConfiguration..::..CALConfigurationNamedCALs Class See Also Send Feedback
The currently configured maximum number of assigned Named CALs allowed.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int Limit { get; set; }
Visual Basic
Public Property Limit As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationNamedCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationSessionCALs Class

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationSessionCALs Class
CALConfiguration Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.CALs.CALConfiguration.CALConfigurationSessionCALs"]

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class CALConfigurationSessionCALs
Visual Basic
Public Class CALConfigurationSessionCALs

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CALConfiguration..::..CALConfigurationSessionCALs

See Also

CALConfiguration..::..CALConfigurationSessionCALs Members
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationSessionCALs Members

[image] [image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationSessionCALs Members
CALConfiguration..::..CALConfigurationSessionCALs Class Properties See Also Send Feedback

Represents the CAL configuration on a QVS.

The CALConfiguration..::..CALConfigurationSessionCALs type exposes the following members.

Properties

 | Name | Description
Public property | Available | The number of Session CALs avaible. This property is read only.
Public property | InLicense | The maximum number of Session CALs as defined in the current license.
Public property | Limit | The currently configured maximum number of Session CALs allowed. If changed, QVS needs to be restarted

See Also

CALConfiguration..::..CALConfigurationSessionCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationSessionCALs Properties

[image] [image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationSessionCALs Properties
CALConfiguration..::..CALConfigurationSessionCALs Class See Also Send Feedback

The CALConfiguration..::..CALConfigurationSessionCALs type exposes the following members.

Properties

 | Name | Description
Public property | Available | The number of Session CALs avaible. This property is read only.
Public property | InLicense | The maximum number of Session CALs as defined in the current license.
Public property | Limit | The currently configured maximum number of Session CALs allowed. If changed, QVS needs to be restarted

See Also

CALConfiguration..::..CALConfigurationSessionCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


Available Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationSessionCALs..::..Available Property
CALConfiguration..::..CALConfigurationSessionCALs Class See Also Send Feedback
The number of Session CALs avaible. This property is read only.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int Available { get; set; }
Visual Basic
Public Property Available As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationSessionCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


InLicense Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationSessionCALs..::..InLicense Property
CALConfiguration..::..CALConfigurationSessionCALs Class See Also Send Feedback
The maximum number of Session CALs as defined in the current license.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int InLicense { get; set; }
Visual Basic
Public Property InLicense As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationSessionCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


Limit Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationSessionCALs..::..Limit Property
CALConfiguration..::..CALConfigurationSessionCALs Class See Also Send Feedback
The currently configured maximum number of Session CALs allowed. If changed, QVS needs to be restarted

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int Limit { get; set; }
Visual Basic
Public Property Limit As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationSessionCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationUsageCALs Class

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationUsageCALs Class
CALConfiguration Class Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.CALs.CALConfiguration.CALConfigurationUsageCALs"]

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class CALConfigurationUsageCALs
Visual Basic
Public Class CALConfigurationUsageCALs

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CALConfiguration..::..CALConfigurationUsageCALs

See Also

CALConfiguration..::..CALConfigurationUsageCALs Members
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationUsageCALs Members

[image] [image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationUsageCALs Members
CALConfiguration..::..CALConfigurationUsageCALs Class Properties See Also Send Feedback

Represents the CAL configuration on a QVS.

The CALConfiguration..::..CALConfigurationUsageCALs type exposes the following members.

Properties

 | Name | Description
Public property | Available |
Public property | InLicense |
Public property | Limit |

See Also

CALConfiguration..::..CALConfigurationUsageCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


CALConfiguration.CALConfigurationUsageCALs Properties

[image] [image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationUsageCALs Properties
CALConfiguration..::..CALConfigurationUsageCALs Class See Also Send Feedback

The CALConfiguration..::..CALConfigurationUsageCALs type exposes the following members.

Properties

 | Name | Description
Public property | Available |
Public property | InLicense |
Public property | Limit |

See Also

CALConfiguration..::..CALConfigurationUsageCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


Available Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationUsageCALs..::..Available Property
CALConfiguration..::..CALConfigurationUsageCALs Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.CALs.CALConfiguration.CALConfigurationUsageCALs.Available"]

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int Available { get; set; }
Visual Basic
Public Property Available As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationUsageCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


InLicense Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationUsageCALs..::..InLicense Property
CALConfiguration..::..CALConfigurationUsageCALs Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.CALs.CALConfiguration.CALConfigurationUsageCALs.InLicense"]

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int InLicense { get; set; }
Visual Basic
Public Property InLicense As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationUsageCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


Limit Property

[image]

QlikView Management Service API
CALConfiguration..::..CALConfigurationUsageCALs..::..Limit Property
CALConfiguration..::..CALConfigurationUsageCALs Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.CALs.CALConfiguration.CALConfigurationUsageCALs.Limit"]

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public int Limit { get; set; }
Visual Basic
Public Property Limit As Integer
    Get
    Set

See Also

CALConfiguration..::..CALConfigurationUsageCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


DocumentCAL Class

[image]

QlikView Management Service API
DocumentCAL Class
Members See Also Send Feedback
Represents a Document CAL.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class DocumentCAL : CAL
Visual Basic
Public Class DocumentCAL _
    Inherits CAL

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CAL
PIX.QMSAPI.DataObjects.CALs..::..DocumentCAL

See Also

DocumentCAL Members
PIX.QMSAPI.DataObjects.CALs Namespace


DocumentCAL Members

[image] [image]

QlikView Management Service API
DocumentCAL Members
DocumentCAL Class Properties See Also Send Feedback

The DocumentCAL type exposes the following members.

Properties

 | Name | Description
Public property | DocumentName | The name of the document this license was assigned to.
Public property | LastUsed | Date when the license was used the last time. (Inherited from CAL.)
Public property | MachineID | The ID of the machine where this license was used. (Inherited from CAL.)
Public property | QuarantinedUntil | The date to which this license is quarantined. (Inherited from CAL.)
Public property | UserName | The name of the user to which the license is assigned. (Inherited from CAL.)

See Also

DocumentCAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


DocumentCAL Properties

[image] [image]

QlikView Management Service API
DocumentCAL Properties
DocumentCAL Class See Also Send Feedback

The DocumentCAL type exposes the following members.

Properties

 | Name | Description
Public property | DocumentName | The name of the document this license was assigned to.
Public property | LastUsed | Date when the license was used the last time. (Inherited from CAL.)
Public property | MachineID | The ID of the machine where this license was used. (Inherited from CAL.)
Public property | QuarantinedUntil | The date to which this license is quarantined. (Inherited from CAL.)
Public property | UserName | The name of the user to which the license is assigned. (Inherited from CAL.)

See Also

DocumentCAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


DocumentName Property

[image]

QlikView Management Service API
DocumentCAL..::..DocumentName Property
DocumentCAL Class See Also Send Feedback
The name of the document this license was assigned to.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public string DocumentName { get; set; }
Visual Basic
Public Property DocumentName As String
    Get
    Set

See Also

DocumentCAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


LeasedNamedCAL Class

[image]

QlikView Management Service API
LeasedNamedCAL Class
Members See Also Send Feedback
Represents a leased CAL.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class LeasedNamedCAL : CAL
Visual Basic
Public Class LeasedNamedCAL _
    Inherits CAL

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..CAL
PIX.QMSAPI.DataObjects.CALs..::..LeasedNamedCAL

See Also

LeasedNamedCAL Members
PIX.QMSAPI.DataObjects.CALs Namespace


LeasedNamedCAL Members

[image] [image]

QlikView Management Service API
LeasedNamedCAL Members
LeasedNamedCAL Class Properties See Also Send Feedback

The LeasedNamedCAL type exposes the following members.

Properties

 | Name | Description
Public property | LastUsed | Date when the license was used the last time. (Inherited from CAL.)
Public property | LeasedAt | The date and time when this license was leased.
Public property | MachineID | The ID of the machine where this license was used. (Inherited from CAL.)
Public property | QuarantinedUntil | The date to which this license is quarantined. (Inherited from CAL.)
Public property | UserName | The name of the user to which the license is assigned. (Inherited from CAL.)

See Also

LeasedNamedCAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


LeasedNamedCAL Properties

[image] [image]

QlikView Management Service API
LeasedNamedCAL Properties
LeasedNamedCAL Class See Also Send Feedback

The LeasedNamedCAL type exposes the following members.

Properties

 | Name | Description
Public property | LastUsed | Date when the license was used the last time. (Inherited from CAL.)
Public property | LeasedAt | The date and time when this license was leased.
Public property | MachineID | The ID of the machine where this license was used. (Inherited from CAL.)
Public property | QuarantinedUntil | The date to which this license is quarantined. (Inherited from CAL.)
Public property | UserName | The name of the user to which the license is assigned. (Inherited from CAL.)

See Also

LeasedNamedCAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


LeasedAt Property

[image]

QlikView Management Service API
LeasedNamedCAL..::..LeasedAt Property
LeasedNamedCAL Class See Also Send Feedback
The date and time when this license was leased.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public DateTime LeasedAt { get; set; }
Visual Basic
Public Property LeasedAt As DateTime
    Get
    Set

See Also

LeasedNamedCAL Class
PIX.QMSAPI.DataObjects.CALs Namespace


UserCALs Class

[image]

QlikView Management Service API
UserCALs Class
Members See Also Send Feedback
Holds the licenses assigned to a single user.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public class UserCALs
Visual Basic
Public Class UserCALs

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.CALs..::..UserCALs

See Also

UserCALs Members
PIX.QMSAPI.DataObjects.CALs Namespace


UserCALs Members

[image] [image]

QlikView Management Service API
UserCALs Members
UserCALs Class Properties See Also Send Feedback

The UserCALs type exposes the following members.

Properties

 | Name | Description
Public property | DocumentCALs | The Document CALs currently used by the user.
Public property | LeasedNamedCALs | The leased CALs currently used by the user.
Public property | NamedCAL | The named CAL assigned to a specific user.

See Also

UserCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


UserCALs Properties

[image] [image]

QlikView Management Service API
UserCALs Properties
UserCALs Class See Also Send Feedback

The UserCALs type exposes the following members.

Properties

 | Name | Description
Public property | DocumentCALs | The Document CALs currently used by the user.
Public property | LeasedNamedCALs | The leased CALs currently used by the user.
Public property | NamedCAL | The named CAL assigned to a specific user.

See Also

UserCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


DocumentCALs Property

[image]

QlikView Management Service API
UserCALs..::..DocumentCALs Property
UserCALs Class See Also Send Feedback
The Document CALs currently used by the user.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public List<DocumentCAL> DocumentCALs { get; set; }
Visual Basic
Public Property DocumentCALs As List(Of DocumentCAL)
    Get
    Set

See Also

UserCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


LeasedNamedCALs Property

[image]

QlikView Management Service API
UserCALs..::..LeasedNamedCALs Property
UserCALs Class See Also Send Feedback
The leased CALs currently used by the user.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public List<LeasedNamedCAL> LeasedNamedCALs { get; set; }
Visual Basic
Public Property LeasedNamedCALs As List(Of LeasedNamedCAL)
    Get
    Set

See Also

UserCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


NamedCAL Property

[image]

QlikView Management Service API
UserCALs..::..NamedCAL Property
UserCALs Class See Also Send Feedback
The named CAL assigned to a specific user.

Namespace: PIX.QMSAPI.DataObjects.CALs

Syntax

C#
public AssignedNamedCAL NamedCAL { get; set; }
Visual Basic
Public Property NamedCAL As AssignedNamedCAL
    Get
    Set

See Also

UserCALs Class
PIX.QMSAPI.DataObjects.CALs Namespace


PIX.QMSAPI.DataObjects.Document Namespace

[image]

QlikView Management Service API
PIX.QMSAPI.DataObjects.Document Namespace
Send Feedback
Contains document specific classes.

Classes

 | Class | Description
Public class | DocumentInfo |
Public class | Field | This class represents a single field in a document.
Public class | FieldContent | Represents the content of a single field. A field can have multiple values.
Public class | FieldValue | Represents the value of a single field. It is used to represents both text values and numeric values.
Public class | Report | Represents a document report.


DocumentInfo Class

[image]

QlikView Management Service API
DocumentInfo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.Document.DocumentInfo"]

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public class DocumentInfo
Visual Basic
Public Class DocumentInfo

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Document..::..DocumentInfo

See Also

DocumentInfo Members
PIX.QMSAPI.DataObjects.Document Namespace


DocumentInfo Members

[image] [image]

QlikView Management Service API
DocumentInfo Members
DocumentInfo Class Properties See Also Send Feedback

The DocumentInfo type exposes the following members.

Properties

 | Name | Description
Public property | AllowServerObjects |
Public property | Trigger |

See Also

DocumentInfo Class
PIX.QMSAPI.DataObjects.Document Namespace


DocumentInfo Properties

[image] [image]

QlikView Management Service API
DocumentInfo Properties
DocumentInfo Class See Also Send Feedback

The DocumentInfo type exposes the following members.

Properties

 | Name | Description
Public property | AllowServerObjects |
Public property | Trigger |

See Also

DocumentInfo Class
PIX.QMSAPI.DataObjects.Document Namespace


AllowServerObjects Property

[image]

QlikView Management Service API
DocumentInfo..::..AllowServerObjects Property
DocumentInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.Document.DocumentInfo.AllowServerObjects"]

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public bool AllowServerObjects { get; private set; }
Visual Basic
Public Property AllowServerObjects As Boolean
    Get
    Private Set

See Also

DocumentInfo Class
PIX.QMSAPI.DataObjects.Document Namespace


Trigger Property

[image]

QlikView Management Service API
DocumentInfo..::..Trigger Property
DocumentInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.Document.DocumentInfo.Trigger"]

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public Trigger Trigger { get; private set; }
Visual Basic
Public Property Trigger As Trigger
    Get
    Private Set

See Also

DocumentInfo Class
PIX.QMSAPI.DataObjects.Document Namespace


Field Class

[image]

QlikView Management Service API
Field Class
Members See Also Send Feedback
This class represents a single field in a document.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public class Field
Visual Basic
Public Class Field

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Document..::..Field

See Also

Field Members
PIX.QMSAPI.DataObjects.Document Namespace


Field Members

[image] [image]

QlikView Management Service API
Field Members
Field Class Properties See Also Send Feedback

The Field type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the field.

See Also

Field Class
PIX.QMSAPI.DataObjects.Document Namespace


Field Properties

[image] [image]

QlikView Management Service API
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the field.

See Also

Field Class
PIX.QMSAPI.DataObjects.Document Namespace


Name Property

[image]

QlikView Management Service API
Field..::..Name Property
Field Class See Also Send Feedback
The name of the field.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

Field Class
PIX.QMSAPI.DataObjects.Document Namespace


FieldContent Class

[image]

QlikView Management Service API
FieldContent Class
Members See Also Send Feedback
Represents the content of a single field. A field can have multiple values.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public class FieldContent
Visual Basic
Public Class FieldContent

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Document..::..FieldContent

See Also

FieldContent Members
PIX.QMSAPI.DataObjects.Document Namespace


FieldContent Members

[image] [image]

QlikView Management Service API
FieldContent Members
FieldContent Class Properties See Also Send Feedback

The FieldContent type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the field.
Public property | Values | The values of the field.

See Also

FieldContent Class
PIX.QMSAPI.DataObjects.Document Namespace


FieldContent Properties

[image] [image]

QlikView Management Service API
FieldContent Properties
FieldContent Class See Also Send Feedback

The FieldContent type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the field.
Public property | Values | The values of the field.

See Also

FieldContent Class
PIX.QMSAPI.DataObjects.Document Namespace


Name Property

[image]

QlikView Management Service API
FieldContent..::..Name Property
FieldContent Class See Also Send Feedback
The name of the field.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

FieldContent Class
PIX.QMSAPI.DataObjects.Document Namespace


Values Property

[image]

QlikView Management Service API
FieldContent..::..Values Property
FieldContent Class See Also Send Feedback
The values of the field.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public List<FieldValue> Values { get; set; }
Visual Basic
Public Property Values As List(Of FieldValue)
    Get
    Set

See Also

FieldContent Class
PIX.QMSAPI.DataObjects.Document Namespace


FieldValue Class

[image]

QlikView Management Service API
FieldValue Class
Members See Also Send Feedback
Represents the value of a single field. It is used to represents both text values and numeric values.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public class FieldValue
Visual Basic
Public Class FieldValue

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Document..::..FieldValue

See Also

FieldValue Members
PIX.QMSAPI.DataObjects.Document Namespace


FieldValue Members

[image] [image]

QlikView Management Service API
FieldValue Members
FieldValue Class Properties See Also Send Feedback

The FieldValue type exposes the following members.

Properties

 | Name | Description
Public property | IsNumeric |
Public property | Number |
Public property | SortOrder |
Public property | State |
Public property | Text |

See Also

FieldValue Class
PIX.QMSAPI.DataObjects.Document Namespace


FieldValue Properties

[image] [image]

QlikView Management Service API
FieldValue Properties
FieldValue Class See Also Send Feedback

The FieldValue type exposes the following members.

Properties

 | Name | Description
Public property | IsNumeric |
Public property | Number |
Public property | SortOrder |
Public property | State |
Public property | Text |

See Also

FieldValue Class
PIX.QMSAPI.DataObjects.Document Namespace


IsNumeric Property

[image]

QlikView Management Service API
FieldValue..::..IsNumeric Property
FieldValue Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.Document.FieldValue.IsNumeric"]

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public bool IsNumeric { get; private set; }
Visual Basic
Public Property IsNumeric As Boolean
    Get
    Private Set

See Also

FieldValue Class
PIX.QMSAPI.DataObjects.Document Namespace


Number Property

[image]

QlikView Management Service API
FieldValue..::..Number Property
FieldValue Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.Document.FieldValue.Number"]

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public double Number { get; set; }
Visual Basic
Public Property Number As Double
    Get
    Set

See Also

FieldValue Class
PIX.QMSAPI.DataObjects.Document Namespace


SortOrder Property

[image]

QlikView Management Service API
FieldValue..::..SortOrder Property
FieldValue Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.Document.FieldValue.SortOrder"]

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public int SortOrder { get; set; }
Visual Basic
Public Property SortOrder As Integer
    Get
    Set

See Also

FieldValue Class
PIX.QMSAPI.DataObjects.Document Namespace


State Property

[image]

QlikView Management Service API
FieldValue..::..State Property
FieldValue Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.Document.FieldValue.State"]

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public FieldValueState State { get; set; }
Visual Basic
Public Property State As FieldValueState
    Get
    Set

See Also

FieldValue Class
PIX.QMSAPI.DataObjects.Document Namespace


Text Property

[image]

QlikView Management Service API
FieldValue..::..Text Property
FieldValue Class See Also Send Feedback

[Missing <summary> documentation for "P:PIX.QMSAPI.DataObjects.Document.FieldValue.Text"]

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

See Also

FieldValue Class
PIX.QMSAPI.DataObjects.Document Namespace


Report Class

[image]

QlikView Management Service API
Report Class
Members See Also Send Feedback
Represents a document report.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public class Report
Visual Basic
Public Class Report

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Document..::..Report

See Also

Report Members
PIX.QMSAPI.DataObjects.Document Namespace


Report Members

[image] [image]

QlikView Management Service API
Report Members
Report Class Properties See Also Send Feedback

The Report type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID of the report.
Public property | Name | The name of the report.

See Also

Report Class
PIX.QMSAPI.DataObjects.Document Namespace


Report Properties

[image] [image]

QlikView Management Service API
Report Properties
Report Class See Also Send Feedback

The Report type exposes the following members.

Properties

 | Name | Description
Public property | ID | The ID of the report.
Public property | Name | The name of the report.

See Also

Report Class
PIX.QMSAPI.DataObjects.Document Namespace


ID Property

[image]

QlikView Management Service API
Report..::..ID Property
Report Class See Also Send Feedback
The ID of the report.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public string ID { get; private set; }
Visual Basic
Public Property ID As String
    Get
    Private Set

See Also

Report Class
PIX.QMSAPI.DataObjects.Document Namespace


Name Property

[image]

QlikView Management Service API
Report..::..Name Property
Report Class See Also Send Feedback
The name of the report.

Namespace: PIX.QMSAPI.DataObjects.Document

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

Report Class
PIX.QMSAPI.DataObjects.Document Namespace


PIX.QMSAPI.DataObjects.Enums Namespace

[image]

QlikView Management Service API
PIX.QMSAPI.DataObjects.Enums Namespace
Send Feedback
Contains the enums used by the QMSAPI.

Enumerations

 | Enumeration | Description
Public enumeration | AuthenticationMethod | Represents the various authentication methods available.
Public enumeration | CategoriesScope | Represents the scope when retrieving categories.
Public enumeration | CPUPriority | Represents the various CPU priority levels available.
Public enumeration | DocumentClearOptions | These flags are used to define the behavior when removing selections from a document.
Public enumeration | DocumentDownloadAccess | Represents the download access levels.
Public enumeration | DocumentState | Represents the various document states used when creating a new QDSDocumentSession.
Public enumeration | EnabledState |
Public enumeration | FieldContentType | Represents the types of values that a FieldContent contains.
Public enumeration | FieldValueState | Represents the various field value states available.
Public enumeration | LicenseType | Represents the supported license types.
Public enumeration | LogLevel | Log levels used by a Distribution Service.
Public enumeration | QDSSettingsScope | The different available scopes for a QDSSettings object. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | QueryTarget | Represents if you access a QVS as a single node or as a member of a cluster.
Public enumeration | SectionAccessScope | This enum is used to control the behavior when retrieving a SectionAccessTable.
Public enumeration | ServiceComposition | The different compositions a service can have. Single - The service can pnly have one member. Cluster - The service can have multiple members.
Public enumeration | ServiceStatusFlag | These are the possible states a service can have. It is a flag which implies that a service could have multiple states.
Public enumeration | UserRestriction |


AuthenticationMethod Enumeration

[image]

QlikView Management Service API
AuthenticationMethod Enumeration
See Also Send Feedback
Represents the various authentication methods available.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
[FlagsAttribute]
public enum AuthenticationMethod
Visual Basic
<FlagsAttribute> _
Public Enumeration AuthenticationMethod

Members

Member name | Value | Description
None | 0 |
Anonymous | 1 |
UserNameAndPassword | 2 |
UseQDSAccount | 4 |

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


CategoriesScope Enumeration

[image]

QlikView Management Service API
CategoriesScope Enumeration
See Also Send Feedback
Represents the scope when retrieving categories.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum CategoriesScope
Visual Basic
Public Enumeration CategoriesScope

Members

Member name | Value | Description
All | 0 | All categories will be retrieved.
Used | 1 | Only currently used categories will be retrieved.

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


CPUPriority Enumeration

[image]

QlikView Management Service API
CPUPriority Enumeration
See Also Send Feedback
Represents the various CPU priority levels available.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum CPUPriority
Visual Basic
Public Enumeration CPUPriority

Members

Member name | Value | Description
High | 0 |
Normal | 1 |
Low | 2 |

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


DocumentClearOptions Enumeration

[image]

QlikView Management Service API
DocumentClearOptions Enumeration
See Also Send Feedback
These flags are used to define the behavior when removing selections from a document.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
[FlagsAttribute]
public enum DocumentClearOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration DocumentClearOptions

Members

Member name | Value | Description
UnlockAll | 1 | Unlocks all locked selections.
ClearSelectionsWithUnlockBefore | 2 | Fields are unlocked before they are cleared.
ClearSelections | 4 | Clear all unlocked selections.
ClearAllOneAndAlwaysOne | 8 |

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


DocumentDownloadAccess Enumeration

[image]

QlikView Management Service API
DocumentDownloadAccess Enumeration
See Also Send Feedback
Represents the download access levels.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum DocumentDownloadAccess
Visual Basic
Public Enumeration DocumentDownloadAccess

Members

Member name | Value | Description
All | 0 | All users can download this document.
Restricted | 1 | Only some users can download this document.
None | 2 | No user can download this document.

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


DocumentState Enumeration

[image]

QlikView Management Service API
DocumentState Enumeration
See Also Send Feedback
Represents the various document states used when creating a new QDSDocumentSession.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum DocumentState
Visual Basic
Public Enumeration DocumentState

Members

Member name | Value | Description
NoAttemptToOpenHasBeenMade | 1 |
OpenedSuccessfully | 2 |
CouldNotOpenDocument | 3 |
CouldNotGetSlot | 4 |
Closed | 5 |
OtherError | 6 |

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


EnabledState Enumeration

[image]

QlikView Management Service API
EnabledState Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.Enums.EnabledState"]

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum EnabledState
Visual Basic
Public Enumeration EnabledState

Members

Member name | Value | Description
Any | 0 |
Enabled | 1 |
Disabled | 2 |

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


FieldContentType Enumeration

[image]

QlikView Management Service API
FieldContentType Enumeration
See Also Send Feedback
Represents the types of values that a FieldContent contains.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum FieldContentType
Visual Basic
Public Enumeration FieldContentType

Members

Member name | Value | Description
All | 0 | All field values
CurrentSelections | 1 | The currently selected fields values.

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


FieldValueState Enumeration

[image]

QlikView Management Service API
FieldValueState Enumeration
See Also Send Feedback
Represents the various field value states available.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
[FlagsAttribute]
public enum FieldValueState
Visual Basic
<FlagsAttribute> _
Public Enumeration FieldValueState

Members

Member name | Value | Description
InternalUnknown | 1 |
Selected | 2 | Green values (Selected)
Optional | 4 | White values (Not selected, but possible to select within the current total selections)
Excluded | 8 | Grey values (Not selected, and not possible to select within the current selections)
Locked | 16 | Locked
Alternative | 32 | White values (Not selected, but possible to select within the current total selections)
Deselected | 64 | Items that was not selectable (for AddSelections)
InternalSelectedExcluded | 10 | Grey values (selected excluded)
All | 127 | All values, regardless of their state

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


LicenseType Enumeration

[image]

QlikView Management Service API
LicenseType Enumeration
See Also Send Feedback
Represents the supported license types.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum LicenseType
Visual Basic
Public Enumeration LicenseType

Members

Member name | Value | Description
None | 0 | The default value. It does not have the EnumMember attribute since this value should not be serialized.
Publisher | 1 | A QlikView Publisher license type.
QlikViewServer | 2 | A QlikViewServer license type.

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


LogLevel Enumeration

[image]

QlikView Management Service API
LogLevel Enumeration
See Also Send Feedback
Log levels used by a Distribution Service.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum LogLevel
Visual Basic
Public Enumeration LogLevel

Members

Member name | Value | Description
None | 0 |
Normal | 1 |
Debug | 2 |

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


QDSSettingsScope Enumeration

[image]

QlikView Management Service API
QDSSettingsScope Enumeration
See Also Send Feedback
The different available scopes for a QDSSettings object.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
[FlagsAttribute]
public enum QDSSettingsScope
Visual Basic
<FlagsAttribute> _
Public Enumeration QDSSettingsScope

Members

Member name | Value | Description
None | 0 | No scope specified.
General | 1 | Represents general settings, such as data folder, cluster members and log level, and corresponds to General.
Email | 2 | Represents email settings, such as templates and alert receivers, and corresponds to Email.
Login | 4 | Represents login settings and corresponds to Login.
Advanced | 8 | Represents advanced settings, such as CPU and QVB configurations, and corresponds to Advanced.
All | 65535 | Full scope. Represents all settings.

See Also

PIX.QMSAPI.DataObjects.Enums Namespace
PIX.QMSAPI.DataObjects..::..QVSSettings


QueryTarget Enumeration

[image]

QlikView Management Service API
QueryTarget Enumeration
See Also Send Feedback
Represents if you access a QVS as a single node or as a member of a cluster.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
[FlagsAttribute]
public enum QueryTarget
Visual Basic
<FlagsAttribute> _
Public Enumeration QueryTarget

Members

Member name | Value | Description
Resource | 0 |
ClusterMember | 1 |

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


SectionAccessScope Enumeration

[image]

QlikView Management Service API
SectionAccessScope Enumeration
See Also Send Feedback
This enum is used to control the behavior when retrieving a SectionAccessTable.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum SectionAccessScope
Visual Basic
Public Enumeration SectionAccessScope

Members

Member name | Value | Description
None | 0 | Minimal information is retrieved, no information about columns or data.
IncludeColumns | 1 | Information about the columns are included.
IncludeData | 2 | All data rows are included.

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


ServiceComposition Enumeration

[image]

QlikView Management Service API
ServiceComposition Enumeration
See Also Send Feedback
The different compositions a service can have. Single - The service can pnly have one member. Cluster - The service can have multiple members.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum ServiceComposition
Visual Basic
Public Enumeration ServiceComposition

Members

Member name | Value | Description
None | 0 | The default value. It does not have the EnumMember attribute since this value should not be serialized.
Single | 1 | The service can only have one single member.
Cluster | 2 | The service can contain one or more members, working as a cluser.

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


ServiceStatusFlag Enumeration

[image]

QlikView Management Service API
ServiceStatusFlag Enumeration
See Also Send Feedback
These are the possible states a service can have. It is a flag which implies that a service could have multiple states.

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
[FlagsAttribute]
public enum ServiceStatusFlag
Visual Basic
<FlagsAttribute> _
Public Enumeration ServiceStatusFlag

Members

Member name | Value | Description
None | 0 | No flags specified.
OK | 1 | The services is online and fully functional.
OffDuty | 2 | The service is not active.
CouldNotContact | 4 | Unable to contact the service.
RestartNeeded | 8 | The services needs to be restarted.
Unlicensed | 16 | The service is not licensed.
QVPRUnavailable | 32 | The QlikView Publisher is not available.
StartupFailed | 64 | The service failed to start.
LEFInvalid | 128 | The LEF (License Enabler File) is invalid.
Initializing | 256 | The status is initializing.

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


UserRestriction Enumeration

[image]

QlikView Management Service API
UserRestriction Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:PIX.QMSAPI.DataObjects.Enums.UserRestriction"]

Namespace: PIX.QMSAPI.DataObjects.Enums

Syntax

C#
public enum UserRestriction
Visual Basic
Public Enumeration UserRestriction

Members

Member name | Value | Description
All | 0 |
List | 1 |
None | 2 |

See Also

PIX.QMSAPI.DataObjects.Enums Namespace


PIX.QMSAPI.DataObjects.Triggers Namespace

[image]

QlikView Management Service API
PIX.QMSAPI.DataObjects.Triggers Namespace
Send Feedback
Contains trigger specific classes.

Classes

 | Class | Description
Public class | ExternalEventTrigger | Represents an externally triggered event.
Public class | MultipleEventTrigger | Represents a trigger which can fire multiple triggers.
Public class | RecurrenceTrigger | Represents a trigger, executing on a regular basis.
Public class | RecurrenceTrigger..::..RecurrenceTriggerDaily | Represents a trigger which is executed on an daily basis.
Public class | RecurrenceTrigger..::..RecurrenceTriggerHourly | Represents a trigger which is executed on an hourly basis.
Public class | RecurrenceTrigger..::..RecurrenceTriggerMonthly | Represents a trigger which is executed on an monthly basis.
Public class | RecurrenceTrigger..::..RecurrenceTriggerWeekly | Represents a trigger which is executed on an weekly basis.
Public class | ScheduleTrigger | Represents a scheduled trigger.
Public class | TaskEventTrigger | Represents a trigger which is executed when a task has finished.
Public class | Trigger | A base class used by all different triggers.


ExternalEventTrigger Class

[image]

QlikView Management Service API
ExternalEventTrigger Class
Members See Also Send Feedback
Represents an externally triggered event.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class ExternalEventTrigger : Trigger
Visual Basic
Public Class ExternalEventTrigger _
    Inherits Trigger

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..Trigger
PIX.QMSAPI.DataObjects.Triggers..::..ExternalEventTrigger

See Also

ExternalEventTrigger Members
PIX.QMSAPI.DataObjects.Triggers Namespace


ExternalEventTrigger Members

[image] [image]

QlikView Management Service API
ExternalEventTrigger Members
ExternalEventTrigger Class Properties See Also Send Feedback

The ExternalEventTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | Password | The password to be used for triggering this event.
Public property | Type | The type of the trigger. (Inherited from Trigger.)

See Also

ExternalEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


ExternalEventTrigger Properties

[image] [image]

QlikView Management Service API
ExternalEventTrigger Properties
ExternalEventTrigger Class See Also Send Feedback

The ExternalEventTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | Password | The password to be used for triggering this event.
Public property | Type | The type of the trigger. (Inherited from Trigger.)

See Also

ExternalEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Password Property

[image]

QlikView Management Service API
ExternalEventTrigger..::..Password Property
ExternalEventTrigger Class See Also Send Feedback
The password to be used for triggering this event.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set

See Also

ExternalEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


MultipleEventTrigger Class

[image]

QlikView Management Service API
MultipleEventTrigger Class
Members See Also Send Feedback
Represents a trigger which can fire multiple triggers.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class MultipleEventTrigger : Trigger
Visual Basic
Public Class MultipleEventTrigger _
    Inherits Trigger

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..Trigger
PIX.QMSAPI.DataObjects.Triggers..::..MultipleEventTrigger

See Also

MultipleEventTrigger Members
PIX.QMSAPI.DataObjects.Triggers Namespace


MultipleEventTrigger Members

[image] [image]

QlikView Management Service API
MultipleEventTrigger Members
MultipleEventTrigger Class Properties See Also Send Feedback

The MultipleEventTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | SubTriggers | A list of triggers to execute.
Public property | TimeConstraint | The time in seconds after which the sub triggers will be executed.
Public property | Type | The type of the trigger. (Inherited from Trigger.)

See Also

MultipleEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


MultipleEventTrigger Properties

[image] [image]

QlikView Management Service API
MultipleEventTrigger Properties
MultipleEventTrigger Class See Also Send Feedback

The MultipleEventTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | SubTriggers | A list of triggers to execute.
Public property | TimeConstraint | The time in seconds after which the sub triggers will be executed.
Public property | Type | The type of the trigger. (Inherited from Trigger.)

See Also

MultipleEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


SubTriggers Property

[image]

QlikView Management Service API
MultipleEventTrigger..::..SubTriggers Property
MultipleEventTrigger Class See Also Send Feedback
A list of triggers to execute.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public List<Trigger> SubTriggers { get; private set; }
Visual Basic
Public Property SubTriggers As List(Of Trigger)
    Get
    Private Set

See Also

MultipleEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


TimeConstraint Property

[image]

QlikView Management Service API
MultipleEventTrigger..::..TimeConstraint Property
MultipleEventTrigger Class See Also Send Feedback
The time in seconds after which the sub triggers will be executed.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public int TimeConstraint { get; set; }
Visual Basic
Public Property TimeConstraint As Integer
    Get
    Set

See Also

MultipleEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger Class

[image]

QlikView Management Service API
RecurrenceTrigger Class
Members See Also Send Feedback
Represents a trigger, executing on a regular basis.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class RecurrenceTrigger : ScheduleTrigger
Visual Basic
Public Class RecurrenceTrigger _
    Inherits ScheduleTrigger

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..Trigger
PIX.QMSAPI.DataObjects.Triggers..::..ScheduleTrigger
PIX.QMSAPI.DataObjects.Triggers..::..RecurrenceTrigger

See Also

RecurrenceTrigger Members
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger Members

[image] [image]

QlikView Management Service API
RecurrenceTrigger Members
RecurrenceTrigger Class Properties See Also Send Feedback

The RecurrenceTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Daily | Used for triggers executing every day.
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ExpireAt | Specifies when the trigger expires.
Public property | Hourly | Used for triggers executing every hour.
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | MaxOccurrences | Specifies how manyh times the trigger should execute.
Public property | Monthly | Used for triggers executing every month.
Public property | StartAt | When to start the trigger. (Inherited from ScheduleTrigger.)
Public property | Type | The type of the trigger. (Overrides Trigger..::..Type.)
Public property | Weekly | Used for triggers executing every week.

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger Properties

[image] [image]

QlikView Management Service API
RecurrenceTrigger Properties
RecurrenceTrigger Class See Also Send Feedback

The RecurrenceTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Daily | Used for triggers executing every day.
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ExpireAt | Specifies when the trigger expires.
Public property | Hourly | Used for triggers executing every hour.
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | MaxOccurrences | Specifies how manyh times the trigger should execute.
Public property | Monthly | Used for triggers executing every month.
Public property | StartAt | When to start the trigger. (Inherited from ScheduleTrigger.)
Public property | Type | The type of the trigger. (Overrides Trigger..::..Type.)
Public property | Weekly | Used for triggers executing every week.

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Daily Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..Daily Property
RecurrenceTrigger Class See Also Send Feedback
Used for triggers executing every day.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public RecurrenceTrigger..::..RecurrenceTriggerDaily Daily { get; private set; }
Visual Basic
Public Property Daily As RecurrenceTrigger..::..RecurrenceTriggerDaily
    Get
    Private Set

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


ExpireAt Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..ExpireAt Property
RecurrenceTrigger Class See Also Send Feedback
Specifies when the trigger expires.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public DateTime ExpireAt { get; set; }
Visual Basic
Public Property ExpireAt As DateTime
    Get
    Set

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Hourly Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..Hourly Property
RecurrenceTrigger Class See Also Send Feedback
Used for triggers executing every hour.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public RecurrenceTrigger..::..RecurrenceTriggerHourly Hourly { get; private set; }
Visual Basic
Public Property Hourly As RecurrenceTrigger..::..RecurrenceTriggerHourly
    Get
    Private Set

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


MaxOccurrences Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..MaxOccurrences Property
RecurrenceTrigger Class See Also Send Feedback
Specifies how manyh times the trigger should execute.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public int MaxOccurrences { get; set; }
Visual Basic
Public Property MaxOccurrences As Integer
    Get
    Set

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Monthly Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..Monthly Property
RecurrenceTrigger Class See Also Send Feedback
Used for triggers executing every month.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public RecurrenceTrigger..::..RecurrenceTriggerMonthly Monthly { get; private set; }
Visual Basic
Public Property Monthly As RecurrenceTrigger..::..RecurrenceTriggerMonthly
    Get
    Private Set

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Type Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..Type Property
RecurrenceTrigger Class See Also Send Feedback
The type of the trigger.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public override TaskTriggerType Type { get; set; }
Visual Basic
Public Overrides Property Type As TaskTriggerType
    Get
    Set

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Weekly Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..Weekly Property
RecurrenceTrigger Class See Also Send Feedback
Used for triggers executing every week.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public RecurrenceTrigger..::..RecurrenceTriggerWeekly Weekly { get; private set; }
Visual Basic
Public Property Weekly As RecurrenceTrigger..::..RecurrenceTriggerWeekly
    Get
    Private Set

See Also

RecurrenceTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerDaily Class

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerDaily Class
RecurrenceTrigger Class Members See Also Send Feedback
Represents a trigger which is executed on an daily basis.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class RecurrenceTriggerDaily
Visual Basic
Public Class RecurrenceTriggerDaily

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..RecurrenceTrigger..::..RecurrenceTriggerDaily

See Also

RecurrenceTrigger..::..RecurrenceTriggerDaily Members
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerDaily Members

[image] [image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerDaily Members
RecurrenceTrigger..::..RecurrenceTriggerDaily Class Properties See Also Send Feedback

Represents a trigger, executing on a regular basis.

The RecurrenceTrigger..::..RecurrenceTriggerDaily type exposes the following members.

Properties

 | Name | Description
Public property | RecurEvery | How many days to wait until triggered again.

See Also

RecurrenceTrigger..::..RecurrenceTriggerDaily Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerDaily Properties

[image] [image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerDaily Properties
RecurrenceTrigger..::..RecurrenceTriggerDaily Class See Also Send Feedback

The RecurrenceTrigger..::..RecurrenceTriggerDaily type exposes the following members.

Properties

 | Name | Description
Public property | RecurEvery | How many days to wait until triggered again.

See Also

RecurrenceTrigger..::..RecurrenceTriggerDaily Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurEvery Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerDaily..::..RecurEvery Property
RecurrenceTrigger..::..RecurrenceTriggerDaily Class See Also Send Feedback
How many days to wait until triggered again.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public int RecurEvery { get; set; }
Visual Basic
Public Property RecurEvery As Integer
    Get
    Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerDaily Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerHourly Class

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerHourly Class
RecurrenceTrigger Class Members See Also Send Feedback
Represents a trigger which is executed on an hourly basis.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class RecurrenceTriggerHourly
Visual Basic
Public Class RecurrenceTriggerHourly

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..RecurrenceTrigger..::..RecurrenceTriggerHourly

See Also

RecurrenceTrigger..::..RecurrenceTriggerHourly Members
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerHourly Members

[image] [image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerHourly Members
RecurrenceTrigger..::..RecurrenceTriggerHourly Class Properties See Also Send Feedback

Represents a trigger, executing on a regular basis.

The RecurrenceTrigger..::..RecurrenceTriggerHourly type exposes the following members.

Properties

 | Name | Description
Public property | DayOfWeekConstraints | Which days of the week the trigger should be active,
Public property | RecurEvery | How many minutes to wait until the next execution.
Public property | TimeConstraintFrom | When the trigger should start.
Public property | TimeConstraintTo | When the trigger should stop.

See Also

RecurrenceTrigger..::..RecurrenceTriggerHourly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerHourly Properties

[image] [image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerHourly Properties
RecurrenceTrigger..::..RecurrenceTriggerHourly Class See Also Send Feedback

The RecurrenceTrigger..::..RecurrenceTriggerHourly type exposes the following members.

Properties

 | Name | Description
Public property | DayOfWeekConstraints | Which days of the week the trigger should be active,
Public property | RecurEvery | How many minutes to wait until the next execution.
Public property | TimeConstraintFrom | When the trigger should start.
Public property | TimeConstraintTo | When the trigger should stop.

See Also

RecurrenceTrigger..::..RecurrenceTriggerHourly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


DayOfWeekConstraints Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerHourly..::..DayOfWeekConstraints Property
RecurrenceTrigger..::..RecurrenceTriggerHourly Class See Also Send Feedback
Which days of the week the trigger should be active,

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public List<DayOfWeek> DayOfWeekConstraints { get; private set; }
Visual Basic
Public Property DayOfWeekConstraints As List(Of DayOfWeek)
    Get
    Private Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerHourly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurEvery Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerHourly..::..RecurEvery Property
RecurrenceTrigger..::..RecurrenceTriggerHourly Class See Also Send Feedback
How many minutes to wait until the next execution.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public int RecurEvery { get; set; }
Visual Basic
Public Property RecurEvery As Integer
    Get
    Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerHourly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


TimeConstraintFrom Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerHourly..::..TimeConstraintFrom Property
RecurrenceTrigger..::..RecurrenceTriggerHourly Class See Also Send Feedback
When the trigger should start.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public DateTime TimeConstraintFrom { get; set; }
Visual Basic
Public Property TimeConstraintFrom As DateTime
    Get
    Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerHourly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


TimeConstraintTo Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerHourly..::..TimeConstraintTo Property
RecurrenceTrigger..::..RecurrenceTriggerHourly Class See Also Send Feedback
When the trigger should stop.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public DateTime TimeConstraintTo { get; set; }
Visual Basic
Public Property TimeConstraintTo As DateTime
    Get
    Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerHourly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerMonthly Class

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerMonthly Class
RecurrenceTrigger Class Members See Also Send Feedback
Represents a trigger which is executed on an monthly basis.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class RecurrenceTriggerMonthly
Visual Basic
Public Class RecurrenceTriggerMonthly

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..RecurrenceTrigger..::..RecurrenceTriggerMonthly

See Also

RecurrenceTrigger..::..RecurrenceTriggerMonthly Members
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerMonthly Members

[image] [image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerMonthly Members
RecurrenceTrigger..::..RecurrenceTriggerMonthly Class Properties See Also Send Feedback

Represents a trigger, executing on a regular basis.

The RecurrenceTrigger..::..RecurrenceTriggerMonthly type exposes the following members.

Properties

 | Name | Description
Public property | DayConstraints | The days to execute the trigger.
Public property | DayOfWeekConstraints | Which week days the trigger can be executed on.
Public property | Months | Which months the trigger is active.
Public property | Occurrences | How many times the trigger is executed.

See Also

RecurrenceTrigger..::..RecurrenceTriggerMonthly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerMonthly Properties

[image] [image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerMonthly Properties
RecurrenceTrigger..::..RecurrenceTriggerMonthly Class See Also Send Feedback

The RecurrenceTrigger..::..RecurrenceTriggerMonthly type exposes the following members.

Properties

 | Name | Description
Public property | DayConstraints | The days to execute the trigger.
Public property | DayOfWeekConstraints | Which week days the trigger can be executed on.
Public property | Months | Which months the trigger is active.
Public property | Occurrences | How many times the trigger is executed.

See Also

RecurrenceTrigger..::..RecurrenceTriggerMonthly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


DayConstraints Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerMonthly..::..DayConstraints Property
RecurrenceTrigger..::..RecurrenceTriggerMonthly Class See Also Send Feedback
The days to execute the trigger.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public List<int> DayConstraints { get; private set; }
Visual Basic
Public Property DayConstraints As List(Of Integer)
    Get
    Private Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerMonthly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


DayOfWeekConstraints Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerMonthly..::..DayOfWeekConstraints Property
RecurrenceTrigger..::..RecurrenceTriggerMonthly Class See Also Send Feedback
Which week days the trigger can be executed on.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public List<DayOfWeek> DayOfWeekConstraints { get; private set; }
Visual Basic
Public Property DayOfWeekConstraints As List(Of DayOfWeek)
    Get
    Private Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerMonthly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Months Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerMonthly..::..Months Property
RecurrenceTrigger..::..RecurrenceTriggerMonthly Class See Also Send Feedback
Which months the trigger is active.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public List<int> Months { get; private set; }
Visual Basic
Public Property Months As List(Of Integer)
    Get
    Private Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerMonthly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Occurrences Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerMonthly..::..Occurrences Property
RecurrenceTrigger..::..RecurrenceTriggerMonthly Class See Also Send Feedback
How many times the trigger is executed.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public List<int> Occurrences { get; private set; }
Visual Basic
Public Property Occurrences As List(Of Integer)
    Get
    Private Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerMonthly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerWeekly Class

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerWeekly Class
RecurrenceTrigger Class Members See Also Send Feedback
Represents a trigger which is executed on an weekly basis.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class RecurrenceTriggerWeekly
Visual Basic
Public Class RecurrenceTriggerWeekly

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..RecurrenceTrigger..::..RecurrenceTriggerWeekly

See Also

RecurrenceTrigger..::..RecurrenceTriggerWeekly Members
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerWeekly Members

[image] [image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerWeekly Members
RecurrenceTrigger..::..RecurrenceTriggerWeekly Class Properties See Also Send Feedback

Represents a trigger, executing on a regular basis.

The RecurrenceTrigger..::..RecurrenceTriggerWeekly type exposes the following members.

Properties

 | Name | Description
Public property | DayOfWeekConstraints | Which days of the week of which the trigger is active.
Public property | RecurEvery | How many days to wait until triggered again.

See Also

RecurrenceTrigger..::..RecurrenceTriggerWeekly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurrenceTrigger.RecurrenceTriggerWeekly Properties

[image] [image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerWeekly Properties
RecurrenceTrigger..::..RecurrenceTriggerWeekly Class See Also Send Feedback

The RecurrenceTrigger..::..RecurrenceTriggerWeekly type exposes the following members.

Properties

 | Name | Description
Public property | DayOfWeekConstraints | Which days of the week of which the trigger is active.
Public property | RecurEvery | How many days to wait until triggered again.

See Also

RecurrenceTrigger..::..RecurrenceTriggerWeekly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


DayOfWeekConstraints Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerWeekly..::..DayOfWeekConstraints Property
RecurrenceTrigger..::..RecurrenceTriggerWeekly Class See Also Send Feedback
Which days of the week of which the trigger is active.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public List<DayOfWeek> DayOfWeekConstraints { get; private set; }
Visual Basic
Public Property DayOfWeekConstraints As List(Of DayOfWeek)
    Get
    Private Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerWeekly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


RecurEvery Property

[image]

QlikView Management Service API
RecurrenceTrigger..::..RecurrenceTriggerWeekly..::..RecurEvery Property
RecurrenceTrigger..::..RecurrenceTriggerWeekly Class See Also Send Feedback
How many days to wait until triggered again.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public int RecurEvery { get; set; }
Visual Basic
Public Property RecurEvery As Integer
    Get
    Set

See Also

RecurrenceTrigger..::..RecurrenceTriggerWeekly Class
PIX.QMSAPI.DataObjects.Triggers Namespace


ScheduleTrigger Class

[image]

QlikView Management Service API
ScheduleTrigger Class
Members See Also Send Feedback
Represents a scheduled trigger.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class ScheduleTrigger : Trigger
Visual Basic
Public Class ScheduleTrigger _
    Inherits Trigger

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..Trigger
PIX.QMSAPI.DataObjects.Triggers..::..ScheduleTrigger
PIX.QMSAPI.DataObjects.Triggers..::..RecurrenceTrigger

See Also

ScheduleTrigger Members
PIX.QMSAPI.DataObjects.Triggers Namespace


ScheduleTrigger Members

[image] [image]

QlikView Management Service API
ScheduleTrigger Members
ScheduleTrigger Class Properties See Also Send Feedback

The ScheduleTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | StartAt | When to start the trigger.
Public property | Type | The type of the trigger. (Inherited from Trigger.)

See Also

ScheduleTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


ScheduleTrigger Properties

[image] [image]

QlikView Management Service API
ScheduleTrigger Properties
ScheduleTrigger Class See Also Send Feedback

The ScheduleTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | StartAt | When to start the trigger.
Public property | Type | The type of the trigger. (Inherited from Trigger.)

See Also

ScheduleTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


StartAt Property

[image]

QlikView Management Service API
ScheduleTrigger..::..StartAt Property
ScheduleTrigger Class See Also Send Feedback
When to start the trigger.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public DateTime StartAt { get; set; }
Visual Basic
Public Property StartAt As DateTime
    Get
    Set

See Also

ScheduleTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


TaskEventTrigger Class

[image]

QlikView Management Service API
TaskEventTrigger Class
Members See Also Send Feedback
Represents a trigger which is executed when a task has finished.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class TaskEventTrigger : Trigger
Visual Basic
Public Class TaskEventTrigger _
    Inherits Trigger

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..Trigger
PIX.QMSAPI.DataObjects.Triggers..::..TaskEventTrigger

See Also

TaskEventTrigger Members
PIX.QMSAPI.DataObjects.Triggers Namespace


TaskEventTrigger Members

[image] [image]

QlikView Management Service API
TaskEventTrigger Members
TaskEventTrigger Class Properties See Also Send Feedback

The TaskEventTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | TaskID | The ID of the task.
Public property | Type | The type of the trigger. (Inherited from Trigger.)

See Also

TaskEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


TaskEventTrigger Properties

[image] [image]

QlikView Management Service API
TaskEventTrigger Properties
TaskEventTrigger Class See Also Send Feedback

The TaskEventTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not. (Inherited from Trigger.)
Public property | ID | The ID of the trigger. (Inherited from Trigger.)
Public property | TaskID | The ID of the task.
Public property | Type | The type of the trigger. (Inherited from Trigger.)

See Also

TaskEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


TaskID Property

[image]

QlikView Management Service API
TaskEventTrigger..::..TaskID Property
TaskEventTrigger Class See Also Send Feedback
The ID of the task.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public Guid TaskID { get; set; }
Visual Basic
Public Property TaskID As Guid
    Get
    Set

See Also

TaskEventTrigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Trigger Class

[image]

QlikView Management Service API
Trigger Class
Members See Also Send Feedback
A base class used by all different triggers.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public class Trigger
Visual Basic
Public Class Trigger

Inheritance Hierarchy

System..::..Object
PIX.QMSAPI.DataObjects.Triggers..::..Trigger
PIX.QMSAPI.DataObjects.Triggers..::..ExternalEventTrigger
PIX.QMSAPI.DataObjects.Triggers..::..MultipleEventTrigger
PIX.QMSAPI.DataObjects.Triggers..::..ScheduleTrigger
PIX.QMSAPI.DataObjects.Triggers..::..TaskEventTrigger

See Also

Trigger Members
PIX.QMSAPI.DataObjects.Triggers Namespace


Trigger Members

[image] [image]

QlikView Management Service API
Trigger Members
Trigger Class Properties See Also Send Feedback

The Trigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not.
Public property | ID | The ID of the trigger.
Public property | Type | The type of the trigger.

See Also

Trigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Trigger Properties

[image] [image]

QlikView Management Service API
Trigger Properties
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | A flag indicating whether the trigger is enabled or not.
Public property | ID | The ID of the trigger.
Public property | Type | The type of the trigger.

See Also

Trigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Enabled Property

[image]

QlikView Management Service API
Trigger..::..Enabled Property
Trigger Class See Also Send Feedback
A flag indicating whether the trigger is enabled or not.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

See Also

Trigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


ID Property

[image]

QlikView Management Service API
Trigger..::..ID Property
Trigger Class See Also Send Feedback
The ID of the trigger.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public Guid ID { get; set; }
Visual Basic
Public Property ID As Guid
    Get
    Set

See Also

Trigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


Type Property

[image]

QlikView Management Service API
Trigger..::..Type Property
Trigger Class See Also Send Feedback
The type of the trigger.

Namespace: PIX.QMSAPI.DataObjects.Triggers

Syntax

C#
public virtual TaskTriggerType Type { get; set; }
Visual Basic
Public Overridable Property Type As TaskTriggerType
    Get
    Set

See Also

Trigger Class
PIX.QMSAPI.DataObjects.Triggers Namespace


PIX.QMSAPI.Exceptions Namespace

[image]

QlikView Management Service API
PIX.QMSAPI.Exceptions Namespace
Send Feedback
Contains exceptions defined by the QMSAPI.

Classes

 | Class | Description
Public class | AlertException | Used for alert messages which should be displayed to the end user.
Public class | DataValidationException | Represents the result of a failed validation.


AlertException Class

[image]

QlikView Management Service API
AlertException Class
Members See Also Send Feedback
Used for alert messages which should be displayed to the end user.

Namespace: PIX.QMSAPI.Exceptions

Syntax

C#
public class AlertException : Exception
Visual Basic
Public Class AlertException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
PIX.QMSAPI.Exceptions..::..AlertException

See Also

AlertException Members
PIX.QMSAPI.Exceptions Namespace


AlertException Members

[image] [image]

QlikView Management Service API
AlertException Members
AlertException Class Methods Properties Events See Also Send Feedback

The AlertException type exposes the following members.

Methods

 | Name | Description
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

AlertException Class
PIX.QMSAPI.Exceptions Namespace


AlertException Methods

[image] [image]

QlikView Management Service API
AlertException Methods
AlertException Class See Also Send Feedback

The AlertException type exposes the following members.

Methods

 | Name | Description
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AlertException Class
PIX.QMSAPI.Exceptions Namespace


AlertException Properties

[image] [image]

QlikView Management Service API
AlertException Properties
AlertException Class See Also Send Feedback

The AlertException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AlertException Class
PIX.QMSAPI.Exceptions Namespace


AlertException Events

[image] [image]

QlikView Management Service API
AlertException Events
AlertException Class See Also Send Feedback

The AlertException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

AlertException Class
PIX.QMSAPI.Exceptions Namespace


DataValidationException Class

[image]

QlikView Management Service API
DataValidationException Class
Members See Also Send Feedback
Represents the result of a failed validation.

Namespace: PIX.QMSAPI.Exceptions

Syntax

C#
[SerializableAttribute]
public class DataValidationException : Exception
Visual Basic
<SerializableAttribute> _
Public Class DataValidationException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
PIX.QMSAPI.Exceptions..::..DataValidationException

See Also

DataValidationException Members
PIX.QMSAPI.Exceptions Namespace


DataValidationException Members

[image] [image]

QlikView Management Service API
DataValidationException Members
DataValidationException Class Methods Properties Events See Also Send Feedback

The DataValidationException type exposes the following members.

Methods

 | Name | Description
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | A summary of the validation. (Overrides Exception..::..Message.)
Public property | Messages | Validation messages.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValidatedType | The type that was validated.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DataValidationException Class
PIX.QMSAPI.Exceptions Namespace


DataValidationException Methods

[image] [image]

QlikView Management Service API
DataValidationException Methods
DataValidationException Class See Also Send Feedback

The DataValidationException type exposes the following members.

Methods

 | Name | Description
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DataValidationException Class
PIX.QMSAPI.Exceptions Namespace


DataValidationException Properties

[image] [image]

QlikView Management Service API
DataValidationException Properties
DataValidationException Class See Also Send Feedback

The DataValidationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | A summary of the validation. (Overrides Exception..::..Message.)
Public property | Messages | Validation messages.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValidatedType | The type that was validated.

See Also

DataValidationException Class
PIX.QMSAPI.Exceptions Namespace


Message Property

[image]

QlikView Management Service API
DataValidationException..::..Message Property
DataValidationException Class See Also Send Feedback
A summary of the validation.

Namespace: PIX.QMSAPI.Exceptions

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get

Implements

_Exception..::..Message

See Also

DataValidationException Class
PIX.QMSAPI.Exceptions Namespace


Messages Property

[image]

QlikView Management Service API
DataValidationException..::..Messages Property
DataValidationException Class See Also Send Feedback
Validation messages.

Namespace: PIX.QMSAPI.Exceptions

Syntax

C#
public List<string> Messages { get; private set; }
Visual Basic
Public Property Messages As List(Of String)
    Get
    Private Set

See Also

DataValidationException Class
PIX.QMSAPI.Exceptions Namespace


ValidatedType Property

[image]

QlikView Management Service API
DataValidationException..::..ValidatedType Property
DataValidationException Class See Also Send Feedback
The type that was validated.

Namespace: PIX.QMSAPI.Exceptions

Syntax

C#
public Type ValidatedType { get; set; }
Visual Basic
Public Property ValidatedType As Type
    Get
    Set

See Also

DataValidationException Class
PIX.QMSAPI.Exceptions Namespace


DataValidationException Events

[image] [image]

QlikView Management Service API
DataValidationException Events
DataValidationException Class See Also Send Feedback

The DataValidationException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DataValidationException Class
PIX.QMSAPI.Exceptions Namespace


PIX.Services Namespace

[image]

QlikView Management Service API
PIX.Services Namespace
Send Feedback
Contains the QMSAPI service definition.

Interfaces

 | Interface | Description
Public interface | IQMS | The QMS backend interface, hosting all of the available QlikView Management Service API methods.


IQMS Interface

[image]

QlikView Management Service API
IQMS Interface
Members See Also Send Feedback
The QMS backend interface, hosting all of the available QlikView Management Service API methods.

Namespace: PIX.Services

Syntax

C#
public interface IQMS
Visual Basic
Public Interface IQMS

See Also

IQMS Members
PIX.Services Namespace


IQMS Members

[image] [image]

QlikView Management Service API
IQMS Members
IQMS Interface Methods See Also Send Feedback

The IQMS type exposes the following members.

Methods

 | Name | Description
Public method | AbortTask | Aborts a single task.
Public method | AddSelections | Adds or toggles the currently selected fields within a document.
Public method | ClearLicense | Clears the license for a service. After this method has been called, the service will be unlicensed and might not be available until a new license has been applied. Only the QlikViewServer-license type is currently supported.
Public method | ClearQVSCache | Clears the QlikView Server cache of the QlikView Management Service from the specified cache objects.
Public method | ClearSelections | Clears or unlocks the selection of the specified field. If the field is empty, all fields will be cleared/unlocked.
Public method | CloseAndInstallExtensionObject | Finalizes the uploads. This involves verifying that the upload is a valid package and that the installation is successful.
Public method | CloseSession | Closes a previously opened session towards a document on a QDS server.
Public method | CreateSession | Creates a session towards a document on a QDS server.
Public method | DeleteSectionAccessTable | Removes a single SectionAccessTable.
Public method | DeleteServerObject | Removes a server object from a document.
Public method | DeleteTask | Deletes a single task.
Public method | FindEDX | Finds all matching EDX tasks.
Public method | FindTask | Finds a single task given its name.
Public method | GetAlertText | Returns a simple text message describing the current state of the QMS.
Public method | GetAvailableDirectories | Returns a list of available directory paths for a certain type of Directory Service Provider.
Public method | GetAvailableDSProviders | Returns the available Directory Service Providers supported by a certain Directory Service Connector.
Public method | GetCALConfiguration | Gets the current session/document and named CAL configuration from a QVS.
Public method | GetCALInfoForUser | Gets the licenses currently used by a certain user.
Public method | GetCategories | Returns all categories matching the given scope.
Public method | GetDocumentBookmarkNames | Retrieves a list of all document book marks defined in the document.
Public method | GetDocumentFolder | Gets the document folder with the specified ID.
Public method | GetDocumentMetaData | Gets the document metadata.
Public method | GetDocumentTask | Gets the document task. The scope parameter is used to define what information to retrieve about the task.
Public method | GetDSResources | Returns all Directory Services managed by a certain Directory Service Connector.
Public method | GetEDXTaskStatus | Gets the EDX task status.
Public method | GetFieldContentList | Retrieves the values for a specific field. It is possible to retrieve only the currently selected values or all values for the field.
Public method | GetFieldList | Retrieves all available fields from a document.
Public method | GetLicense | Retrieves the currently set license for a service.
Public method | GetQDSSettings | Retrieves the current settings for the QlikView Distribution service with the specified ID.
Public method | GetQVSDocumentsAndUsers | Gets each document loaded on the QVS and the users connected to each on respectively.
Public method | GetQVSDocumentsPerUser | Gets the number of documents each user on the QVS is connected to.
Public method | GetQVSPerformanceData | Gets QVS performance data.
Public method | GetQVSSettings | Gets settings for the QlikView Server with the specified ID.
Public method | GetQVSUtilizationData | Gets QVS utilization data.
Public method | GetReports | Retrieves reports defined within a document.
Public method | GetSectionAccessTable | Retrieves a single SectionAccessTable. The scope parameter is used to control how much information that should be included.
Public method | GetSectionAccessTableByName | Retrieves a SectionAccessTable by name.
Public method | GetSectionAccessTables | Retrieves all defined SectionAccessTable's. Each table contains information about its columns, but no table data is returned.
Public method | GetServerObjectMetaDataForUser | Retrieves a list of all ServerObjectMetaData objects from a QlikView Server, accessible to a certain user.
Public method | GetServerObjects | Retrieves a list of server objects from a document.
Public method | GetServices | Gets information about all registered services of the specified type.
Public method | GetServiceStatuses | Gets the status of all services which matches the provided list of service ID's.
Public method | GetSourceDocumentFolders | Gets all source document folders for the QlikView Distribution Service with the specified ID.
Public method | GetSourceDocumentNodes | Gets source document nodes for the specified relative path and the specified source document folder and QlikView Distribution Service ID.
Public method | GetSourceDocuments | Gets all source documents for the QlikView Distribution Service with the specified ID.
Public method | GetTask | Retrieves a single task using its id.
Public method | GetTasks | Retrieves all task from a QDS.
Public method | GetTasksForDocument | Gets the tasks for document.
Public method | GetTaskStatus | Gets the status of a task.
Public method | GetTaskStatuses | Gets the task statuses.
Public method | GetTaskStatusNodes | Gets the task status nodes.
Public method | GetTimeLimitedServiceKey | Gets a time limited service key.
Public method | GetUserDocumentFolders | Gets all user document folders for the QlikView Server with the specified ID.
Public method | GetUserDocumentNodes | Gets user document nodes for the specified relative path and the specified user document folder and QlikView Server ID.
Public method | GetUserDocuments | Gets all user documents for the QlikView Server with the specified ID.
Public method | ImportAllDocumentTasksForQds | Imports all document tasks from a remote QlikView Distribution Server.
Public method | ImportDocumentTask | Imports a single document task from a remote QlikView Distribution Server.
Public method | InitiateUploadExtensionObject | Initiates an new upload of an extension object.
Public method | IsPublisherQDS | This method checks if a QlikView Distribition Service has a publisher license or not.
Public method | LookupNames | Given a list of user or group names, this method performs a lookup of each name on a Directory Service Connector.
Public method | Ping | Pings this instance.
Public method | QDSNeedRestart | Sets that the QDS needs a restart.
Public method | QVSNeedRestart | Sets that the QVS needs a restart.
Public method | RemoteGetDocumentTask | Retrieves a single task from a remote QlikView Management Service.
Public method | RemoteGetServices | Retrieves information about services managed by a remote QlikView Management Console.
Public method | RemoteGetSourceDocumentFolders | Gets all source document folders for a QlikView Distribution Service, managed by a remote QlikView Management Service, with the specified ID.
Public method | RemoteGetSourceDocumentNodes | Connects to a remote QlikView Management Service and retrieves the source document nodes for the specified relative path and the specified source document folder and QlikView Distribution Service ID.
Public method | RemoteGetTaskListForDocID | Retrieves a list of all tasks for a specific document from a remote QlikView Management Service.
Public method | RemoteGetTasks | Retrieves all tasks from a remote QlikViewDistribution Service.
Public method | ResolveUserGroups | This method returns all groups that a certain user is a member of.
Public method | RestartQDS | Restarts the QDS.
Public method | RestartQVS | Restarts the QVS.
Public method | RunTask | Runs a single task.
Public method | SaveCALConfiguration | Saves the CAL configuration.
Public method | SaveDocumentMetaData | Saves the document metadata.
Public method | SaveDocumentTask | Saves the document task.
Public method | SaveLicense | Sets a license on a service. The license includes a LicenseType which is used together with the serviceID parameter to find the correct service.
Public method | SaveQDSSettings | Updates the settings for a certain QlikView Distribution service.
Public method | SaveQVSSettings | Saves the specified QlikView Server settings.
Public method | SaveSectionAccessTable | Saves a SectionAccessTable. If the table does not exist, it will be created. Otherwise it will be updated.
Public method | SendDistributionServiceWorkorder | Updates the configuration of a QlikView Distribution Service, includning task definitions.
Public method | ServiceHasValidLicense | Checks a service to see whether it has a valid license or not.
Public method | TakeServerObject | Changes the owner of a server object.
Public method | TriggerEDXTask | Triggers an EDX task.
Public method | UpdateLicense | Updates the service with the current license. This will refresh the license for all the members of the service.
Public method | ValidateLicense | Validates a license, making sure that the information that it contains is correct.
Public method | WriteExtensionObject | Uploads a piece of an extension object. The handle returned contains the current state of the upload.

See Also

IQMS Interface
PIX.Services Namespace


IQMS Methods

[image] [image]

QlikView Management Service API
IQMS Methods
IQMS Interface See Also Send Feedback

The IQMS type exposes the following members.

Methods

 | Name | Description
Public method | AbortTask | Aborts a single task.
Public method | AddSelections | Adds or toggles the currently selected fields within a document.
Public method | ClearLicense | Clears the license for a service. After this method has been called, the service will be unlicensed and might not be available until a new license has been applied. Only the QlikViewServer-license type is currently supported.
Public method | ClearQVSCache | Clears the QlikView Server cache of the QlikView Management Service from the specified cache objects.
Public method | ClearSelections | Clears or unlocks the selection of the specified field. If the field is empty, all fields will be cleared/unlocked.
Public method | CloseAndInstallExtensionObject | Finalizes the uploads. This involves verifying that the upload is a valid package and that the installation is successful.
Public method | CloseSession | Closes a previously opened session towards a document on a QDS server.
Public method | CreateSession | Creates a session towards a document on a QDS server.
Public method | DeleteSectionAccessTable | Removes a single SectionAccessTable.
Public method | DeleteServerObject | Removes a server object from a document.
Public method | DeleteTask | Deletes a single task.
Public method | FindEDX | Finds all matching EDX tasks.
Public method | FindTask | Finds a single task given its name.
Public method | GetAlertText | Returns a simple text message describing the current state of the QMS.
Public method | GetAvailableDirectories | Returns a list of available directory paths for a certain type of Directory Service Provider.
Public method | GetAvailableDSProviders | Returns the available Directory Service Providers supported by a certain Directory Service Connector.
Public method | GetCALConfiguration | Gets the current session/document and named CAL configuration from a QVS.
Public method | GetCALInfoForUser | Gets the licenses currently used by a certain user.
Public method | GetCategories | Returns all categories matching the given scope.
Public method | GetDocumentBookmarkNames | Retrieves a list of all document book marks defined in the document.
Public method | GetDocumentFolder | Gets the document folder with the specified ID.
Public method | GetDocumentMetaData | Gets the document metadata.
Public method | GetDocumentTask | Gets the document task. The scope parameter is used to define what information to retrieve about the task.
Public method | GetDSResources | Returns all Directory Services managed by a certain Directory Service Connector.
Public method | GetEDXTaskStatus | Gets the EDX task status.
Public method | GetFieldContentList | Retrieves the values for a specific field. It is possible to retrieve only the currently selected values or all values for the field.
Public method | GetFieldList | Retrieves all available fields from a document.
Public method | GetLicense | Retrieves the currently set license for a service.
Public method | GetQDSSettings | Retrieves the current settings for the QlikView Distribution service with the specified ID.
Public method | GetQVSDocumentsAndUsers | Gets each document loaded on the QVS and the users connected to each on respectively.
Public method | GetQVSDocumentsPerUser | Gets the number of documents each user on the QVS is connected to.
Public method | GetQVSPerformanceData | Gets QVS performance data.
Public method | GetQVSSettings | Gets settings for the QlikView Server with the specified ID.
Public method | GetQVSUtilizationData | Gets QVS utilization data.
Public method | GetReports | Retrieves reports defined within a document.
Public method | GetSectionAccessTable | Retrieves a single SectionAccessTable. The scope parameter is used to control how much information that should be included.
Public method | GetSectionAccessTableByName | Retrieves a SectionAccessTable by name.
Public method | GetSectionAccessTables | Retrieves all defined SectionAccessTable's. Each table contains information about its columns, but no table data is returned.
Public method | GetServerObjectMetaDataForUser | Retrieves a list of all ServerObjectMetaData objects from a QlikView Server, accessible to a certain user.
Public method | GetServerObjects | Retrieves a list of server objects from a document.
Public method | GetServices | Gets information about all registered services of the specified type.
Public method | GetServiceStatuses | Gets the status of all services which matches the provided list of service ID's.
Public method | GetSourceDocumentFolders | Gets all source document folders for the QlikView Distribution Service with the specified ID.
Public method | GetSourceDocumentNodes | Gets source document nodes for the specified relative path and the specified source document folder and QlikView Distribution Service ID.
Public method | GetSourceDocuments | Gets all source documents for the QlikView Distribution Service with the specified ID.
Public method | GetTask | Retrieves a single task using its id.
Public method | GetTasks | Retrieves all task from a QDS.
Public method | GetTasksForDocument | Gets the tasks for document.
Public method | GetTaskStatus | Gets the status of a task.
Public method | GetTaskStatuses | Gets the task statuses.
Public method | GetTaskStatusNodes | Gets the task status nodes.
Public method | GetTimeLimitedServiceKey | Gets a time limited service key.
Public method | GetUserDocumentFolders | Gets all user document folders for the QlikView Server with the specified ID.
Public method | GetUserDocumentNodes | Gets user document nodes for the specified relative path and the specified user document folder and QlikView Server ID.
Public method | GetUserDocuments | Gets all user documents for the QlikView Server with the specified ID.
Public method | ImportAllDocumentTasksForQds | Imports all document tasks from a remote QlikView Distribution Server.
Public method | ImportDocumentTask | Imports a single document task from a remote QlikView Distribution Server.
Public method | InitiateUploadExtensionObject | Initiates an new upload of an extension object.
Public method | IsPublisherQDS | This method checks if a QlikView Distribition Service has a publisher license or not.
Public method | LookupNames | Given a list of user or group names, this method performs a lookup of each name on a Directory Service Connector.
Public method | Ping | Pings this instance.
Public method | QDSNeedRestart | Sets that the QDS needs a restart.
Public method | QVSNeedRestart | Sets that the QVS needs a restart.
Public method | RemoteGetDocumentTask | Retrieves a single task from a remote QlikView Management Service.
Public method | RemoteGetServices | Retrieves information about services managed by a remote QlikView Management Console.
Public method | RemoteGetSourceDocumentFolders | Gets all source document folders for a QlikView Distribution Service, managed by a remote QlikView Management Service, with the specified ID.
Public method | RemoteGetSourceDocumentNodes | Connects to a remote QlikView Management Service and retrieves the source document nodes for the specified relative path and the specified source document folder and QlikView Distribution Service ID.
Public method | RemoteGetTaskListForDocID | Retrieves a list of all tasks for a specific document from a remote QlikView Management Service.
Public method | RemoteGetTasks | Retrieves all tasks from a remote QlikViewDistribution Service.
Public method | ResolveUserGroups | This method returns all groups that a certain user is a member of.
Public method | RestartQDS | Restarts the QDS.
Public method | RestartQVS | Restarts the QVS.
Public method | RunTask | Runs a single task.
Public method | SaveCALConfiguration | Saves the CAL configuration.
Public method | SaveDocumentMetaData | Saves the document metadata.
Public method | SaveDocumentTask | Saves the document task.
Public method | SaveLicense | Sets a license on a service. The license includes a LicenseType which is used together with the serviceID parameter to find the correct service.
Public method | SaveQDSSettings | Updates the settings for a certain QlikView Distribution service.
Public method | SaveQVSSettings | Saves the specified QlikView Server settings.
Public method | SaveSectionAccessTable | Saves a SectionAccessTable. If the table does not exist, it will be created. Otherwise it will be updated.
Public method | SendDistributionServiceWorkorder | Updates the configuration of a QlikView Distribution Service, includning task definitions.
Public method | ServiceHasValidLicense | Checks a service to see whether it has a valid license or not.
Public method | TakeServerObject | Changes the owner of a server object.
Public method | TriggerEDXTask | Triggers an EDX task.
Public method | UpdateLicense | Updates the service with the current license. This will refresh the license for all the members of the service.
Public method | ValidateLicense | Validates a license, making sure that the information that it contains is correct.
Public method | WriteExtensionObject | Uploads a piece of an extension object. The handle returned contains the current state of the upload.

See Also

IQMS Interface
PIX.Services Namespace


AbortTask Method

[image]

QlikView Management Service API
IQMS..::..AbortTask Method
IQMS Interface Example See Also Send Feedback
Aborts a single task.

Namespace: PIX.Services

Syntax

C#
void AbortTask(
    Guid taskID
)
Visual Basic
Sub AbortTask ( _
    taskID As Guid _
)

Parameters

taskID
Type: System..::..Guid
The task ID.

Remarks

Used to end the execution of a running task.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example starts the execution of a task, then aborts it after 20 seconds. This establishes some task log information. Then it retrieves the task status and prints the last log messages.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Threading;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid taskId = new Guid("28a4fae4-8e75-4681-8ddc-751b7664a025");
            apiClient.RunTask(taskId); // A service call to initiate the execution of a task.
            Thread.Sleep(20*1000); //Wait for 20 seconds so that the task has time to start.
            apiClient.AbortTask(taskId); // A service call to end the execution of the same task.
            TaskStatus taskStatus = apiClient.GetTaskStatus(taskId,TaskStatusScope.All); // A service call to retrieve the task status.
            Console.WriteLine(taskStatus.Extended.LastLogMessages); // Displays the last log messages.
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..SaveDocumentTask(DocumentTask)
IQMS..::..GetTasks(Guid)
IQMS..::..GetTasksForDocument(Guid)
IQMS..::..GetDocumentTask(Guid, DocumentTaskScope)
IQMS..::..DeleteTask(Guid, TaskType)
IQMS..::..RunTask(Guid)


AddSelections Method

[image]

QlikView Management Service API
IQMS..::..AddSelections Method
IQMS Interface Example See Also Send Feedback
Adds or toggles the currently selected fields within a document.

Namespace: PIX.Services

Syntax

C#
List<FieldContent> AddSelections(
    QDSDocumentSession session,
    List<FieldContent> fieldContents,
    bool lockSelection,
    bool toggleSelect,
    bool returnSelectedList
)
Visual Basic
Function AddSelections ( _
    session As QDSDocumentSession, _
    fieldContents As List(Of FieldContent), _
    lockSelection As Boolean, _
    toggleSelect As Boolean, _
    returnSelectedList As Boolean _
) As List(Of FieldContent)

Parameters

session
Type: PIX.QMSAPI.DataObjects..::..QDSDocumentSession
The session to be used.
fieldContents
Type: System.Collections.Generic..::..List <(Of <(<' FieldContent >)>)>
The selected fields to add or toggle
lockSelection
Type: System..::..Boolean
Set this to true if you want to lock the selected fields.
toggleSelect
Type: System..::..Boolean
If set to true, toggles to selected fields, otherwise sets them to be selected in the document.
returnSelectedList
Type: System..::..Boolean
Set to true if a list of currently selected fields should be returned.

Return Value

A list of selected fields.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example assumes that the document used contains a Quarter field which is related to a Month field. It retrieves all the values from the Quarter field and adds a new selection using the first value. Next it retrieves the values from the Month field and prints them to the console. Here it is possible to see which of the months that were selected or excluded after the quarter selection.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using System.Threading;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             ServiceInfo serviceInfo = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();
             if (serviceInfo != null)
             {
                 QDSDocumentSessionConfiguration sessionConfig = new QDSDocumentSessionConfiguration();

                 sessionConfig.QDSID = serviceInfo.ID;
                 sessionConfig.FilePath = @"C:\ProgramData\QlikTech\SourceDocuments\Sales.qvw";

                 QDSDocumentSession documentSession = apiClient.CreateSession(sessionConfig);

                 if (documentSession != null && documentSession.OpenDocumentResult == DocumentState.OpenedSuccessfully)
                 {
                     List<FieldContent> fieldContentList = apiClient.GetFieldContentList(documentSession, "Quarter", FieldContentType.All, 0, 4);
                     FieldContent firstField = fieldContentList.FirstOrDefault();
                     if(firstField != null)
                     {
                         //Remove all fields but the first one and add it as a selection.
                         firstField.Values.RemoveRange(1, firstField.Values.Count - 1);
                         apiClient.AddSelections(documentSession, new List<FieldContent>(){firstField}, false, false, true );

                         //Retrieve all the contents of the Month field.
                         FieldContent monthField = apiClient.GetFieldContentList(documentSession, "Month", FieldContentType.All, 0, 12).FirstOrDefault();

                         if (monthField != null) {

                             Console.WriteLine(monthField.Name);

                             //Print all the values for the month field.
                             foreach(FieldValue fv in monthField.Values )
                             {
                                 Console.WriteLine(string.Format("{0} {1}", fv.IsNumeric ? fv.Number.ToString() : fv.Text, fv.State ));
                             }
                         }
                         apiClient.CloseSession(documentSession);
                     }
                 }
                 else
                 {
                     Console.WriteLine("Failed to open the document.");
                 }
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
 }

See Also

IQMS Interface
PIX.Services Namespace


ClearLicense Method

[image]

QlikView Management Service API
IQMS..::..ClearLicense Method
IQMS Interface Example See Also Send Feedback
Clears the license for a service. After this method has been called, the service will be unlicensed and might not be available until a new license has been applied. Only the QlikViewServer-license type is currently supported.

Namespace: PIX.Services

Syntax

C#
void ClearLicense(
    LicenseType licenseType,
    Guid serviceID
)
Visual Basic
Sub ClearLicense ( _
    licenseType As LicenseType, _
    serviceID As Guid _
)

Parameters

licenseType
Type: PIX.QMSAPI.DataObjects.Enums..::..LicenseType
The type of license to return.
serviceID
Type: System..::..Guid
The ID if the service.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following example clears the license for the first QVS found.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             //Find a QlikView Server service.
             ServiceInfo qlikViewServiceInfo = apiClient.GetServices(ServiceTypes.QlikViewServer).FirstOrDefault();
             if( qlikViewServiceInfo != null) {
                 apiClient.ClearLicense(LicenseType.QlikViewServer, qlikViewServiceInfo.ID);
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown if the provided licenseType parameter is unsupported.

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects.Enums..::..LicenseType
IQMS..::..SaveLicense(License, Guid)


ClearQVSCache Method

[image]

QlikView Management Service API
IQMS..::..ClearQVSCache Method
IQMS Interface Example See Also Send Feedback
Clears the QlikView Server cache of the QlikView Management Service from the specified cache objects.

Namespace: PIX.Services

Syntax

C#
void ClearQVSCache(
    QVSCacheObjects objects
)
Visual Basic
Sub ClearQVSCache ( _
    objects As QVSCacheObjects _
)

Parameters

objects
Type: PIX.QMSAPI.DataObjects..::..QVSCacheObjects
The cache objects to clear.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example uses the QMS API to clear the QlikView Server cache, retrieve a registered QlikView Server and all its user documents. The names and paths of the user documents are then printed. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.IO;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // clear the QMS's QVS object cache from user document listings
            // so that the any new user documents can be discovered
            apiClient.ClearQVSCache(QVSCacheObjects.UserDocumentList);
            // get a list of QVS services
            List<ServiceInfo> qvsServices = apiClient.GetServices(ServiceTypes.QlikViewServer);
            if (qvsServices.Count > 0)
            {
                // retrieve all user documents for the first QVS in the list
                List<DocumentNode> userDocuments = apiClient.GetUserDocuments(qvsServices[0].ID);
                // print the names of all user documents
                Console.WriteLine("The " + qvsServices[0].Name + " contains the following user documents:" + Environment.NewLine);
                foreach (DocumentNode userDocument in userDocuments.OrderBy(x => x.RelativePath).ThenBy(x => x.Name))
                {
                    Console.WriteLine(Path.Combine(userDocument.RelativePath, userDocument.Name));
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..QVSCacheObjects


ClearSelections Method

[image]

QlikView Management Service API
IQMS..::..ClearSelections Method
IQMS Interface See Also Send Feedback
Clears or unlocks the selection of the specified field. If the field is empty, all fields will be cleared/unlocked.

Namespace: PIX.Services

Syntax

C#
void ClearSelections(
    QDSDocumentSession session,
    string fieldName,
    DocumentClearOptions clearOptions
)
Visual Basic
Sub ClearSelections ( _
    session As QDSDocumentSession, _
    fieldName As String, _
    clearOptions As DocumentClearOptions _
)

Parameters

session
Type: PIX.QMSAPI.DataObjects..::..QDSDocumentSession
The session to be used.
fieldName
Type: System..::..String
The name of the field to clear/unlock. If empty, all fields are cleared/unlocked.
clearOptions
Type: PIX.QMSAPI.DataObjects.Enums..::..DocumentClearOptions
Specifies how the fields are cleared.

Remarks

This method can be used when a selection has been made using the AddSelections(QDSDocumentSession, List<(Of <<'(FieldContent>)>>), Boolean, Boolean, Boolean) method.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

See Also

IQMS Interface
PIX.Services Namespace


CloseAndInstallExtensionObject Method

[image]

QlikView Management Service API
IQMS..::..CloseAndInstallExtensionObject Method
IQMS Interface Example See Also Send Feedback
Finalizes the uploads. This involves verifying that the upload is a valid package and that the installation is successful.

Namespace: PIX.Services

Syntax

C#
List<QVSMessage> CloseAndInstallExtensionObject(
    ExtensionUploadHandle handle
)
Visual Basic
Function CloseAndInstallExtensionObject ( _
    handle As ExtensionUploadHandle _
) As List(Of QVSMessage)

Parameters

handle
Type: PIX.QMSAPI.DataObjects..::..ExtensionUploadHandle
The handle identifying the upload.

Return Value

Messages describing the result.

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

The following code example uploads a document extension to a QVS.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.IO;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //This is a valid QVS guid
            Guid qvsId = new Guid("{6afbbc64-9681-406b-8917-e78bc370a05c}");

            //Initiate the upload
            ExtensionUploadHandle handle = apiClient.InitiateUploadExtensionObject(qvsId);

            if (handle != null)
            {
                FileStream fs = new FileStream(@"C:\FlexiGrid.qar", FileMode.Open);

                int maxBufferSize = 1024 * 16;

                byte[] buffer = new byte[maxBufferSize];
                int bytesRead;

                while ((bytesRead = fs.Read(buffer, 0, maxBufferSize)) > 0)
                {
                    //Copy the read bytes into a new buffer with the same size as the number of received bytes
                    byte[] byteWireBuffer = new byte[bytesRead];
                    Buffer.BlockCopy(buffer, 0, byteWireBuffer, 0, bytesRead);

                    //Write the buffer to the QVS
                    handle = apiClient.WriteExtensionObject(handle, byteWireBuffer);
                }

                //Finalize the upload. This will install the extension object if it is valid.
                List<QVSMessage> msg = apiClient.CloseAndInstallExtensionObject(handle);
                msg.ForEach(m => Console.WriteLine(m.Text));
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..ExtensionUploadHandle
PIX.QMSAPI.DataObjects..::..QVSMessage


CloseSession Method

[image]

QlikView Management Service API
IQMS..::..CloseSession Method
IQMS Interface Example See Also Send Feedback
Closes a previously opened session towards a document on a QDS server.

Namespace: PIX.Services

Syntax

C#
void CloseSession(
    QDSDocumentSession session
)
Visual Basic
Sub CloseSession ( _
    session As QDSDocumentSession _
)

Parameters

session
Type: PIX.QMSAPI.DataObjects..::..QDSDocumentSession
The session to be closed.

Remarks

If the session has already been closed, because of a timeout for example, it is still safe to call this method.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example shows how to open and close a document session.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using System.Threading;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             ServiceInfo serviceInfo = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();
             if (serviceInfo != null)
             {
                 QDSDocumentSessionConfiguration sessionConfig = new QDSDocumentSessionConfiguration();

                 sessionConfig.QDSID = serviceInfo.ID;
                 sessionConfig.FilePath = @"C:\ProgramData\QlikTech\SourceDocuments\Test.qvw";

                 QDSDocumentSession documentSession = apiClient.CreateSession(sessionConfig);

                 if(documentSession != null && documentSession.OpenDocumentResult == DocumentState.OpenedSuccessfully)
                 {
                     //...Do some work...
                     apiClient.CloseSession(documentSession);
                 } else
                 {
                     Console.WriteLine("Failed to open the document.");
                 }
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
 }

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..QDSDocumentSessionConfiguration
PIX.QMSAPI.DataObjects.Enums..::..DocumentState


CreateSession Method

[image]

QlikView Management Service API
IQMS..::..CreateSession Method
IQMS Interface Example See Also Send Feedback
Creates a session towards a document on a QDS server.

Namespace: PIX.Services

Syntax

C#
QDSDocumentSession CreateSession(
    QDSDocumentSessionConfiguration configuration
)
Visual Basic
Function CreateSession ( _
    configuration As QDSDocumentSessionConfiguration _
) As QDSDocumentSession

Parameters

configuration
Type: PIX.QMSAPI.DataObjects..::..QDSDocumentSessionConfiguration
The configuration of the session.

Return Value

A new session.

Remarks

If a session has not been used for 20 minutes, it will automatically be closed.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example creates a new session towards a source document on a Distribution Server.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using System.Threading;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             ServiceInfo serviceInfo = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();
             if (serviceInfo != null)
             {
                 QDSDocumentSessionConfiguration sessionConfig = new QDSDocumentSessionConfiguration();

                 sessionConfig.QDSID = serviceInfo.ID;
                 sessionConfig.FilePath = @"C:\ProgramData\QlikTech\SourceDocuments\Test.qvw";

                 QDSDocumentSession documentSession = apiClient.CreateSession(sessionConfig);

                 if(documentSession != null && documentSession.OpenDocumentResult == DocumentState.OpenedSuccessfully)
                 {
                     //...Do some work...
                     apiClient.CloseSession(documentSession);
                 } else
                 {
                     Console.WriteLine("Failed to open the document.");
                 }
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
 }

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..QDSDocumentSessionConfiguration
PIX.QMSAPI.DataObjects.Enums..::..DocumentState


DeleteSectionAccessTable Method

[image]

QlikView Management Service API
IQMS..::..DeleteSectionAccessTable Method
IQMS Interface Example See Also Send Feedback
Removes a single SectionAccessTable.

Namespace: PIX.Services

Syntax

C#
void DeleteSectionAccessTable(
    Guid tableId
)
Visual Basic
Sub DeleteSectionAccessTable ( _
    tableId As Guid _
)

Parameters

tableId
Type: System..::..Guid
The ID of the table to remove.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following example deletes a known section access table.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Remove a section access table.
            apiClient.DeleteSectionAccessTable(new Guid("12a32214-1122-112a-8099-8765ce564112"));
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


DeleteServerObject Method

[image]

QlikView Management Service API
IQMS..::..DeleteServerObject Method
IQMS Interface Example See Also Send Feedback
Removes a server object from a document.

Namespace: PIX.Services

Syntax

C#
void DeleteServerObject(
    Guid qvsID,
    string documentName,
    string id
)
Visual Basic
Sub DeleteServerObject ( _
    qvsID As Guid, _
    documentName As String, _
    id As String _
)

Parameters

qvsID
Type: System..::..Guid
The ID of a QlikView Server
documentName
Type: System..::..String
The full path of the document to delete server objects from.
id
Type: System..::..String
The id of the server object to delete.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example retrieves the server objects from a document hosted by a Qlik View Server and writes the information to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Find a Qlik View Server
            ServiceInfo qvsService = apiClient.GetServices(ServiceTypes.QlikViewServer).FirstOrDefault();

            if (qvsService != null)
            {
                //Get all server objects
                List<ServerObject> serverObjects = apiClient.GetServerObjects(qvsService.ID, "Test.qvw");

                //Find the ones belonging to johndoe
                var userObjects = serverObjects.Where(c => c.OwnerId == "Domain\\johndoe").ToList();

                //Delete the objects found.
                userObjects.ForEach(c => apiClient.DeleteServerObject(qvsService.ID, "Test.qvw", c.Id));
            }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace


DeleteTask Method

[image]

QlikView Management Service API
IQMS..::..DeleteTask Method
IQMS Interface Example See Also Send Feedback
Deletes a single task.

Namespace: PIX.Services

Syntax

C#
bool DeleteTask(
    Guid taskID,
    TaskType taskType
)
Visual Basic
Function DeleteTask ( _
    taskID As Guid, _
    taskType As TaskType _
) As Boolean

Parameters

taskID
Type: System..::..Guid
The task ID.
taskType
Type: PIX.QMSAPI.DataObjects..::..TaskType
Type of the task. This must be specified correctly to be able to perform the service. Undefined is a specific type and not a wildcard option.

Return Value

True if the task was successfully removed, otherwise false.

Remarks

Permanently removes a task from the task list.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example simply deletes a task. Note however that there is no generic task type so you must to define the type parameter correctly.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

 class Program
 {
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             Guid taskId = new Guid("ad549720-6bb5-4c66-b8c7-c6a5fb68e2a9"); // A known task Guid.

             bool result = apiClient.DeleteTask(taskId, TaskType.PauseTask); // A service call. Only applicable to pause type tasks.
             Console.WriteLine(result ? "Task deleted succesfully." : "Failed to delete task");
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..SaveDocumentTask(DocumentTask)
IQMS..::..GetTasks(Guid)
IQMS..::..GetTasksForDocument(Guid)
IQMS..::..GetDocumentTask(Guid, DocumentTaskScope)
IQMS..::..RunTask(Guid)
IQMS..::..AbortTask(Guid)
IQMSGetTaskLog(Guid, Guid, Int32)


FindEDX Method

[image]

QlikView Management Service API
IQMS..::..FindEDX Method
IQMS Interface Example See Also Send Feedback
Finds all matching EDX tasks.

Namespace: PIX.Services

Syntax

C#
List<TaskInfo> FindEDX(
    string name
)
Visual Basic
Function FindEDX ( _
    name As String _
) As List(Of TaskInfo)

Parameters

name
Type: System..::..String
The name to match the tasks on. If the name of an EDX tasks contains this value, it will be included in the returned result.

Return Value

A list of matching tasks

Remarks

Security Note

Requires membership of local group QlikView EDX.

Examples

The following code example retrieves matching EDX tasks and prints some information about each.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

           //Get all EDX tasks wit a name containing 'Ext'.
           List<TaskInfo> taskInfos = apiClient.FindEDX("Ext");
           taskInfos.ForEach( delegate(TaskInfo info)
               {
                   //Print information about the current task.
                   Console.WriteLine( String.Format("Name:{0}\tID:{1}\tEnabled:{2}",info.Name, info.ID, info.Enabled ? "Yes" : "No"));
               }
           );
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


FindTask Method

[image]

QlikView Management Service API
IQMS..::..FindTask Method
IQMS Interface Example See Also Send Feedback
Finds a single task given its name.

Namespace: PIX.Services

Syntax

C#
TaskInfo FindTask(
    Guid qdsId,
    TaskType taskType,
    string name
)
Visual Basic
Function FindTask ( _
    qdsId As Guid, _
    taskType As TaskType, _
    name As String _
) As TaskInfo

Parameters

qdsId
Type: System..::..Guid
The id of the QDS to search.
taskType
Type: PIX.QMSAPI.DataObjects..::..TaskType
The type of the task to look for.
name
Type: System..::..String
The exact name of the task to look for.

Return Value

The task, if found.

Remarks

Security Note

Requires membership of local group QlikView EDX.

Examples

The following code example retrieves matching task and prints some information about it.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

           //A known QDS id
           Guid qdsId = new Guid("5ac16136-f00b-47c4-8099-23ff7f178423");

           //Get a task with a known name
           TaskInfo taskInfo = apiClient.FindTask(qdsId, TaskType.ExternalProgramTask, "ExtGenerateGlobalReport");

           if (taskInfo != null) {
               //Print information about the task.
               Console.WriteLine(String.Format("Name:{0}\tID:{1}\tEnabled:{2}", taskInfo.Name, taskInfo.ID, taskInfo.Enabled ? "Yes" : "No"));
           }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetAlertText Method

[image]

QlikView Management Service API
IQMS..::..GetAlertText Method
IQMS Interface Example See Also Send Feedback
Returns a simple text message describing the current state of the QMS.

Namespace: PIX.Services

Syntax

C#
string GetAlertText()
Visual Basic
Function GetAlertText As String

Return Value

A text message

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

The following code example retrieves the alert string from the QMS and prints it if it is not empty.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

           string alert = apiClient.GetAlertText();
           if(!string.IsNullOrWhiteSpace(alert))
               Console.WriteLine("Alert message from QMS:" + alert);
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetAvailableDirectories Method

[image]

QlikView Management Service API
IQMS..::..GetAvailableDirectories Method
IQMS Interface Example See Also Send Feedback
Returns a list of available directory paths for a certain type of Directory Service Provider.

Namespace: PIX.Services

Syntax

C#
List<string> GetAvailableDirectories(
    Guid dscID,
    string type
)
Visual Basic
Function GetAvailableDirectories ( _
    dscID As Guid, _
    type As String _
) As List(Of String)

Parameters

dscID
Type: System..::..Guid
The ID of the Directory Service Connector to use.
type
Type: System..::..String
The type of the Directory Service Provider.

Return Value

A list of available directories.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example retrieves all available Directory Service providers and prints the directories for each of them.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo dscService = apiClient.GetServices(ServiceTypes.QlikViewDirectoryServiceConnector).FirstOrDefault();
            if (dscService != null)
            {
                //Get all available Directory Services Providers
                List<DSProvider> providers = apiClient.GetAvailableDSProviders(dscService.ID);

                foreach (DSProvider provider in providers)
                {
                    Console.WriteLine("Name:" + provider.Name);
                    Console.WriteLine("Type:" + provider.Type);

                    //Get available directories for the current provider.
                     List<string> directories = apiClient.GetAvailableDirectories(dscService.ID, provider.Type);

                    Console.WriteLine("Directories:");

                    //Write all dorectories
                    directories.ForEach(Console.WriteLine);

                    Console.WriteLine();
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetAvailableDSProviders Method

[image]

QlikView Management Service API
IQMS..::..GetAvailableDSProviders Method
IQMS Interface Example See Also Send Feedback
Returns the available Directory Service Providers supported by a certain Directory Service Connector.

Namespace: PIX.Services

Syntax

C#
List<DSProvider> GetAvailableDSProviders(
    Guid dscID
)
Visual Basic
Function GetAvailableDSProviders ( _
    dscID As Guid _
) As List(Of DSProvider)

Parameters

dscID
Type: System..::..Guid
The ID of the Directory Service Connector.

Return Value

A list of supported Directory Service Providers

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example retrieves all available Directory Service providers and prints them to the screen.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo dscService = apiClient.GetServices(ServiceTypes.QlikViewDirectoryServiceConnector).FirstOrDefault();
            if (dscService != null)
            {
                List<DSProvider> providers = apiClient.GetAvailableDSProviders(dscService.ID);
                foreach (DSProvider provider in providers)
                {
                    Console.WriteLine("Name:" + provider.Name);
                    Console.WriteLine("Type:" + provider.Type);
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetCALConfiguration Method

[image]

QlikView Management Service API
IQMS..::..GetCALConfiguration Method
IQMS Interface Example See Also Send Feedback
Gets the current session/document and named CAL configuration from a QVS.

Namespace: PIX.Services

Syntax

C#
CALConfiguration GetCALConfiguration(
    Guid qvsID,
    CALConfigurationScope scope
)
Visual Basic
Function GetCALConfiguration ( _
    qvsID As Guid, _
    scope As CALConfigurationScope _
) As CALConfiguration

Parameters

qvsID
Type: System..::..Guid
The QVS ID.
scope
Type: PIX.QMSAPI.DataObjects..::..CALConfigurationScope
The scope.

Return Value

If successful, the CAL configuration is returned.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example retrieves the CAL information from a QVS and prints information to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
           // create a QMS API client
           IQMS apiClient = new QMSClient();

           //retrieve a time limited service key
           ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();
           ServiceInfo qvsService = apiClient.GetServices(ServiceTypes.QlikViewServer).First();

           CALConfiguration config = apiClient.GetCALConfiguration(qvsService.ID,CALConfigurationScope.All);
           if(config != null)
           {
               //Document CALs
               Console.WriteLine("Document CALs\n");
               Console.WriteLine("# assigned document CALs:" + config.DocumentCALs.Assigned);
               Console.WriteLine("# in license document CALs:" + config.DocumentCALs.InLicense);
               Console.WriteLine("# limit document CALs:" + config.DocumentCALs.Limit);

               //Named CALs
               Console.WriteLine("\n\nNamed CALs\n");
               Console.WriteLine("Identification mode:" + config.NamedCALs.IdentificationMode);
               Console.WriteLine("# assigned named CALs:" + config.NamedCALs.Assigned);
               Console.WriteLine("# in license named CALs:" + config.NamedCALs.InLicense);
               Console.WriteLine("# limit document CALs:" + config.NamedCALs.Limit);
               config.NamedCALs.AssignedCALs.ForEach(
                   assignedCal => Console.WriteLine(String.Format("User:{0}\nLast used:{1}", assignedCal.UserName, assignedCal.LastUsed))
                   );

               config.NamedCALs.LeasedCALs.ForEach(
                   leasedCal => Console.WriteLine(String.Format("User:{0}\nLast used:{1}", leasedCal.UserName, leasedCal.LastUsed))
                   );

               //Session CALs
               Console.WriteLine("\n\nSession CALs\n");
               Console.WriteLine("# available session CALs:" + config.SessionCALs.Available);
               Console.WriteLine("# in license session CALs:" + config.SessionCALs.InLicense);
               Console.WriteLine("# limit session CALs:" + config.SessionCALs.Limit);
           }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

Exceptions

Exception | Condition
System..::..Exception | Thrown if there were any problems retrieving the CAL configuration.

See Also

IQMS Interface
PIX.Services Namespace


GetCALInfoForUser Method

[image]

QlikView Management Service API
IQMS..::..GetCALInfoForUser Method
IQMS Interface Example See Also Send Feedback
Gets the licenses currently used by a certain user.

Namespace: PIX.Services

Syntax

C#
UserCALs GetCALInfoForUser(
    Guid qvsID,
    string user
)
Visual Basic
Function GetCALInfoForUser ( _
    qvsID As Guid, _
    user As String _
) As UserCALs

Parameters

qvsID
Type: System..::..Guid
The ID of the QVS to get thge information from.
user
Type: System..::..String
The user name for which to return CAL usage information.

Return Value

License information for the specified user, UserCALs.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example checks whether the publisher license is valid or not and prints the result.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            UserCALs userCals = apiClient.GetCALInfoForUser(new Guid("d82abaeb-25ef-43b2-b600-3cff06b23953"), "SomeDomain\\johndoe" );

             if(userCals != null)
            {
       Console.WriteLine("Dcument CALs:");
       userCals.DocumentCALs.ForEach(
           dc=>Console.WriteLine(string.Format("LastUsed:{0}\tDocumentName:{1}", dc.LastUsed.ToShortDateString(), dc.DocumentName))
       );

       Console.WriteLine("\nLeased CALs:");
       userCals.LeasedNamedCALs.ForEach(
           lnc => Console.WriteLine(string.Format("Last used:{0}\tLeased date:{1}\tLeased on machine:{2}", lnc.LastUsed, lnc.LeasedAt, lnc.MachineID))
       );
   }

        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetCategories Method

[image]

QlikView Management Service API
IQMS..::..GetCategories Method
IQMS Interface Example See Also Send Feedback
Returns all categories matching the given scope.

Namespace: PIX.Services

Syntax

C#
List<Category> GetCategories(
    CategoriesScope scope
)
Visual Basic
Function GetCategories ( _
    scope As CategoriesScope _
) As List(Of Category)

Parameters

scope
Type: PIX.QMSAPI.DataObjects.Enums..::..CategoriesScope
The scope of the categories to return.

Return Value

A list of categories.

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

The following code example retrieves and prints the currently used categories.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
           // create a QMS API client
           IQMS apiClient = new QMSClient();

           //retrieve a time limited service key
           ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

           //Retrieves all categories currently assigned to at least one task.
           List<Category> categories = apiClient.GetCategories(CategoriesScope.Used);

           Console.WriteLine("Used categories:");
           categories.ForEach(category => Console.WriteLine(category.Name));
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetDocumentBookmarkNames Method

[image]

QlikView Management Service API
IQMS..::..GetDocumentBookmarkNames Method
IQMS Interface Example See Also Send Feedback
Retrieves a list of all document book marks defined in the document.

Namespace: PIX.Services

Syntax

C#
List<string> GetDocumentBookmarkNames(
    QDSDocumentSession session
)
Visual Basic
Function GetDocumentBookmarkNames ( _
    session As QDSDocumentSession _
) As List(Of String)

Parameters

session
Type: PIX.QMSAPI.DataObjects..::..QDSDocumentSession
The session to be used.

Return Value

A list of bookmark names.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example retrieves a list of all document bookmarks in a document and prints them to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo serviceInfo = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();
            if (serviceInfo != null)
            {
                QDSDocumentSessionConfiguration sessionConfig = new QDSDocumentSessionConfiguration();

                sessionConfig.QDSID = serviceInfo.ID;
                sessionConfig.FilePath = @"C:\ProgramData\QlikTech\SourceDocuments\Test.qvw";

                QDSDocumentSession documentSession = apiClient.CreateSession(sessionConfig);

                if (documentSession != null && documentSession.OpenDocumentResult == DocumentState.OpenedSuccessfully)
                {
                    List<string> bookmarkNames = apiClient.GetDocumentBookmarkNames(documentSession);
                    bookmarkNames.ForEach(Console.WriteLine);

                    apiClient.CloseSession(documentSession);
                }
                else
                {
                    Console.WriteLine("Failed to open the document.");
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetDocumentFolder Method

[image]

QlikView Management Service API
IQMS..::..GetDocumentFolder Method
IQMS Interface Example See Also Send Feedback
Gets the document folder with the specified ID.

Namespace: PIX.Services

Syntax

C#
DocumentFolder GetDocumentFolder(
    Guid id,
    DocumentFolderScope scope
)
Visual Basic
Function GetDocumentFolder ( _
    id As Guid, _
    scope As DocumentFolderScope _
) As DocumentFolder

Parameters

id
Type: System..::..Guid
The ID of the document folder to retrieve.
scope
Type: PIX.QMSAPI.DataObjects..::..DocumentFolderScope
The scope of the document folder to retrieve.

Return Value

The document folder with the specified ID and scope.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example retrieves the document folder for a certain task and prints the administrators set on the folder.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
           // create a QMS API client
           IQMS apiClient = new QMSClient();

           //retrieve a time limited service key
           ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

           //Id of a known task
           Guid someTaskId = new Guid("5ac16136-f00b-47c4-8099-23ff7f178423");
           DocumentTask documentTask = apiClient.GetDocumentTask(someTaskId, DocumentTaskScope.All);

           if(documentTask != null)
           {
               DocumentFolder folder = apiClient.GetDocumentFolder(documentTask.Document.FolderID, DocumentFolderScope.All);
               if(folder != null)
               {
                   Console.WriteLine("Path:" + folder.General.Path);
                   Console.WriteLine("Administrators:");
                   folder.Administrators.UserNames.ForEach(name=>Console.Write(name + ";"));
               }
           }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

Exceptions

Exception | Condition
System..::..Exception | Thrown if the caller does not have access to the document folder with the specified ID.

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..DocumentFolder
PIX.QMSAPI.DataObjects..::..DocumentFolderScope
IQMS..::..GetSourceDocumentFolders(Guid, DocumentFolderScope)
IQMS..::..GetUserDocumentFolders(Guid, DocumentFolderScope)


GetDocumentMetaData Method

[image]

QlikView Management Service API
IQMS..::..GetDocumentMetaData Method
IQMS Interface Example See Also Send Feedback
Gets the document metadata.

Namespace: PIX.Services

Syntax

C#
DocumentMetaData GetDocumentMetaData(
    DocumentNode userDocument,
    DocumentMetaDataScope scope
)
Visual Basic
Function GetDocumentMetaData ( _
    userDocument As DocumentNode, _
    scope As DocumentMetaDataScope _
) As DocumentMetaData

Parameters

userDocument
Type: PIX.QMSAPI.DataObjects..::..DocumentNode
The user document.
scope
Type: PIX.QMSAPI.DataObjects..::..DocumentMetaDataScope
The scope.

Return Value

The assoicated document metadata.

Remarks

Every document has an information set asssociated with it describing for example its name and position in the node hierarchy. Note that this service only accepts user documents as its input.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example retrieves the document metadata of a specific document and then saves it. In order to be able to find and use the correct node in the service call we call on a list of all user document nodes and then select the first one for the sake of this example.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid qvsId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The originating QVS ID.
            IList<DocumentNode> documentNodes = apiClient.GetUserDocuments(qvsId); // Collecting a list of user document nodes.
            DocumentNode userDocument = documentNodes[0]; // Assigning the first element of the list to a new object.

            // A client call to collect the metadata for a specific document.
            DocumentMetaData documentMetaData = apiClient.GetDocumentMetaData(userDocument, DocumentMetaDataScope.All);
            Console.WriteLine("Document name:" + documentMetaData.UserDocument.Name); // Prints the name of the document.

            apiClient.SaveDocumentMetaData(documentMetaData); // Saving the document metadata that was retrieved.
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..SaveDocumentMetaData(DocumentMetaData)


GetDocumentTask Method

[image]

QlikView Management Service API
IQMS..::..GetDocumentTask Method
IQMS Interface Example See Also Send Feedback
Gets the document task. The scope parameter is used to define what information to retrieve about the task.

Namespace: PIX.Services

Syntax

C#
DocumentTask GetDocumentTask(
    Guid documentTaskID,
    DocumentTaskScope scope
)
Visual Basic
Function GetDocumentTask ( _
    documentTaskID As Guid, _
    scope As DocumentTaskScope _
) As DocumentTask

Parameters

documentTaskID
Type: System..::..Guid
The document task ID.
scope
Type: PIX.QMSAPI.DataObjects..::..DocumentTaskScope
The scope.

Return Value

A task with the specified ID and scope.

Remarks

Each document can have tasks associated with it.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following example retrieves a task associated with a document, displays the name of the task and then saves the document task. It would have been just as easy to change the task information instead of displaying it.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

 class Program
 {
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             Guid documentTaskId = new Guid("e95ecd5a-683d-1d33-26bf-66e94ff08223");
             DocumentTask documentTask = apiClient.GetDocumentTask(documentTaskId, DocumentTaskScope.All); // A service call to collect the document task.
             Console.WriteLine(documentTask.Document.Name); // Displays the name of the specified document.
             apiClient.SaveDocumentTask(documentTask); // A service call to save the document task.
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..SaveDocumentTask(DocumentTask)
IQMS..::..GetTasks(Guid)
IQMS..::..GetTasksForDocument(Guid)
IQMS..::..DeleteTask(Guid, TaskType)
IQMS..::..RunTask(Guid)
IQMS..::..AbortTask(Guid)
IQMSGetTaskLog(Guid, Guid, Int32)


GetDSResources Method

[image]

QlikView Management Service API
IQMS..::..GetDSResources Method
IQMS Interface Example See Also Send Feedback
Returns all Directory Services managed by a certain Directory Service Connector.

Namespace: PIX.Services

Syntax

C#
List<DSResource> GetDSResources(
    Guid dscID
)
Visual Basic
Function GetDSResources ( _
    dscID As Guid _
) As List(Of DSResource)

Parameters

dscID
Type: System..::..Guid
The ID of the Directory Service Connector to retrieve Directory Services from.

Return Value

A list of found Directory Services

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The example below retrieves all Directory Service Resource

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo dscService = apiClient.GetServices(ServiceTypes.QlikViewDirectoryServiceConnector).FirstOrDefault();
            if(dscService != null)
            {
                List<DSResource> dsResources = apiClient.GetDSResources(dscService.ID);
                foreach (var dsResource in dsResources)
                {
                    Console.WriteLine("Name: " + dsResource.Name);
                    Console.WriteLine("Settings:");
                    foreach (string key in dsResource.Settings.Keys)
                    {
                        Console.WriteLine(key + "=" + dsResource.Settings[key]);
                    }
                    Console.WriteLine("Path: " + dsResource.Path);
                    Console.WriteLine();
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetEDXTaskStatus Method

[image]

QlikView Management Service API
IQMS..::..GetEDXTaskStatus Method
IQMS Interface Example See Also Send Feedback
Gets the EDX task status.

Namespace: PIX.Services

Syntax

C#
EDXStatus GetEDXTaskStatus(
    Guid qdsID,
    Guid executionID
)
Visual Basic
Function GetEDXTaskStatus ( _
    qdsID As Guid, _
    executionID As Guid _
) As EDXStatus

Parameters

qdsID
Type: System..::..Guid
The QDS ID.
executionID
Type: System..::..Guid
The execution instance ID.

Return Value

The status of a specific execution of the task.

Remarks

Security Note

Requires membership of local group QlikView EDX.

Examples

The following example shows how to trigger a task and then wait until it has finished or a certain amount of time has passed.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using System.Threading;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a Distribution Service.
            ServiceInfo qdsService = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();

            if (qdsService != null)
            {
                //Trigger the task
                TriggerEDXTaskResult result = apiClient.TriggerEDXTask(qdsService.ID, "PauseEDX", "edx", "", new List<string>());

                EDXStatus executionStatus = null;

                //Wait until the task is completed or 60 seconds has passed.
                SpinWait.SpinUntil(() =>
                    {
                        System.Threading.Thread.Sleep(1000);
                        Console.WriteLine("Checking the task...");

                        //Get the current state of the task.
                        executionStatus = apiClient.GetEDXTaskStatus(qdsService.ID, result.ExecId);

                        //Return true if the task has completed.
                        return executionStatus != null && executionStatus.TaskStatus == TaskStatusValue.Completed;
                }, 60 * 1000);

                //Write the result
                if (executionStatus != null)
                    Console.WriteLine(executionStatus.TaskStatus);
                else
                    Console.WriteLine("Failed to get execution status.");

            }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
EDXStatus
IQMS..::..TriggerEDXTask(Guid, String, String, String, List<(Of <<'(String>)>>))


GetFieldContentList Method

[image]

QlikView Management Service API
IQMS..::..GetFieldContentList Method
IQMS Interface Example See Also Send Feedback
Retrieves the values for a specific field. It is possible to retrieve only the currently selected values or all values for the field.

Namespace: PIX.Services

Syntax

C#
List<FieldContent> GetFieldContentList(
    QDSDocumentSession session,
    string forFieldName,
    FieldContentType fieldContentType,
    int index,
    int length
)
Visual Basic
Function GetFieldContentList ( _
    session As QDSDocumentSession, _
    forFieldName As String, _
    fieldContentType As FieldContentType, _
    index As Integer, _
    length As Integer _
) As List(Of FieldContent)

Parameters

session
Type: PIX.QMSAPI.DataObjects..::..QDSDocumentSession
The session to be used.
forFieldName
Type: System..::..String
The name of the field
fieldContentType
Type: PIX.QMSAPI.DataObjects.Enums..::..FieldContentType
The type of values to return, either all or currently selected.
index
Type: System..::..Int32
The index of the first value to return.
length
Type: System..::..Int32
The maximum number of values to return.

Return Value

A list of field values.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example retrieves values for all the fields and prints them to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             ServiceInfo serviceInfo = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();
             if (serviceInfo != null)
             {
                 QDSDocumentSessionConfiguration sessionConfig = new QDSDocumentSessionConfiguration();

                 sessionConfig.QDSID = serviceInfo.ID;
                 sessionConfig.FilePath = @"C:\ProgramData\QlikTech\SourceDocuments\Sales.qvw";

                 QDSDocumentSession documentSession = apiClient.CreateSession(sessionConfig);

                 if (documentSession != null && documentSession.OpenDocumentResult == DocumentState.OpenedSuccessfully)
                 {
                     List<Field> fields = apiClient.GetFieldList(documentSession);
                     foreach(Field f in fields)
                     {
                         List<FieldContent> fieldContent = apiClient.GetFieldContentList(documentSession, f.Name, FieldContentType.All, 0, 5);
                         foreach(FieldContent fc in fieldContent)
                         {
                             Console.WriteLine("\nName: " + fc.Name);
                             Console.WriteLine("Values: " + fc.Name);
                             fc.Values.ForEach(v=>Console.WriteLine(v.IsNumeric ? v.Number.ToString() : v.Text));
                         }
                     }

                     apiClient.CloseSession(documentSession);
                 }
                 else
                 {
                     Console.WriteLine("Failed to open the document.");
                 }
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
 }

See Also

IQMS Interface
PIX.Services Namespace


GetFieldList Method

[image]

QlikView Management Service API
IQMS..::..GetFieldList Method
IQMS Interface Example See Also Send Feedback
Retrieves all available fields from a document.

Namespace: PIX.Services

Syntax

C#
List<Field> GetFieldList(
    QDSDocumentSession session
)
Visual Basic
Function GetFieldList ( _
    session As QDSDocumentSession _
) As List(Of Field)

Parameters

session
Type: PIX.QMSAPI.DataObjects..::..QDSDocumentSession
The document session to be used.

Return Value

A list of fields

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example retrieves all fields from a document and prints them to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo serviceInfo = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();
            if (serviceInfo != null)
            {
                QDSDocumentSessionConfiguration sessionConfig = new QDSDocumentSessionConfiguration();

                sessionConfig.QDSID = serviceInfo.ID;
                sessionConfig.FilePath = @"C:\ProgramData\QlikTech\SourceDocuments\Sales.qvw";

                QDSDocumentSession documentSession = apiClient.CreateSession(sessionConfig);

                if (documentSession != null && documentSession.OpenDocumentResult == DocumentState.OpenedSuccessfully)
                {
                    List<Field> fields = apiClient.GetFieldList(documentSession);
                    fields.ForEach(f=>Console.WriteLine(f.Name));

                    apiClient.CloseSession(documentSession);
                }
                else
                {
                    Console.WriteLine("Failed to open the document.");
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetLicense Method

[image]

QlikView Management Service API
IQMS..::..GetLicense Method
IQMS Interface Example See Also Send Feedback
Retrieves the currently set license for a service.

Namespace: PIX.Services

Syntax

C#
License GetLicense(
    LicenseType licenseType,
    Guid serviceID
)
Visual Basic
Function GetLicense ( _
    licenseType As LicenseType, _
    serviceID As Guid _
) As License

Parameters

licenseType
Type: PIX.QMSAPI.DataObjects.Enums..::..LicenseType
The type of license to return.
serviceID
Type: System..::..Guid
The ID if the service.

Return Value

The license of the service. If there is no license for the service, null is returned.

Remarks

If the licenseType parameter is set to LicenseType.Publisher, the serviceID will be ignored and can be set to Guid.Empty.
Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example uses the QMS API to retrieve the Publisher and QlikViewServer licenses and prints them to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             List<License> licenses = new List<License>();
             // get the publisher license
             License publisherLicense = apiClient.GetLicense(LicenseType.Publisher, Guid.Empty);
             if (publisherLicense != null)
               licenses.Add(publisherLicense);

             ServiceInfo qvsService = apiClient.GetServices(ServiceTypes.QlikViewServer).FirstOrDefault();
             if (qvsService != null)
             {
                 // get a QlikViewServer license
                 License qlikViewServerLicense = apiClient.GetLicense(LicenseType.QlikViewServer, qvsService.ID);
                 if (qlikViewServerLicense != null)
                     licenses.Add(qlikViewServerLicense);
             }

             //Write license information
             licenses.ForEach(currentLicense =>
             {
                 Console.WriteLine(currentLicense.LicenseType);
                 Console.WriteLine(currentLicense.Name);
                 Console.WriteLine(currentLicense.Corporation);
                 Console.WriteLine(currentLicense.Serial);
             });
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects.Enums..::..LicenseType


GetQDSSettings Method

[image]

QlikView Management Service API
IQMS..::..GetQDSSettings Method
IQMS Interface Example See Also Send Feedback
Retrieves the current settings for the QlikView Distribution service with the specified ID.

Namespace: PIX.Services

Syntax

C#
QDSSettings GetQDSSettings(
    Guid qdsID,
    QDSSettingsScope scope
)
Visual Basic
Function GetQDSSettings ( _
    qdsID As Guid, _
    scope As QDSSettingsScope _
) As QDSSettings

Parameters

qdsID
Type: System..::..Guid
The ID of the service.
scope
Type: PIX.QMSAPI.DataObjects.Enums..::..QDSSettingsScope
The scope of the settings to retrieve.

Return Value

The current settings for the QlikView Distributioun service

Remarks

The scope parameter indicates which parts of the returned object that will be populated with data.
Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following example retrieves a list of QlikView Distribution Services and prints out some of their settings.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             //Get a list of QlikView Distribution services
             List<ServiceInfo> qdsServices = apiClient.GetServices(ServiceTypes.QlikViewDistributionService);

             //Loops through all services
             foreach(ServiceInfo info in qdsServices)
             {
                Console.WriteLine(string.Format("{0}", info.Name));
                Console.WriteLine("".PadLeft(info.Name.Length, '='));

                //Gets the General settings for the current service and print information abput the folders used.
                QDSSettings qdsSettings = apiClient.GetQDSSettings(info.ID, QDSSettingsScope.General);
                if(qdsSettings != null)
                {
                    Console.WriteLine("Folders:");
                    qdsSettings.General.SourceFolders.ForEach(folder=>Console.WriteLine("\t" + folder.General.Path));

                    Console.WriteLine("\nApplicationDataFolder:\n\t" + qdsSettings.General.ApplicationDataFolder);
                }
                Console.WriteLine("\n\n");
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..QDSSettings
PIX.QMSAPI.DataObjects.Enums..::..QDSSettingsScope
PIX.QMSAPI.DataObjects..::..ServiceInfo


GetQVSDocumentsAndUsers Method

[image]

QlikView Management Service API
IQMS..::..GetQVSDocumentsAndUsers Method
IQMS Interface Example See Also Send Feedback
Gets each document loaded on the QVS and the users connected to each on respectively.

Namespace: PIX.Services

Syntax

C#
Dictionary<string, List<string>> GetQVSDocumentsAndUsers(
    Guid qvsID,
    QueryTarget target
)
Visual Basic
Function GetQVSDocumentsAndUsers ( _
    qvsID As Guid, _
    target As QueryTarget _
) As Dictionary(Of String, List(Of String))

Parameters

qvsID
Type: System..::..Guid
The QVS ID.
target
Type: PIX.QMSAPI.DataObjects.Enums..::..QueryTarget
The target of the query.

Return Value

If successful, the documents and connected users are returned.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example retrieves documents and connected users from a specific qvs and prints it to standard output.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid qvsId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The originating QVS ID.
            Dictionary<string, List<string>> docsAndUsers = apiClient.GetQVSDocumentsAndUsers(qvsId, QueryTarget.Resource);
            foreach(string doc in docsAndUsers.Keys)
            {
                Console.Write("Document: " + doc + ", User(s):");
                foreach(string user in docsAndUsers[doc])
                {
                    Console.Write(" " + user);
                }
                Console.Write("\n");
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetQVSDocumentsPerUser Method

[image]

QlikView Management Service API
IQMS..::..GetQVSDocumentsPerUser Method
IQMS Interface Example See Also Send Feedback
Gets the number of documents each user on the QVS is connected to.

Namespace: PIX.Services

Syntax

C#
Dictionary<string, int> GetQVSDocumentsPerUser(
    Guid qvsID,
    QueryTarget target
)
Visual Basic
Function GetQVSDocumentsPerUser ( _
    qvsID As Guid, _
    target As QueryTarget _
) As Dictionary(Of String, Integer)

Parameters

qvsID
Type: System..::..Guid
The QVS ID.
target
Type: PIX.QMSAPI.DataObjects.Enums..::..QueryTarget
The target of the query.

Return Value

If successful, number of documents per user is returned.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid qvsId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The originating QVS ID.
            Dictionary<string, int> docsPerUser = apiClient.GetQVSDocumentsPerUser(qvsId, QueryTarget.Resource);
            foreach(string name in docsPerUser.Keys)
            {
                Console.WriteLine("User: " + name + ", Number of documents: " + docsPerUser[name].ToString());
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetQVSPerformanceData Method

[image]

QlikView Management Service API
IQMS..::..GetQVSPerformanceData Method
IQMS Interface Example See Also Send Feedback
Gets QVS performance data.

Namespace: PIX.Services

Syntax

C#
Dictionary<string, string> GetQVSPerformanceData(
    Guid qvsID,
    QueryTarget target
)
Visual Basic
Function GetQVSPerformanceData ( _
    qvsID As Guid, _
    target As QueryTarget _
) As Dictionary(Of String, String)

Parameters

qvsID
Type: System..::..Guid
The QVS ID.
target
Type: PIX.QMSAPI.DataObjects.Enums..::..QueryTarget
The target of the query.

Return Value

If successful, QVS performance data is returned.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example retrieves QVS performance data from a specific qvs and prints it to standard output.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

Guid qvsId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The originating QVS ID.
Dictionary<string, string> perfData = apiClient.GetQVSPerformanceData(qvsId, QueryTarget.Resource);
foreach(string name in perfData.Keys)
{
    Console.WriteLine("Name: " + name + ", Value: " + perfData[name]);
}
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetQVSSettings Method

[image]

QlikView Management Service API
IQMS..::..GetQVSSettings Method
IQMS Interface Example See Also Send Feedback
Gets settings for the QlikView Server with the specified ID.

Namespace: PIX.Services

Syntax

C#
QVSSettings GetQVSSettings(
    Guid qvsID,
    QVSSettingsScope scope
)
Visual Basic
Function GetQVSSettings ( _
    qvsID As Guid, _
    scope As QVSSettingsScope _
) As QVSSettings

Parameters

qvsID
Type: System..::..Guid
The QlikView Server ID.
scope
Type: PIX.QMSAPI.DataObjects..::..QVSSettingsScope
The scope of settings to retrieve.

Return Value

The QlikView Server settings for the specified scope.

Remarks

The scope parameter indicates which parts of the returned object that will be populated with data.

All settings except General and Distribution requires that the QlikView Management Service is able to communicate with the QlikView Server.

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example uses the QMS API to retrieve a registered QlikView Server and its logging settings. It changes the log folder and then saves the logging settings. If everything goes well, it prints the original logging folder and then a message when it's done. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // get a list of QVS services
            List<ServiceInfo> qvsServices = apiClient.GetServices(ServiceTypes.QlikViewServer);
            if (qvsServices.Count > 0)
            {
                // retrieve logging settings for the first QVS in the list
                QVSSettings qvsSettings = apiClient.GetQVSSettings(qvsServices[0].ID, QVSSettingsScope.Logging);
                Console.WriteLine("QVS log folder before change: " + qvsSettings.Logging.Folder);
                // change log folder
                qvsSettings.Logging.Folder = @"\\myshare\logs";
                // save settings
                apiClient.SaveQVSSettings(qvsSettings);
                Console.WriteLine("Settings saved. Log folder changed.");
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..QVSSettings
PIX.QMSAPI.DataObjects..::..QVSSettingsScope
IQMS..::..SaveQVSSettings(QVSSettings)


GetQVSUtilizationData Method

[image]

QlikView Management Service API
IQMS..::..GetQVSUtilizationData Method
IQMS Interface Example See Also Send Feedback
Gets QVS utilization data.

Namespace: PIX.Services

Syntax

C#
Dictionary<string, string> GetQVSUtilizationData(
    Guid qvsID,
    QueryTarget target
)
Visual Basic
Function GetQVSUtilizationData ( _
    qvsID As Guid, _
    target As QueryTarget _
) As Dictionary(Of String, String)

Parameters

qvsID
Type: System..::..Guid
The QVS ID.
target
Type: PIX.QMSAPI.DataObjects.Enums..::..QueryTarget
The target of the query.

Return Value

If successful, QVS utilization data is returned.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example retrieves QVS utilization data from a specific qvs and prints it to standard output.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid qvsId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The originating QVS ID.
            Dictionary<string, string> utilData = apiClient.GetQVSUtilizationData(qvsId, QueryTarget.Resource);
            foreach(string name in utilData.Keys)
            {
                Console.WriteLine("Name: " + name + ", Value: " + utilData[name]);
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetReports Method

[image]

QlikView Management Service API
IQMS..::..GetReports Method
IQMS Interface Example See Also Send Feedback
Retrieves reports defined within a document.

Namespace: PIX.Services

Syntax

C#
IEnumerable<Report> GetReports(
    QDSDocumentSession session
)
Visual Basic
Function GetReports ( _
    session As QDSDocumentSession _
) As IEnumerable(Of Report)

Parameters

session
Type: PIX.QMSAPI.DataObjects..::..QDSDocumentSession
The session to be used.

Return Value

A list of reports defined within the document referred to by the session..

Remarks

This method can be used when creating a document task which distributes PDF reports.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example retrieves the reports within a document.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo serviceInfo = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();
            if (serviceInfo != null)
            {
                QDSDocumentSessionConfiguration sessionConfig = new QDSDocumentSessionConfiguration();

                sessionConfig.QDSID = serviceInfo.ID;
                sessionConfig.FilePath = @"C:\ProgramData\QlikTech\SourceDocuments\Sales.qvw";

                QDSDocumentSession documentSession = apiClient.CreateSession(sessionConfig);

                if (documentSession != null && documentSession.OpenDocumentResult == DocumentState.OpenedSuccessfully)
                {
                    List<Report> reports = apiClient.GetReports(documentSession);
                    reports.ForEach(r=>Console.WriteLine(string.Format("{0} {1}",r.ID, r.Name)));
                    apiClient.CloseSession(documentSession);
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetSectionAccessTable Method

[image]

QlikView Management Service API
IQMS..::..GetSectionAccessTable Method
IQMS Interface Example See Also Send Feedback
Retrieves a single SectionAccessTable. The scope parameter is used to control how much information that should be included.

Namespace: PIX.Services

Syntax

C#
SectionAccessTable GetSectionAccessTable(
    Guid tableId,
    SectionAccessScope scope
)
Visual Basic
Function GetSectionAccessTable ( _
    tableId As Guid, _
    scope As SectionAccessScope _
) As SectionAccessTable

Parameters

tableId
Type: System..::..Guid
The ID of the table to retrieve.
scope
Type: PIX.QMSAPI.DataObjects.Enums..::..SectionAccessScope
The scope of the returned value.

Return Value

A single SectionAccessTable

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example retrieves a table using its ID and prints information about name and columns.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            SectionAccessTable sectionAccessTable = apiClient.GetSectionAccessTable(new Guid("12a32214-1122-112a-8099-8765ce564112"), SectionAccessScope.IncludeColumns);
            if( sectionAccessTable != null) {
                Console.WriteLine(sectionAccessTable.Name);
                sectionAccessTable.Columns.ForEach(column => Console.Write(string.Format("{0}\t", column.Name)));
                Console.WriteLine();

             }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetSectionAccessTableByName Method

[image]

QlikView Management Service API
IQMS..::..GetSectionAccessTableByName Method
IQMS Interface Example See Also Send Feedback
Retrieves a SectionAccessTable by name.

Namespace: PIX.Services

Syntax

C#
SectionAccessTable GetSectionAccessTableByName(
    string tableName,
    SectionAccessScope scope
)
Visual Basic
Function GetSectionAccessTableByName ( _
    tableName As String, _
    scope As SectionAccessScope _
) As SectionAccessTable

Parameters

tableName
Type: System..::..String
The name of the table to
scope
Type: PIX.QMSAPI.DataObjects.Enums..::..SectionAccessScope
The scope of the returned value.

Return Value

A single SectionAccessTable.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example retrieves a table by name and prints information about the columns.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            SectionAccessTable sectionAccessTable = apiClient.GetSectionAccessTableByName("productAccess", SectionAccessScope.IncludeColumns);
            if (sectionAccessTable != null)
            {
                Console.WriteLine(sectionAccessTable.Name);
                sectionAccessTable.Columns.ForEach(column => Console.Write(string.Format("{0}\t", column.Name)));
                Console.WriteLine();
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetSectionAccessTables Method

[image]

QlikView Management Service API
IQMS..::..GetSectionAccessTables Method
IQMS Interface Example See Also Send Feedback
Retrieves all defined SectionAccessTable's. Each table contains information about its columns, but no table data is returned.

Namespace: PIX.Services

Syntax

C#
List<SectionAccessTable> GetSectionAccessTables(
    SectionAccessScope scope
)
Visual Basic
Function GetSectionAccessTables ( _
    scope As SectionAccessScope _
) As List(Of SectionAccessTable)

Parameters

scope
Type: PIX.QMSAPI.DataObjects.Enums..::..SectionAccessScope
The scope of the returned value.

Return Value

A list of SectionAccessTable's

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example retrieves a list of all tables and prints their names and IDs

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            List<SectionAccessTable> sectionAccessTables = apiClient.GetSectionAccessTables(SectionAccessScope.None);

            sectionAccessTables.ForEach(table=> Console.WriteLine(string.Format("ID:{0}\tName:{1}",table.ID, table.Name)));
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetServerObjectMetaDataForUser Method

[image]

QlikView Management Service API
IQMS..::..GetServerObjectMetaDataForUser Method
IQMS Interface Example See Also Send Feedback
Retrieves a list of all ServerObjectMetaData objects from a QlikView Server, accessible to a certain user.

Namespace: PIX.Services

Syntax

C#
List<ServerObjectMetaData> GetServerObjectMetaDataForUser(
    Guid qvsID,
    string user
)
Visual Basic
Function GetServerObjectMetaDataForUser ( _
    qvsID As Guid, _
    user As String _
) As List(Of ServerObjectMetaData)

Parameters

qvsID
Type: System..::..Guid
The ID of the QlikView Server managing the document.
user
Type: System..::..String
The user id to retrieve server objects for.

Return Value

A list of ServerObjectMetaData objects.

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

This example retrieves all ServerObjectMetaData's from a QVS, accessible by a certain user.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo qvsService = apiClient.GetServices(ServiceTypes.QlikViewServer).FirstOrDefault();
            if( qvsService != null)
            {
                List<ServerObjectMetaData> serverObjectMetaDatas = apiClient.GetServerObjectMetaDataForUser( qvsService.ID, "SomeDomain\\johndoe");
                serverObjectMetaDatas.ForEach(meta=>
                {
                    Console.WriteLine("Id: " + meta.Id);
                    Console.WriteLine("Type: " + meta.Type );
                    Console.WriteLine("Sub type: " + meta.SubType);
                    Console.WriteLine("Document: " + meta.DocumentName);
                });
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..ServerObjectMetaData


GetServerObjects Method

[image]

QlikView Management Service API
IQMS..::..GetServerObjects Method
IQMS Interface Example See Also Send Feedback
Retrieves a list of server objects from a document.

Namespace: PIX.Services

Syntax

C#
List<ServerObject> GetServerObjects(
    Guid qvsID,
    string documentName
)
Visual Basic
Function GetServerObjects ( _
    qvsID As Guid, _
    documentName As String _
) As List(Of ServerObject)

Parameters

qvsID
Type: System..::..Guid
The ID of the QlikView Server managing the document.
documentName
Type: System..::..String
The full path of the document to retrieve server objects from.

Return Value

A list of ServerObjects .

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

This example retrieves the server objects from a document hosted by a Qlik View Server and writes the information to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Find a QlikView Server
            ServiceInfo qvsService = apiClient.GetServices(ServiceTypes.QlikViewServer).FirstOrDefault();

            if (qvsService != null)
            {
                //Get all the collaboration objects
                List<ServerObject> serverObjects = apiClient.GetServerObjects(qvsService.ID, "SomeQVDoc.qvw");
                serverObjects.ForEach(t =>
                    {
                        Console.WriteLine("==========================");
                        Console.WriteLine("ID:{0}", t.Id);
                        Console.WriteLine("Type:{0}", t.Type);
                        Console.WriteLine("SubType:{0}", t.SubType);
                        Console.WriteLine("Owner:{0}", t.OwnerName);
                        Console.WriteLine("Last modified:{0}", t.UtcModifyTime);
                        Console.WriteLine("Shared:{0}", t.Shared);
                        Console.WriteLine("==========================");
                        Console.WriteLine();
                    });
            }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace


GetServices Method

[image]

QlikView Management Service API
IQMS..::..GetServices Method
IQMS Interface Example See Also Send Feedback
Gets information about all registered services of the specified type.

Namespace: PIX.Services

Syntax

C#
List<ServiceInfo> GetServices(
    ServiceTypes serviceTypes
)
Visual Basic
Function GetServices ( _
    serviceTypes As ServiceTypes _
) As List(Of ServiceInfo)

Parameters

serviceTypes
Type: PIX.QMSAPI.DataObjects..::..ServiceTypes
The service types to return.

Return Value

Information about all registered services of the specified type.

Remarks

It is not possible to retrieve Reload Engines with this method.

Security Note

Requires membership of local group QlikView Management API.

Examples

The following code example retrieves all services, ordered by type, and prints them.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
           // create a QMS API client
           IQMS apiClient = new QMSClient();

           //retrieve a time limited service key
           ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

           //Retrieve all services.
           List<ServiceInfo> orderedServices = apiClient.GetServices(ServiceTypes.All).OrderBy(serviceInfo => serviceInfo.Type).ToList();

           ServiceTypes currentType = ServiceTypes.None;

           orderedServices.ForEach( service=>
               {
                   if(currentType != service.Type)
                   {
                       currentType = service.Type;
                       Console.WriteLine( "\n" + Enum.GetName(typeof(ServiceTypes), service.Type));
                   }
                   Console.WriteLine(String.Format("Name:{0}\nAddress:{1}", service.Name, service.Address));

               }

           );
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..ServiceTypes
PIX.QMSAPI.DataObjects..::..ServiceInfo


GetServiceStatuses Method

[image]

QlikView Management Service API
IQMS..::..GetServiceStatuses Method
IQMS Interface Example See Also Send Feedback
Gets the status of all services which matches the provided list of service ID's.

Namespace: PIX.Services

Syntax

C#
List<ServiceStatus> GetServiceStatuses(
    List<Guid> serviceIDs
)
Visual Basic
Function GetServiceStatuses ( _
    serviceIDs As List(Of Guid) _
) As List(Of ServiceStatus)

Parameters

serviceIDs
Type: System.Collections.Generic..::..List <(Of <(<' Guid >)>)>
A list of service IDs.

Return Value

A list of statuses of all services with a matching ID.

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

The following example starts by retrieving a list of all QDS-services and then asks for their status.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             // get a list of QDS services
             List<ServiceInfo> qdsServices = apiClient.GetServices(ServiceTypes.QlikViewDistributionService);
             if (qdsServices.Count > 0)
             {
                 //Get the service statuses of all the QDSs using their IDs
                 List<ServiceStatus> serviceStatuses = apiClient.GetServiceStatuses(qdsServices.Select(qdsService => qdsService.ID).ToList());

                 //Loop through all received statuses
                 foreach (ServiceStatus serviceStatus in serviceStatuses)
                 {
                 //Print the name of the service
                 Console.WriteLine(serviceStatus.Name);
                 //For all members, print the host they are executing on and their current status
                 serviceStatus.MemberStatusDetails.ForEach(serviceDetail => Console.WriteLine(serviceDetail.Host + ":" + serviceDetail.Status));
                 }
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
ServiceStatus
IQMS..::..GetServices(ServiceTypes)


GetSourceDocumentFolders Method

[image]

QlikView Management Service API
IQMS..::..GetSourceDocumentFolders Method
IQMS Interface Example See Also Send Feedback
Gets all source document folders for the QlikView Distribution Service with the specified ID.

Namespace: PIX.Services

Syntax

C#
List<DocumentFolder> GetSourceDocumentFolders(
    Guid qdsID,
    DocumentFolderScope scope
)
Visual Basic
Function GetSourceDocumentFolders ( _
    qdsID As Guid, _
    scope As DocumentFolderScope _
) As List(Of DocumentFolder)

Parameters

qdsID
Type: System..::..Guid
The ID of the QlikView Distribution Service for which to retrieve source document folders.
scope
Type: PIX.QMSAPI.DataObjects..::..DocumentFolderScope
The scope of the source document folders to retrieve.

Return Value

All source document folders with the specified scope for the QlikView Distribution Service with the specified ID.

Remarks

Only source document folders that the caller have access to will be returned.

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example uses the QMS API to retrieve a registered QlikView Distribution Service, all its source document folders and nodes. The GetSourceDocumentNodes(Guid, Guid, String) method is called recursively to print sub folders and source documents as a tree structure. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // get a list of QDS services
            List<ServiceInfo> qdsServices = apiClient.GetServices(ServiceTypes.QlikViewDistributionService);
            if (qdsServices.Count > 0)
            {
                // retrieve all source document folders for the first QDS in the list
                Console.WriteLine("The " + qdsServices[0].Name
                    + " contains has following source document file structure:" + Environment.NewLine);
                List<DocumentFolder> sourceDocumentsFolders = apiClient.GetSourceDocumentFolders(qdsServices[0].ID,
                    DocumentFolderScope.General | DocumentFolderScope.Services);
                // loop through all source document folders
                foreach (DocumentFolder sourceDocumentFolder in sourceDocumentsFolders.OrderBy(x => x.General.Path))
                {
                    // print the names of all source document folders, prefix with [R] for root folders
                    Console.WriteLine("[R] " + sourceDocumentFolder.General.Path);
                    // print all sub nodes of the current source document folder
                    PrintSourceDocumentNodes(apiClient, sourceDocumentFolder, string.Empty, 1);
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }

    static void PrintSourceDocumentNodes(IQMS apiClient, DocumentFolder sourceDocumentFolder,
        string relativePath, int indentationDepth)
    {
        // retrieve all source document nodes of the given folder and under the specified relative path
        List<DocumentNode> sourceDocumentNodes = apiClient.GetSourceDocumentNodes(sourceDocumentFolder.Services.QDSID,
            sourceDocumentFolder.ID, relativePath);
        // loop through all current source document nodes
        foreach (DocumentNode sourceDocumentNode in sourceDocumentNodes
            .OrderByDescending(x => x.IsSubFolder).ThenBy(x => x.Name))
        {
            // print the names of all source document nodes, indent and
            // prefix with [F] for folders and [D] for documents
            string indentation = new string(' ', indentationDepth * 3);
            string nodePrefix = (sourceDocumentNode.IsSubFolder ? "[F]" : "[D]");
            Console.WriteLine(indentation + nodePrefix + " " + sourceDocumentNode.Name);
            // print all sub nodes of the current source document node if it represents a folder
            if (sourceDocumentNode.IsSubFolder)
            {
                PrintSourceDocumentNodes(apiClient, sourceDocumentFolder,
                    relativePath + "\\" + sourceDocumentNode.Name, indentationDepth + 1);
            }
        }
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..DocumentFolder
PIX.QMSAPI.DataObjects..::..DocumentFolderScope
IQMS..::..GetUserDocumentFolders(Guid, DocumentFolderScope)
IQMS..::..GetDocumentFolder(Guid, DocumentFolderScope)
IQMS..::..GetSourceDocuments(Guid)
IQMS..::..GetSourceDocumentNodes(Guid, Guid, String)


GetSourceDocumentNodes Method

[image]

QlikView Management Service API
IQMS..::..GetSourceDocumentNodes Method
IQMS Interface Example See Also Send Feedback
Gets source document nodes for the specified relative path and the specified source document folder and QlikView Distribution Service ID.

Namespace: PIX.Services

Syntax

C#
List<DocumentNode> GetSourceDocumentNodes(
    Guid qdsID,
    Guid folderID,
    string relativePath
)
Visual Basic
Function GetSourceDocumentNodes ( _
    qdsID As Guid, _
    folderID As Guid, _
    relativePath As String _
) As List(Of DocumentNode)

Parameters

qdsID
Type: System..::..Guid
The QlikView Disitribution Service ID for which to retrieve source document nodes.
folderID
Type: System..::..Guid
The source document folder ID for which to retrieve source document nodes.
relativePath
Type: System..::..String
The relative path for which to retrieve source document nodes.

Return Value

Source document nodes for the specified relative path and the specified source document folder and QlikView Distribution Service ID.

Remarks

This method is typically used to retrieve the source documents as a tree structure. Each returned DocumentNode contains a RelativePath property which describes where in the tree structure the node belongs. It also contains a IsSubFolder property that indicates whether the node represents a sub folder or a document.

To retrieve the first level of nodes under the source document root folder specified by folderID, set the relativePath parameter to an empty string. For deeper levels of nodes, set the relativePath parameter to a path combined of the relative path and the name of the parent node at the previous level.

The first level of nodes under each source document root folder will always contain a sub folder named <Orphans> that contains a folder structure of "ghost" source documents. Any such "ghost" source documents have at least one task assigned to it, but the document itself does no longer exist. Such "ghost" source documents will automatically disappear from the orphans structure when its tasks are removed or when the source document exist again. The source document node representing the orphans sub folder and all its sub nodes will have the IsOrphan property set to trueTruetruetrue (True in Visual Basic).

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example uses the QMS API to retrieve a registered QlikView Distribution Service, all its source document folders and nodes. The GetSourceDocumentNodes(Guid, Guid, String) method is called recursively to print sub folders and source documents as a tree structure. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // get a list of QDS services
            List<ServiceInfo> qdsServices = apiClient.GetServices(ServiceTypes.QlikViewDistributionService);
            if (qdsServices.Count > 0)
            {
                // retrieve all source document folders for the first QDS in the list
                Console.WriteLine("The " + qdsServices[0].Name
                    + " contains has following source document file structure:" + Environment.NewLine);
                List<DocumentFolder> sourceDocumentsFolders = apiClient.GetSourceDocumentFolders(qdsServices[0].ID,
                    DocumentFolderScope.General | DocumentFolderScope.Services);
                // loop through all source document folders
                foreach (DocumentFolder sourceDocumentFolder in sourceDocumentsFolders.OrderBy(x => x.General.Path))
                {
                    // print the names of all soucrce document folders, prefix with [R] for root folders
                    Console.WriteLine("[R] " + sourceDocumentFolder.General.Path);
                    // print all sub nodes of the current source document folder
                    PrintSourceDocumentNodes(apiClient, sourceDocumentFolder, string.Empty, 1);
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }

    static void PrintSourceDocumentNodes(IQMS apiClient, DocumentFolder sourceDocumentFolder,
        string relativePath, int indentationDepth)
    {
        // retrieve all source document nodes of the given folder and under the specified relative path
        List<DocumentNode> sourceDocumentNodes = apiClient.GetSourceDocumentNodes(sourceDocumentFolder.Services.QDSID,
            sourceDocumentFolder.ID, relativePath);
        // loop through all current source document nodes
        foreach (DocumentNode sourceDocumentNode in sourceDocumentNodes
            .OrderByDescending(x => x.IsSubFolder).ThenBy(x => x.Name))
        {
            // print the names of all source document nodes, indent and
            // prefix with [F] for folders and [D] for documents
            string indentation = new string(' ', indentationDepth * 3);
            string nodePrefix = (sourceDocumentNode.IsSubFolder ? "[F]" : "[D]");
            Console.WriteLine(indentation + nodePrefix + " " + sourceDocumentNode.Name);
            // print all sub nodes of the current source document node if it represents a folder
            if (sourceDocumentNode.IsSubFolder)
            {
                PrintSourceDocumentNodes(apiClient, sourceDocumentFolder,
                    relativePath + "\\" + sourceDocumentNode.Name, indentationDepth + 1);
            }
        }
    }
}

Exceptions

Exception | Condition
System..::..Exception | Thrown if the caller does not have access to the source document folder with the specified ID.

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..DocumentNode
IQMS..::..GetSourceDocuments(Guid)
IQMS..::..GetSourceDocumentFolders(Guid, DocumentFolderScope)
IQMS..::..GetUserDocumentNodes(Guid, Guid, String)


GetSourceDocuments Method

[image]

QlikView Management Service API
IQMS..::..GetSourceDocuments Method
IQMS Interface Example See Also Send Feedback
Gets all source documents for the QlikView Distribution Service with the specified ID.

Namespace: PIX.Services

Syntax

C#
List<DocumentNode> GetSourceDocuments(
    Guid qdsID
)
Visual Basic
Function GetSourceDocuments ( _
    qdsID As Guid _
) As List(Of DocumentNode)

Parameters

qdsID
Type: System..::..Guid
The ID of the QlikView Distribution Service for which to retrieve source documents.

Return Value

All source documents for the QlikView Distribution Service with the specified ID.

Remarks

Only source documents that belongs to source document folders that the caller have access to will be returned.

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example uses the QMS API to retrieve a registered QlikView Distribution Service and all its source documents. The names and paths of the source documents are then printed. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.IO;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // get a list of QDS services
            List<ServiceInfo> qdsServices = apiClient.GetServices(ServiceTypes.QlikViewDistributionService);
            if (qdsServices.Count > 0)
            {
                // retrieve all source documents for the first QDS in the list
                List<DocumentNode> sourceDocuments = apiClient.GetSourceDocuments(qdsServices[0].ID);
                // print the names of all source documents
                Console.WriteLine("The " + qdsServices[0].Name + " contains the following source documents:" + Environment.NewLine);
                foreach (DocumentNode sourceDocument in sourceDocuments.OrderBy(x => x.RelativePath).ThenBy(x => x.Name))
                {
                    Console.WriteLine(Path.Combine(sourceDocument.RelativePath, sourceDocument.Name));
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..DocumentNode
IQMS..::..GetSourceDocumentFolders(Guid, DocumentFolderScope)
IQMS..::..GetSourceDocumentNodes(Guid, Guid, String)
IQMS..::..GetUserDocuments(Guid)


GetTask Method

[image]

QlikView Management Service API
IQMS..::..GetTask Method
IQMS Interface Example See Also Send Feedback
Retrieves a single task using its id.

Namespace: PIX.Services

Syntax

C#
TaskInfo GetTask(
    Guid taskID
)
Visual Basic
Function GetTask ( _
    taskID As Guid _
) As TaskInfo

Parameters

taskID
Type: System..::..Guid
The task ID.

Return Value

A task with the provided ID.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example retrieves all services, ordered by type, and prints them.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
           // create a QMS API client
           IQMS apiClient = new QMSClient();

           //retrieve a time limited service key
           ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

           //Some known task id
           Guid taskId = new Guid("5ac16136-f00b-47c4-8099-23ff7f178423");

           TaskInfo taskInfo = apiClient.GetTask(taskId);

           if(taskInfo != null) {
               Console.WriteLine(String.Format("Name:{0}\nEnabled:{1}\nID:{2}\nQDSID:{3}\nType:{4}", taskInfo.Name, taskInfo.Enabled ? "Yes" : "No", taskInfo.ID, taskInfo.QDSID, Enum.GetName(typeof(TaskType), taskInfo.Type)));
           }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


GetTasks Method

[image]

QlikView Management Service API
IQMS..::..GetTasks Method
IQMS Interface Example See Also Send Feedback
Retrieves all task from a QDS.

Namespace: PIX.Services

Syntax

C#
List<TaskInfo> GetTasks(
    Guid qdsID
)
Visual Basic
Function GetTasks ( _
    qdsID As Guid _
) As List(Of TaskInfo)

Parameters

qdsID
Type: System..::..Guid
The QDS ID.

Return Value

A list of all tasks present on the QDS.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example retrieves a list of the tasks on the QDS and displays the task name of the first element.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

 class Program
 {
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             Guid qdsId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The originating QDS ID.
             IList<TaskInfo> taskInfoList = apiClient.GetTasks(qdsId); // A service call.
             Console.WriteLine(taskInfoList[0].Name); // Prints the name of the first task.
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..SaveDocumentTask(DocumentTask)
IQMS..::..GetTasksForDocument(Guid)
IQMS..::..GetDocumentTask(Guid, DocumentTaskScope)
IQMS..::..DeleteTask(Guid, TaskType)
IQMS..::..RunTask(Guid)
IQMS..::..AbortTask(Guid)
IQMSGetTaskLog(Guid, Guid, Int32)


GetTasksForDocument Method

[image]

QlikView Management Service API
IQMS..::..GetTasksForDocument Method
IQMS Interface Example See Also Send Feedback
Gets the tasks for document.

Namespace: PIX.Services

Syntax

C#
List<TaskInfo> GetTasksForDocument(
    Guid documentID
)
Visual Basic
Function GetTasksForDocument ( _
    documentID As Guid _
) As List(Of TaskInfo)

Parameters

documentID
Type: System..::..Guid
The document ID.

Return Value

A list of all tasks associated with a specific document.

Remarks

Each document can have tasks associated with it.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example retrieves a list of the tasks associated with a specific document and displays the task name of the first element.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

 class Program
 {
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             Guid documentId = new Guid("e95ecd5a-683d-1d33-26bf-66e94ff08223");
             IList<TaskInfo> documentTasks = apiClient.GetTasksForDocument(documentId); // A service call.
             Console.WriteLine(documentTasks[0].Name); // Displays the name of the first element.
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..SaveDocumentTask(DocumentTask)
IQMS..::..GetTasks(Guid)
IQMS..::..GetDocumentTask(Guid, DocumentTaskScope)
IQMS..::..DeleteTask(Guid, TaskType)
IQMS..::..RunTask(Guid)
IQMS..::..AbortTask(Guid)
IQMSGetTaskLog(Guid, Guid, Int32)


GetTaskStatus Method

[image]

QlikView Management Service API
IQMS..::..GetTaskStatus Method
IQMS Interface Example See Also Send Feedback
Gets the status of a task.

Namespace: PIX.Services

Syntax

C#
TaskStatus GetTaskStatus(
    Guid taskID,
    TaskStatusScope scope
)
Visual Basic
Function GetTaskStatus ( _
    taskID As Guid, _
    scope As TaskStatusScope _
) As TaskStatus

Parameters

taskID
Type: System..::..Guid
The ID of the task.
scope
Type: PIX.QMSAPI.DataObjects..::..TaskStatusScope
The scope.

Return Value

Depending on the scope it can return the task name, current operating status and other metadata information.

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

The following code example retrieves the extended metadata for a specific task and then writes it to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid taskId = new Guid("28a4fae4-8e75-4681-8ddc-751b7664a025"); //A known task id.
            TaskStatus taskStatus = apiClient.GetTaskStatus(taskId, TaskStatusScope.Extended); // A service call.
            Console.WriteLine(taskStatus.Extended.TaskSummary); // Print the resulting task summary.
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..GetTaskStatusNodes(List<(Of <<'(TaskStatusNodeRequest>)>>), TaskStatusFilter, TaskStatusScope)
IQMS..::..GetTaskStatuses(TaskStatusFilter, TaskStatusScope)
IQMS..::..Ping()()()()


GetTaskStatuses Method

[image]

QlikView Management Service API
IQMS..::..GetTaskStatuses Method
IQMS Interface Example See Also Send Feedback
Gets the task statuses.

Namespace: PIX.Services

Syntax

C#
List<TaskStatus> GetTaskStatuses(
    TaskStatusFilter filter,
    TaskStatusScope scope
)
Visual Basic
Function GetTaskStatuses ( _
    filter As TaskStatusFilter, _
    scope As TaskStatusScope _
) As List(Of TaskStatus)

Parameters

filter
Type: PIX.QMSAPI.DataObjects..::..TaskStatusFilter
Filter filter to be used on the result.
scope
Type: PIX.QMSAPI.DataObjects..::..TaskStatusScope
The scope.

Return Value

Depending on the filter and scope it can return a list of all the task names, current operating status and other metadata information.

Remarks

Note
This method does not support filtering on a certain FromDate. If this is required, GetTaskStatusNodes should be used instead.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example retrieves a list of all task statuses which are running, and then writes part of the extended metadata of the first element in the list to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            TaskStatusFilter taskStatusFilter = new TaskStatusFilter();
            taskStatusFilter.TaskStatuses.Add(TaskStatusValue.Running);
            List<TaskStatus> taskStatuses = apiClient.GetTaskStatuses(taskStatusFilter, TaskStatusScope.Extended); // A service call.
            Console.WriteLine(taskStatuses[0].Extended.TaskSummary.ToString()); // Print part of the metadata of the first element in the list.
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..GetTaskStatusNodes(List<(Of <<'(TaskStatusNodeRequest>)>>), TaskStatusFilter, TaskStatusScope)
IQMS..::..GetTaskStatus(Guid, TaskStatusScope)
IQMS..::..Ping()()()()


GetTaskStatusNodes Method

[image]

QlikView Management Service API
IQMS..::..GetTaskStatusNodes Method
IQMS Interface Example See Also Send Feedback
Gets the task status nodes.

Namespace: PIX.Services

Syntax

C#
List<TaskStatusNode> GetTaskStatusNodes(
    List<TaskStatusNodeRequest> taskStatusNodeRequests,
    TaskStatusFilter filter,
    TaskStatusScope scope
)
Visual Basic
Function GetTaskStatusNodes ( _
    taskStatusNodeRequests As List(Of TaskStatusNodeRequest), _
    filter As TaskStatusFilter, _
    scope As TaskStatusScope _
) As List(Of TaskStatusNode)

Parameters

taskStatusNodeRequests
Type: System.Collections.Generic..::..List <(Of <(<' TaskStatusNodeRequest >)>)>
The task status node requests.
filter
Type: PIX.QMSAPI.DataObjects..::..TaskStatusFilter
The filter to be used
scope
Type: PIX.QMSAPI.DataObjects..::..TaskStatusScope
The scope.

Return Value

A list of matching TaskStatusNodes

Remarks

Return a type depending on whether or not QDS ID and/or category name is specified, but never return a type that is higher up in the type chain than the root type; QDS > Category > Task > Dependent Task

Using DependentTask as root type in the request list will produce an error since it is implicitly a child element.

QDS ID specified | Category name specified | Task ID specified | Root type: QDS | Root type: Category | Root type: Task
No | No | No | QDS | Category | Task
Yes | No | No | Category | Category | Task
No | Yes | No | --- | Task | Task
Yes | Yes | No | Task | Task | Task
No | No | Yes | --- | --- | Dep.Task
Yes | No | Yes | --- | --- | Dep.Task
No | Yes | Yes | --- | Dep.Task | Dep.Task
Yes | Yes | Yes | Dep.Task | Dep.Task | Dep.Task
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example shows how to make a GetTaskStatusNodes service call. It starts by adding a new task status node request array. We also need to populate the array with an object or any attempt to traverse the array will end in an exception. Next a filter is created which says that only failed document tasks. Finally it retrieves the task status nodes for this object. It will produce a list of the categories at the root level of that specific QDS.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Threading;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid qdsId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The originating QDS ID.
            List<TaskStatusNodeRequest> taskStatusNodeRequests = new List<TaskStatusNodeRequest>(); // Creating a new task status node request array.
            TaskStatusNodeRequest taskStatusNodeRequest = new TaskStatusNodeRequest(); // Populating the array with a new object.
            taskStatusNodeRequest.RootType = TaskStatusNodeType.QDS;
            taskStatusNodeRequest.QDSID = qdsId;
            taskStatusNodeRequests.Add(taskStatusNodeRequest);

            TaskStatusFilter taskStatusFilter = new TaskStatusFilter();
            taskStatusFilter.TaskStatuses.Add(TaskStatusValue.Failed);
            taskStatusFilter.TaskTypes.Add(TaskType.DocumentTask);

            List<TaskStatusNode> statusNodes = apiClient.GetTaskStatusNodes(taskStatusNodeRequests, taskStatusFilter, TaskStatusScope.All); // A service call using the array and a scope.
            foreach(TaskStatusNode node in statusNodes) {
                Console.WriteLine(node.Name + "\\t" + node.Status);
            }

        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..GetTaskStatuses(TaskStatusFilter, TaskStatusScope)
IQMS..::..GetTaskStatus(Guid, TaskStatusScope)
IQMS..::..Ping()()()()


GetTimeLimitedServiceKey Method

[image]

QlikView Management Service API
IQMS..::..GetTimeLimitedServiceKey Method
IQMS Interface Example See Also Send Feedback
Gets a time limited service key.

Namespace: PIX.Services

Syntax

C#
string GetTimeLimitedServiceKey()
Visual Basic
Function GetTimeLimitedServiceKey As String

Return Value

A service key that is valid for one minute.

Remarks

A service key returned by this method should be supplied as a HTTP header of each other operation call. See the Introduction for more information on how to use the service key.

Examples

See the Samples for examples on how this method can be used.

See Also

IQMS Interface
PIX.Services Namespace


GetUserDocumentFolders Method

[image]

QlikView Management Service API
IQMS..::..GetUserDocumentFolders Method
IQMS Interface Example See Also Send Feedback
Gets all user document folders for the QlikView Server with the specified ID.

Namespace: PIX.Services

Syntax

C#
List<DocumentFolder> GetUserDocumentFolders(
    Guid qvsID,
    DocumentFolderScope scope
)
Visual Basic
Function GetUserDocumentFolders ( _
    qvsID As Guid, _
    scope As DocumentFolderScope _
) As List(Of DocumentFolder)

Parameters

qvsID
Type: System..::..Guid
The ID of the QlikView Server for which to retrieve user document folders.
scope
Type: PIX.QMSAPI.DataObjects..::..DocumentFolderScope
The scope of the user document folders to retrieve.

Return Value

All user document folders with the specified scope for the QlikView Server with the specified ID.

Remarks

Only user document folders that the caller have access to will be returned.

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example uses the QMS API to retrieve a registered QlikView Server, all its user document folders and nodes. The GetUserDocumentNodes(Guid, Guid, String) method is called recursively to print sub folders and user documents as a tree structure. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.IO;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // get a list of QVS services
            List<ServiceInfo> qvsServices = apiClient.GetServices(ServiceTypes.QlikViewServer);
            if (qvsServices.Count > 0)
            {
                // retrieve all user document folders for the first QVS in the list
                Console.WriteLine("The " + qvsServices[0].Name
                    + " contains has following user document file structure:" + Environment.NewLine);
                List<DocumentFolder> userDocumentsFolders = apiClient.GetUserDocumentFolders(qvsServices[0].ID,
                    DocumentFolderScope.General | DocumentFolderScope.Services);
                // loop through all user document folders
                foreach (DocumentFolder userDocumentFolder in userDocumentsFolders.OrderBy(x => x.General.Path))
                {
                    // print the names of all user document folders,
                    // prefix with [R] for root folder and [M] for mounts
                    string folderPrefix = (string.IsNullOrEmpty(userDocumentFolder.General.Path) ? "[R]" : "[M]");
                    string folderName = (string.IsNullOrEmpty(userDocumentFolder.General.Path)
                        ? qvsServices[0].Name : userDocumentFolder.General.Path);
                    Console.WriteLine(folderPrefix + " " + folderName);
                    // print all sub nodes of the current user document folder
                    PrintUserDocumentNodes(apiClient, userDocumentFolder, string.Empty, 1);
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }

    static void PrintUserDocumentNodes(IQMS apiClient, DocumentFolder userDocumentFolder,
        string relativePath, int indentationDepth)
    {
        // retrieve all user document nodes of the given folder and under the specified relative path
        List<DocumentNode> userDocumentNodes = apiClient.GetUserDocumentNodes(userDocumentFolder.Services.QVSID,
            userDocumentFolder.ID, relativePath);
        // loop through all current user document nodes
        foreach (DocumentNode userDocumentNode in userDocumentNodes
            .OrderByDescending(x => x.IsSubFolder).ThenBy(x => x.Name))
        {
            // print the names of all user document nodes, indent and
            // prefix with [F] for folders and [D] for documents
            string indentation = new string(' ', indentationDepth * 3);
            string nodePrefix = (userDocumentNode.IsSubFolder ? "[F]" : "[D]");
            Console.WriteLine(indentation + nodePrefix + " " + userDocumentNode.Name);
            // print all sub nodes of the current user document node if it represents a folder
            if (userDocumentNode.IsSubFolder)
            {
                PrintUserDocumentNodes(apiClient, userDocumentFolder,
                    Path.Combine(relativePath, userDocumentNode.Name), indentationDepth + 1);
            }
        }
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..DocumentFolder
PIX.QMSAPI.DataObjects..::..DocumentFolderScope
IQMS..::..GetSourceDocumentFolders(Guid, DocumentFolderScope)
IQMS..::..GetDocumentFolder(Guid, DocumentFolderScope)
IQMS..::..GetUserDocuments(Guid)
IQMS..::..GetUserDocumentNodes(Guid, Guid, String)


GetUserDocumentNodes Method

[image]

QlikView Management Service API
IQMS..::..GetUserDocumentNodes Method
IQMS Interface Example See Also Send Feedback
Gets user document nodes for the specified relative path and the specified user document folder and QlikView Server ID.

Namespace: PIX.Services

Syntax

C#
List<DocumentNode> GetUserDocumentNodes(
    Guid qvsID,
    Guid folderID,
    string relativePath
)
Visual Basic
Function GetUserDocumentNodes ( _
    qvsID As Guid, _
    folderID As Guid, _
    relativePath As String _
) As List(Of DocumentNode)

Parameters

qvsID
Type: System..::..Guid
The QlikView Server ID for which to retrieve user document nodes.
folderID
Type: System..::..Guid
The user document folder ID for which to retrieve user document nodes.
relativePath
Type: System..::..String
The relative path for which to retrieve user document nodes.

Return Value

User document nodes for the specified relative path and the specified user document folder and QlikView Server ID.

Remarks

This method is typically used to retrieve the user documents as a tree structure. Each returned DocumentNode contains a RelativePath property which describes where in the tree structure the node belongs. It also contains a IsSubFolder property that indicates whether the node represents a sub folder or a document.

To retrieve the first level of nodes under the user document folder specified by folderID, set the relativePath parameter to an empty string. For deeper levels of nodes, set the relativePath parameter to a path combined of the relative path and the name of the parent node at the previous level.

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example uses the QMS API to retrieve a registered QlikView Server, all its user document folders and nodes. The GetUserDocumentNodes(Guid, Guid, String) method is called recursively to print sub folders and user documents as a tree structure. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes.

CopyC#
using System;
using System.Collections.Generic;
using System.IO;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // get a list of QVS services
            List<ServiceInfo> qvsServices = apiClient.GetServices(ServiceTypes.QlikViewServer);
            if (qvsServices.Count > 0)
            {
                // retrieve all user document folders for the first QVS in the list
                Console.WriteLine("The " + qvsServices[0].Name
                    + " contains has following user document file structure:" + Environment.NewLine);
                List<DocumentFolder> userDocumentsFolders = apiClient.GetUserDocumentFolders(qvsServices[0].ID,
                    DocumentFolderScope.General | DocumentFolderScope.Services);
                // loop through all user document folders
                foreach (DocumentFolder userDocumentFolder in userDocumentsFolders.OrderBy(x => x.General.Path))
                {
                    // print the names of all user document folders,
                    // prefix with [R] for root folder and [M] for mounts
                    string folderPrefix = (string.IsNullOrEmpty(userDocumentFolder.General.Path) ? "[R]" : "[M]");
                    string folderName = (string.IsNullOrEmpty(userDocumentFolder.General.Path)
                        ? qvsServices[0].Name : userDocumentFolder.General.Path);
                    Console.WriteLine(folderPrefix + " " + folderName);
                    // print all sub nodes of the current user document folder
                    PrintUserDocumentNodes(apiClient, userDocumentFolder, string.Empty, 1);
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }

    static void PrintUserDocumentNodes(IQMS apiClient, DocumentFolder userDocumentFolder,
        string relativePath, int indentationDepth)
    {
        // retrieve all user document nodes of the given folder and under the specified relative path
        List<DocumentNode> userDocumentNodes = apiClient.GetUserDocumentNodes(userDocumentFolder.Services.QVSID,
            userDocumentFolder.ID, relativePath);
        // loop through all current user document nodes
        foreach (DocumentNode userDocumentNode in userDocumentNodes
            .OrderByDescending(x => x.IsSubFolder).ThenBy(x => x.Name))
        {
            // print the names of all user document nodes, indent and
            // prefix with [F] for folders and [D] for documents
            string indentation = new string(' ', indentationDepth * 3);
            string nodePrefix = (userDocumentNode.IsSubFolder ? "[F]" : "[D]");
            Console.WriteLine(indentation + nodePrefix + " " + userDocumentNode.Name);
            // print all sub nodes of the current user document node if it represents a folder
            if (userDocumentNode.IsSubFolder)
            {
                PrintUserDocumentNodes(apiClient, userDocumentFolder,
                    Path.Combine(relativePath, userDocumentNode.Name), indentationDepth + 1);
            }
        }
    }
}

Exceptions

Exception | Condition
System..::..Exception | Thrown if the caller does not have access to the user document folder with the specified ID.

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..DocumentNode
IQMS..::..GetUserDocuments(Guid)
IQMS..::..GetUserDocumentFolders(Guid, DocumentFolderScope)
IQMS..::..GetSourceDocumentNodes(Guid, Guid, String)


GetUserDocuments Method

[image]

QlikView Management Service API
IQMS..::..GetUserDocuments Method
IQMS Interface Example See Also Send Feedback
Gets all user documents for the QlikView Server with the specified ID.

Namespace: PIX.Services

Syntax

C#
List<DocumentNode> GetUserDocuments(
    Guid qvsID
)
Visual Basic
Function GetUserDocuments ( _
    qvsID As Guid _
) As List(Of DocumentNode)

Parameters

qvsID
Type: System..::..Guid
The ID of the QlikView Server for which to retrieve user documents.

Return Value

All user documents for the QlikView Server with the specified ID.

Remarks

Only user documents that belongs to user document folders that the caller have access to will be returned.

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example uses the QMS API to clear the QlikView Server cache, retrieve a registered QlikView Server and all its user documents. The names and paths of the user documents are then printed. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes.

CopyC#
using System;
using System.Collections.Generic;
using System.IO;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // clear the QMS's QVS object cache from user document listings
            // so that the any new user documents can be discovered
            apiClient.ClearQVSCache(QVSCacheObjects.UserDocumentList);
            // get a list of QVS services
            List<ServiceInfo> qvsServices = apiClient.GetServices(ServiceTypes.QlikViewServer);
            if (qvsServices.Count > 0)
            {
                // retrieve all user documents for the first QVS in the list
                List<DocumentNode> userDocuments = apiClient.GetUserDocuments(qvsServices[0].ID);
                // print the names of all user documents
                Console.WriteLine("The " + qvsServices[0].Name + " contains the following user documents:" + Environment.NewLine);
                foreach (DocumentNode userDocument in userDocuments.OrderBy(x => x.RelativePath).ThenBy(x => x.Name))
                {
                    Console.WriteLine(Path.Combine(userDocument.RelativePath, userDocument.Name));
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..DocumentNode
IQMS..::..GetUserDocumentFolders(Guid, DocumentFolderScope)
IQMS..::..GetUserDocumentNodes(Guid, Guid, String)
IQMS..::..ClearQVSCache(QVSCacheObjects)
IQMS..::..GetSourceDocuments(Guid)


ImportAllDocumentTasksForQds Method

[image]

QlikView Management Service API
IQMS..::..ImportAllDocumentTasksForQds Method
IQMS Interface Example See Also Send Feedback
Imports all document tasks from a remote QlikView Distribution Server.

Namespace: PIX.Services

Syntax

C#
void ImportAllDocumentTasksForQds(
    Guid remoteQmsId,
    Guid remoteQdsId,
    Guid destinationQdsId
)
Visual Basic
Sub ImportAllDocumentTasksForQds ( _
    remoteQmsId As Guid, _
    remoteQdsId As Guid, _
    destinationQdsId As Guid _
)

Parameters

remoteQmsId
Type: System..::..Guid
The ID of the remote QlikView Management Console managing the QlikView Distribution Service.
remoteQdsId
Type: System..::..Guid
The ID of the remote QlikView Distribution Service.
destinationQdsId
Type: System..::..Guid
The ID of the QlikView Distribution Service receiving the tasks.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example imports all document tasks from one QlikView Distribution Service to another.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo remoteQMSService = apiClient.GetServices(ServiceTypes.RemoteQlikViewManagementService).FirstOrDefault();

            if (remoteQMSService != null)
            {
                ServiceInfo remoteQDS = apiClient.RemoteGetServices(remoteQMSService.ID, ServiceTypes.QlikViewDistributionService).FirstOrDefault();
                ServiceInfo destinationQDS = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();

                if(remoteQDS != null && destinationQDS != null)
                {
                    apiClient.ImportAllDocumentTasksForQds( remoteQMSService.ID, remoteQDS.ID, destinationQDS.ID);
                }

            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


ImportDocumentTask Method

[image]

QlikView Management Service API
IQMS..::..ImportDocumentTask Method
IQMS Interface Example See Also Send Feedback
Imports a single document task from a remote QlikView Distribution Server.

Namespace: PIX.Services

Syntax

C#
void ImportDocumentTask(
    Guid remoteQmsId,
    Guid remoteDocumentTaskId,
    Guid destinationQdsId,
    DocumentNode destinationDocument
)
Visual Basic
Sub ImportDocumentTask ( _
    remoteQmsId As Guid, _
    remoteDocumentTaskId As Guid, _
    destinationQdsId As Guid, _
    destinationDocument As DocumentNode _
)

Parameters

remoteQmsId
Type: System..::..Guid
The ID of the remote QMS.
remoteDocumentTaskId
Type: System..::..Guid
The ID of the remote task to be imported.
destinationQdsId
Type: System..::..Guid
The ID of the QDS to which the task is to be imported.
destinationDocument
Type: PIX.QMSAPI.DataObjects..::..DocumentNode
The document to import the task to.

Remarks

Only source document folders that the caller have access to will be returned.

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

In the example below, a list of tasks is retrieved for a known source document on a remote QlikView Management Service. Each task is imported to a document on the "local" QMS.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Find a the remote QMS service.
            ServiceInfo remoteQMSService = apiClient.GetServices(ServiceTypes.RemoteQlikViewManagementService).FirstOrDefault();

            //Find a local QDS service
            ServiceInfo localQDS = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();

            //Get the tasks of a remote document.
            Guid remoteDocId = new Guid ("12a32214-1122-112a-8099-8765ce564112"); // The remote document ID.
            List<TaskInfo> taskInfos = apiClient.RemoteGetTaskListForDocID(remoteQMSService.ID, remoteDocId);

            //Get a local document.
            Guid localDocId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The local document ID.
            DocumentNode destinationDocument = apiClient.GetSourceDocuments(localQDS.ID).Where(dn => dn.ID == localDocId).FirstOrDefault();

            if (destinationDocument != null)
            {
                //Apply each remote task on the local document.
                foreach(TaskInfo taskInfo in taskInfos) {
                    apiClient.ImportDocumentTask(remoteQMSService.ID, taskInfo.ID, localQDS.ID, destinationDocument);
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


InitiateUploadExtensionObject Method

[image]

QlikView Management Service API
IQMS..::..InitiateUploadExtensionObject Method
IQMS Interface Example See Also Send Feedback
Initiates an new upload of an extension object.

Namespace: PIX.Services

Syntax

C#
ExtensionUploadHandle InitiateUploadExtensionObject(
    Guid qvsId
)
Visual Basic
Function InitiateUploadExtensionObject ( _
    qvsId As Guid _
) As ExtensionUploadHandle

Parameters

qvsId
Type: System..::..Guid
The ID of the QVS where the upload should be placed.

Return Value

A handle which holds information about the upload.

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

The following code example uploads a document extension to a QVS.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.IO;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //This is a valid QVS guid
            Guid qvsId = new Guid("{6afbbc64-9681-406b-8917-e78bc370a05c}");

            //Initiate the upload
            ExtensionUploadHandle handle = apiClient.InitiateUploadExtensionObject(qvsId);

            if (handle != null)
            {
                FileStream fs = new FileStream(@"C:\FlexiGrid.qar", FileMode.Open);

                int maxBufferSize = 1024 * 16;

                byte[] buffer = new byte[maxBufferSize];
                int bytesRead;

                while ((bytesRead = fs.Read(buffer, 0, maxBufferSize)) > 0)
                {
                    //Copy the read bytes into a new buffer with the same size as the number of received bytes
                    byte[] byteWireBuffer = new byte[bytesRead];
                    Buffer.BlockCopy(buffer, 0, byteWireBuffer, 0, bytesRead);

                    //Write the buffer to the QVS
                    handle = apiClient.WriteExtensionObject(handle, byteWireBuffer);
                }

                //Finalize the upload. This will install the extension object if it is valid.
                List<QVSMessage> msg = apiClient.CloseAndInstallExtensionObject(handle);
                msg.ForEach(m => Console.WriteLine(m.Text));
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..ExtensionUploadHandle


IsPublisherQDS Method

[image]

QlikView Management Service API
IQMS..::..IsPublisherQDS Method
IQMS Interface Example See Also Send Feedback
This method checks if a QlikView Distribition Service has a publisher license or not.

Namespace: PIX.Services

Syntax

C#
bool IsPublisherQDS(
    Guid qdsID
)
Visual Basic
Function IsPublisherQDS ( _
    qdsID As Guid _
) As Boolean

Parameters

qdsID
Type: System..::..Guid
The ID of the QlikView Distribution Service.

Return Value

True if the distribution service has a publisher license set, otherwise false.

Remarks

Security Note

Requires membership of local groups QlikView Management API.

Examples

This example retrieves all Distribution Services and checks whether they have a valid Publisher license or not.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

 class Program
 {
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a list of QlikView Distribution Services.
            List<ServiceInfo> qdsServices = apiClient.GetServices(ServiceTypes.QlikViewDistributionService);

            //Loop through the list and write whether it is licensed as publisher or not.
            qdsServices.ForEach( delegate(ServiceInfo info)
                {
                    Console.Write("{0}({1}) is ",info.Name, info.Address);
                    Console.WriteLine(apiClient.IsPublisherQDS(info.ID) ? "a publisher." : "not a publisher.");
                  ;
                }
            );
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace


LookupNames Method

[image]

QlikView Management Service API
IQMS..::..LookupNames Method
IQMS Interface Example See Also Send Feedback
Given a list of user or group names, this method performs a lookup of each name on a Directory Service Connector.

Namespace: PIX.Services

Syntax

C#
List<DirectoryServiceObject> LookupNames(
    Guid dscID,
    List<string> names
)
Visual Basic
Function LookupNames ( _
    dscID As Guid, _
    names As List(Of String) _
) As List(Of DirectoryServiceObject)

Parameters

dscID
Type: System..::..Guid
The ID of the Directory Service Connector to perform the lookup on.
names
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A list of names to lookup.

Return Value

A list of found users or groups.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

In the example below, a set of users and groups are added as recipients to an existing document task.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a Directory Service Connector
            ServiceInfo dscService = apiClient.GetServices(ServiceTypes.QlikViewDirectoryServiceConnector).FirstOrDefault();

            Guid docId = new Guid("12a32214-1122-112a-8099-8765ce564112"); // The document ID.

            //Get the task. Only the distribtion details are neede.
            DocumentTask someTask = apiClient.GetDocumentTask(docId, DocumentTaskScope.Distribute);

            if (dscService != null && someTask != null)
            {
                //Create a list with two users and one group.
                List<string> names = new List<string>(){"johnb","lindac","Sales", "Finance"};

                //Lookup the names in the list.
                List<DirectoryServiceObject> dsObjects = apiClient.LookupNames(dscService.ID, names);

                if(dsObjects != null) {

                    //Add the found users/groups to the receivers of all static distributions.
                    foreach( TaskDistributionEntry distEntry in someTask.Distribute.Static.DistributionEntries)
                    {
                        distEntry.Recipients.AddRange(dsObjects);
                    }

                    //Save the task
                    apiClient.SaveDocumentTask(someTask);
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


Ping Method

[image]

QlikView Management Service API
IQMS..::..Ping Method
IQMS Interface See Also Send Feedback
Pings this instance.

Namespace: PIX.Services

Syntax

C#
void Ping()
Visual Basic
Sub Ping

Remarks

Provides a way to see if the server is running and responding to requests.
Security Note

Requires membership of local group QlikView Management API.

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..GetTaskStatusNodes(List<(Of <<'(TaskStatusNodeRequest>)>>), TaskStatusFilter, TaskStatusScope)
IQMS..::..GetTaskStatuses(TaskStatusFilter, TaskStatusScope)
IQMS..::..GetTaskStatus(Guid, TaskStatusScope)
IQMS..::..GetTimeLimitedServiceKey()()()()


QDSNeedRestart Method

[image]

QlikView Management Service API
IQMS..::..QDSNeedRestart Method
IQMS Interface Example See Also Send Feedback
Sets that the QDS needs a restart.

Namespace: PIX.Services

Syntax

C#
bool QDSNeedRestart(
    Guid qdsID,
    out string reason
)
Visual Basic
Function QDSNeedRestart ( _
    qdsID As Guid, _
    <OutAttribute> ByRef reason As String _
) As Boolean

Parameters

qdsID
Type: System..::..Guid
The QDS ID.
reason
Type: System..::..String %
The reason for the restart.

Return Value

The service returns the boolean value True if the operation was performed successfully.

Remarks

The service sets the server to accept that it needs to be restarted. A string named Reason can be sent to the service as part of the call, which is useful for logging purposes.
Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This code example checks if the QDS is set to need a restart and then executes the restart.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using System.Threading;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             Guid qdsId = new Guid("67968710-6a84-446d-b759-ceb0cc9d656f"); // The originating QDS ID
             String RestartReason;
             if (apiClient.QDSNeedRestart(out RestartReason, qdsId) == true)    //QDS requires restart if DocFolder changed
             {
                 Console.WriteLine("QDS will be restarted. Reason: " + RestartReason);
                 apiClient.RestartQDS(qdsId);
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..RestartQDS(Guid)


QVSNeedRestart Method

[image]

QlikView Management Service API
IQMS..::..QVSNeedRestart Method
IQMS Interface Example See Also Send Feedback
Sets that the QVS needs a restart.

Namespace: PIX.Services

Syntax

C#
bool QVSNeedRestart(
    Guid qvsID,
    out string reason
)
Visual Basic
Function QVSNeedRestart ( _
    qvsID As Guid, _
    <OutAttribute> ByRef reason As String _
) As Boolean

Parameters

qvsID
Type: System..::..Guid
The QVS ID.
reason
Type: System..::..String %
The reason for the restart.

Return Value

The service returns the boolean value True if the operation was performed successfully.

Remarks

The service sets the server to accept that it needs to be restarted. A string named Reason can be sent to the service as part of the call, which is useful for logging purposes.
Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This code example checks if the QVS is set to need a restart and then executes the restart.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid qvsId = new Guid("e07c145f-7606-4161-b986-b4288650e3b7"); // The originating QVS ID
            String RestartReason;
            if (apiClient.QVSNeedRestart(out RestartReason, qvsId) == true)    //QVS requires restart if DocFolder changed
            {
                Console.WriteLine("QVS will be restarted. Reason: " + RestartReason);
                apiClient.RestartQVS(qvsId);
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..RestartQVS(Guid)


RemoteGetDocumentTask Method

[image]

QlikView Management Service API
IQMS..::..RemoteGetDocumentTask Method
IQMS Interface Example See Also Send Feedback
Retrieves a single task from a remote QlikView Management Service.

Namespace: PIX.Services

Syntax

C#
DocumentTask RemoteGetDocumentTask(
    Guid remoteQmsId,
    Guid taskId,
    DocumentTaskScope scope
)
Visual Basic
Function RemoteGetDocumentTask ( _
    remoteQmsId As Guid, _
    taskId As Guid, _
    scope As DocumentTaskScope _
) As DocumentTask

Parameters

remoteQmsId
Type: System..::..Guid
The ID of the remote QlikView Management Service.
taskId
Type: System..::..Guid
The ID of the task to import.
scope
Type: PIX.QMSAPI.DataObjects..::..DocumentTaskScope
The scope identifies which settings of the task to retrieve.

Return Value

A document task.

Remarks

Each document can have tasks associated with it.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example retrieves detailed information about all tasks for a specific document.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a remote QlikView Management service.
            ServiceInfo remoteQMSService = apiClient.GetServices(ServiceTypes.RemoteQlikViewManagementService).FirstOrDefault();

            if (remoteQMSService != null)
            {
                Guid docId = new Guid ("12a32214-1122-112a-8099-8765ce564112"); // The document ID.

                //Get a list of tasks for the document.
                List<TaskInfo> taskInfos = apiClient.RemoteGetTaskListForDocID(remoteQMSService.ID, docId);
                taskInfos.ForEach( delegate (TaskInfo taskInfo)
                    {
                        //Retrieve full information about the task.
                        DocumentTask documentTask = apiClient.RemoteGetDocumentTask(remoteQMSService.ID, taskInfo.ID, DocumentTaskScope.All);

                        if (documentTask == null) return;

                        Console.WriteLine("Name:" + documentTask.General.TaskName);
                        Console.WriteLine("Description" + documentTask.General.TaskDescription);
                        Console.WriteLine();
                    }
                );
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


RemoteGetServices Method

[image]

QlikView Management Service API
IQMS..::..RemoteGetServices Method
IQMS Interface Example See Also Send Feedback
Retrieves information about services managed by a remote QlikView Management Console.

Namespace: PIX.Services

Syntax

C#
List<ServiceInfo> RemoteGetServices(
    Guid remoteQmsId,
    ServiceTypes serviceTypes
)
Visual Basic
Function RemoteGetServices ( _
    remoteQmsId As Guid, _
    serviceTypes As ServiceTypes _
) As List(Of ServiceInfo)

Parameters

remoteQmsId
Type: System..::..Guid
The ID of the remote QlikView Management Console.
serviceTypes
Type: PIX.QMSAPI.DataObjects..::..ServiceTypes
The type of services to return.

Return Value

A list of services.

Remarks

Only source document folders that the caller have access to will be returned.

Security Note

Requires membership of local group QlikView Management API and the role QlikView Administrator.

Examples

This example retrieves all services managed by a remote QlikView Management Service and prints information about them to the console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Retrieve a remote QlikViewManagement-service
            ServiceInfo remoteQMSService = apiClient.GetServices(ServiceTypes.RemoteQlikViewManagementService).FirstOrDefault();

            if(remoteQMSService != null)
            {
                //Get all services managed by the remote service.
                List<ServiceInfo> remoteServices = apiClient.RemoteGetServices(remoteQMSService.ID, ServiceTypes.All);
                {
                    remoteServices.ForEach( delegate (ServiceInfo serviceInfo)
                        {
                            Console.WriteLine( string.Format( "{0} {1}",serviceInfo.Name, serviceInfo.Type));
                        }
                    );
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


RemoteGetSourceDocumentFolders Method

[image]

QlikView Management Service API
IQMS..::..RemoteGetSourceDocumentFolders Method
IQMS Interface Example See Also Send Feedback
Gets all source document folders for a QlikView Distribution Service, managed by a remote QlikView Management Service, with the specified ID.

Namespace: PIX.Services

Syntax

C#
List<DocumentFolder> RemoteGetSourceDocumentFolders(
    Guid remoteQmsId,
    Guid remoteQdsId,
    DocumentFolderScope scope
)
Visual Basic
Function RemoteGetSourceDocumentFolders ( _
    remoteQmsId As Guid, _
    remoteQdsId As Guid, _
    scope As DocumentFolderScope _
) As List(Of DocumentFolder)

Parameters

remoteQmsId
Type: System..::..Guid
The ID of the remote QlikView Management Service, managing the remote QlikView Distribution Service.
remoteQdsId
Type: System..::..Guid
The ID of the remote QlikView Distribution Service for which to retrieve source document folders.
scope
Type: PIX.QMSAPI.DataObjects..::..DocumentFolderScope
The scope of the source document folders to retrieve.

Return Value

All source document folders with the specified scope for the QlikView Distribution Service with the specified ID.

Remarks

Only source document folders that the caller have access to will be returned.

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example retrieves all source document folders from all QlikView Distribution services managed by a remote QlikView Management Service.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a remote QlikView Management service.
            ServiceInfo remoteQMSService = apiClient.GetServices(ServiceTypes.RemoteQlikViewManagementService).FirstOrDefault();

            if (remoteQMSService != null)
            {
                //Get all QlikView Distribution services on the remote QMS.
                List<ServiceInfo> remoteQDS = apiClient.RemoteGetServices(remoteQMSService.ID, ServiceTypes.QlikViewDistributionService);
                {
                    //Print the name of the QMS and the source folders found.
                    remoteQDS.ForEach(delegate(ServiceInfo qdsInfo)
                        {
                            Console.WriteLine("Source document folders on " + qdsInfo.Name);
                            List<DocumentFolder> sourceDocumentFolders = apiClient.RemoteGetSourceDocumentFolders(remoteQMSService.ID, qdsInfo.ID, DocumentFolderScope.All);
                            sourceDocumentFolders.ForEach(folder=>Console.WriteLine(folder.General.Path));
                        }
                    );
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


RemoteGetSourceDocumentNodes Method

[image]

QlikView Management Service API
IQMS..::..RemoteGetSourceDocumentNodes Method
IQMS Interface Example See Also Send Feedback
Connects to a remote QlikView Management Service and retrieves the source document nodes for the specified relative path and the specified source document folder and QlikView Distribution Service ID.

Namespace: PIX.Services

Syntax

C#
List<DocumentNode> RemoteGetSourceDocumentNodes(
    Guid remoteQmsId,
    Guid remoteQdsId,
    Guid folderId,
    string relativePath
)
Visual Basic
Function RemoteGetSourceDocumentNodes ( _
    remoteQmsId As Guid, _
    remoteQdsId As Guid, _
    folderId As Guid, _
    relativePath As String _
) As List(Of DocumentNode)

Parameters

remoteQmsId
Type: System..::..Guid
The ID of the remote QlikView Management Service.
remoteQdsId
Type: System..::..Guid
The QlikView Disitribution Service ID for which to retrieve source document nodes.
folderId
Type: System..::..Guid
The source document folder ID for which to retrieve source document nodes.
relativePath
Type: System..::..String
The relative path for which to retrieve source document nodes.

Return Value

Source document nodes for the specified relative path and the specified source document folder and QlikView Distribution Service ID.

Remarks

This method is typically used to retrieve the source documents as a tree structure. Each returned DocumentNode contains a RelativePath property which describes where in the tree structure the node belongs. It also contains a IsSubFolder property that indicates whether the node represents a sub folder or a document.

To retrieve the first level of nodes under the source document root folder specified by folderId, set the relativePath parameter to an empty string. For deeper levels of nodes, set the relativePath parameter to a path combined of the relative path and the name of the parent node at the previous level.

The first level of nodes under each source document root folder will always contain a sub folder named <Orphans> that contains a folder structure of "ghost" source documents. Any such "ghost" source documents have at least one task assigned to it, but the document itself does no longer exist. Such "ghost" source documents will automatically disappear from the orphans structure when its tasks are removed or when the source document exist again. The source document node representing the orphans sub folder and all its sub nodes will have the IsOrphan property set to trueTruetruetrue (True in Visual Basic).

Only source document folders that the caller have access to will be returned.

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example uses the QMS API to retrieve a registered QlikView Distribution Service, all its source document folders and nodes. The GetSourceDocumentNodes(Guid, Guid, String) method is called recursively to print sub folders and source documents as a tree structure. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a remote QlikView Management service.
            ServiceInfo remoteQMSService = apiClient.GetServices(ServiceTypes.RemoteQlikViewManagementService).FirstOrDefault();

            if (remoteQMSService != null)
            {
                //Get all QlikView Distribution services on the remote QMS.
                List<ServiceInfo> remoteQDS = apiClient.RemoteGetServices(remoteQMSService.ID, ServiceTypes.QlikViewDistributionService);
                {
                    //Print the name of the QMS and the source folders found.
                    remoteQDS.ForEach(delegate(ServiceInfo qdsInfo)
                        {
                            Console.WriteLine("Document structures on " + qdsInfo.Name);

                            List<DocumentFolder> sourceDocumentFolders = apiClient.RemoteGetSourceDocumentFolders(remoteQMSService.ID, qdsInfo.ID, DocumentFolderScope.All);
                            sourceDocumentFolders.ForEach(delegate (DocumentFolder folder)
                                {
                                    PrintSourceDocumentNodes( apiClient, remoteQMSService.ID, folder, string.Empty, 1);
                                }
                            );
                        }
                    );
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }

    static void PrintSourceDocumentNodes(IQMS apiClient, Guid remoteQmsId,DocumentFolder sourceDocumentFolder, string relativePath, int indentationDepth)
    {
        // retrieve all source document nodes of the given folder and under the specified relative path
        List<DocumentNode> sourceDocumentNodes = apiClient.RemoteGetSourceDocumentNodes(remoteQmsId, sourceDocumentFolder.Services.QDSID, sourceDocumentFolder.ID, relativePath);

        // loop through all current source document nodes
        foreach (DocumentNode sourceDocumentNode in sourceDocumentNodes
            .OrderByDescending(x => x.IsSubFolder).ThenBy(x => x.Name))
        {
            // print the names of all source document nodes, indent and
            // prefix with [F] for folders and [D] for documents
            string indentation = new string(' ', indentationDepth * 3);
            string nodePrefix = (sourceDocumentNode.IsSubFolder ? "[F]" : "[D]");
            Console.WriteLine(indentation + nodePrefix + " " + sourceDocumentNode.Name);
            // print all sub nodes of the current source document node if it represents a folder
            if (sourceDocumentNode.IsSubFolder)
            {
                PrintSourceDocumentNodes(apiClient, remoteQmsId, sourceDocumentFolder,
                    relativePath + "\\" + sourceDocumentNode.Name, indentationDepth + 1);
            }
        }
     }
}

Exceptions

Exception | Condition
System..::..Exception | Thrown if the caller does not have access to the source document folder with the specified ID.

See Also

IQMS Interface
PIX.Services Namespace


RemoteGetTaskListForDocID Method

[image]

QlikView Management Service API
IQMS..::..RemoteGetTaskListForDocID Method
IQMS Interface Example See Also Send Feedback
Retrieves a list of all tasks for a specific document from a remote QlikView Management Service.

Namespace: PIX.Services

Syntax

C#
List<TaskInfo> RemoteGetTaskListForDocID(
    Guid remoteQmsId,
    Guid documentId
)
Visual Basic
Function RemoteGetTaskListForDocID ( _
    remoteQmsId As Guid, _
    documentId As Guid _
) As List(Of TaskInfo)

Parameters

remoteQmsId
Type: System..::..Guid
The ID of the remote QlikView Management Service.
documentId
Type: System..::..Guid
The ID of the document to retrieve tasks for.

Return Value

A list of TaskInfo's, TaskInfo

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The example below retrieves tasks from a document from a remote QlikView Management Service.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Create GUIDs for a known QMS and document
            Guid remoteQMSId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The remote QMS QVS ID.
            Guid documentId = new Guid ("12a32214-1122-112a-8099-8765ce564112"); // The document ID.

            //Get the document tasks
            List<TaskInfo> taskInfos = apiClient.RemoteGetTaskListForDocID(remoteQMSId, documentId);

            //Print the tasks to the console.
            taskInfos.ForEach( delegate(TaskInfo task)
                {
                    Console.WriteLine(string.Format("Name:{0}\nID:{1}Enabled:{2}\nType:{3}\n",task.Name, task.ID, task.Enabled, task.Type));
                }
            );
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


RemoteGetTasks Method

[image]

QlikView Management Service API
IQMS..::..RemoteGetTasks Method
IQMS Interface Example See Also Send Feedback
Retrieves all tasks from a remote QlikViewDistribution Service.

Namespace: PIX.Services

Syntax

C#
List<TaskInfo> RemoteGetTasks(
    Guid remoteQmsId,
    Guid remoteQdsId
)
Visual Basic
Function RemoteGetTasks ( _
    remoteQmsId As Guid, _
    remoteQdsId As Guid _
) As List(Of TaskInfo)

Parameters

remoteQmsId
Type: System..::..Guid
The ID of the remote QlikView Management Service.
remoteQdsId
Type: System..::..Guid
The ID of the remote QlikView Distribution Service

Return Value

A list of all tasks found.

Remarks

Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

This example retrieves a remote QlikView Management Service and prints information about all tasks on the QDS's found on it.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a remote QlikView Management service.
            ServiceInfo remoteQMSService = apiClient.GetServices(ServiceTypes.RemoteQlikViewManagementService).FirstOrDefault();

            if (remoteQMSService != null)
            {
                //Get all QlikView Distribution services on the remote QMS.
                List<ServiceInfo> remoteQDS = apiClient.RemoteGetServices(remoteQMSService.ID, ServiceTypes.QlikViewDistributionService);
                {
                    //Print the name of the QDS and the tasks found.
                    remoteQDS.ForEach(delegate(ServiceInfo qdsInfo)
                        {
                            Console.WriteLine("Tasks on " + qdsInfo.Name);
                            List<TaskInfo> remoteTasks = apiClient.RemoteGetTasks(remoteQMSService.ID, qdsInfo.ID);
                            remoteTasks.ForEach( delegate (TaskInfo task)
                                {
                                    Console.WriteLine(string.Format("Name:{0}\nID:{1}Enabled:{2}\nType:{3}\n", task.Name, task.ID, task.Enabled, task.Type));
                                });
                        }
                    );
                }
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


ResolveUserGroups Method

[image]

QlikView Management Service API
IQMS..::..ResolveUserGroups Method
IQMS Interface Example See Also Send Feedback
This method returns all groups that a certain user is a member of.

Namespace: PIX.Services

Syntax

C#
List<string> ResolveUserGroups(
    Guid dscID,
    string user
)
Visual Basic
Function ResolveUserGroups ( _
    dscID As Guid, _
    user As String _
) As List(Of String)

Parameters

dscID
Type: System..::..Guid
The Directory Service Connector to use.
user
Type: System..::..String
The name of the user, including domain name.

Return Value

A list of group names found.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

This example retrieves all groups for a single user and prints them to the console.
CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            ServiceInfo dscService = apiClient.GetServices(ServiceTypes.QlikViewDirectoryServiceConnector).FirstOrDefault();
            if (dscService != null)
            {
            List<string> groups = apiClient.ResolveUserGroups(dscService.ID, "corpdomain\\johnb");
                groups.ForEach(Console.WriteLine);
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


RestartQDS Method

[image]

QlikView Management Service API
IQMS..::..RestartQDS Method
IQMS Interface Example See Also Send Feedback
Restarts the QDS.

Namespace: PIX.Services

Syntax

C#
void RestartQDS(
    Guid qdsID
)
Visual Basic
Sub RestartQDS ( _
    qdsID As Guid _
)

Parameters

qdsID
Type: System..::..Guid
The QDS ID.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This code example checks if the QDS is set to need a restart and then executes the restart.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using System.Threading;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             Guid qdsId = new Guid("67968710-6a84-446d-b759-ceb0cc9d656f"); // The originating QDS ID
             String RestartReason;
             if (apiClient.QDSNeedRestart(out RestartReason, qdsId) == true)    //QDS requires restart if DocFolder changed
             {
                 Console.WriteLine("QDS will be restarted. Reason: " + RestartReason);
                 apiClient.RestartQDS(qdsId);
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..QDSNeedRestart(Guid, String%)


RestartQVS Method

[image]

QlikView Management Service API
IQMS..::..RestartQVS Method
IQMS Interface Example See Also Send Feedback
Restarts the QVS.

Namespace: PIX.Services

Syntax

C#
void RestartQVS(
    Guid qvsID
)
Visual Basic
Sub RestartQVS ( _
    qvsID As Guid _
)

Parameters

qvsID
Type: System..::..Guid
The QVS ID.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This code example checks if the QVS is set to need a restart and then executes the restart.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid qvsId = new Guid("e07c145f-7606-4161-b986-b4288650e3b7"); // The originating QVS ID
            String RestartReason;
            if (apiClient.QVSNeedRestart(out RestartReason, qvsId) == true)    //QVS requires restart if DocFolder changed
            {
                Console.WriteLine("QVS will be restarted. Reason: " + RestartReason);
                apiClient.RestartQVS(qvsId);
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..QVSNeedRestart(Guid, String%)


RunTask Method

[image]

QlikView Management Service API
IQMS..::..RunTask Method
IQMS Interface Example See Also Send Feedback
Runs a single task.

Namespace: PIX.Services

Syntax

C#
void RunTask(
    Guid taskID
)
Visual Basic
Sub RunTask ( _
    taskID As Guid _
)

Parameters

taskID
Type: System..::..Guid
The task ID.

Remarks

Used to initiate a specific task.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example starts the execution of a task, then immediately aborts it. This establishes some task log information. Then it retrieves this and any other existing information from the log into a list and displays the text entry for the first element.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.Threading;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid taskId = new Guid("28a4fae4-8e75-4681-8ddc-751b7664a025");
            apiClient.RunTask(taskId); // A service call to initiate the execution of a task.
            Thread.Sleep(20*1000); //Wait for 20 seconds so that the task has time to start.
            apiClient.AbortTask(taskId); // A service call to end the execution of the same task.
            TaskStatus taskStatus = apiClient.GetTaskStatus(taskId,TaskStatusScope.All); // A service call to retrieve the task status.
            Console.WriteLine(taskStatus.Extended.LastLogMessages); // Displays the last log messages.
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..SaveDocumentTask(DocumentTask)
IQMS..::..GetTasks(Guid)
IQMS..::..GetTasksForDocument(Guid)
IQMS..::..GetDocumentTask(Guid, DocumentTaskScope)
IQMS..::..DeleteTask(Guid, TaskType)
IQMS..::..AbortTask(Guid)
IQMSGetTaskLog(Guid, Guid, Int32)


SaveCALConfiguration Method

[image]

QlikView Management Service API
IQMS..::..SaveCALConfiguration Method
IQMS Interface Example See Also Send Feedback
Saves the CAL configuration.

Namespace: PIX.Services

Syntax

C#
void SaveCALConfiguration(
    CALConfiguration calConfiguration
)
Visual Basic
Sub SaveCALConfiguration ( _
    calConfiguration As CALConfiguration _
)

Parameters

calConfiguration
Type: PIX.QMSAPI.DataObjects.CALs..::..CALConfiguration
The cal configuration.

Remarks

Not all fields in the configuration can be changed using this method. For all CAL types (Session, Document, Named and Usage), the Limit can be set. The maximum value is limited by the license on the QVS. The other fields that can be set are related to NamedCALs: NamedCalMode, AllowBorrowCal, AllowDynamicNamedCals and AssignedUsers.
Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example retrieves the CAL configuration for a QVS, changes a setting and saves it back.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
           // create a QMS API client
           IQMS apiClient = new QMSClient();

           //retrieve a time limited service key
           ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

           //Some known QVS id
           Guid qvsId = new Guid("5ac16136-f00b-47c4-8099-23ff7f178423");

           CALConfiguration calConfiguration = apiClient.GetCALConfiguration(qvsId, CALConfigurationScope.NamedCALs);
           calConfiguration.NamedCALs.AllowDynamicAssignment = false;

           apiClient.SaveCALConfiguration(calConfiguration);
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


SaveDocumentMetaData Method

[image]

QlikView Management Service API
IQMS..::..SaveDocumentMetaData Method
IQMS Interface Example See Also Send Feedback
Saves the document metadata.

Namespace: PIX.Services

Syntax

C#
void SaveDocumentMetaData(
    DocumentMetaData documentMetaData
)
Visual Basic
Sub SaveDocumentMetaData ( _
    documentMetaData As DocumentMetaData _
)

Parameters

documentMetaData
Type: PIX.QMSAPI.DataObjects..::..DocumentMetaData
The documentMetaData object.

Remarks

Every document has an information set asssociated with it describing for example its name and position in the node hierarchy.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following code example retrieves the document metadata of a specific document and then saves it. In order to be able to find and use the correct node in the service call we call on a list of all user document nodes and then select the first one for the sake of this example.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            Guid qvsId = new Guid("c7c66836-f00b-47c4-8099-23ff7f178423"); // The originating QVS ID.
            IList<DocumentNode> documentNodes = apiClient.GetUserDocuments(qvsId); // Collecting a list of user document nodes.
            DocumentNode userDocument = documentNodes[0]; // Assigning the first element of the list to a new object.

            // A client call to collect the metadata for a specific document.
            DocumentMetaData documentMetaData = apiClient.GetDocumentMetaData(userDocument, DocumentMetaDataScope.All);

            Console.WriteLine("Document name:" + documentMetaData.UserDocument.Name); // Displaying the name of the document.
            apiClient.SaveDocumentMetaData(documentMetaData); // Saving the document metadata that was retrieved.
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..GetDocumentMetaData(DocumentNode, DocumentMetaDataScope)


SaveDocumentTask Method

[image]

QlikView Management Service API
IQMS..::..SaveDocumentTask Method
IQMS Interface Example See Also Send Feedback
Saves the document task.

Namespace: PIX.Services

Syntax

C#
void SaveDocumentTask(
    DocumentTask documentTask
)
Visual Basic
Sub SaveDocumentTask ( _
    documentTask As DocumentTask _
)

Parameters

documentTask
Type: PIX.QMSAPI.DataObjects..::..DocumentTask
The document task.

Remarks

Each document can have tasks associated with it.
Security Note

Requires membership of local group QlikView Management API and the role Document Folder Administrator.

Examples

The following example retrieves a task associated with a document, displays the name of the task and then saves the document task. It would have been just as easy to change the task information instead of displaying it.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

 class Program
 {
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             Guid documentTaskId = new Guid("e95ecd5a-683d-1d33-26bf-66e94ff08223");
             DocumentTask documentTask = apiClient.GetDocumentTask(documentTaskId, DocumentTaskScope.All);
             Console.WriteLine(documentTask.Document.Name);
             apiClient.SaveDocumentTask(documentTask);
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
IQMS..::..GetTasks(Guid)
IQMS..::..GetTasksForDocument(Guid)
IQMS..::..GetDocumentTask(Guid, DocumentTaskScope)
IQMS..::..DeleteTask(Guid, TaskType)
IQMS..::..RunTask(Guid)
IQMS..::..AbortTask(Guid)
IQMSGetTaskLog(Guid, Guid, Int32)


SaveLicense Method

[image]

QlikView Management Service API
IQMS..::..SaveLicense Method
IQMS Interface Example See Also Send Feedback
Sets a license on a service. The license includes a LicenseType which is used together with the serviceID parameter to find the correct service.

Namespace: PIX.Services

Syntax

C#
string SaveLicense(
    License license,
    Guid serviceID
)
Visual Basic
Function SaveLicense ( _
    license As License, _
    serviceID As Guid _
) As String

Parameters

license
Type: PIX.QMSAPI.DataObjects..::..License
The license to set on the service.
serviceID
Type: System..::..Guid
The ID of the service that should have the license

Return Value

An empty string is returned if the operation were successful, otherwise an error message is returned.

Remarks

If the license parameter is a Publisher license, the serviceID will be ignored and can be set to Guid.Empty.
Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example uses the QMS API to set a new Publisher license.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             //Create the new license
             License newLicense = new License();
             newLicense.LicenseType = LicenseType.Publisher;
             newLicense.Serial = "<A valid serial number>";
             newLicense.Control = "<A valid control number>";
             newLicense.Name = "<Some name>";
             newLicense.Corporation = "<Some corporation>";
             newLicense.LEFFile = System.IO.File.ReadAllText("<Path to LEF file>");

             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             //Set the license
             string result = apiClient.SaveLicense(newLicense, Guid.Empty);

             //Check the result
             if(result != string.Empty)
                 Console.WriteLine("License was successfully set.");
             else
                 Console.WriteLine("Error when setting the license: " + result);
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..License


SaveQDSSettings Method

[image]

QlikView Management Service API
IQMS..::..SaveQDSSettings Method
IQMS Interface Example See Also Send Feedback
Updates the settings for a certain QlikView Distribution service.

Namespace: PIX.Services

Syntax

C#
string SaveQDSSettings(
    QDSSettings qdsSettings
)
Visual Basic
Function SaveQDSSettings ( _
    qdsSettings As QDSSettings _
) As String

Parameters

qdsSettings
Type: PIX.QMSAPI.DataObjects..::..QDSSettings
The settings to apply.

Return Value

If everything went well, an empty string is returned. If there were some issues, a description of those is returned.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following example retrieves the settings for all registered QlikView Distribution Services. It updates the settings and sends it

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

 class Program
 {
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a list of QlikView Distribution Services.
            List<ServiceInfo> qdsServices = apiClient.GetServices(ServiceTypes.QlikViewDistributionService);

            //Loop through the list
            foreach(ServiceInfo info in qdsServices)
            {
                Console.WriteLine("Updating QDS at " + info.Name);

                //Get the General settings for a QlikView Distribition Service.
                QDSSettings settings = apiClient.GetQDSSettings(info.ID, QDSSettingsScope.General);

                if(settings != null)
                {
                    //Set the LogLevel and set the updated settings.
                    settings.General.LogLevel = LogLevel.Normal;
                    string result = apiClient.SaveQDSSettings(settings);

                    if (string.IsNullOrWhiteSpace(result))
                        Console.WriteLine("Update OK.");
                    else
                        Console.WriteLine("Issues while updating: " + result);
                } else
                {
                    Console.WriteLine("Failed to retrieve the settings.");
                }
            }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

Exceptions

Exception | Condition
System..::..Exception | If an error occurs, an exception will be thrown.

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..QDSSettings
PIX.QMSAPI.DataObjects..::..ServiceInfo


SaveQVSSettings Method

[image]

QlikView Management Service API
IQMS..::..SaveQVSSettings Method
IQMS Interface Example See Also Send Feedback
Saves the specified QlikView Server settings.

Namespace: PIX.Services

Syntax

C#
void SaveQVSSettings(
    QVSSettings qvsSettings
)
Visual Basic
Sub SaveQVSSettings ( _
    qvsSettings As QVSSettings _
)

Parameters

qvsSettings
Type: PIX.QMSAPI.DataObjects..::..QVSSettings
The QlikView Server settings to save.

Remarks

Note

The QVSID property of qvsSettings must contain a valid QlikView Server ID.

Only the settings specified by the Scope property will be saved. None of the properties of qvsSettings corresponding to the specified scope can be nullNothingnullptra null reference (Nothing in Visual Basic).

All settings except General and Distribution requires that the QlikView Management Service is able to communicate with the QlikView Server.

If the settings are saved with Scope set to Cluster and any of the specified cluster Members have a license with a different serial number than the main QlikView Server (first cluster member in the list), the correct license ControlNumber must be supplied.

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following code example uses the QMS API to retrieve a registered QlikView Server and its logging settings. It changes the log folder and then saves the logging settings. If everything goes well, it prints the original logging folder and then a message when it's done. If anything goes wrong, it prints an error message.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            // get a list of QVS services
            List<ServiceInfo> qvsServices = apiClient.GetServices(ServiceTypes.QlikViewServer);
            if (qvsServices.Count > 0)
            {
                // retrieve logging settings for the first QVS in the list
                QVSSettings qvsSettings = apiClient.GetQVSSettings(qvsServices[0].ID, QVSSettingsScope.Logging);
                Console.WriteLine("QVS log folder before change: " + qvsSettings.Logging.Folder);
                // change log folder
                qvsSettings.Logging.Folder = @"\\myshare\logs";
                // save settings
                apiClient.SaveQVSSettings(qvsSettings);
                Console.WriteLine("Settings saved. Log folder changed.");
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadKey();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..QVSSettings
IQMS..::..GetQVSSettings(Guid, QVSSettingsScope)


SaveSectionAccessTable Method

[image]

QlikView Management Service API
IQMS..::..SaveSectionAccessTable Method
IQMS Interface Example See Also Send Feedback
Saves a SectionAccessTable. If the table does not exist, it will be created. Otherwise it will be updated.

Namespace: PIX.Services

Syntax

C#
void SaveSectionAccessTable(
    SectionAccessTable table
)
Visual Basic
Sub SaveSectionAccessTable ( _
    table As SectionAccessTable _
)

Parameters

table
Type: PIX.QMSAPI.DataObjects..::..SectionAccessTable
The SectionAccessTable to store.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example retrieves a table and adds a new column to it.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Retrieve a table which is to be changed.
            SectionAccessTable sectionAccessTable = apiClient.GetSectionAccessTableByName("newTable", SectionAccessScope.IncludeData);

            if(sectionAccessTable != null) {
                //Add a new column.
                sectionAccessTable.Columns.Add(new SectionAccessTable.SectionAccessColumn(){Name="City"});

                //Save the changed table.
                apiClient.SaveSectionAccessTable(sectionAccessTable);
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace


SendDistributionServiceWorkorder Method

[image]

QlikView Management Service API
IQMS..::..SendDistributionServiceWorkorder Method
IQMS Interface Example See Also Send Feedback
Updates the configuration of a QlikView Distribution Service, includning task definitions.

Namespace: PIX.Services

Syntax

C#
void SendDistributionServiceWorkorder(
    Guid qdsID
)
Visual Basic
Sub SendDistributionServiceWorkorder ( _
    qdsID As Guid _
)

Parameters

qdsID
Type: System..::..Guid
The id of the QlikView Distribution Service to update.

Remarks

The method will return immediately, but it takes a little longer before the QDS has been updated. The time is dependant on the number of nodes in the cluster and the amount of tasks.
Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example retrieves a list of all Distribution Service services and forces an updated of their configuration.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

 class Program
 {
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a list of QlikView Distribution Services.
            List<ServiceInfo> qdsServices = apiClient.GetServices(ServiceTypes.QlikViewDistributionService);

            //Loop through the list
            foreach (ServiceInfo info in qdsServices)
            {
                //Update the configuration and tasks of the service
                apiClient.SendDistributionServiceWorkorder(info.ID);
            }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..ServiceInfo


ServiceHasValidLicense Method

[image]

QlikView Management Service API
IQMS..::..ServiceHasValidLicense Method
IQMS Interface Example See Also Send Feedback
Checks a service to see whether it has a valid license or not.

Namespace: PIX.Services

Syntax

C#
bool ServiceHasValidLicense(
    LicenseType licenseType,
    Guid serviceID
)
Visual Basic
Function ServiceHasValidLicense ( _
    licenseType As LicenseType, _
    serviceID As Guid _
) As Boolean

Parameters

licenseType
Type: PIX.QMSAPI.DataObjects.Enums..::..LicenseType
The type of license to check.
serviceID
Type: System..::..Guid
The ID of the service to check.

Return Value

True if the service has a valid license, otherwise false.

Remarks

Security Note

Requires membership of local group QlikView Management API.

Examples

This example checks whether the publisher license is valid or not and prints the result.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            bool hasPublisherLicense = apiClient.ServiceHasValidLicense(LicenseType.Publisher, Guid.Empty);

            if(hasPublisherLicense)
                Console.WriteLine("The publisher license is valid.");
            else
                Console.WriteLine("The publisher license is not valid.");
         }
         catch(Exception e)
         {
             Console.WriteLine("An error occured when validating the license: " + e.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects.Enums..::..LicenseType


TakeServerObject Method

[image]

QlikView Management Service API
IQMS..::..TakeServerObject Method
IQMS Interface Example See Also Send Feedback
Changes the owner of a server object.

Namespace: PIX.Services

Syntax

C#
void TakeServerObject(
    Guid qvsID,
    string documentName,
    string id,
    string owner
)
Visual Basic
Sub TakeServerObject ( _
    qvsID As Guid, _
    documentName As String, _
    id As String, _
    owner As String _
)

Parameters

qvsID
Type: System..::..Guid
The ID of a QlikView Server
documentName
Type: System..::..String
The full path of the document to retrieve server objects from.
id
Type: System..::..String
The id of the server object.
owner
Type: System..::..String
The new owner

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

The following example finds all server objects in a certain document that belongs to a specific user. Next, the owner of the found server object is changed to another user.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             //Get a Qlik View Server
             ServiceInfo qvsService = apiClient.GetServices(ServiceTypes.QlikViewServer).FirstOrDefault();

             if (qvsService != null)
             {
                 //Get all collaboration objects
                 List<ServerObject> serverObjects = apiClient.GetServerObjects(qvsService.ID, "Test.qvw");

                 //Find the ones belonging to johndoe
                 var userObjects = serverObjects.Where(c => c.OwnerId == "Domain\\johndoe").ToList();

                 //Change the owner to someone else.
                 userObjects.ForEach(c => apiClient.TakeServerObject(qvsService.ID, "Test.qvw", c.Id, "Domain\\marysmith"));
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace


TriggerEDXTask Method

[image]

QlikView Management Service API
IQMS..::..TriggerEDXTask Method
IQMS Interface Example See Also Send Feedback
Triggers an EDX task.

Namespace: PIX.Services

Syntax

C#
TriggerEDXTaskResult TriggerEDXTask(
    Guid qdsID,
    string taskNameOrID,
    string password,
    string variableName,
    List<string> variableValues
)
Visual Basic
Function TriggerEDXTask ( _
    qdsID As Guid, _
    taskNameOrID As String, _
    password As String, _
    variableName As String, _
    variableValues As List(Of String) _
) As TriggerEDXTaskResult

Parameters

qdsID
Type: System..::..Guid
The QDS ID.
taskNameOrID
Type: System..::..String
The task name or ID.
password
Type: System..::..String
The password.
variableName
Type: System..::..String
Name of the variable.
variableValues
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
The variable values.

Return Value

The result of the trigger. This includes an execution ID which is used to check the status of the edx task. This allows for multiple instances of the same task to be triggered, while still being able to check the state of a specific execution.

Remarks

In order to be accessible through this interface an EDX task has to be configured first. This can be considered an alternative to the RunTask(Guid) service. The taskNameOrID parameter can accept either a complete, correctly capitalized, unique task name or an task ID.
Security Note

Requires membership of local group QlikView EDX.

If the task name matches multiple tasks, no task will be started abd the EDXTaskStartResult will be set to CouldNotDetermineTaskByName.

If the provided password is wrong, a new log entry will be created in the event log with information about the name of the task and the id of the calling user.

If the task does exist, the result will have its EDXTaskStartResult field set to TaskNotFound.

Examples

The following example shows how to trigger a task and then wait until it has finished or a certain amount of time has passed.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using System.Threading;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {

             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //Get a Distribution Service.
            ServiceInfo qdsService = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();

            if (qdsService != null)
            {
                //Trigger the task
                TriggerEDXTaskResult result = apiClient.TriggerEDXTask(qdsService.ID, "PauseEDX", "edx", "", new List<string>());

                EDXStatus executionStatus = null;

                //Wait until the task is completed or 60 seconds has passed.
                SpinWait.SpinUntil(() =>
                    {
                        System.Threading.Thread.Sleep(1000);
                        Console.WriteLine("Checking the task...");

                        //Get the current state of the task.
                        executionStatus = apiClient.GetEDXTaskStatus(qdsService.ID, result.ExecId);

                        //Return true if the task has completed.
                        return executionStatus != null && executionStatus.TaskStatus == TaskStatusValue.Completed;
                }, 60 * 1000);

                //Write the result
                if (executionStatus != null)
                    Console.WriteLine(executionStatus.TaskStatus);
                else
                    Console.WriteLine("Failed to get execution status.");

            }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..EDXStatus
IQMS..::..TriggerEDXTask(Guid, String, String, String, List<(Of <<'(String>)>>))
PIX.QMSAPI.DataObjects..::..TriggerEDXTaskResult
IQMS..::..GetEDXTaskStatus(Guid, Guid)


UpdateLicense Method

[image]

QlikView Management Service API
IQMS..::..UpdateLicense Method
IQMS Interface Example See Also Send Feedback
Updates the service with the current license. This will refresh the license for all the members of the service.

Namespace: PIX.Services

Syntax

C#
void UpdateLicense(
    LicenseType licenseType,
    Guid serviceID
)
Visual Basic
Sub UpdateLicense ( _
    licenseType As LicenseType, _
    serviceID As Guid _
)

Parameters

licenseType
Type: PIX.QMSAPI.DataObjects.Enums..::..LicenseType
The type of license to return.
serviceID
Type: System..::..Guid
The ID if the service.

Remarks

If the licenseType parameter is set to LicenseType.Publisher, the serviceID will be ignored and can be set to Guid.Empty.
Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example updates the licenses of the Publisher and QlikViewServer services.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             //Update the Publisher license. The ID can be set to an empty GUID.
             apiClient.UpdateLicense( LicenseType.Publisher, Guid.Empty);

             //Find a QlikViewServer service and updates the license.
             ServiceInfo qlikViewServiceInfo = apiClient.GetServices(ServiceTypes.QlikViewServer).FirstOrDefault();
             if (qlikViewServiceInfo != null)
             {
                 apiClient.UpdateLicense(LicenseType.QlikViewServer, qlikViewServiceInfo.ID);
             }
         }
         catch (Exception ex)
         {
             Console.WriteLine("An exception occurred: " + ex.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects.Enums..::..LicenseType


ValidateLicense Method

[image]

QlikView Management Service API
IQMS..::..ValidateLicense Method
IQMS Interface Example See Also Send Feedback
Validates a license, making sure that the information that it contains is correct.

Namespace: PIX.Services

Syntax

C#
void ValidateLicense(
    License license
)
Visual Basic
Sub ValidateLicense ( _
    license As License _
)

Parameters

license
Type: PIX.QMSAPI.DataObjects..::..License
The license to validate.

Remarks

Security Note

Requires membership of local groups QlikView Management API and QlikView Administrator.

Examples

This example creates a new license and validates it. The result is printed to the Console.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
 using System;
 using System.Collections.Generic;
 using System.Linq;
 using QMSAPI;

class Program
{
     static void Main(string[] args)
     {
         License newLicense = new License();
         newLicense.LicenseType = LicenseType.Publisher;
         newLicense.Serial = "<A valid serial number>";
         newLicense.Control = "<A valid control number>";
         newLicense.Name = "<Some name>";
         newLicense.Corporation = "<Some corporation>";
         newLicense.LEFFile = System.IO.File.ReadAllText("<Path to LEF file>");

         try
         {
             // create a QMS API client
             IQMS apiClient = new QMSClient();

             //retrieve a time limited service key
             ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

             apiClient.ValidateLicense( newLicense);
             Console.WriteLine("The license is valid.");
         }
         catch(ArgumentException ae)
         {
             Console.WriteLine(string.Format("The license information is not valid. The {0} parameter is empty. It must contain a valid value.", ae.ParamName));
         }
         catch(Exception e)
         {
             Console.WriteLine("An error occured when validating the license: " + e.Message);
         }
         // wait for user to press any key
         Console.ReadLine();
     }
}

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown if any of the required values provided in the license are empty.
System..::..Exception | Thrown if there is a problem with the license.

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..License


WriteExtensionObject Method

[image]

QlikView Management Service API
IQMS..::..WriteExtensionObject Method
IQMS Interface Example See Also Send Feedback
Uploads a piece of an extension object. The handle returned contains the current state of the upload.

Namespace: PIX.Services

Syntax

C#
ExtensionUploadHandle WriteExtensionObject(
    ExtensionUploadHandle handle,
    byte[] chunk
)
Visual Basic
Function WriteExtensionObject ( _
    handle As ExtensionUploadHandle, _
    chunk As Byte() _
) As ExtensionUploadHandle

Parameters

handle
Type: PIX.QMSAPI.DataObjects..::..ExtensionUploadHandle
The handle which identifies the upload.
chunk
Type: array< System..::..Byte >[]()[][]
The data to upload.

Return Value

A handle which contains the current state of the upload.

Remarks

An upload usually requires several calls to this method and it is very important that the handle used is the handle which was returned from the last successful call.
Security Note

Requires membership of local group QlikView Management API.

Examples

The following code example uploads a document extension to a QVS.

The service key injection is assumed to be handled behind the scenes. For an example on how to inject the service key, see Samples.

CopyC#
using System;
using System.Collections.Generic;
using System.Linq;
using System.IO;
using QMSAPI;

class Program
{
    static void Main(string[] args)
    {
        try
        {
            // create a QMS API client
            IQMS apiClient = new QMSClient();

            //retrieve a time limited service key
            ServiceKeyClientMessageInspector.ServiceKey = apiClient.GetTimeLimitedServiceKey();

            //This is a valid QVS guid
            Guid qvsId = new Guid("{6afbbc64-9681-406b-8917-e78bc370a05c}");

            //Initiate the upload
            ExtensionUploadHandle handle = apiClient.InitiateUploadExtensionObject(qvsId);

            if (handle != null)
            {
                FileStream fs = new FileStream(@"C:\FlexiGrid.qar", FileMode.Open);

                int maxBufferSize = 1024 * 16;

                byte[] buffer = new byte[maxBufferSize];
                int bytesRead;

                while ((bytesRead = fs.Read(buffer, 0, maxBufferSize)) > 0)
                {
                    //Copy the read bytes into a new buffer with the same size as the number of received bytes
                    byte[] byteWireBuffer = new byte[bytesRead];
                    Buffer.BlockCopy(buffer, 0, byteWireBuffer, 0, bytesRead);

                    //Write the buffer to the QVS
                    handle = apiClient.WriteExtensionObject(handle, byteWireBuffer);
                }

                //Finalize the upload. This will install the extension object if it is valid.
                List<QVSMessage> msg = apiClient.CloseAndInstallExtensionObject(handle);
                msg.ForEach(m => Console.WriteLine(m.Text));
            }
        }
        catch (Exception ex)
        {
            Console.WriteLine("An exception occurred: " + ex.Message);
        }
        // wait for user to press any key
        Console.ReadLine();
    }
}

See Also

IQMS Interface
PIX.Services Namespace
PIX.QMSAPI.DataObjects..::..ExtensionUploadHandle


Basic app.config

[image]

QlikView Management Service API
Basic app.config
Send Feedback
CopyExample of an app.config file not using certificate security
    <?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <system.serviceModel>
      <extensions>
        <behaviorExtensions>
          <add name="serviceKeyBehavior" type="MyTestApplication.ServiceKeyBehaviorExtensionElement, MyTestApplication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"/>
        </behaviorExtensions>
      </extensions>
      <behaviors>
        <endpointBehaviors>
          <behavior name="ServiceKeyEndpointBehavior">
            <serviceKeyBehavior/>
          </behavior>
        </endpointBehaviors>
      </behaviors>

      <bindings>
        <basicHttpBinding>
          <binding name="BasicHttpBinding_IQMS" closeTimeout="00:01:00"
            openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00"
            allowCookies="false" bypassProxyOnLocal="false" hostNameComparisonMode="StrongWildcard"
            maxBufferSize="65536" maxBufferPoolSize="524288" maxReceivedMessageSize="65536"
            messageEncoding="Text" textEncoding="utf-8" transferMode="Buffered"
            useDefaultWebProxy="true">
            <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384"
              maxBytesPerRead="4096" maxNameTableCharCount="16384" />
            <security mode="TransportCredentialOnly">
              <transport clientCredentialType="Ntlm" proxyCredentialType="None"
                realm="" />
              <message clientCredentialType="UserName" algorithmSuite="Default" />
            </security>
          </binding>
        </basicHttpBinding>
      </bindings>
        <client>
          <endpoint address="http://localhost:4799/QMS/Service" binding="basicHttpBinding"
                bindingConfiguration="BasicHttpBinding_IQMS" contract="QMSAPI.IQMS"
                name="BasicHttpBinding_IQMS" behaviorConfiguration="ServiceKeyEndpointBehavior"/>
        </client>
    </system.serviceModel>
</configuration>


Certificate Security app.config

[image]

QlikView Management Service API
Certificate Security app.config
Send Feedback
CopyExample of an app.config file using certificate security
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <system.serviceModel>
      <extensions>
        <behaviorExtensions>
          <add name="serviceKeyBehavior" type="MyTestApplication.ServiceKeyBehaviorExtensionElement, MyTestApplication, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"/>
        </behaviorExtensions>
      </extensions>
      <behaviors>
        <endpointBehaviors>
          <behavior name="ServiceKeyEndpointBehavior">
            <serviceKeyBehavior/>
            <clientCredentials>
              <clientCertificate findValue="CN=QVProxy" x509FindType="FindBySubjectDistinguishedName" storeLocation="LocalMachine" storeName="My" />
              <serviceCertificate>
                <authentication certificateValidationMode="ChainTrust" revocationMode="NoCheck"/>
              </serviceCertificate>
            </clientCredentials>
          </behavior>
        </endpointBehaviors>
      </behaviors>

      <bindings>
        <wsHttpBinding>
          <binding name="WSHttpBinding_IQMS" closeTimeout="00:01:00" openTimeout="00:01:00"
                    receiveTimeout="00:10:00" sendTimeout="00:01:00" bypassProxyOnLocal="false"
                    transactionFlow="false" hostNameComparisonMode="StrongWildcard"
                    maxBufferPoolSize="524288" maxReceivedMessageSize="65536"
                    messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true"
                    allowCookies="false">
              <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384"
                        maxBytesPerRead="4096" maxNameTableCharCount="16384" />
              <reliableSession ordered="true" inactivityTimeout="00:10:00"
                        enabled="false" />
              <security mode="Transport">
                <transport clientCredentialType="Certificate" proxyCredentialType="None"
                            realm="" />
                <message clientCredentialType="Windows" negotiateServiceCredential="true" />
              </security>
            </binding>
          </wsHttpBinding>
        </bindings>
        <client>
          <endpoint address="https://localhost:4799/QMS/Service" binding="wsHttpBinding"
                bindingConfiguration="WSHttpBinding_IQMS" contract="QMSAPI.IQMS"
                name="WSHttpBinding_IQMS" behaviorConfiguration="ServiceKeyEndpointBehavior"/>
        </client>
    </system.serviceModel>
</configuration>